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Preface 

The AutoCAD® 2024: Beyond the Basics guide is designed for those using AutoCAD® 2024 with 
a Windows operating system. This guide is not designed for the AutoCAD for Mac software. 
The objective of AutoCAD 2024: Beyond the Basics is to enable you to create, modify, and work 
with a 2D drawing in the AutoCAD software. 
The AutoCAD 2024: Beyond the Basics guide continues on from the topics covered in the 
AutoCAD 2024: Essentials guide. It covers more sophisticated techniques that extend your 
mastery of the software. For example, here you go beyond the basic skill of using a template to 
understand the process of setting up a template, creating annotation styles, and how to work 
with external references. You learn such skills as: 

Using more advanced editing and construction techniques 

Adding parametric constraints to objects 

Creating local and global blocks 

Setting up layers, styles, and templates 

Attaching external references 

Prerequisites 

Access to the 2024.0 version of the software, to ensure compatibility with this guide. Future 
software updates that are released by Autodesk may include changes that are not reflected 
in this guide. The practices and files included with this guide are not compatible with prior 
versions (e.g., 2023). 

Knowledge of AutoCAD basics as taught in AutoCAD: Essentials, or equivalent experience. 

A working knowledge of your operating system. 

Note on Software Setup 
This guide assumes a standard installation of the software using the default preferences during 
installation. Lectures and practices use the standard software templates and default options 
for the Content Libraries. 
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Lead Contributor: Renu Muthoo 
Renu uses her instructional design training to develop courseware for AutoCAD and AutoCAD 
vertical products, Autodesk 3ds Max, Autodesk Showcase and various other Autodesk software 
products. She has worked with Autodesk products for the past 20 years with a main focus on 
design visualization software. 
Renu holds a bachelor's degree in Computer Engineering and started her career as a 
Instructional Designer/ Author where she co-authored a number of Autodesk 3ds Max and 
AutoCAD books, some of which were translated into other languages for a wide audience 
reach. In her next role as a Technical Specialist at a 3D  visualization company, Renu used 3ds 
Max in real-world scenarios on a daily basis. There, she developed customized 3D  web planner 
solutions to create specialized 3D models with photorealistic texturing and lighting to produce 
high quality renderings. 
Renu Muthoo has been the Lead Contributor for AutoCAD: Beyond the Basics since 2015. 
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I n  This Gu ide 

The following highl ights the key features of this guide. 

Feature 

Practice Files 

Chapters 

Appendices 

Description 

The Practice F i les page inc ludes a l i nk  to the p ractice fi les and i nstruct ions 
on how to download and i nsta l l  them. The p ractice fi l es a re requ i red to 
comp lete the pract ices i n  th is  gu ide .  

A chapter consists of the fo l lowing :  Learn ing Objectives, I nstructiona l  
Content, Practices, Chapter Review Quest ions, and Command Summary. 
• Learning Objectives define  the ski l ls you can acqu i re by learn ing the 

content provided i n  the chapter. 
• I nstructional Content, which beg ins right after Lea rn i ng  Objectives, refers 

to the descr ipt ive and procedura l  informat ion related to var ious topics .  
Each main topic i ntroduces a product featu re, d i scusses var ious aspects 
of that featu re, and provides step-by-step p rocedu res on how to use that 
featu re. Where re levant, examples, f igu res, he lpfu l h i nts, and notes are 
prov ided .  

• Practice for a topic fo l lows the i nstruct iona l  content. Practices enab le you 
to use the software to perform a hands-on  review of a topic .  It is  requ i red 
that you down load the practice f i les (us ing  the l i nk  found on the Practice 
F i les page) pr ior to start ing the fi rst practice. 

• Chapter Review Questions, located close to the end of a chapter, enable 
you to test your knowledge of the key concepts d iscussed i n  the chapter. 

• Command Summary concludes a chapter. I t  conta i ns  a l i st of the software 
commands that a re used throughout the chapter and provides i nformation 
on where the command can be found i n  the software.  

Append ices provide addit iona l  i nfo rmat ion to the main course content .  It 
could be i n  the form of i nstruct iona l  content, practices, tab les, p rojects, or 
ski l l s  assessment. 
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Practice Fi les 

To download the practice files for this guide, use the following steps: 
1 .  Type the URL exactly as shown below into the address bar of your Internet browser, to 

access the Course File Download page. 

Note: If you are using the ebook, you do not have to type the URL. Instead, you can 
access the page simply by clicking the URL below. 

https://www.ascented.com/getfi le/id/poropanchaxPF 

Now fab · · - - - . .  ·- �·- + / address bar o f a browser 

c • TYPE URL HERE 

□ X 

* e 
2. On the Course File Download page, click the DOWNLOAD NOW button, as shown below, to 

download the .Z I P  file that contains the practice files. 

1'• DOWNLOAD NOW,► I 

3 .  Once the download is  complete, unzip the file and extract its contents. 
The recommended practice files folder location is: 
C: \AutoCAD 2024 Fundamentals Practice Files 

Note: It is recommended that you do not change the location of the practice fifes folder. 
Doing so may cause errors when completing the practices. 

Stay Informed! 

To receive i nformation about upcom ing events, p romot iona l  offers, and 
compl imentary webcasts, v is it: 

www.ASCENTed.com/updates 
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I nstructor Notes 

The AutoCAD 2024: Beyond the Basics instructor guide is designed to be used in conjunction 
with an instructor guiding a small group of students. Each student should have their own 
workstation. The guide was designed with the idea that computer skills are best learned by 
immediately practicing what the instructor explains and demonstrates. 

Managing C lass Time 
The instructor must carefully manage the class time t o  complete all of the elements o f  the 
course. Have your schedule for the day clearly in mind before you begin. Be prepared for fast or 
slow classes and for the mixed-skill class in which students have varying levels of experience 
and aptitude. Advanced students can work on extra practices while you assist the other 
students. A suggested schedule for the class is provided in the Schedule section of this 
document. 

i The estimated time for completing a chapter and each practice is provided beside 
the hourglass icon. 

Practices 
After each topic is introduced, students complete a hands-on practice that reinforces the topic 
or skill that was just presented. The topics and practices generally follow a building-block 
approach, where each succeeding practice reinforces earlier topics. The instructor should work 
individually with students to answer any questions and ensure that they all are able to 
understand and complete the practices. 

Projects 
Projects provide additional hands-on practice that typically cover the topics of several chapters 
and practices, and can include similar tasks that focus on a particular industry (i.e., Mechanical, 
Architectural, Civil, etc.). Students should work on the practices that best apply to their specific 
industry during class time. 
The projects can be used at the instructor's discretion, based on the speed of the class. The 
times for the project chapters are set to provide the students with the time to work on a few of 
the projects for each chapter during class time, but they are not expected to finish all of them. 
Most classes should have time to complete a substantial number of the projects. 
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Chapter Review Questions 
Review questions are included at the end of each chapter. These questions are designed to 
evaluate the student's understanding of the key concepts of each chapter. The answers are 
provided adjacent to the question in this Instructor Guide, but are not included in the student's 
Learning Guide. 

Command Summaries 
A sum marized list of  the key commands that were taught in the chapter is  included at  the end 
of each chapter. Encourage the students to pull the page or photocopy it for quick access when 
they return to their office. 

Ski l ls Assessment 
Skills Assessments are designed to evaluate the student's understanding of the key concepts 
presented in the entire guide, rather than in a single chapter. 

Template Fi les 
Several custom template files (.DWT) are included with the practice files. Students need to start 
new drawings based on these templates for many of the practices. Leave the template files in 
the practice folder and set that folder as the Drawing Template File Location (Options dialog 
box>Fi/es tab). 

xiv 

AEC-Millimeters.dwt: Template for architectural drawings, in millimeters. 

Civil-Meters.dwt: Template for civil drawings, in meters. 

Civil-Millimeters.dwt: Template for civil drawings, in millimeters. 

Mech-Millimeters.dwt: Template for mechanical drawings, in millimeters. 

Template-Millimeters.dwt: Template for drawings, in mi I Ii meters. 
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Overheads 

To download the overhead files for this instructor guide, use the following steps: 
1 .  Type the URL exactly as shown below into the address bar of your Internet browser, to 

access the Course File Download page. 

Note: If you are using the ebook, you do not have to type the URL. Instead, you can 
access the page simply by clicking the URL below. 

https://www.ascented.com/ getfi le/id/hamphodonOH 

New Tab 
_ _ __ .. : . .  + /

address bar of a browser 

➔ c TYPE URL H ERE 

□ X 

* e 
2. On the Course File Download page, click the DOWNLOAD NOW button, as shown below, to 

download the .Z I P  file that contains the overheads. 

3 .  Once the download is complete, unzip the file to  a local folder. The unzipped file contains 
the overheads in a series of PDF files. 
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Schedu le 

If you are using this content as the curriculum in a formal training class, the following schedule 
outlines the approximate time required to discuss and demonstrate the content and have the 
students complete any practice or project material. It is recommended that this content be 
taught over 2 days (16 hours) . Content in the Appendices can be taught if there is time and 
interest. 

Day 1 

Chapter 
Chapter 1 :  Work ing Effect ively with AutoCAD 

Chapter 2: Accurate Posit ion ing 

Chapter 3 :  Projects: Productivity Tools 

Chapter 4: Parametr ic D rawing 

Chapter 5: Work ing w i th  B locks 

Chapter 6: Projects: Creat ing  and Organ iz ing B locks 

Day 2 

Chapter 
Chapter 7 :  Creating Templates 

Chapter 8 :  Advanced Layouts 

Chapter 9 :  Annotation Styles 

Chapter 1 0: Projects: D rawing  Setup and Ut i l it ies 

Chapter 1 1 :  Extern al References 

Chapter 1 2: Projects: D rawing  

Appendix A: Optiona l  Topics 

Appendix B :  Ski l ls Assessment 

© 2023, ASCENT - Center for Technical Knowledge® 

Estimated Time 
1 h r  50min  

1 h r  20min  

30min  

1 hr 20min  

1 h r  35min  

45min  

Estimated Time 
1 h r  30m in  

1 h r  35m in  

1 h r  20min  

30min  

1 h r 20min  

1 h r  

(Optional) 

(Optional) 
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Working Effectively with AutoCAD 
I n  this chapter, you learn how to  use the ribbon, workspaces, and keyboard shortcuts. You also 
learn copy and paste methods to duplicate information between drawings, how to edit objects 
with advanced grip techniques, and how to use additional layer tools. 

Learn ing Objectives :i 1 hr 50min 

• Create and save a custom workspace. 
• Set up the ribbon to dock and hide palettes. 
• Start commands using various methods. 
• Create new objects of the same type and properties as a selected object. 
• Cycle through overlapping objects and select one. 
• Control the transparency and visibility of objects in a drawing. 
• Switch between multiple open drawings using various interface components and 

commands. 
• Copy, move, and paste information from one drawing to another. 
• Modify layers and objects using grips. 
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1 . 1 Creating a Custom Workspace 

As you learn the various ways o f  working with the AutoCAD® software, you need t o  set up your 
personal workspace. You can specify how the ribbon tabs and panels display, which tool 
palettes you want open, and how you want them to be organized, as shown in the example in 
Figure 1-1. When you are finished, you can create a new workspace to save the arrangement. 

y • -1f Share Drawi r  

Home Insert Annotate View Manage Output Add-ins Collaborate Express Tools Fea1 

k-. � □ I1+ @� ii 
Viewpo,1 . . . Named. . .  Model Vi . Coord ina . . .  Compare H istory 

Start Drawing1 • X + 

ITI?, ' [~][Top] IZD Wi reframe] 

Figure 1 -1 

Palettes Interface 

• 0 "" (Workspaces) controls the display of ribbon tabs and panels, tool palettes and other 
palettes, and even the Command Line. You can select from the default workspaces, as 
shown in Figure 1-2, or create a custom version. 
• To maximize the drawing window, you can temporarily toggle off the ribbon and all of the 

tool palettes in the Status Bar by clicking � (Clean screen). The Quick Access Tool bar, 
Command Line, and Status Bar are still displayed. 

✓ Drafting & Annotation 

3D Basics 

3D Modeling 

Save Current As... ;J 
Workspace Settings... 

Customize ... 

Display Workspace label 

� Jt. A 1:1 ... 0 ... + � Q ... �o � Id - 1 

Figure 1 -2 

• The Drafting & Annotation workspace is the default. When you set it to be current, the 
default ribbon tabs and panels display. Any palettes and toolbars that you have displayed 
are closed. Most of the tools you need can be found in the ribbon. 
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How To: Create a Custom Workspace 

1 .  Set up the ribbon as you want it to be displayed. 
2. Open the tool palettes that you want to include in the workspace, close any that you do not 

want to display, and arrange them in the drawing window. 
3. In the Status Bar, expand the Workspace drop-down list, and select Save Current As . . . .  
4. In the Save Workspace dialog box, type a name for the new workspace and click Save, as 

shown in Figure 1-3. 

Save Workspace 

Name: "-I ____________ ___,v I Save 

Figure 1 -3 

• The new workspace becomes the current workspace. 

Cancel  

X 

• Selecting Workspace Settings opens a dialog box in which you can control the display and 
order of the workspaces in the list and add separator lines between names in the list, as 
shown in Figure 1-4. You also have the option of saving or not saving any changes to the 
workspace. 

ll1 Workspace Setti ngs 

� My Workspace = Drafting & Annotatio n  - --�] 

Menu D isp lay and Qrder 

Drafting & Annotation 
f2] 3D Bas ic s  
f2] 3D Model ing 

'{ihen  Switching W orkspaces 

@ Do not save changes to workspace 

Q Automatica l ly  save workspace changes 

OK Cancel  

Figure 1 -4 
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Docking and Hid ing Pa lettes 

Many floating windows and palettes, such as Properties, DesignCenter, and Tool Palettes, can 
remain open at all times. You can dock and hide or anchor them to one side of the drawing 
window. 
To dock a palette, select the title bar and drag it to one side of the drawing window until it 
docks. Alternatively, you can right-click on the title bar and select Anchor Left < or Anchor 
Right >. Allow Docking should be selected for Anchor Left < and Anchor Right > to be available. 
• To hide the docked palette, click • ◄ to minimize it, as shown in Figure 1-5. 

Stllrt Parking-CM• X + 
PROPERTIES 

L ine  

General 
Co lor 

Figure 1 -5 

�� X 

,., 'ti" [ �  � 

■ Bylayer 

• When palettes are hidden, you can display either Text only or Icons only, as shown in 
Figure 1-6. 

Start Parking-CM• X + 
� )( 

..,, Icons only 
Text only 

•JSnr• ... 
Figure 1 -6 

• When the palette is hidden, hover the cursor over the title bar to display the full palette, as 
shown in Figure 1- 7. 

Li ne  

General 

Figure 1 -7 

• To keep a palette open, click t➔ (Auto-hide). 
• To close a palette, click X (Close). 
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• The palettes provided in the AutoCAD software are grouped together in the View tab> 
Palettes panel, as shown in Figure 1 -8 .  

• Open palette icons are highlighted in blue in the View tab>Palettes panel, as shown for the 
Properties palette in Figure 1 -8.  

[ill !] � � ill � ,� 
Tool Propert ies Bloclc:s Count Command Sheet Set 

Pa lettes �-� Macros Manager tra! 0 
Pa lettes • 

Figure 1 -8 

Setting Up the Ribbon 

The ribbon is  the primary place for starting commands. The ribbon can be docked to  the top or 
side of the drawing window, or be kept floating. You can control how much of the ribbon 
displays, and you can drag and drop the ribbon panels to the drawing window or in a ribbon tab. 
• Some of the panels contain extra tools. Click • to expand the panel and display them. Click 

-t:::J (Pin) to keep the expanded panel displayed in the drawing window, as shown in 
Figure 1 -9 .  

+ Move 
o-. -OJ LOpy 

m Stretch 

§"l 
L.7 

II'!!• t.l!J 

I tJ Cl CJ 

G Rotate 

Llb.. Mirror 

5] Scale 

.. :.) t!i 
➔if- � 

Modify 

·i- Trim 

(- Fillet 

88 Array 

1(, □ □  
□� . 

� 1 

Figure 1 -9 

. 
. 10[1 . 

� . 

• Some of the ribbon panels display � in their bottom right corners, which enables you to 
open a related dialog box. 
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Displaying the Ribbon 
When the ribbon is docked at the top of the interface, you can control how i t  displays by clicking 

to the right of the tabs. By default, it is set to Cycle through All, which cycles through the 
display settings of Minimize to Tabs, Minimize to Panel Titles, and Minimize to Panel Buttons, 
as shown in Figure 1-10. 

CD '  
�inimite to Tabs 

Minim!re to Panel Til!es 

Minimize to Pa11el Buttons 

' ,I Cycle tt1 rough All 

0.. A rmuthoo 

Home Insert Annotate View Manage Output Add•ins Collaborate Express Tools Featured Apps CD • 

Start Drawing2" x· + 
Minimize to Tabs 

· ... o e s s  0.. A rmuthoo 

Home Insert Annotate View Manage Output Add· ins Collaborate !:•press Tools Fe,atured Apps C;J • 
V1ewport lool s  Named Views Model Viewports Compare Histor1 v Palettes Interface- � 

Start Drawlng2' X + 
Minimize to Panel Titles 

Home I nsert Annotate View Manage Output Add ins Collaborate 

□ @2J 
Model V i . . .  Compare Hi story Palettes Interface 

SWt Drawingz• X + 
Minimize to Panel Buttons 

Figure 1 -1 0  
• When the ribbon is minimized to tabs, select the tab to display the panels. 
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• When the ribbon is minimized to panel titles, hover the cursor over the title to display the 
commands, as shown in Figure 1-11. 

Home Insert Annotate View Manage Output Ade 
Draw Modify Annotat ion Layers Sl ack Properties � G roups 

_ + Move C Rotate i Trim • -•-

[-J[Tor °di Copy A� Mirror (- F i l let • ,otl 
m Stretch □ 1 Scale 8a Array • \f; 

� !"&1 / . :..) (� 1?1· g�. 

� t'.J O -• .::: �o .J. ,�"' 

Figure 1 -1 1  

Relocating I ndividual Panels 
Ribbon panels can be moved around. You can drag and drop panels to reorder them in a 
specific ribbon tab (but not between different tabs). You can also float an individual panel in the 
drawing window, as shown in Figure 1-12. 

A H Linear • 

/0 Leader • 
Text 

ff!:l rable 
Annotation 

Figure 1 -1 2  

► 

• To float an individual panel, drag and drop it on the drawing window. To re-dock the panel, 
drag it back to the ribbon. 

• If you have a dual-monitor setup, individual panels can be moved to the second monitor and 
left open. 
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Docking/Float ing the Ribbon 
If you want to increase your drawing window space, you can float the ribbon or dock i t  to one 
side of the drawing window, as shown in Figure 1-13 .  The ribbon then becomes like other 
palettes that you can hide and display. 

Q f ,.., j' 0 Wal l s  

i �� = � � � rf!J Make Current Layer 
Properties l?: , � �• @l. Match Layer 

Unsaved Layer State 
� � i.• � :=: � L; 

� Locked 1a ·, er fad 1g 50% 
layers 

z 
0 
00 
00 
iY 

Figure 1 -1 3  

How To: Float and Dock the Enti re Ribbon 

� 

:i.: 

+ 
Modify S" 

◄ 

Annotation 

� 

ft 

Layers 
� 

L, 
::l. 

< 
B lock 

�=]� 
� 

0 
Properties 

◄ 

1 .  Right-click in an empty space in the ribbon and select Undock, as shown in Figure 1-14. 
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Base 

,oard 

Show Related Tool Pa lette Group 
Tool Palette Group 

Show Tabs 
Show Panels 

,/ Show Panel Titles 

Unrlock !)�-----� 
Close 

Figure 1 -1 4  

2. The ribbon floats in the drawing window. I f  you want the ribbon to be docked to the side, 
click and hold on the ribbon title and drag it to the side of the drawing window. 

• When the ribbon is docked, you can click � ◄  (as shown in Figure 1-15) to hide the palette. 

RIBBON 

., 
0 
l: 

Qt 

Start Drawing2• X + 

Draw 

+ 
Modify< 

a 
z=:� 
lay·ers 

► 

Figure 1 -1 5  
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r;/ Hint: Tool Palette Groups 
You can associate a tool pa lette g roup w ith a tab, so that when you r ight-c l i ck  on the tab and  
select Show Related Tool Palette Group, the too l  pa lette g roup automatica l ly opens .  You 
can se lect from exist i ng g roups, as shown i n  F igure 1 - 1 6 . Th is makes it easy to open the 
tool pa lettes you want to use .  

rnotate Paramen-i, 

� Show/Hide 

� Show All 

� Hide All 

Show Related Tool Pa.lette Group 

Tool Pa.lette Group 

Show Tabs 

le 
► 

,. I Show Panels ► ,.. I 

.------- ------+ ,/ Show Panel. Titles 

Undock 

Close 

Figure 1 -1 6  

• I f  a tab does not have a re lated tool pa lette g rou p, the Show Related Tool Palette 
Group opt ion is g rayed out i n  the shortcut menu .  

• When you select Show Related Tool Palette Group, it opens the Too l  Pa lette window, 
if it was not a l ready open .  
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Practice 1 a  

Set Up Workspaces 

Practice Objective 

• Create a custom workspace and switch between workspaces. 

i 5 minutes 

I n  th is  practice, you w i l l  create a custom workspace, as shown in F igu re 1 - 1 7, and note the 
effects of switch ing workspaces. 

Herne Insert Annotate Parametric View Manage Output Add - i ns Col l abo 
Draw Annotation Layers Bloclc Properties • G roups Uti l i t ies Clipboard View _. 

Start Drawing4 x + 
� 

[-J(Top][2D Wi refra me] 

§I + Move G Rotate i: T11m -·-

" �_;; Copy & Mi rror (- F i l l et tw ► m Stretch 5] Scale gg Array Is 
Modify 

Figure 1 -1 7  

1 .  Start a new d rawing  based o n  the default AutoCAD template. 

2. In the Status Bar, expand D "' (Workspaces) and se lect 3D Modeling. Note a l l  the tabs 
and pane ls .  

3. Change back to the Drafting & Annotation workspace.  What a re the d ifferences? 
4. Open the Propert ies pa lette (View tab>Pa lettes pane l  o r  press <Ctr l >+< 1 > ) .  R ight-c l i ck on 

the t i t le  bar  and se lect Allow Docking and Anchor Left < to dock it to the l eft s ide  of the 
d rawing window. 

5. I f the pa lette i s  in the max im ize pos it ion, hover the cursor on  the tit le bar near the top of the 
docked pa lette and c l ick  �◄ to m i n i m ize the pa lette .  

6.  Right-c l ick on the pa lette t i t l e  bar  and se lect Icons only. 
7. Open the Des ignCenter (press <Ctr l >+<2>) and Too l  Pa lettes (press <Ctr l>+<3>) .  Dock and 

m in im ize both of  them to the same s ide  of  the d rawing window as the Propert ies pa lette. 
8. I n  any r ibbon tab, c l ick on the panel bar  (for examp le, the Mod ify pane l  i n  the Home tab) and 

d rag it onto the d rawing window. 

9. Set the r ibbon to Minimize to Panel Titles by us ing .. 
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10. In the Status Bar, expand O ..... (Workspaces) and select Save Current As . . . .  
11. I n  the Save Workspace dialog box, type My 2D Workspace and click Save . I n  the Status Bar, 

expand O • (Workspaces) and note that the new workspace is listed there and is 
currently active. 

12. Switch to the Drafting & Annotation workspace. What are the differences? 
13. Stay in the Drafting & Annotation workspace and close the file. Do not save it. Your 

workspace is still available to use in other drawing files. 

End of practice 
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1 .2 Using the Keyboard Effectively 
The Command Line and Dynamic Input use information typed on the keyboard, as shown in 
Figure 1-18 . For example, you can start the Line command by typing the command name (line) 
or shortcut (L) .  When you press < Enter> to start the command, its options display in the 
Command Line. To use one of the options, you can type the capitalized letter(s) of the option or 
select it in the Command Line. 

m 
S ecif first oint: 

\t X ; ,., LINE Specify next point or [Undo ] :  

Model' Layoutl layout2 + 
Figure 1 -1 8  

• All AutoCAD command can be typed in the Command Line or Dynamic Input. 

• [Q (Dynamic Input) should be toggled on (in the Status Bar) for the command prompts to 
display at the cursor location. 

• To use typed commands, you must know the exact command name and spelling. For 
example, the command to draw polylines is pline, not polyline. 

• You can start typing the first letters of a command name and then select the command in 
the AutoComplete list. 
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• You can quickly search for additional information about a command or system variable in 
the AutoComplete suggestion list. Hover the cursor over the required item in the list. A 
tooltip displays, providing a description of the command's functions, as shown in the left of 
Figure 1-19 .  

• The Autocomplete list in the Command line also provides the Search in Help or Search on 
Internet icons, as shown in the right of Figure 1-19 .  

trn:�� 
, L (LINE) 
• • LENGTH (DISTI 
� LA (lAR8) l ( L H IE ) 

. . .  lAYOUhSNE (:XUNE) 
ffl LI � Manages la1ers and layer properties 

• • L ENGTH (DIS  r )  

.:ftJ LA ( LAYER)  

Use layers to control the v1s ,btl 1ty of obJects ,md t< 
properties such 35 cotor and hnectype. ObJe<ts on , 

. · • LAYOUT L INE (XL I NE ) 

H. u ( U ST ) 

assume the properties of th� layer, However, you • LAVI so 
any layer property of an obJeCL for example, ,f an ---' LAYF RZ 
property 1s set to 8YtAYER. the obJect d isplays theL .. -, 
l ayer, If the ob;ect's color 1$ set to Red. the Object LAYEREVAL 
regardless or tile cotor assigned to that layer. :- Bfock: TBLK-ANSI EXPANDED A (1 1 .0 . . .  

-;; LAYER 

Press F1 for more help 

Figure 1 -1 9  
• You can easily reuse any command or number that you have typed. Press <Up Arrow> or 

<Down Arrow> to scroll through your typed input, and press <Enter> when you reach the 
command that you want to reuse. 

• You can quickly select from a list of the most recent commands by expanding >- "" in the 
Command Line. 

• You can also copy and paste information from the Text Window to the Command Line. 
Highlight the text, right-click, and select Paste to Cmdline . 

Command Al iases 

Rather than typing the entire command name, you can use abbreviations called command 
aliases. The following aliases are some of the standard ones in the AutoCAD software. 

Note: Click E:1 (Command Aliases) in the Express Tools tab> Tools panel to define or 
modify command aliases in the file acad.pgp. 
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. To locate most commands ,  try typ ing  the fi rst character of the command,  then try the fi rst 

two, and then try the fi rst th ree. Other commands use var ious letters .  

Alias Command Alias Command 
A Arc LT L inetype 

AA Area M Move 

AR Array M l  M i rror 

B B lock MS Mspace 

BR B reak 0 Offset 

C C i rc le OS Osnap 

CHA Chamfer PE Pedit (Poly l i ne Ed it) 

CO, CP  Copy PL P l i ne  (Poly l i ne) 

D D imstyle PR Propert ies 

DAL D ima l i gned PS Pspace 

DAN D imangu la r  PU Purge 

DBA D imbase l ine R Redraw 

DCO D imcont inue RA Redrawa l l  

DD I  D imd iameter RE Regen 

DI D istance REC Rectang (Rectang le) 

D IV Div ide REN Rename 

DL I  D im l inear RO Rotate 

DRA D imrad ius s Stretch 

E Erase SC Scale 

ED Texted it ( dded it) SP Spe l l  

EX Extend T, MT Mtext (Mu lt i l i ne  Text) 

F F i l l et TR Tr im 

H Hatch u Undo 

HE  Hatched it V View 

I nsert w Wblock 

L L ine X Explode 

LA Layer z Zoom 
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Shortcut Keys 

Another quick way to launch commands or change settings is to use the shortcut keys (also 
called accelerator keys). Many of these keystrokes follow the Microsoft Office standard. 
To use the default shortcut keys, press <Ctrl> and a letter or number. You can also define 
customized key combinations in the Customize dialog box. 

+<A> Select Al l  +<N> New drawing 

+<B> Snap on/off +<O> Open d rawin g  

+<C> Copy to the C l i pboard +<P> Plot 

+<D> Dynamic UCS on/off +<R> Cycles l ayout viewports 

+<E> Togg le  I sometr ic p lane +<S> Save 

+<F> Object Snap on/off +<T> Tablet on/off 

+<G> Grid on/off +<U> Polar on/off 

+<J> Executes last command  +<V> Paste from the c l i pboard 

+<K> Create Hyperl i nk  +<W> Select ion cyc l i ng  on/off 

+<L> Ortho on/off +<X> Cut to c l i pboard 

+<1 > Propert ies pa lette on/off +<7> Markup Set Manager on/off 

+<2> DesignCenter on/off +<8> Qu ickCalc on/off 

+<3> Tool Pa lettes on/off +<9> Command L ine on/off 

+<4> Sheet Sets on/off +<0> (zero) C leanscreen on/off 

Function Keys 

Function keys control most of the toggles for the drafting settings and several other features. 

<F1 > Help <F7> Gr id on/off 

<F2> Text Screen <FS> Ortho on/off 

<F3> Osnap on/off <F9> Snap on/off 

<F4> 3DOsnap on/off <F1 0> Po la r  on/off 

<FS> l sop lane switch <F1 1 > Osnap Tracki ng on/off 

<F6> Dynamic  UCS on/off <F1 2> Dynamic  I n put on/off 
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Practice 1 b  

Use the Keyboard Effectively 

Practice Objectives 
• Draw objects using keyboard commands. 
• Use various techniques for entering information. 

i 5 minutes 

In this practice, you wil l  draw lines, circles, and trim objects (as shown in Figure 1-20) using 
keyboard commands. You wil l  select commands in the AutoComplete l ist using partial 
keyboard commands. You wil l  also be able to toggle Command Line on and off using keyboard 
commands. 

1 75 

R25 

- 65 -, 
--·- - 1 30 -- ----

Figure 1 -20 

,- R25 ! 
i 

r 1 00 

50 

t l 

1 .  Start a new drawing based on Mech-Millimeters.dwt, which is located in your practice fi les 
folder. 

2. Draw the objects shown above in Figure 1-20. Use the command aliases L (Line), C 
(Circle), and TR (Trim) to start the required commands. Type the distances using Polar 
Tracking and Dynamic Input. 

Note: Verify that � (Dynamic Input) is toggled on so that command prompts display at 
the crosshairs. 
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3. Set the layer to Dimensions. To test the AutoComplete list of command names, type D and 
select DIM (the shortcut for Dimension command) in the list. This starts the command. 
Dimension the objects. If the Select Annotation Scale dialog box opens, set the Scale to 1 :1 
and click OK. Use other dimension commands such as Linear and Radius, as required. 

4. Save the drawing as Jig.dwg and close it. 

End of practice 
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1 .3 Object Creation, Selection, and Visibi l ity 

Object Creation 

You can use Add Selected to create new objects of the same type and properties as the 
selected object. Select an object, right-click, and select Add Selected as shown in Figure 1-21. 
The AutoCAD software launches the command that was used to create the selected object and 
sets some of the properties (such as the layer or color) to be the same as the original object. 

Rotate 
Draw Order 
Group 

•• Add Selected 

Select Simi l a r 

Deselect All 

Figure 1 -21 

Selecting Simi lar Objects 

> 
> 

You can use Select Similar (as shown in Figure 1-21) to select an object and automatically 
select other objects of the same type and properties at the same time. For example, if you 
select a red rectangle on the layer Walls, all of the other red rectangles on the layer Walls are 
also selected. 

How To: Select Simi lar Objects 

1 .  Select an object. 
2. Right-click and select Select Similar. All of the other objects that match the settings are 

selected. 
• If you select more than one object and then use Select Similar, all of the objects that match 

the properties of all of the selected objects are selected. 

How To: Modify Select Simi lar  Settings 

1 .  Without any object selected, at the Command Line, type or dynamically input selectsimilar. 
2. At the Select objects prompt, press <Down Arrow> and select SEttings. 
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3. In the Select Similar Settings dialog box (shown in Figure 1-22) ,  select the property types 
by which you want to filter the selection set. 

g Select S imi lar  Sett ings X 

Simi lar  Based On 

D �olor 

[;2] l,ayer 

0 Linetype 

D Line!'fpe scale 

D Line'{;eight 

0 .Elot style 

0 Object .§lyle 

G2J Name 

OK 

L �e lp  

Figure 1 -22 

• The properties that are set in the dialog box are used to filter the selection process. The 
objects that are selected have the same properties. 

• If you clear the Name option in the dialog box, the command looks for all of the objects that 
match the properties no matter what type they are. 

Object Selection Cyc l ing 

I f  you need to select an object in a location in which many objects overlap, you can use Object 
Selection Cycling. When it is toggled on, and you hover the cursor over an area where some 
objects are overlapping, Qi displays, indicating that more than one object can be selected. 
Clicking on the object displays the Selection dialog box where you can select an object from the 
list, as shown in Figure 1-23. 
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Figure 1 -23 

How To: Use Object Selection Cycl ing 

1 .  In the Status Bar, toggle on +r (Selection Cycling) . 

L 

2. Hover the cursor over some overlapping objects close to where the objects intersect. 
Qi displays, indicating that there are overlapping objects. 

3. Click to open the Selection dialog box. 
4. Select the object that you want to use. 

Object Visibi l ity 

You can control whether objects are displayed or hidden in the drawing. The Isolate Objects, 
Hide Objects, and End Object Isolation commands control this display. 

Isolate Objects 

Hide Objects 

End Object Isolation 

Select the objects that you want to iso l ate, r ight-c l ick, and se lect 
lsolate>lsolate Objects. The se lected objects d i sp lay and  a l l  other objects 
are h idden .  

Select the objects that you want to h ide, r ight-c l i ck, and se l ect lsolate>Hide 
Objects . The se lected obj ects a re h idden .  

Rig ht-c l i ck anywhere i n  the d rawing window and se lect lsolate>End Object 
Isolation.  Al l  h i dden objects d i splay. 

• If a drawing contains hidden or isolated objects, m (Unisolate Objects) (highlighted) 
displays in the Status Bar. 

• If a drawing does not contain hidden objects, 'i0 (Isolate Objects) displays in the 
Status Bar. 
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How To: Isolate or Hide Objects 

1 .  Right-c l ick and select lsolate>lsolate Objects or Hide Objects, as shown i n  F igure 1 -24. 

You can also use 11° ( lso late/ H ide/Un iso late) i n  the Status  Bar. 

'0 

m t!U ll 
&epeat UNI SOLA 71:0BJECTS 
Recent Input 

Clipboard 

g;olate ► 1 □ Isolate Objects 
'; t!1de Objects � 

·<;,. Undo Pan 
�-- [ied0 

c, �d Object Isolation Uri+-.' ",... ______ _, 
:e:J Pg_n 
±0. £Com 

Figure 1 -24 

2. If you selected objects before sta rt ing  the command, the objects a re h idden or iso lated . I f  
you d id not sel ect objects, y o u  a re prompted t o  se lect them. 

3. To d isp lay the iso lated o r  h idden objects, r ight-c l i ck  and  select lsolate>End Object Isolation 

or  c l ick � (Un iso late Objects) i n  the Status Bar, and se lect End Object Isolation. 
• If o bjects a re a l ready h i dden o r  iso lated, you can add add it iona l  objects to the iso lated 

se lect ion set by c l ick ing � (Un iso late Objects) in the Status  Bar, and select ing  Isolate 
Additional Objects, as shown i n  F igure 1 -25 .  

1 -22 

Iso late Add itional Objects 

Hide Objects 

End Object Isolation 

O · + � •·• n 
Figure 1 -25 
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Setting Transparency 

Transparency can be applied to objects similar to applying other properties (such as Layer, 
Color, or Linetype). It can be set individually, Bylayer, or ByBlock . It is very useful when 
displaying hatches, as shown in Figure 1-26. 

Transparency = 0 

-· -

: " ,-t·· -�- - --- - - - - ,,.__  _ _ _  _ 

� 1 "-'-'"'."""'" . --
1 • -

I L l. w f 
L.:::::::: 

\ 

Transparency = 50 

Figure 1 -26 

• Transparency values vary from O (least transparent) to 90 (most transparent). 
• When you are creating or editing objects, you can set the transparency in the Home tab> • 

expanded Properties panel. You can also expand the Transparency drop-down list and 
select one of the options shown in Figure 1-27. 

� ■ Bylayer 
2!:_ �  = 

Match 
= --- Rylayer 

Properties ,:.: --- Bylayer 

!!l1:J • r nsparency 1 1  

;;;;;· 6yLayer Transparency 

� ByBlod Trnnsparen,;y 

Figure 1 -27 
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• Transparency is also available in the Properties palette when objects have been selected. 

• You can toggle � (Transparency) on and off in the Status Bar. 
• Transparency can be set in the Layer Properties Manager, as shown in Figure 1-28. It can 

also be modified by layer in a viewport. 

)• Current layer. Object SeardI for layer 0, 

i:. q. f7 I � 0 ::_, a. f3. C (t 
F i l ters « S ... Name 

I Q 
• 0 . .  F ... L.. P ... Color linetype lineweight 

El i1 All 
. E:i, All Ust .,,,, Border 

.,,,, Center 
.,,,, Constructi . . . 

ffi .,,,, Defpoints 

� .,,,, Dimensions 
� .,,,, Hatching 

:;; .,,,, H idden 

� v Object 

• � ■ wh . . .  
f • � ■ blue 

■ 54 

Continu  . . .  
Continu . . .  
CENTER 
DASHED 

- Defa . . .  
- 0.50 . . .  
- 0.25 . . .  
- Defa . . .  

Layer Transparency 

Iransparency va lue (0-90): 

Transp . . .  N .. Description 
0 � 
0 � 
0 :r; 
0 � 

X 

� 1 Text 
0 
� _I < _____ >�I .,,,, Viewports 

OK Cance_'..__J [ t!elp 

D I nvert fi l « < 

� All :  1 1  l ayers d isp layed of 1 1  total l ayers 

Figure 1 -28 

• Transparency can be set for Match Properties, as shown in Figure 1-29, and for Quick 
Select and Filter. 

' Property Settings 

Bas ic  Prope rties  

D rolor  

□ Layer 

O Linetype 

D Linel)'pe Scale 

D Linel!Yeight 

( G2] Transparency 

n[hicknesS: 

■ Bylayer 

Object 

Bylayer 

1 .0000 

Bylayer 

Bylayer) 

Figure 1 -29 

X 

OK 

Cancel 

Help 

> 
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• To plot transparent objects, select the Plot transparency option in the Plot dialog box, as 
shown in Figure 1-30. This is toggled off by default because the file must be converted into 
raster for the transparency to plot. 

Plot o pt ions 

D Plot i n  bac�ground 

D P lot object l ineweights 

( 12] Plot transparency ) 

0 Plot with plot stylgs 

0:Plot paperspace __ l ast 

D H ide  paperspace objects 

D Plot stam p  on 

D Sa',,'.e changes to l ayout 

Figure 1 -30 
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Practice 1 c  

Object Creation, Selection, and Visibi l ity 

Practice Objective 

• Modify the display of objects using various commands and options. 

:i 5 minutes 

In this practice, you will modify the way objects display in a drawing using Select Similar, H ide 
Objects, and Isolate Objects. You will also modify the display of objects using the 
Transparency option. 

Task 1 :  Use selection and visibi l ity tools.  

1 .  Open Office-Plan1-AM.dwg from your practice files folder. 

2. In the Status Bar, ensure that �a ( Isolate Objects) is displayed. If not, select it from the = (Customization) list. 
3. Select one of the double sided corner desks on the layer Cubicles (blue color). 
4. Right-click and select Select Similar. All of the double sided corner desks are selected, as 

shown in Figure 1-31. Press <Esc> to exit the command. 

Figure 1 -31  

5 .  Select one of  the red desks and one of  the red chairs and use Select Similar. All of  the 
chairs are selected along with a few desks (there are different types of desks; only those 
desks which are similar to the selected one are selected) . 
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6. In the Status Bar, click �o (Isolate Objects) and select H ide Objects. Note how the selected 
� 

objects are hidden and _£j (Unisolate Objects) is highlighted in the Status Bar. 
7. Use Select Simi lar to select the rest of the furniture (red-colored furniture objects). Hide 

them as well (� (Unisolate Objects)>Hide Objects) . You might have to select some red 
objects individually and hide them. 

,-□al 
8. In the Status Bar, click � (Unisolate Objects) and select End Object Isolation to unhide 

the objects. 

Task 2: Modify object transparency. 

1 .  Toggle on the layer Hatching. 

2. In the Status Bar, toggle on ffl (Transparency). 
3. Select one of the hatches. 
4. In the Hatch Editor contextual tab>Properties panel, for the Hatch Transparency, use the 

slider bar to increase it and note that it lightens the selected hatch. Close the Hatch Editor. 
5. Open the Layer Properties Manager. 
6. In the Hatching row, set the Transparency value to 50, as shown in Figure 1-32. 

S ... Name A 0 . . F . . .  L. . .  P . . . Co lar Linetype Lineweight Transp . . .  N . .  Description 
.I 0 " �  ■ wh . . .  Continu . . .  - Defa . . .  0 .r' 
I Border � ■ blue Continu . . .  - Defa . . .  0 ,r; 
I Cubic les � 0 1 32 Con tinu . . .  - Defa . . .  0 .r' 
I Defpoints ■ wh . . .  Conti nu  . . .  - Defa . .. 0 _r1 

.I Dimensions = red Contin u . . .  - Defa . . .  0 .r' ...., 
.I Doors � 0 40 Continu . . .  - Defa . . .  0 t' 
I E lectrical " � □ 1 32 Con tinu  . . .  - Defa  . . .  0 .r' .,. Furnitu re � [:I red Contin u  . . .  - Defa

� 
..  .r· 

I Hatch ing ,; � red Cont inu . . .  - Defa . 50 r" 
I Headers � ■ wh . . .  Conti nu  . . .  - Defa . . .  r 

.{_), r7 " "  r' 

Figure 1 -32 

7. All of the other hatches (except the one selected in Step 3) are lightened because they are 
all on the same layer, and each of their Transparency options is set to Bylayer. 

8. Save and close the drawing. 

End of practice 
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1 .4 Working i n  Multip le Drawings 
You can open multiple drawings in the same session of the AutoCAD software, as shown in 
Figure 1-33. This can make it easier to copy information across drawings. 

Start Office-Planl ·A• Bea r:ing Dimensionst -t• X Wheel - Section- I  + 
[-]!Top][20 Wireframe] 

Figure 1 -33 

By default, the Files Tab bar is displayed along the top of the drawing window and has the = (Files tab menu), and the Start tab always displayed. The Start tab is the first active tab and 
clicking it displays the initial Start window, which contains tools to create new drawings, open 
existing ones, open the recently used files, and many other file and help related options. 

Fi le  Tabs 

The File Tabs or the Drawing Tabs along the top of the drawing window are an easy way to 
switch between open drawing files and the initial Start window. 

Switching Windows 
The File Tabs along the top of the drawing window display the names of the open drawings. 
• The names of all of the open drawings display as tabs in the File Tabs bar. The currently 

active drawing tab displays with a white background. 
• They display in the order in which they are opened, but you can change their order by 

dragging and moving the tabs. 
• You can cycle between the drawings by pressing <Ctrl>+<Tab> or by selecting the required 

file tab in the File Tabs bar. The selected drawing tab opens the drawing and makes it active. 
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• At the beg inning of the Files Tab bar is the (Fi les tab menu), which displays a complete 
list of open files, as shown in Figure 1 -34. Here you can select the required f ilename to 
switch to that open drawing file. You can hover your cursor on a drawing to display all the 
layouts for that drawing and open the drawing in the required layout tab, as shown in 
Figure 1 -34. The Fi les tab menu also provides you with opt ions to create or open a drawing 
along with saving and closing all drawings together. 

Start Office-Plan l A• 

Start 

Office Plan l ·A· 

• Bea ring Oimensions t - I• 

Whei?!-Sect ion -1 

+ New Drawing 

D New . . . 

le, Open .. . 

El Save All 

'Ca Close All 

Bearing Dimens ions 1 - I•  X Wheel-Section -I + 

C:\AutoCAD 2024 Fundamen als Practice Fdes\Office Pla n 1  A.dwg 

Model A Srzed D Srzed 

Figure 1 -34 

• You can also open and make another drawing active by clicking tc:l (Switch Windows) in 
the View tab>lnterface panel, and then selecting the drawing from the l ist, as shown in 
F igure 1 -35 .  

S?7 �J I, I B Tile  Horizontal ly 

S . h . OD Ti le Vertica l ly w,tc • F i le  Layout 
Wind� Tabs Tabs � Cascade 

C:\AutoCAD 2020 Fund Practice Fi les\Office­

Drawing5 .dwg 

✓ Drawing6 .dwg 

Figure 1 -35 

• If you want all of the open drawings to display together, click E5 (Ti le Horizontally), DO (Tile 

Vertically), or licJ (Cascade). 
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Floating Windows 
You can d isp lay mult ip le  d rawings at the same t ime as float ing w indows.  The f loat i ng  d rawing 
tabs enable you to work on  mu lt ip le  d rawings s ide by s ide without hav ing to switch between 
tabs .  
• You can pu l l  (c l ick and d rag) the d rawing tabs and d isp lay them as  separate d rawi ng 

windows, as shown i n  F igure 1 -36 .  

1 

;< 

137 50 

162 SO 

200.00 

tiZt.2.Wf.t&.i!· ·i €44-4i4·iuiJI· aamm.LG.Uil.!ltifiWii 

Figure 1 -36 

..... J 

S..,,rt(� J F,M- ] "'"'"l LU 
W1noo.,..,, 1 . .T•b�. __ Tabs. rra Cil..cad• 

lt11t>rf.l(.� 

• As w ith any other w indows funct ion ,  you can res ize the windows, p lace them s ide  by s ide or  
let them over lap one on  top of the other. I f  you have a second mon itor, you can eas i ly  d rag 
the floati ng d raw ing o nto that screen and have the two d rawing  f i les d i sp layed on two 
separate screens s ide by s ide .  

I f  you want to  keep the d rawing i n  the over lapp ing mode, then the currently active d rawing 

remains on top.  I f  you want to keep the floati ng w indow a lways on top, c l ick  - to p in  it .  
It ignores the active d rawing and a l l ows the float ing d rawing to a lways stay o n  top of the 
main app l ication  window. 
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• The floating window has its own Command Line, Dynamic Input, and Layout Tabs bar. 
• The ribbon, the Quick Access Tool bar, and the Status Bar are only available in the main 

application window, but you can use them in the floating drawing window as well . These 
tools are associated with the drawing that is currently active. To make the drawing current, 
click inside it and the cursor displays in the current drawing. 

• If you do not want to have the floating drawing tabs as separate windows, you can simply 
drag and drop the floating drawing window back onto the File Tabs bar, as shown in 
Figure 1-37. 

= Start Office Planl A• 

-1rropJ12D WlreframeJ 
... g 

: I 

Figure 1 -37 

Appearance and Preview 
The file tabs include some visual tools. 
• A drawing file that is open as read-only is indicated by a lock on its tab. 

ft □ X 

• A drawing file that has been modified since its last save is indicated by an asterisk on 
its tab. 
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• To d isp lay a preview image of the model tab and layouts of any other  open d rawing,  hover 
the cursor over its fi lename tab, then hover the cursor over one  of the p rev iews to h igh l i ght 
it, as  shown i n  F igure 1 -38 .  Se lect the preview to switch to that model  or l ayout. 

Start Office Planl A� Bearing Otmensions1 1· Be1mng Oimens1ons2 M .. Bank. layouts 

C:\AutoCAD 2023 Fund Metnc\Pract1ce Files\AutoCAD 2023 Fundamentals Practice F 1 1es\Beanng 01mensions2 M.dwg 

� 

Model ISO AO ISO AI  ISO A2 ISO A3 ISO A 

\ 

Figure 1 -38 

When a prev iew image i s  h i gh l i ghted, the i cons at the top of the preview enab le  you to 

1�1 (Plot) o r  [sj (Pub l i sh) it. 

Shortcut Menu 
You can r ight-c l ick on any fi le  tab to  d i sp lay a menu  (shown i n  F igure 1 -39) with var ious fi le  
com mands, inc lud ing opt ions to create, open ,  save, and c lose f i les .  

Start Office-Planl A• 

·- J[Top][2D Wireframe] D New ... 

O Open ... 

El s,we AII 

Close 

� Close AII 

Close AU Other Drawings 

Copy ful l  file Patil 

Open file Location 

Figure 1 -39 

You can use Close All to close al l of the d rawings except the 
Start tab. 

Wh••l·S•<lion- 1 •  X 

(F i le  tab menu) and the 
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• Select Close All Other Drawings to close al l of the drawings except the = (File tab menu), 
Start tab, and the drawing where you opened the shortcut menu from. 

• Selecting any of the closing options prompts you to save/discard the drawing files that have 
any changes that were not saved prior to closing them. 

• Other options include copying the ful l  file path to the cl ipboard and opening the fi le location 
in Windows Explorer. 

Toggle Fi le Tabs On/Off 
By default, the File Tabs bar displays along the top of the drawing window. However, when 
maximum screen real estate is more important, you can hide the File Tabs bar by toggling 
� (Fi le Tabs) off in the View tab> lnterface panel, as shown in Figure 1-40. 

Svvitch 
Windo·Ns 

� c;,:J 15 Tile Horizontally 

.1 OD TIie Vertically 
Fi e ayout 

Tabs Tabs lieJ cascade 

Interface 

Figure 1 -40 

Selecting Drawings in  the Appl ication Menu 

The Application Menu provides access to al l  of the already saved open drawings and recently 
used drawings, as shown in Figure 1-41. 

Recent 
Documents 0 New 

[) Open 

Save 

&J J,J d] Recent Documents 

• ►► --d SharE 

By Ordered List .,. -······· .,,. 

!l;f Office-Plan 1 -A.dwg 

9i Bearing Dimensions2 - 1 .dwg 

Dimensioned Plan2-Adwg 

9: Bearing Dimensions 1 - l .dwg 

Figure 1 -41 

• When you hover the cursor over a drawing name, a thumbnail of the drawing disp lays. Hover 
the cursor a while longer to display more information about the fi le. 
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• Click � (Recent Documents) to display a list of recently used drawing files or click 

(Open Documents) to display a list of open drawing files. 
• You can customize the way the drawings are listed and displayed, as shown in Figure 1-42. 

By Order!!d List t:i, :::::, • 
-.I By OrderM Lst 

dwg 

d M  

By Ordered List • = • 

Data f:(tractlon 
Sam;,1e.dw9 

Figure 1 -42 

✓ Small lcons 

Large loom 

• Expand Q (Close) in the Application Menu to close either the current drawing or all open 
drawings, as shown in Figure 1-43. 

dose the drawing 

� 
Current Drawing 
Close the current drawing . 

All Drawings 
Close all currently open drawings ,  

Figure 1 -43 
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1 . 5 Copying and Pasting Between Drawings 
You can place i nformat ion on  the c l i pboard by copyi ng o r  cutt i ng  i t  from a docu ment. You can 
then paste the i nformat ion from the c l i pboard i nto the same document or i nto a d i fferent one, 
even i n  a d ifferent app l ication .  To copy, move and paste i nformat ion between d rawi ngs you 
must use the Windows Copy command .  The AutoCAD Copy command does not work between 
drawings .  
• The vari ous Cut, Copy, and Paste commands are ava i l ab le  i n  the Home tab>C l ipboard panel  

and  i n  the shortcut menu .  

Cut to the Cl ipboard 
When us ing the Windows Cut command,  you have the fo l lowi n g  opt ions :  

� 
Cut Cl ip 

+:i Cut with L � Base Point 

Removes the selected objects from the i r  f i le  and  p laces them on the 
c l ipboard .  

Enab les you t o  select the base point before se lect ing t h e  objects t o  b e  cut. 
This option provides more control over the location of the objects when they 
are p laced . The base po int is  on ly s ign i ficant when the o bjects a re pasted i nto 
the AutoCAD software. 

Copy to the Cl ipboard 
When us ing the Windows Copy command,  you have the fo l l owing opt ions :  

L[J 

r · - 1  
-+ 

NA 

Copy Clip 

Copy with 
Base Point 

Copy Link 

Copies the selected objects to the c l i pboa rd, us ing  the lower left corner of the 
bound ing  box of al l  of the objects as the base po int .  <Ctrl >+<C> starts the 
command .  

Enab les you  to select t he  base point before the  objects a re sel ected. Th is 
opt ion p rovides more control over the locat ion of the objects when they are 
p laced.  The base point is on ly s ign if icant when the objects a re pasted i nto the 
AutoCAD software. 

Type copyl ink at the Command Line.  I t  copies the contents of the cu rrent view 
to the cl i pboard.  

Paste from the Cl ipboard 
When us ing the Windows Paste command,  you have the fol l owing opt ions :  

ID Paste 

Paste as Block 

Prompts you to select a location for the base po int at which it then 
p laces the objects .  <Ctrl>+<V> sta rts the command .  

The copied objects a re p laced as a b lock. The AutoCAD software 
g ives the block an arbitrary name.  Th is option is on ly ava i l ab le  if 
the objects on the c l i pboard a re AutoCAD objects .  
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Paste to Original 
Coordinates 

Paste as Hyperl ink 

Paste Special 

Drag-and-Drop Copying 

Places the objects a t  the same coord i nates a s  i n  the drawing from 
which they were taken .  Th is opt ion is on ly ava i l ab le  if the objects 
on the c l i pboard are AutoCAD objects. 

C reates a hyperl i nk  of an  object, text o r  fi l e  a l ready copied to 
c l ipboard, and then associates it with another object . 

Enab les you to control the format of an  a l ready cop ied data wh i le  
past ing it i nto the act ive draw ing .  

When two drawing windows are open, you can also drag and drop objects to copy them from 
one drawing into another. 

How To: Copy Using Drag and Drop 

1 .  Without a command running, select the objects that you want to copy. 
2. Hold the mouse button with the cursor on the objects (do not select a grip). 
3. Drag the objects into the other drawing window and release the mouse button. 

Match Propert ies Across Drawings 
'iiil 
-� " (Match Properties) works across drawings. You can select an object in one drawing and 
apply its properties to objects in another drawing. 
Match Properties works for general object properties, such as color, linetype, and lineweight, 
and for the formatting of some specific object types, including text, dimensions, hatching, and 
tables. 

•l 
.:::::.. " (Match Properties) is located in the Home tab>Properties panel. 

1 -36  © 2023, ASCENT - Center for Technical Knowledge® 



Working Effect ively with AutoCAD 

Practice 1 d  
Work in Mu ltiple Drawings 

Practice Objectives '.I 1 0  minutes 

• Switch between drawings and display them as floating windows. 
• Copy and paste objects between drawings. 

In this practice, you will switch between multiple drawings using file tabs and Open Documents. 
You will display drawings side by side by separating the drawing windows. You will then copy 
and paste objects between the drawings, as shown in Figure 1-44 . 

= Start Bighouu- 1 -AM� X + 
·][Tqpl(2D Wirefr,nni:!) 

;::; Mo<ll'I 1<;;v ;,. :.J 1sn -3 + 

X • ::) ... 

ISO AO ISO A 1 ISO Al ISO A3 fSO AJ Portrait + 

Figure 1 -44 

1 .  Open Bighouse1-AM.dwg and Floor Plan-AM.dwg from your practice files folder. Close any 
other open drawings. 
• You can use < Ctrl> to select both files in the Select File dialog box and click Open to 

open them together. 
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2. If not already active, in the Fife Tabs bar, select the Bighouse1 -AM.dwg tab to activate it. 
Hover your cursor over the Floor Plan-AM.dwg tab to display the preview images of the 
drawing and its layouts, as shown in Figure 1-45. Select the Model preview to switch to 
Floor Plan-AM.dwg with its Model tab active. 
• Depending on the selection of the filenames while opening them, your drawing tabs 

might be reversed. You can click and drag them to display as shown in Figure 1-45. 

Start Bighouset -AM X Floor Plan AM X + 
C:\AutoCAD 2024 Fundamenta l 

Model ISO A0 ISO Al  

Figure 1 -45 

3. Thaw the layer Text (in Floor Plan-AM) . 

4. In the Application Menu, click (Open Documents) and display the thumbnails of the two 
drawings by hovering the cursor over them, as shown in Figure 1-46. Select 
Bighouse1-AM.dwg to make that drawing current. Press <Esc> .  

c£J -� .... � Open  Do cum ents 

·- • 
O N ew ► 

B o pen 

Save 

t·f( B i g h o u s e 1 -AM . Wg . ..,. 
•·'Ill! F l o o r  Pl a n -AM. 

Figure 1 -46 

C:\AutoCAD 20, 
AM.dwg 

5. Click, hold, and drag Floor Plan-AM.dwg out of the File Tabs bar and place it adjacent to the 
Bighouse1-AM.dwg as shown in Figure 1-47. 

Note: I f  you have a second monitor, you can move Floor Plan-AM.dwg to tha t  screen 
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6. Resize the Floor Plan-AM drawing window so that it is completely inside the main drawing 

window and click to pin on top, as shown in Figure 1-47. 
7. Zoom to the extents of the Floor Plan-AM.dwg, as shown in Figure 1-47. 
8. Click inside Bighousel -AM.dwg so that the cursor is now active inside its window. Pan and 

zoom such that the Primary Bedroom (upper left corner of floor plan) is displayed in the 
drawing window, as shown in Figure 1-47. Note that when you click inside the 
Bighousel -AM.dwg, the Floor Plan-AM.dwg still stays on top as it has been pinned there. 

,sl )2 
X 

TOI 

1 :  . , : ,  1,c� 
Kitchen 

Uving.iF amily 
R.oom 

_ Mod�! ISOAC ISO A I  !SOA:2 lSOA3 !SO M Portrint + 

Figure 1 -47 .. . 
9. Ensure that your cursor is active in the Bighousel -AM.dwg . Start the I� ',c (Match 

Properties) command (Home tab>Properties panel). Select the text PRIMARY BEDROOM 
as the source object. Note that the cursor changes into a brush with a little square. 
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10. Click inside Floor Plan-AM.dwg once to activate it (the brush cursor is now available in 
Floor Plan-AM.dwg). Select each of the text labels in Floor Plan-AM.dwg as the destination 
object, as shown in Figure 1-48. Press <Enter> to exit the command. The text properties 
are matched in both drawings. 

Start s;ghou,e1 •AM" X + 
· J [Top]l20 WireframeJ 

,r 
� 

\ i 

. -� til 
i 

floo, Plan-AM,dwg" 

{-l[Tcp]l2D Wireframe) 

y 

1 1 
..-- . l., 

' 

L
J 

--- - ··
1
===::.-i 
1 =  ' J 

,. . .J 

" 
l • , .  ' 

6 • •  - · ,  • • • 

_3 � )( ,Ji' E;J• PAINTPROP Select destination object ( , )  or [ Settings ] :  
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Figure 1 -48 

ISO A2 ISO A3 ISO A4· Portrait + 

11. Make Bighouse1 -AM.dwg the active window by clicking in it . In the Home tab>Clipboard 

panel, click f
r
'l (Copy with Base Point) . For the basepoint, select the corner of the walls 

behind the fireplace (in the primary bedroom). Select the fireplace (they might be separate 
objects) and the short diagonal walls that frame it, as shown in Figure 1-49 . Press < Enter>. 

Basepoint 

t ,--I Se-lect-ob-�ects:----.1 

Figure 1 -49 
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12. Click inside Floor Plan-AM.dwg once to activate it. In the Home tab>Clipboard panel, click 

ID (Paste) . For the insertion point, select the top left corner of the larger bedroom to paste 
the fireplace there. 

1 3 . Click, hold, and drag the Floor Plan-AM.dwg drawing window back on the File Tabs bar, as 
shown in Figure 1-50 .  

_ Stan Bighous�t-AM� 

JfTopJ [20 WireframeJ 

....... T- .-.. ..... " -
._� I 

NDH 

� "  .f' :::i• 
_ Mbd�I l�JAG l :) 4.1 W ;;... 1 50  150 AJ • 1  + 11 ........ :� .. . �..... . ,, ,J t 

0 X 

TO> 

_ Model 1c;,_, AQ ,) A1 MDDfl. jj! ::: • + b. . �  • gj[g • !:il • @@ • 00 A' ).. 1,1 • (f • + ;;_ 12) ::: 

Figure 1 -50 

1 4. Close both drawings without saving the changes. 

End of practice 
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1 . 6 Using Gr ips Effectively 
Grips are a very powerful tool and using them helps you to  quickly and easily modify drawings. 
You can increase the effectiveness of using grips by changing the base point, copying with 
grips, using the reference option, stretching multiple objects (as shown in Figure 1-51 ), and 
modifying grip settings. 

Figure 1 -51  

• If E;] (Dynamic Input) is on, dynamic dimensions (and if it is a multifunctional grip, a 
dynamic list of options) display when you hover the cursor over a grip. Select one of the 
optional commands, such as Stretch, Lengthen, or Add Vertex. 

• When you select a grip you can edit the dimensions to stretch the object. Use <Tab> to 
highlight the dimension that you want to change. 

• Depending on which grip is selected, the Stretch mode either stretches or moves the object. 
Centers of circles and midpoints of lines move the objects. Standard blocks move because 
they cannot be stretched. Dynamic blocks have special grips. 

• Pressing < Enter> while a grip is hot, sequentially toggles through Move, Rotate, Scale, 
Mirror, and then back to Stretch. 

• To clear grips from objects, press < Esc> or right-click and select Exit. 

Changing the Base Point 

The hot grip becomes the default base point for moving, rotating, etc. To use a different base 
point, right-click and select Base Point as shown in Figure 1-52 (or type B in the Command 
Line) . Select the new base point and continue with the command. 
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Enter 

/4 . .  [f] Stretch 

Lengthen 

Move 

0 Rotate 

Scale 

Lllt, Mirror 

Base Point 
o, 

0) Copy 

Figure 1 -52 

Copying with G rips 

Use the Copy opt ion with any of the gr ip  edit ing  modes to create mu lt ip le  copies wh i le  you 
move, rotate, etc.  

How To: Copy with Grips 

1 .  Select the objects and make one gr ip  hot .  
2. Right-c l ick and se lect the edit ing mode (Stretch, Move, Rotate, etc . ) .  
3. Select the Copy opt ion i n  the shortcut menu o r  Command L ine .  
4 .  Select (or type) the second po i nt, rotat ion ang le, m i rro r l i ne, or  sca le factor. 
• If you ho ld <Ctr l> wh i le  select ing the locatio n  fo r add it iona l  cop ies, the new objects snap to 

the same spacing  as the fi rst copy, as shown i n  F igure 1 - 53 .  

lll - - - - - - - - - -!!l 

Figure 1 -53 
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Rotate and Scale with the Reference Option 

The Reference option enables you t o  select reference points in your drawing to describe the 
rotation angle or scale factor. 

How To: Rotate and Scale with Grips and Reference 

1 .  Select the objects that you want to rotate or scale. 
2. Select the grip to be the base point for rotating or scaling. 
3. Right-click and select Rotate or Scale. 
4. Right-click and select Reference. 

• For Rotate: Specify the reference angle by typing the angle or selecting two points. 
Specify the new angle by typing the angle or selecting a second point. The first point of 
the new angle is the base point. 

• For Scale: Specify the reference length by typing the length or selecting two points. 
Specify the new length by typing the length or selecting a second point. The first point of 
the new length is the base point. 

For example, you might want to straighten a rectangle that is rotated at an unknown angle, as 
shown in Figure 1-54. Select the rectangle and then select the grip at point 1 as the base point 
for rotation. Right-click and select Rotate and Reference. For the Reference angle, select the 
end points at 1 and 2 (this is the current angle of the object) . For the New angle, type 0. 

Figure 1 -54 
• The Reference option is also available with the regular Rotate and Scale commands. 
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Stretch ing Multip le Objects 

In the Stretch mode, only hot grips or objects that contain hot grips are stretched. You can 
make multiple grips hot by holding <Shift> when selecting each grip, as shown in Figure 1-55 .  

-------
[ii---------------------� 
I I 
I I 
I I 
I �- - - - ➔---------+---� 
I I I I 
I I I I I I I I [S----------t----------__._-� 

I 
I 
I 
I I �---------------� 

Figure 1 -55 

How To: Stretch with Grips 

1 .  Select the objects that you want to stretch. 
2. Hold <Shift> and select all of the grips that you want to move using Stretch. 
3. Release <Shift>. 
4. Select the grip that you want to use as a base point .  
5. Select the point that you want to use as the second point of displacement. 

Convert ing to Arcs or Lines 

The multi-functional grips of certain objects (such as polylines) enable you to convert an object 
segment into an arc or an arc segment into a l ine. 

How To: Convert an Object Segment into an Arc or Line Segment 

1 .  Select the object to display its multi-functional grips, as shown for a rectangular object in 
Figure 1-56 .  

Figure 1 -56 
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2. Hover your cursor over the top middle bar grip, as shown in Figure 1-57. You can stretch, 
add a vertex, and convert to an arc using the grip options. 

Stretch 

Add Vertex 

Convert to Arc 

Figure 1 -57 

3. Click Add Vertex and move that point to add a vertex and manipulate the shape of the 
object, as shown in Figure 1-58. 

0 

Figure 1 -58 

Specil'y ncw  
Press Cbl to 
- Sln!tch  
• Add Y!rter 
- ean-tto 

4. Hover your cursor over one of the bar grips and select Convert to Arc. Move the cursor to 
define the position and radius of the arc, as shown in Figure 1-59. 

Figure 1 -59 
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Grip Sett ings 

In the Options dialog box (expand the Application Menu and click Options) ,  in the Selection tab, 
there are several settings related to grips, as shown in Figure 1-60 . 

· · · · · · · ······· ··· ··· · · · · .•· · ······ · · · ·  ·· . . . .. . . . . . .. . . . . . . . . . · · ··· · ·��·-~1· .... . . . . . . . •· · ··~······· -eferences jl_ Drafting J_ 3D Modeling.J 
Selection .Profiles �nline l_ 

Gop size 

II 

Giips 

Grip Colors . . .  

0 Show glips 

D Show glips within blocks 

0 Show grip tips 

I!'.] Show dynamic grip menu 

0 Allow Qrl,cycling behavior 

I!'.] Show single grip on groups 

I!'.] Show bounding box on groups 

[_�oo I 
Object selection limit for display of grips 

Figure 1 -60 

• Grip size enables you to control the size of the grip as it displays in the drawing window. 
• You can also change the grip colors by clicking Grip Colors . . .  and adjusting the values in the 

Grip Colors dialog box, as shown in Figure 1-61. 

IQ Grip Colors 

Settings 

\,lnselected grip color :  

■ color 150  

Selected gr ip  !,Clar: 

■ calor 12  

OK 

Hover grip color: 

O color 1 1  

G riQ contour  color: 

■ color 251 

Cancel 

Figure 1 -61  
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I n  add it ion to gr ip  s ize and  color, you can set the fo l lowing :  

Show grips Tu rns gr ips on or off g loba l ly. 

Show grips in b locks Controls whether gr ips on ly d i splay on a b lock's i nsert ion po int (off) or on  
a l l  nested objects i n  the b lock  (on ) .  Norma l l y  it i s  eas ie r  to work  with th i s  
opt ion off. Th is on ly  app l ies to standard b locks. Dynamic  blocks sti l l  
d i splay gr ips .  

Show grip tips Gr ip  t ips are not ava i l ab le  in the bas ic AutoCAD software, but can d isplay 
for objects from software such as  the AutoCAD® Arch itecture software .  

Show dynamic grip menu Controls whether a menu d isp lays next to a dynam ic  gr ip .  

Allow Ctrl+cycl ing Controls whether you can use <Ctr l> to cyc le through the g ri p's opt ions. 
behavior 

Show single grip on D isp lays a s ing le  gr ip  for an object group.  
groups 

Show bounding box on 
groups 

Object selection l imit for 
display of grips 

1 -48 

D isp lays a bound i ng box around the extents of g rouped objects .  

I f  you select more objects than the  number set here, gr ips do not d isp lay 
on  them. 
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Practice 1 e  
Use Grips Effectively 

Practice Objective i 1 0  minutes 
• Modify a drawing using grips. 

In this practice, you will use grips to edit the schematic drawing, as shown in Figure 1-62. 

l!T - - -- ---- --- ---- - --- - - I 

r SALES 1 
I I 
I I 

: : t:11 : 
l I 

Figure 1 -62 

1 .  Open Computer-M.dwg from your practice files folder. 
2. Use grips to add three, evenly spaced computers to PRODUCTION. Use <Ctrl> when 

selecting the locations for the copies, to place them at even intervals. 
3. Use grips to stretch the red rectangle to include the new computers. Use <Shift> to select 

more than one hot grip. 
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4. Select the three, yellow polylines connecting the ACCOUNTING computers to the hubs. 
Mirror and Copy the three polylines to the PRODUCTION computers using grips and a base 
point at the midpoint of the middle hub. 
• Hint: After selecting the three middle grips using <Shift>, use the shortcut menu to select 

Mirror and hold <Ctrl> to make mirrored copies. Select the three middle grips of the 
mirrored copies, right-click and select Move to move those to the PRODUCTION 
computers. 

5. Use grips to manipulate the new lines so they match up with the new computers. 
6. Save and close the drawing. 

1 - 50 

End of practice 
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1 .  7 Addit ional Layer Tools 
The additional layer commands in the Home tab>Layers panel, can help you to work quickly 
with layers. They include commands that enable you to select layers rather than their names, 
and to change their layer state or current status. 

Changing Object Layer States 

The commands to freeze, toggle off, lock, and unlock layers are the most basic of the additional 
layer commands. They can be accessed in the Home tab>Layers panel, as shown in 
Figure 1 -63. 

Unsaved Layer State 
I � � i· f.';; :L;T: � � 

� cOc ,ea iyer fading 25% 
Layers 

Figure 1 -63 

How To: Freeze or Turn Layers Off 

L7 .a, 1 .  Start * (Layer Freeze) or 'o (Layer Off). 
2. Select an object on the layer that you want to change. It changes automatically. 
3. You can continue selecting objects on other layers as required. 
4. Press <Enter> to finish the command. 

Two other commands are helpful with layer states: 
µ • r: � (Turn All Layers On) 

• = l (Thaw All Layers) 
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Settings 
Layer Freeze and Layer Off have settings for how blocks, Xrefs, and Viewports respond to the 
commands. These settings remain in effect until you change them. 

Block selection Sets the nest ing level of a b lock or Xref: 

Viewports 

• Block (default) : Freezes or tu rns off the l ayer on which the b lock was i nserted . If  
it is  part of a n  Xref, it freezes the layer of the o bject. 

• Entity: On ly freezes or tu rns off the l ayer i n  the b lock or Xref that you actua l ly 
select. 

• None: Freezes or turns off the l ayer on which the block or  Xref was inserted.  

Sets the way the command responds when you a re worki ng i n  a Paper Space 
viewport. 
• VPFreeze (default): Only freezes or turns off the l ayer in the current v iewport. 
• VP Freeze in All Viewports except Current: I n  the Home tab>extended Layers 

r , 

panel ,  use P, (VP Freeze in A l l  Viewports except Current) to freeze a selected 
layer i n  a l l  other v iewports except the active one .  

• Freeze/Off: Freezes or tu rns off the l ayer across the ent i re d rawing .  

How To: Lock or Un lock Layers 

1 .  Click (Layer Lock) or (Layer Unlock) . 
2. Select an object on the layer that you want to change. It changes automatically. 
• A small padlock icon displays when you hover the cursor over a locked layer, as shown in 

Figure 1-64. 
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Figure 1 -64 

Block Refere 
Color D] B  
Layer Sen 
Linetvoe BvL; 
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• Locked layers fade but are sti l l displayed in the drawing. Use the Locked layer fading slider 
in the extended Layers panel to control how much the layers fade, as shown in Figure 1-6 5. 

Unsaved Layer State 

l� l ._ocKec 
.t:J 

Isolating Layers 

Figure 1 -65 

-
25% 

4-� 
Z:::.:- (Layer Isolate) is similar to changing the layer state, but it locks and fades (or turns off) al l 
of the objects in a drawing EXCEPT those that are on the layers that you selected to isolate, as 
shown in Figure 1-66. When you have finished working with the isolated layers, you can return 
them to their original layer state. 

How To: Isolate Layers 

..;:.....--:; 
1 .  Click Z:::.:- (Layer Isolate) . 

I SECRETARY 

Figure 1 -66 

2. Select objects on the layer(s) in which you want to work. 
3 .  Press < Enter>. Al l of the other layers are locked and faded. 
• If you only select one layer to isolate and it is not the current layer, it becomes current. 
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• The layers that are not selected to be isolated are either locked and faded or toggled off. To 
change this, start the Layer Isolate command, select Settings, and select the required 
option, as shown in Figure 1-67. 

I Enter setting for layers not isolated 

• Off 
lock and  fade  

Figure 1 -67 

• When you select Off you are prompted to set the way it works in Paper Space viewports. The 
Vpfreeze option freezes the unisolated layers in the active viewport, and the Off option turns 
the unisolated layers off in all of the viewports. 

How To: Un isolate Layers 

1 .  Click � (Layer Unisolate). 
2. All of the isolated layers are restored . 

.... � • i/? (Layer Previous) also restores layers that have been isolated and changes the current 
layer back to the original if Layer Isolate was last used to change it. 

Chang ing an Object's Layer 
v 

There are other ways of changing the layers of objects in a drawing, including � (Change to 
El'� 

Current Layer) and -!;; (Copy Objects to New Layer). These commands change an object's layer 
by selecting other objects. 

How To: Change to the Current Layer 

V. 
1 .  Click � (Change to Current Layer). 
2. Select the objects that you want to place on the current layer. 
3. Press <Enter> to complete the command and note that the objects are moved to the 

current layer. 

How To: Copy an Object to a New Layer 

This command creates new copies of selected objects and places them on a new layer. You 
can then move the copies to a new location while you are still in the command or leave them on 
top of existing objects . 

..2,l-
1 .  Click � (Copy Objects to New Layer). 
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2. Select the objects that you want to copy and press < Enter> to complete the selection set. 
3. Select an object on the destination layer or use the Name option to open the Copy To Layer 

dialog box, in which you can select a layer name, as shown in Figure 1-68. 

Copy To Layer 

Destination layer. 

10 
I 
B o rder  
Cente r 
Computer 
Constructions  
Defpo ints 
Department 
Dime n s ions 
Hatching 
Hidden 
l ines 

X 

V 

OK Cancel 7 [ !:ielp 

Figure 1 -68 

4. Select a base point from which to copy. I f  you want the new copies to be on top of the 
originals, you can press < Enter> to exit without moving the objects. 

5. Select a second point to place the new objects on the selected layer. 
• The new layer to which objects are going to be copied must exist for this command to 

be used. 

Modifying Layers 
£:7. 

In the Home tab>extended Layers panel, use � (Layer Merge) to move all of the objects on 
selected layers to a target layer. It automatically then purges the empty layer. 

x (Layer Delete) removes a layer and any objects associated with that layer. 
• The default response to the final prompt of Do you wish to continue? for each of these 

commands is No. You must specify Yes to complete the process. 

How To: Merge Layers 

0.1 1 .  Click ., (Layer Merge). 
2. Select an object on the layer that you want to merge. You can select several layers before 

pressing < Enter> to continue. 
3. Select an object on the target layer. 
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4. A warning box opens, listing the layers that you are going to merge into the target layer. If 
you type Y for Yes, the objects are moved to the target layer and the other layers are deleted 
from the drawing. 

How To: Delete Layers 

1 .  Click x (Layer Delete). 
2 .  Select an object on the layer that you want to delete. You can select several layers before 

pressing < Enter> to continue. If you select multiple layers, the objects disappear from the 
drawing as you click them. 

3. A warning box opens, listing the layers that you are going to delete. I f  you type Y for Yes, the 
objects and layers are deleted from the drawing. 
• If blocks are associated with the layer, they are redefined with objects from the deleted 

layer. 

Ci/ Hint: Layer Translator (LAYTRANS command) 

t:;, The -� (Layer Translator) enables you to move all the elements on a selected layer to 
another new layer that you have to create first. In the Layer Translator dialog box (as shown 
in Figure 1-69), create a new layer where you want the objects of the old layer to be moved 
into. It automatically then purges the empty layer. 
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Q Layer Translator 

Trans late Erom 

Ef:Jo 
@Center 
� Constructions 
� Defpoints 

Selec6on Filter 

V 

> 

X 

Translate TQ 

Map 

i,oad ... New ... 

Figure 1 -69 
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Layer Walk  
�� 
=u (Layer Walk) provides an interface in which you can quickly display objects on specified 
layers and then modify them in a di a log box, as shown in Figure 1-70. Use this command to 
find out which layers the objects display on and then use other commands to move them to the 
correct layer. 

IQ LayerWalk - Layers: 18 X 

v Biter 

Defpoints ,.., 
Dimensions 

Bectrical 
Furniture 
Hatching 
HVAC 
Misc 
Partitions 
Plumbing ••w 
Text 
Viewports 

12] Restore on exit [ !::!� LQose ] 

Figure 1 -70 
• You can either select from the list of layer names in the LayerWalk dialog box or use 

l!fD (Select Objects) to select objects in the drawing window. 
• Use <Ctrl> and <Shift> or drag to select multiple layers. 
• Double-click on the name if you always want a layer to be displayed. An asterisk displays 

next to the name. You can also right-click and select Hold Selection. You can release the 
hold layers individually or as a group by right-clicking and selecting Release Selection and 
Release All . 

• If a layer does not contain any objects, you can click Purge to remove it from the drawing. 
• When you have finished working in the dialog box, you can display the layer setup in your 

drawing if you clear the Restore on exit option. If it is selected, the modifications you made 
in the dialog box are not displayed in the drawing window. 
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Fi ltering Layers 
You can use fi lters to select l ayers more qu ickly .  Type i nformat ion i nc lud ing  a w i ldcard 
cha racter (such as *) and p ress < Enter> to on ly  d isp lay the l ayer names that match the fi lter, as 
shown i n  Figu re 1 -7 1 . 

IQ l_ayerWalk - l_ayers: 3 of 1 8  X 

0 flestore on exit I tielp J I Qose I 
Figure 1 -71  

• To save a fi lter, r ight-c l i ck  i n  the Layer l i st and  se lect Save Current Filter. The fi lter i s  added 
to the d rop-down l i st .  

• Al l  of the layers d isp lay if you clea r the Filter opt ion .  
• I n  the LayerWa lk  d ia log box, r ight-c l i ck  and select Save Layer State to save the cu rrent 

select ion of layers to be used later in the Layer State Manager. 
• I n  the LayerWa l k  d ia log box, r ight-c l i ck  and select Inspect ... to d i sp lay the number of l ayers 

i n  the d rawing, number of layers sel ected, and nu mber of objects on the se lected layers, as 
shown in F igure 1 - 72. 
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Inspect 

Layers in drawing :  I 1 5  
;===� 

Layers se leded :  I 1 
�=====; 

Entiti es  on se leded layers: I�□---� 

Figure 1 -72 

X 
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Use Layer Tools 

Practice Objective 

• Modify the layers using the additional layer commands. 

Working Effectively with AutoCA D 

i: 1 0  minutes 

In this practice, you will freeze and toggle off layers, as shown in Figure 1-73, and then restore 
the layer states. You will isolate and unisolate layers. You will use the Layer Walk and Layer 
Merge commands to determine whether any layers are incorrect in the drawing and then fix 
them as required. 

Figure 1 -73 

1 .  Open Bank-AM.dwg from your practice files folder. 
2. In the Home tab, expand and pin the Layers panel. 
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,r-;r r:,: 

3.  Practice freezing and togg l ing off layers us ing -� (Layer Freeze) and ,._,,;; (Layer Off) . 

4. Restore the layer states us ing � (Tu rn a l l  Layers On) and El. (Thaw A l l  Layers) . 

5. You can a lso try iso lat ing l ayers us ing � (Layer I so late) and � (Layer Un iso late) . 
6. Set the current l ayer to Electrical. 

7. Cl ick � (Layer Freeze) . At the Select an object prompt, press <Down Arrow> a nd select 
Settings>Block selection>Block. Select a door to freeze a nd note what happens .  A l l  the 
doors disappear from the d rawing .  

a 
8.  Cl ick = ; (Thaw Al l  Layers) . 
9. Hover your cursor on one of the text in  the d rawing .  Note that the text i s  on  layer Walls. 
1 0. Set the current layer to Text. 

V. 
1 1 .  Cl ick � (Change to Cu rrent Layer) . Select the text and note how the color changes to b lue, 

which is the color of the layer Text. 
,� 

1 2. Cl ick Ef, (Layer Wa l k) .  I n  the Layer Wa lk  d ia log box, select Doors. Only the objects that a re 
on layer Doors are d isp layed with everyth ing else d i sappeari ng .  S im i l a rly, select Furniture 
and STAIRS to d i sp lay the objects on each layer. Select the layer Walls fi rst and then se lect 
the layer WALL. Note that the wa l l s  in the drawi ng a re on two d i fferent l ayers with most of 
them being on l ayer Walls and few of them being on l ayer WALL. C lose the Layer Wa l k  
d ia log box. 

L7 
1 3 . Set layer O to be the cu rrent layer. C l ick t::7 (Layer Merge) and select an  object on the l ayer 

Walls (top most hor izonta l  wal l of the layout) . Press <Enter>. 
1 4. Select an  object on the layer WALL (a wa l l  between the rooms VICE PRES and PRES) .  

Cl ick Yes. 
1 5 . Expand the Layer Contro l  i n  the Layers panel to verify that one of the wa l l  l ayers is de leted 

and al l the wa l ls a re on  a s ing le  layer. 
1 6 . Save and c lose the drawing .  

End of practice 
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Chapter Review Questions 

1 .  What do Workspaces control? 
a. The available tabs in the ribbon and the display of Tool Palettes. 
b. The settings in the Options dialog box. 
c. The default template location. 
d .  The drawings that are open in the AutoCAD software. 

Answer: a 

2. If  some objects are already hidden or isolated, you cannot add additional objects to the 
isolated selection set . 
a. True 
b. False 

Answer: b 

3. How can you paste AutoCAD objects into a drawing at the same location as in the drawing 
from which they were copied? 
a.  Select Edit>Paste Special in the Application Menu. 
b. Right-click and select Paste to Original Coordinates. 
c. Right-click and select Paste as Block. 
d .  Select Edit>Paste Special in the Menu Browser. 

Answer: b 

4. I f  you have-multiple drawings open, how can you switch between them? (Select all that 
apply.) 
a. Use Open to open the drawing again. 
b. Press <Shift>+<Tab> .  
c. Use Application Menu>Open Documents. 
d. Use View tab>lnterface panel, expanded Switch Windows drop-down list . 

Answer: c, d 

5. What is a function of the Layer Walk command? 
a. Toggle the visibility of layers on and off by selecting them in the LayerWalk dialog box. 
b. Change the properties of a layer. 
c. Change the layer on which an object is located . 
d .  Create new layers in the LayerWalk dialog box. 

Answer: a 
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6. When selecting an object and then a grip, which of the following commands is started by 
default? 
a. Stretch 
b. Copy 
c. Scale 
d. Move 

Answer: a 
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Working Effectively with AutoCAD 

Command Summary -
� 

l>-7 
L �  

0 ,. 

Clipboard 

C-D 

Layer 

Command 

Clean Screen 

Command Aliases 

Workspace Switching 

Copy 

Copy with Base Point 

Cut 

Paste 

Paste as Block 

Paste to Original 
Coordinates 

Location 
• Status Bar 

• Command Prompt: <Ctr l>+<0> (zero), c leanscreenON 
or c leanscreenOFF 

• Ribbon: Express Tools tab> Tools pane l  

• Status Bar 

• Command Prompt: wscurrent 

• Ribbon: Home tab>C l i pboard pane l  

• Shortcut Menu:  Copy 

• Command Prompt: copycl i p  or <Ctr l>+<O> 

• Shortcut Menu: Copy w i th  Basepoint 

• Command Prompt: <Ctr l>+<Shift>+ 
<C> or copybase 

• Ribbon: Home tab>C l i pboard pane l  

• Shortcut Menu:  Cut 

• Command Prompt: <Ctr l>+<X> 
or cutc l i p  

• Ribbon: Home tab>C l i pboard pane l  

• Shortcut Menu:  Paste 

• Command Prompt: <Ctr l>+<V> or pastecl i p  

• Ribbon: Home tab>C l i pboard pane l  

• Shortcut Menu: Paste as B lock 

• Command Prompt: pasteblock 

• Ribbon: Home tab>C l i pboard panel 

• Shortcut Menu: Paste to Or ig ina l  Coord i nates 

• Command Prompt: pasteorig 

Change to Current Layer • Ribbon: Home tab>expanded Layers pane l  

• Command Prompt: laycur 

Copy Objects to New Layer • Ribbon: Home tab>expanded Layers pane l  

• Command Prompt: copytolayer 

Layer Delete • Ribbon: Home tab>expanded Layers pane l  

• Command Prompt: laydel 
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1 - 64 

Command 

Layer Freeze 

Layer Isolate/Layer 
Unisolate 

VP Freeze in All Viewports 
except Current 

Layer Lock/Layer Unlock 

Layer Merge 

Layer Previous 

Layer Off 

Layer Walk 

Thaw All Layers 

Turn a l l  Layers On 

Cascade 

Switch Windows 

Tile Horizontally 

Tile Vertically 

Location 

• Ribbon: Home tab>Layers panel  
• Command Prompt: l ayfrz 

• Ribbon: Home tab>Layers panel  
• Command Prompt: lay iso or layun iso 

• Ribbon: Home tab>expanded Layers pane l  
• Command Prompt: layvpi 

• Ribbon: Home tab>Layers panel 
• Command Prompt: lay lck or  l ayu lk  

• Ribbon: Home tab>expanded Layers pane l  
• Command Prompt: laymrg 

• Ribbon: Home tab>expanded Layers panel  
• Command Prompt: layerp 

• Ribbon: Home tab>Layers pane l  
• Command Prompt: l ayoff 

• Ribbon: Home tab>expanded Layers panel  
• Command Prompt: Jaywa lk 

• Ribbon: Home tab>Layers panel 
• Command Prompt: l aythw 

• Ribbon: Home tab>Layers panel 
• Command Prompt:  layon 

• Ribbon: View tab> lnterface pane l  

• Ribbon: View tab> l nterface pane l  

• Ribbon: View tab> l nterface pane l  

• Ribbon: View tab> l nterface pane l  
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Accurate Position i ng 
I n  th is  cha pter, you learn how to use abso lute, relative, and re lat ive po lar  coord i nates to spec ify 
a po i nt, use t racki ng to specify a po int based o n  exist ing po ints, use construct ion l i nes, and 
p lace reference po i nts . 

Learn ing Objectives ;i 1 hr 20min 

• Locate pos iti ons i n  a d rawi ng and new poi nts based on exist ing object snap points. 
• Create gu ide l i nes that a re infi n ite i n  one or both d i rect ions .  
• Add ind iv idua l  poi nts and mu lt ip le  i nd iv idua l  poi nts. 
• Create a pattern of mult ip le i nd iv idua l  po ints .  
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2. 1 Coord inate Entry 
The AutoCAD® software has several ways of locating positions in a drawing by typing 
coordinates or by coordinate entry, as shown in Figure 2-1: 
• Absolute Cartesian Coordinates (X,Y) 

• Relative Cartesian Coordinates (@X,Y) 

• Relative Polar Coordinates (@Distance<Angle) 

� ......... l[r]!]lLJ 
Cartesian Format (X, Y) 

16.0000 

. . . . . j 

Polar Format (Distance<Angle) 

Figure 2-1 

Absolute Cartesian Coordinates (X,V) 

Absolute Cartesian coordinates (X,Y) specify a point's absolute location based on the origin 
(0,0). You can use absolute coordinates to specify the first point of a line or the center point of 
a circle. For example, typing 8,2 locates a point eight units in the X-direction and two units in the 
Y-direction from the origin, as shown in Figure 2-2. 

Figure 2-2 

• Absolute Cartesian Coordinates are useful when you are given the coordinates to use, such 
as in some mapping applications or drawings for numeric control machinery. 

Relative Cartesian Coord inates (@X,V) 

Relative Cartesian coordinates specify a point's distance away from the last point entered using 
X- and Y-values. 
• Relative Cartesian coordinates are useful when you are given an X- and Y-distance rather 

than a distance and angle. 

• When using ];j (Dynamic Input), the coordinates you type for the next point or second point 
in a command are automatically relative by default. 
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• I f +_ (Dynamic Input) is toggled off, you have to force coordinates to be relative by putting 
@ in front of them (@X,Y). @ is a shorthand way of identifying the last point entered. 

• When you type coordinates in the X,Y format, it overrides the default distance and angle 
format. 

How To: Draw Using Relative Coordinates 

In the example shown in Figure 2-3 the angled line is drawn using the specified dimensions 
and relative coordinates. The drawing requires X- and Y-values, rather than distance and angle 
values. 

------- 4.00 -----

1 . 75 

100 

·- Figure 2-3 

1 .  Verify that � (Dynamic Input) is toggled on (highlighted) . 
2. Start the Line command. 
3. Draw the short vertical segment 1 unit straight up. 
4. At the Specify next point: prompt, type 4, 1 .75  and press < Enter> .  This places the endpoint of 

the segment 4 units to the right (X-value) and 1 .75 units up (Y-value) from the last point. 

• When � (Dynamic Input) is toggled on, the coordinates you type for the next point or 
second point in a command are automatically relative by default. Therefore, @ is not 
required. 

5. At the Specify next point: prompt, type 0,-2.75 and press < Enter>. This places the endpoint 
of the segment O units to the right (X-value) and 2.75 units down (Y-value) from the last 
point. 

6. Type C to close the object and complete the drawing. 
• The X- or Y-values can be either positive or negative. For example, @6,0 is a point 6 units 

straight to the right of the last point, but @-6,0 is a point 6 units to the left (back along the 
X-axis) . 
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Relative Polar Coord inates (@Distance<Angle} 

When you are selecting the next point for a line, dynamic dimensions display the distance from 
the last point and angle, as shown in Figure 2-4. Specifying the distance and angle is another 
form of coordinates, known as polar coordinates. 

Figure 2-4 

• Relative polar coordinates identify a point at a specific distance and angle from the last 
point selected. 

• When drawing with P:I (Dynamic Input) toggled on, you can enter the distance, press 
<Tab>, and enter the angle. 

• You can also type polar coordinates in the form of distance 
<angle. For example, @10<45 identifies a point ten units away, up, and to the right at a 
45-degree angle from the last point entered (with +,_ (Dynamic Input) toggled off) . 

• You can use the AutoCAD angle scheme (shown in Figure 2-5) to help type the polar 
coordinates as distance<angle without needing to move the cursor to display the angle on 
the screen. 

2-4 

goo 
1 35

�
45° 

·1 so0�<_r o0 

225N 31 5° 

270° 

Figure 2-5 
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Notes on Coord inate Entry 

• You can use coordinate entry with or without using I+-\ (Dynamic Input). If +_ (Dynamic 
Input) is toggled off, you must use @ to make points relative to the last point. 

• You can use @ alone to indicate the last point. 
• You can force coordinates to be absolute, rather than relative, by typing # in front of the X,Y 

value. For example, #1, 1 always goes to the absolute point 1, 1. 
• The Dynamic Input settings can be changed so that the default for the second or next point 

is absolute instead of relative. In the Status Bar, right-click on + ,_ (Dynamic Input) and 
select Dynamic Input Settings. In the Drafting Settings dialog box, in the Dynamic Input tab> 
Pointer Input area, click Settings . . .  and modify the settings in the Pointer Input Settings 
dialog box. 

• Relative coordinates can be useful in commands (such as Move and Copy) , and in drawing 
com mands. For example, you can use relative coordinates to copy an object at precise X­
and Y- distances from the original. To copy the circle on the lower left (as shown in 
Figure 2-6), use the coordinates 5,3 as the second point. 

/ 

+ 

,__ __ 5 . 0000  -----­
Figure 2-6 
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� Hint: The User Coordinate System 
The User Coordinate System (UCS) refers to the system of X-, Y-, and Z-coordinates, which 
define the AutoCAD Cartesian workspace. In the lower left corner of the window, a horizontal 
line labeled X and a vertical line labeled Y display. This is called the UCS icon, as shown in 
Figure 2-7. 

Figure 2-7 

To hide the UCS icon, click t! (Hide UCS Icon) in the View tab>Coordinates panel, as shown 
in Figure 2-8. You might need to toggle on the Coordinates panel, as it is off by default 
(right-click in any panel of the View tab and select Show Panels>Coordinates) . To have the 
UCS icon remain in the lower left corner of the screen (rather than moving with the 0,0 point), 

click t� (Show UCS Icon). By default, t� (Show UCS Icon at Origin) is selected. 

i • Show UCS Icon at Origin .____. 
� Show UCS Icon 

� Hide UCS Icon 

Figure 2-8 

Typically, you work with a fixed coordinate system called the World Coordinate System or 
WCS. The UCS can also be changed to adjust the orientation of the drawing plane, which is 
primarily used in for 3D models. 
To return to the standard World Coordinate System at any time, click � (World) in the View 
tab>Coordinates panel. 
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Practice 2a 

Draw Using Coord inate Entry 

Practice Objective 
• Draw an object using typed coordinates. 

Accurate Posit ion ing 

i 5 minutes 

In this practice, you will draw using typed coordinates, as shown in Figure 2-9.  

0 
t.[) 

L(") r---

1 00 1 20 

Figure 2-9 

0 
lf) 

1. Start a new drawing based on Mech-Millimeters.dwt, which is located in your practice files 
folder. Save it as New Plate.dwg . 

2. Toggle on r:��J (Dynamic Input) if it is not already on. 
3. Start the Line command. 
4. For the first point, type the absolute coordinates 120,120 and press <Enter>. 
5. For the next point, type 120<0 and press <Enter>. This draws the first segment 120 units 

straight to the right (angle 0) from the last point. 
6. For the next point, type 100,50 and press <Enter>. This places the endpoint 100 units to the 

right (X-value) and 50 units up (Y-value) from the last point. 
7. For the next point, type 75<90 and press <Enter>. 
8. For the next point, type 120<180 and press <Enter>. 
9. For the next point, type -100,-50 and press <Enter> to draw the angled segment down and 

to the left. 
10. Type C and press <Enter> to close the figure. 
11. Save and close the drawing. 

End of practice 
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2.2 Locating Points with Tracking 

Object Snap Tracking Review 

You can use the technique of Object Snap Tracking to locate a new point based on existing 
object snap points. In other words, you can track from two points to find the intersection point 
of their tracking lines. For example, you can find the precise center of an object in your drawing 
by tracking from the midpoints of two sides, as shown in Figure 2-10 . 

. . .  i 
..

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . 
7 �,dpoint < o·. Enctpo;nt < 90• 

Figure 2-1 0 

• [u] (Object Snap) and � (Object Snap Tracking) must both be toggled on to use Object 
Snap Tracking. 

• Hover the cursor over the object snap point and then move it away vertically or horizontally 
to display the tracking line. 

• You can select one point and type a distance to move in one direction along a tracking line 
from that point. 

Temporary Track Point 

a--O (Temporary Track Point) can create additional tracking points, which can be useful when 
you are using Object Snap Tracking and need to have more than two tracking points. It enables 
you to find a location based on two distances from another point. For example, if you need to 
position a circle with its center five units to the left and three units up from an endpoint, you 
need to use Temporary Track Point to add the additional point. 

• [u] (Object Snap) and � (Object Snap Tracking) must both be toggled on to use 
Temporary Track Point. 

• You can start a Temporary Track Point by right-clicking and selecting Osnap Overrides> 
Temporary track point in the shortcut menu or by typing TT in the Command Line, after 
starting a draw command. 
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How To: Use a Temporary Track Point 

1 .  In the Status Bar, toggle on [j] (Object Snap) and [ZJ (Object Snap Tracking). 
2. Start a command, such as Line or Circle. 

3. When prompted for a point, start a-o (Temporary Track Point) by typing tt. 
4. Hover the cursor over an existing point, which is then marked with a small plus mark. 
5. Move the cursor to lock the required tracking angle from the temporary point, and then type 

a distance to move in relation to the temporary point, as shown in Figure 2-11. 

+ 

I Track Point : 1 . 1495 < 270° 1 

Figure 2-1 1 

• Tracking lines display when you have locked a tracking angle from the temporary point. 
• IMPORTANT: Do not move the cursor directly over the cross that marks the temporary 

point. Doing so clears the point. 
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Practice 2b 

Locate Points with Tracking (Mechanical) 

Practice Objective 

• Place holes at certain locations. 

i 5 minutes 

In this practice, you will use Object Snap Tracking and Temporary Track Point to place holes on 
a machine part, as shown in Figure 2-12. 

75 
.......... .. 

l • 

0 

0 - 025 

f 3 X 06 

Figure 2-1 2 

1 .  Open Track-M.dwg from your practice files folder. 
2. Set the Object Snap Settings to Midpoint, and verify that lb] (Object Snap) and � (Object 

Snap Tracking) are toggled on. 
3. To draw a circle using the Circle command, hover the cursor over the midpoint of the left 

vertical line as a tracking point, and then pull the cursor to the right. Note that a tracking line 
is displayed. Type 75, press <Enter>, and set the diameter (using the <Down Arrow>) to 25. 

4. Repeat this process to place the 6 diameter circle, 25 units from the midpoint of the left 
vertical line, as shown above in Figure 2-12. 

5. Start the Circle command again and start the Temporary Track Point override by right­
clicking anywhere and selecting Osnap Overrides> Temporary track point. 

6. Hover the cursor over the midpoint of the left vertical line, and pull the cursor to the right. 
Type 40 (as shown on the left in Figure 2-13) and press <Enter>. A small plus mark 
displays at the temporary track point. Move the cursor directly below the plus mark. A 
vertical tracking line displays. Type 19 (as shown on the right in Figure 2-13) and press 
<Enter> to select another point 19 units down from the temporary point. 
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Specify temporary OTRACK point: 

@ 19 

Figure 2-1 3 

7.  The cursor snaps to the point. Place a 6 diameter circle at  this temporary track point 
location. 

8. Repeat this process to place the last circle (6 diameter) as shown in Figure 2-12, but move 
the cursor directly above the cross. 

9 .  Save and close the drawing. 

End of practice 
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Practice 2c 

Locate Points with Tracking (Architectural) 

Practice Objectives 

• Draw the walls of a building. 
• Position additional wall lines using tracking methods. 

i 1 0  minutes 

In this practice, you will create walls for a simple building outline using the Polyline command 
and then use Object Snap Tracking and Temporary Track Point methods to help position 
interior partitions, as shown in Figure 2-14. 

3000 L 3000 L 
71 ,, 

4500 

9000 6000 

Figure 2-1 4 

1 .  Start a new drawing based on AEC-Millimeters.dwt, which is found in your practice files 
folder. 

2. Make the layer Walls current. Using the Polyline command, verify that the Width option is 
set to 0, and then draw the outside of the building as shown in Figure 2-14. Start from the 
lower left corner and draw counter-clockwise. 

• ILi (Object Snap Tracking) can help to position the point for the top left corner. 
3. Offset the exterior walls 150mm to the inside. 
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4. Make the layer Partitions current and draw the interior partitions except the undimensioned 
partition wall. 

5. Use u5J (Object Snap) and [£] (Object Snap Tracking) to help position the bottom 
partition line and then make it 75mm wide. 

6. From this wall, use the u5J (Object Snap) and [£] (Object Snap Tracking) to draw the 
middle partition wall. 

7. For the top-most floating wall, start the Pline command. Hover the cursor over the top left 
inner corner (Endpoint) of the wall. Enter tt (for Temporary Track Point) and press <Enter>.  

8. Drag the cursor down, enter 1500 and press <Enter> .  A plus mark is established. Drag the 
cursor right, enter 3000 and press <Enter> .  The first point of the polyline is established. 
Draw the floating wall starting from this point. 

9. Save the drawing as Open Office.dwg and close the drawing. 

End of practice 
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2.3 Construction Lines 
Use temporary construction lines as guidelines for creating the more permanent parts of your 
design, as shown in Figure 2-15. Regular lines can serve as construction lines, but do not 
always provide the required length. Construction lines and rays are infinite lines that can be 
used to help construct your drawing. 
• Construction Line and Ray are located in the Home tab>expanded Draw panel. 

/ /'� 

/v 
,,-,-, 
'-1./ i/ � 

r> v 

Figure 2-1 5 

Construction Lines 

The Xline command creates a construction line that is infinite in both directions. 

How To: Draw a Construction Line 

.I' 
1 .  In the Home tab>expanded Draw panel, click •f (Construction Line). 
2. Select two points on the screen for the line to go through or select an option in the menu. If 

you select two points, you can create additional construction lines by continuing to select 
points at different angles around the first point. 

3. Using the <Down Arrow> menu, select the Hor, Ver, or Ang options before selecting the first 
point if you want to make a series of horizontal, vertical, or angled construction lines. 

4. If you want to create construction lines offset by a specific distance, select the Offset 
option in the <Down Arrow> menu. 

5. The Bisect option creates a construction line that bisects a selected angle. It is determined 
by three points: angle vertex point, angle start point, and angle endpoint. 

• Construction lines are not affected by zooming. 
• Construction lines should be placed on a separate layer that can be toggled off or made 

non-plotable. 
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Rays 
A ray extends infinitely in one direction from a specified point and you can input more than one 
ray from the same point. 

How To: Draw a Ray 

1 .  In the Home tab>expanded Draw panel, click (Ray). 
2. Select the start point for the ray. This becomes the end point of the ray. 
3. Select a through point for the ray. 
4. Continue to select other through points to create additional rays at different angles, but 

with the same end point. 
5. Press <Enter> to end the command. 
• Use object snaps to place construction lines and rays precisely on existing objects. 
• Ray does not have the same options as Construction Line. 
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Practice 2d 

Use Construction Lines 

Practice Objective 
• Create guidelines that are used to add geometry. 

i 1 0  minutes 

In this practice, you will draw circles and then add more circles to the plate using construction 
lines for precise placement, as shown in Figure 2-16. 

/ 

X 

Figure 2-1 6 

1 .  Create a new drawing based on Mech-Millimeters.dwt, which is located in your practice 
files folder. Save it as Round Plate.dwg . 

2. Draw two circles (R=50 and R=200) around the center point 250,120. Use the Zoom Extents 
command to display the entire drawing. 

3. Toggle on the Center object snap. 
4. Set the current layer to Construction. 
5. Draw a third circle (R=120) around the same center point. 
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6. In the Home tab>expanded Draw panel, click ,/ (Construction Line). Place the following 
three construction lines through the center point of the circles: 
• Horizontal 
• Vertical 
• Angular at 45 degrees 
Select the Hor, Ver, or Ang options in the < Down Arrow> menu before selecting the through 
point, which is the center of the circles, as shown in Figure 2-17. 

7. Set the current layer to Object. 

Specify a point or 

Hor 

B i sect 
Offset 

Figure 2-1 7 

8. Draw six circles with R=25 at the intersection (Intersection object snap) of the construction 
lines and the middle circle. 

9. Toggle off the layer Construction. 
1 0. Save and close the drawing. 

End of practice 
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2.4 Placing Reference Points 
The Point command places permanent reference markers into a drawing. For example, a point 
could be used to mark the center point of an arc for future reference, or to mark the precise 
location of survey points on a map, as shown in Figure 2-18. The visibility of this reference 
marker can be toggled on and off as required. 

Figure 2-1 8 

• You can add multiple individual points using · . ·  (Multiple Points). Two other commands, 

,<�· (Divide) and ,•i (Measure), create groups of points in a pattern. You can access these 
point commands in the expanded Home tab> Draw panel, as shown in Figure 2-19. 

Home Insert Annotate Param 

/....-· [7 . • r:· . . 
Line Polyl ine Circle Arc 

Figure 2-1 9 

• Once placed in a drawing, points can be moved or erased like other objects. 
• Use the Node object snap to snap to a point. 
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Setting the Point Style 
To change the appearance of points in your drawing, click ·.;,,. (Point Style . . .  ) in the Home tab> 
expanded Utilities panel. The Point Style dialog box opens (as shown in Figure 2-20), enab ling 
you to select from the available point styles. 
• Changing the point style changes the display of all of the points in the drawing. 

Q Point Style 

Point.S.ize: �l s_oooo ____ �I % 

@ Set S ize Relative to Screen 

Q Set Size in 8bs olute Un its 

OK Cance l  

Figure 2-20 

Creating Groups of Points 

l::!elp 

X 

Creating groups of points can be very useful .  For example, you might need to space electrical 
outlets evenly around a large room in a floor plan (as shown in Figure 2-21 ), or to place 
markers every 900 meters along a runway on a map. 

900 900 900 900 900 

EQUAL EQUAL EQUAL EQUAL 

Figure 2-21 
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Placing Even ly Spaced Points on an Object 
The Divide command places points to divide an object into a specified number of equal 
segments. You can specify the number of segments. This is not the number of points: a line 
divided into three segments has two points placed along it as shown in Figure 2-22. 

� 

Figure 2-22 

How To: Divide an Object 

1 .  In the Home tab>expanded Draw panel, click /�rt- (Divide). 
2. Select the object that you want to divide. 
3 .  Enter the number of  segments. The points are evenly spaced, dividing the object into equal 

length segments between the points. 
• You can use the Block option to insert a block instead of a point style. 

Placing Points at Specified I nterva ls on an Object 
The Measure command places points at a specified distance along an object. You specify the 
length of segments (the distance between points). The software begins to measure from the 
end point closest to the location used to select the object. 

How To: Measure an Object 

1 .  In the Home tab>expanded Draw panel, click , .;
t- (Measure). 

2 .  Select the object that you want to  measure. 
3 .  Specify the length of  the segment. The points are spaced at  the specified distance along 

the object. 
• If the object cannot be divided evenly, the remainder is left at the end of the object, opposite 

to where it was selected. 
• You can use the Block option to insert a block instead of a point style. 
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Practice 2e 

Place Points 

Practice Objective 
• Place points to mark the locations on objects. 

i 5 minutes 

In th is practice, you will place points to mark the locations of the centers of holes in a plate. You 
will use Point, Divide, and Measure commands to posit ion the points, as shown in F igure 2-23. 

250 

Figure 2-23 

1 .  Open Points-M.dwg from your pract ice files folder. 
2. Change the current layer to Constructions. 

® 

3. Draw a line from the midpoint of the left side (vertical l ine) of the plate, 250 units straight to 
the right side. 

4. Offset the line 50 units on either side .  
5.  In the Home tab>expanded Ut il it ies panel, click ·:.:.,- (Point Style) to open the Point Style 

dialog box. Select the cross with a circle or other visible point style and click OK. 

6. In the Home tab>expanded Draw panel, click • .  • (Mult iple Points) . Place points at the 
midpoint and right endpoint of the middle construction line. Press <Esc> to end the 
command. 
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7. In the Home tab>expanded Draw panel, click ,<rt· (Divide) and select the top construction 
line. Type 8 as the number of segments. Note that seven points are added, evenly dividing 
the line. 

8. In the Home tab>expanded Draw panel, click ,•:'i· (Measure) and select the bottom 
construction line closer to the left endpoint. Type 70 as the length of segments and press 
< Enter> .  Three points are added, spaced at that distance apart. 

9. Add Node as an additional Object snap. 
1 0. Set the current layer to Object. 
1 1 .  Start the Circle command and place a circle on one of the nodes (points). Select an 

appropriate radius for the circle such that it encloses the cross of the point. 
1 2. Use the Copy command to copy the circle to the other points. 
1 3. Toggle off the layer Constructions. 
14 .  Save and close the drawing. 

End of practice 

2-22 © 2023, ASCENT - Center for Technical Knowledge® 



Accurate Posit ion ing 

Chapter Review Questions 

1 .  With Dynamic Input toggled off, after you pick the first corner for a rectangle, what are the 
typed coordinates that can be used to make it 20 units long and 8 units high? 
a. 20,8 
b. @8,20 
c. 8,20 
d. @20,8 

Answer: d 

2. What does @ represent in the AutoCAD software? 
a. Indicates that Object Snap is going to be used. 
b. Indicates that a temporary tracking point is going to be used. 
c. Indicates a point relative to the last point. 
d. Used in place of 0. 

Answer: c 

3.  What does the Temporary Tracking Point enable you to do that Object Snap Tracking alone 
does not? 
a. Find a location based on two distances from another point. 
b. Draw circles, lines, and rectangles. 
c. Find a location based on only the midpoints of two objects. 
d. Precisely pick a point without using an object snap. 

Answer: a 

4. The difference between construction lines and regular lines is that construction lines 
extend infinitely. 
a. True 
b. False 

Answer: a 

5. Which command would enable you to position points every 5 units along a line? 
a. Temporary Tracking Point 
b. Divide 
c. Point 
d. Measure 

Answer: d 
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6. Relative coordinates are relative to the ___ . 
a. Origin (0,0) 
b. Last point picked 
c. Nearest object snap 
d. Current screen display 

Answer: b 
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Command Summary - Command Location 

" Construction Line • Ribbon: Home tab>expanded Draw panel 
• Command Prompt: x l i ne  or x l  

.. •:.r;-- Divide • Ribbon: Home tab>expanded Draw panel  
• Command Prompt: d iv ide or d iv  

u Hide UCS Icon • Ribbon: View tab>Coord inates pane l  

•' :ts Measure • Ribbon: Home tab>expanded Draw panel  
, 'I' 

• Command Prompt: measure or me 

Point (Multiple Points) • Ribbon: Home tab>expanded Draw pane l  
• Command Prompt: point or po 

· ._;.,.. Point Styles • Ribbon: Home tab>expanded Ut i l i t ies pane l  
• Command Prompt: ddptype 

,/� 
Ray • Ribbon: Home tab>expanded Draw pane l  

• Command Prompt: ray 

t .' Show UCS Icon • Ribbon: View tab>Coord i nates pane l  ·-
t :  Show UCS Icon at Origin • Ribbon: View tab>Coord inates pane l  ·-
l>----0 Temporary Track Point • Shortcut Menu: Snap Overrides> Temporary Track 

Point 
• Command Prompt: tt 

� 
World • Ribbon: View tab>Coord i nates pane l  
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Projects : Productivity Tools 
This chapter conta ins  practice projects that can be used to ga i n  add i t iona l  hands-on experience 
in  the topics and commands covered so fa r i n  this gu ide .  These projects are i ntended to be self­
gu ided and do not inc lude step-by-step i nformation .  

Learning Objectives i 30min 
• Schematic: Mod ify a p ip ing  d iagram us i ng ed it ing techn iques such as  t r im and stretch .  
• Mechanical: Create severa l parts and  objects us ing various D raft ing  Sett ings .  
• Architectural: Create severa l p lans  us ing  var ious track ing and p lacement commands .  
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3. 1 Schematic Project: Purifier Un it 

I 1 5  minutes 
In this project, you will use editing techniques to modify the piping diagram shown in 
Figure 3-1. 

PURI FI ER UN IT  

PUR:FIER 

<:.:..__,,,:/ 
\, . D ISCHARGE PUMP 

Figure 3-1 

1. Open Piping-M.dwg from your practice files folder. 

T 

2. Use the Stretch command to stretch the Heater elements farther to the right, as shown in 
Figure 3-2.  

3-2 

PURI FI ER UN IT  
SUCT!ON PUMP 

\, _ DISCHARGE PUMP 

HEATER 
BY PASS 

PUR:F IER 

Figure 3-2 

HEATU� 

T 
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Projects:  Productivity Tools 

3. Use grips to copy and rotate the gate valve (the blue hourglass shape) to the locations 
shown in Figure 3-3. Use the Nearest object snap to place the valves precisely on the lines. 

4. Use Trim to remove the section of the line inside the valves, as shown in Figure 3-3. 

PURI FI ER UN IT  
SUCTI Of'-1 PUMP 

PURIF IER 

' , \. ___ .,.,/ 
DISCHARGE PUMP 

Figure 3-3 

HEATER 

'><l·· ·q=-- TS ---GJ 
(��) 

5. Use grips to stretch the endpoint of the lines on the left side to connect with the T fittings, 
as shown in Figure 3-4. 

HEATER 

><J� 
TS 

•

.............. 

(r.) 
DISCHARGE PUMP 

Figure 3-4 

© 2023, ASCENT - Center for Technical Knowledge® 3-3 



AutoCAD 2024: Beyond the Bas ics - I nstructor Gu ide 

3.2 Mechanical Project: 2 Views 

I 20 minutes 
In this project, you will create the front and top views of a part, as shown in Figure 3-5. 

2 X 0 1 3  
2 X 045 

01 0 /  

1 20 
60 

Figure 3-5 

1 .  Start a new drawing based on Mech-Millimeters.dwt, which is located in your practice files 
folder and save it as 2Views.dwg. 

2. Use the drawing tools you have learned to create the two views, as shown in Figure 3-5.  

Use construction lines or � (Object Snap Tracking) to help align and draw the views. 
Place the hidden lines on the layer Hidden. 

3. Switch to the ISO A2 layout tab and display the views in a viewport scaled at 1 :1. If time 
permits, add annotative dimensions in the layout viewport, as shown in Figure 3-5.  
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3.3 Arch itectura l/Civi l Project: Formal  Garden 

i 40 minutes 

In this project, you will create a formal garden plan. Use a construction line to establish the 
center line, and then use tracking and other methods to help place the various components as 
shown in Figure 3-6. The dimensions are for reference only. You are not required to draw them. 

1 2000 

D LIN E  

A L L  G A  'ES 900rnrn 
ON CENTER OF WALL '. \NALL 300mm - CIRCULAR STEPS 

R75Qmm INNER 
AND 300mm VVIDE 

••• ELLIPTICAL POOL 
PAVEMENT 3000mm 

GARDEN PATHS 
1 200mm 

Figure 3-6 

1 .  Start a new drawing based on Civil-Millimeters.dwt, which is located in your practice files 
folder and save it as Formal Garden.dwg. 

2. In layer 0, draw the 9000 x 15200 building (extreme left rectangular object in Figure 3-6) 
with the 1500 x 3000 porch along the backside center, as shown in Figure 3 -6.  

3.  Use the Xline command to establish the center line. 
4. Draw the rectangular garden wall (300mm thick) and paths (1200mm) with gates (900mm 

on center of wall), as shown in Figure 3-6. Use tracking or other construction lines to help 
you. Place the objects on the layer Pavement Edge New. 

5. Add three semi-circular steps offset at 300mm with the smallest step of 750mm radius. 
6. (Optional) If time permits, add the elliptical pool and the path leading up to it . 
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3.4 Mechanical Project: Cover P late 

'.i: 30 minutes 

In this project, you will draw one view of a mechanical part, as shown in Figure 3-7. 

i----73---•-ii 

1- R70 
/ .�R45 
• . /  

, 047 / 
,,.. -_�_

·
·-------,r-----=--=-

·
-· ��- --- / / 040 

41 

t-
59 

--

'--------+--� $- ... 

Figure 3-7 

3mm WIDE , 
F ILLET 2mm 

1 .  Start a new drawing based on Mech-Millimeters.dwt, which is located in your practice files 
folder. 

2.  Draw the objects shown in Figure 3-7 with the help of tools such as Dynamic Input, Direct 
Distance Entry, Polar Array, and Object Snap Tracking. Draw only the objects, not the 
dimensions. Note that all of the dimensions are mirror images unless otherwise indicated. 

3. Save the drawing as Cover Plate.dwg. 
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3 .5  Arch itectural Project: Add it ion 

i 1 5  minutes 
In this project, you will draw an addition to an existing house plan, as shown in Figure 3-8. The 
dimensions are for reference only. 

/ 
I 

a 
8 
' 

0 
0 
c.o 
' 

a 
8 

v 3800 

f 

,,.....•, / -; ____ ;~-r·-------
� •,, f----·T---�---\,'=---:::=--:::=--:::;c---��-�

l
_-�=---;=-=--�=--�=--��---=--':=- -·=···-··=···-···=-··=-· -------·-4·· ·-:L·._l��=��=��=����,.1...1 

�' 11 , I  r lh 1 ·l h  i i  Q 

Figure 3-8 

1 .  Open Addition-AM.dwg from your practice files folder. 
2. • Along the top right side, draw the addition shown in Figure 3-8. The walls are 100mm thick . 

Remember to use the appropriate layers. Use Dynamic Input, Direct Distance Entry, Object 
Snaps, Object Snap Tracking, and other drafting tools to help create the drawing. 
• Use the dynamic Door-Metric and Window-Metric blocks from the Architectural tab in 

the Tool Palettes. 
• Use grips to adjust the length and depth of the window and door blocks to match the 

depth of the wall. 
3. Save and close the drawing. 

© 2023, ASCENT - Center for Technical Knowledge® 3-7 



AutoCAD 2024: Beyond the Basics - Instructor Guide 

3.6 Mechanica l Project: B lock 

:i 1 0  minutes 

In this project, you will use the Drafting Settings tools to help draw a mechanical object, as 
shown in Figure 3-9. 

50 

+- ··· · · '---,--- - - - 4-· 
I '' ·,, 

60 
3 x 0B 

1 3  I � c---'- - - - -EB - --- . .  ···-· ··- -· - - o/  
I 

50 

75  

L L---� f---+-1 3  ----<L---� J 

75 --�,�----1 00 -- --- --- -75 ----i 

Figure 3-9 

1 .  Start a new drawing based on Mech-Millimeters.dwt, which is located in your practice files 
folder. Save it as Block.dwg. 

2. Draw the objects shown in Figure 3-9. Draw only the objects, not the dimensions. 

Construction H ints: 
• Toggle on Dynamic Input and use Polar Tracking to draw the outline. Set the Polar Angle to 

30 degrees to draw the angled segments. Depending on how you construct the lines, Object 
Snap Tracking can help you to draw the top undimensioned segments. 

• Use Object Snap Tracking to place the three circles in relation to the outline. 
3. Save and close the drawing. 
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3.  7 Mechanical Project: Plate 

:i 1 5  minutes 

In this project, you will use the Drafting Settings tools to help draw the object shown in 
Figure 3-10 .  

✓ 
60 

' 
25 
i 

50 
t 

25 

..... 

50 

25 ,-

90 

2 X 0 1 3 
3 X R 1 3  

,-----+-✓ 

050 I 

0 
0 0 

6 1  

I 
6 1  

Figure 3-1 0 

1 .  Start a new drawing based on Mech-Mil limeters.dwt, which i s  located i n  your practice f i les 
folder. Save it as Angled Plate.dwg. 

2. Draw the objects shown in Figure 3-10. Draw only the objects, not the dimensions. 

Construction H ints: 
• Start with the circle with a diameter of 50. 
• Use Object Snap Tracking to place the three R13 f i llets (drawn as full circles) in relation to 

the larger circle. Draw the two angled segments on the right Tangent to the R13 circles. You 
will trim  the circles later (after you complete the drawing) to convert them into f i llets. 

• Start at the bottom quadrant of the bottom circle and begin drawing the outline clockwise. 
Use Polar Tracking. Set the Polar Angle to 45 degrees to draw the angled segments at the 
upper left side. Use Object Snap Tracking to draw the remaining segments of the outline. 

• Use Object Snap Tracking to posit ion the two circles with a diameter of 13. 
• Trim the three circles with a radius of 13 to convert them into f i llets. 
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Parametric Drawing 
I n  th is  chapter, you l earn how to add geometr ic and d i mens iona l  constra i nts to objects, mod ify 
parameters, and  create user parameters. 

Learning Objectives i: 1 hr 20min 
• Control how geometry reacts us ing  the Geometric constra i nts. 
• Specify d istances, rad i i , or ang les that must be fulf i l l ed by the geometry. 
• Specify, modify, and de lete an object's geometric constra i nts, and  customize the 

constra int  sett ings .  
• Add d imens iona l  constra i nts and convert the ex ist i ng  d imens ions i nto constra i nts .  
• Mod ify and add formu las to d imens iona l  constra i nts .  
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4. 1 Working with Constraints 
Constraints and parametric tools provide ways of testing design options while maintaining 
specific relationships in a drawing. They are used extensively in software, such as the 
Autodesk® Inventor® software and the Autodesk® Revit® Architecture software. The AutoCAD® 

software uses them to enhance 2D sketching. There are two types of constraints: Geometric 
and Dimensional, as shown in Figure 4-1. 

t ,c JC•=  J 2, /2 lili � Dimensional constraint 

// Geometric constraint 

// 

c: '-: - -- ':<Y:Y) ld 

Figure 4-1 

• Geometric constraints control how geometry reacts. For example, you can specify that a line 
remain horizontal or that two circles are concentric. 

• Dimensional constraints specify distances, radii, or angles that must be fulfilled by the 
geometry. Dimensional constraints can include formulas referencing other constraints or 
using basic mathematical functions. 

• When you hover the cursor over an object that has constraints, dP displays, as shown in 
Figure 4-2. 

dP 

Figure 4-2 
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Parametr ic Drawing 

4.2 Geometric Constra ints 
Once objects have been sketched, you can automatically and manually add constraints to the 
geometry by selecting them in the Parametric tab>Geometric panel, as shown in Figure 4-3. 
Click the required constraint icon and select the objects that you want to constrain. 

Auto 
Constrain 

Geometric 

Figure 4-3 

Auto Constra in ing Objects 

['4 Show All 

H Hide All 

The Auto Constrain command enables you to automate the process of applying various 
constraints to multiple objects together. If you are working with rectangles or multiple lines or 
polylines, you can use the Auto Constrain command first to set up the parallel, perpendicular, 
horizontal, or vertical relationships. This command is best used to constrain rectangles as 
applying other constraints could force the rectangle away from the correct shape. 

How To: Auto Constra in Objects 

1 .  Draw the objects in the design. 
2. In the Parametric tab>Geometric panel, click (Auto Constrain) . 
3. Select the objects that you want to constrain.The constraints are applied as shown on the 

rectangle in Figure 4-4. 
• One perpendicular, one horizontal, and four parallel constraints help a rectangle to keep 

its shape. 

. / 
Perpendicular 

, 
constraint 

Parallel 
constraint 

I 
Horizontal 
constraint 

// "" 

Figure 4-4 

© 2023, ASCENT - Center for Technical Knowledge® 4-3 



AutoCAD 2024: Beyond the Basics - Instructor Guide 

• Commands that duplicate objects, such as Copy, Mirror, and Array, also duplicate any 
related constraints. 

Specifying Geometric Constra ints 

Before you start adding constraints, draw the objects, including any fillets or chamfers. The 
exact sizes and angles of the objects are not important. 
• Linear objects include lines and polyline segments. For the purpose of constraints, a 

polyline segment can be selected separately from the rest of the polyline. 
• Radial objects include circles, arcs, and ellipses. 

Horizonta l and Vertical 

m (Horizontal) and � I (Vertical) constraints force linear objects to remain horizontal or 
vertical. Select the linear object that you want to be horizontal or vertical, as shown in 
Figure 4-5. 

Figure 4-5 

Vertical 
constraint 

Horizontal 
constraint 1 1  

• You can also use these tools to align two points horizontally or vertically, such as center 
points for circles. When prompted to select an object, press <Enter> to select two points. 

• Horizontal and Vertical constraints can also be used with ellipses and text. 

4-4 © 2023, ASCENT - Center for Technical Knowledge® 



Parametr ic Drawing 

Para l lel and Perpendicular 

// (Parallel) constrains two linear objects, forcing them to take on the angle of the first object. 

"< (Perpendicular) constrains the second linear element to rotate 90 degrees from the angle 
of the first linear object. Select a linear object and then a second linear object. The objects take 
on the angle or right angle of the first object, depending on the selected constraint. Examples of 
these constraints are shown in Figure 4-6. 

// 

Perpendicular 
constraint 

Figure 4-6 

// 

'
Parallel 
constraint 

• Parallel and Perpendicular constraints can also be used with ellipses and text. 

Tangent 

Q-, (Tangent) constrains an object to the tangent of a radial object. At least one object needs to 
be a circle, arc, or ellipse, but the objects do not have to touch. Select one object and then select 
a second object. The elements are then forced to be tangent, as shown in Figure 4- 7. 

'
Tangent 
constraint 

o ----------

Figure 4-7 
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Smooth 
-�a 

I.' (Smooth) ensures that the sel ected objects cont inue the same cu rvature va lues between a 
sp l ine a nd other l i near objects . Select the sp l i ne  at the endpo int at which you want the cu rve to 
cont inue .  Select the second l i near  e lement, wh ich can be a l i ne, po ly l i ne, or  another sp l i ne .  I n  
Fi gure 4-8, the endpo int o f  the sp l i ne  a n d  the endpo int o f  the l i n e  ( i nd icated b y  the i r  g r ips) a re 
selected .  

Spline 

Smooth 
constraint 

Figure 4-8 

Coincident 

]_ (Co i ncident) constra ins  two po ints to rema i n  together or  a po int to rema in  touch i ng  another 
point on an object. Sel ect a po int on one object and  then a po int on  a second  obj ect. The point 
on the second object is  moved co inc ident to the po int on  the fi rst object. In the example shown 
in  F igure 4-9, the center of the c i rc le  has been constra i ned to the m idpoint  of the l ine .  A 
constra i nt bar does not d isp lay with co inc ident constra ints, but a sma l l  b l ue  square d isp lays. 

Coincident 
constraint 

Figure 4-9 

• Co incident constrai nts can a lso move a long an object, such as the end of the a rc 
constra ined to the l i ne .  
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Concentric 

@ (Concentric) constrains two radial objects, such as arcs, circles, or ell ipses, to maintain the 
same center point. Select the first center point of a radial object, and then the second center 
point of another radial object. The two objects take on the center point of the first object, as 
shown on the right in Figure 4-10 . 

Coocoot,;, 0 
constraint __.. � 

Figure 4-1 0 

Col inear 
'\ ,/· 
�.., (Colinear) constrains two lines to lie along the same infinite line. They do not need to be 

touching. Select the first line and then select the second line. The second line moves to line up 
with the first line, as shown in Figure 4-11. 

Colinear � -:,' 
constraint _.,.,..,.-- r -

Figure 4-1 1 

• Colinear constraints can also be used to make ellipses and text colinear with other objects, 
such as lines or ellipses. 

Equal 

= (Equal) constrains two linear elements to  maintain the same length or  two radial elements to 
maintain the same radius. 

© 2023, ASCENT - Center for Technical Knowledge® 4-7 



AutoCAD 2024: Beyond the Basics - Instructor Guide 

How To: Apply an Equal  Constraint 

1 .  Select the first object and then the second object. 
2. The second object takes on the measurements of the first object. In Figure 4-12, the object 

on the right was not constrained and only the selected segment of the polyline changed in 
distance. 

Equal = 
constraint ��--� 

= 

I 

Figure 4-1 2 

• When using Auto Constrain and the Equal constraint, it is applied to lines or polylines of the 
same length and circles of the same diameter. 

Fix 

EO (Fix) constrains a point on an object to remain fixed to a specific location on the World 
Coordinate System. You can also fix an entire object, rather than just a single point. 

Symmetrical 

[ i J  (Symmetrical) constrains two points on objects or  forces objects to be symmetrical about a 
symmetry line. 
• Add other constraints first before applying the symmetrical constraint. 

How To: Add a Symmetrica l Constra int 

1 .  Select the first object or press <Enter> to select a point on an object. 
2. Select the second object or point. 
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3. Select the symmetry line. The objects move into symmetry about the symmetry line, as 
shown in Figure 4-13. 

// 

Figure 4-1 3 

Constraint Bars 

I Symme!rical 
1 constraint 

1 1 1�� 
�

--
�i'----7(!]-� 

I 

Constraint bars are icons that display when geometric constraints are applied to objects. If 
more than one constraint is applied to an object, the icons touch, forming a bar. When you 
hover the cursor over a constraint in the constraint bar, the related objects highlight in the 
drawing. 
• To toggle off individual constraint bars, click K, which displays when you hover the cursor 

over the bar, as shown in Figure 4-14. 

777 # K 

Figure 4-1 4 

• Toggling off the display of a constraint bar or an icon does not delete or remove the 
constraint. It only hides the icon. 

[ .,. , • To display the constraints of selected objects, click "· ! (Show/Hide Geometric Constraints) 
in the Geometric panel. [ ,1 • To display all of the constraints in a drawing, click '< .  (Show All Geometric Constraints). 

[ ,, • To hide all of the constraints in a drawing, click "' t (Hide All Geometric Constraints). 

© 2023, ASCENT - Center for Technical Knowledge® 4-9 



AutoCAD 2024: Beyond the Basics - I nstructor Gu ide  

Modifying Geometrical Constraints 

Objects that are constrained can still be modified using grips. When you select the grip, you can 
still stretch, move, rotate, and scale the objects as long as the constraints are satisfied, as 
shown on the left in Figure 4-15. Press <Shift> to cycle between maintaining and relaxing 
constraints. Relaxing constraints (as shown on the right in Figure 4-15) ,  removes those 
constraints. 

r_,:;[� I  
,•EiJ· : : · · · · · · · · · · ·-· · · · · · · · · · · · · · · · · · · ·  

.0 

!pedfy s1md, pant (I'  
Pr- !Mt lo cyde belN!t!n:  --------.--
Press Ol lo cyde .,._,  ·-­
· Add ----

Constraints applied 

Figure 4-1 5 

Speafy -td, l)Of11 (I' 
Press Shft ID cycle between: 
- � --
- llmmg -

PressC.t ID cyde beb,m,: ·-­
- Add -
. -., v,,11,x ID 

Constraints released 

• If you modify the location of the grip when the constraints are released, any unfulfilled 
constraints are automatically deleted. 

• You can relax (remove) a constraint by pressing < Shift> while modifying an object. 

Deleting Constraints 

To delete a constraint, select the constraint in the constraint bar, right-click and select Delete, 
as shown in Figure 4-16. You can also select the constraint and press < Delete> .  

Delete 

Hide 

Hide All Constraints 

Constraint Bar Settings 

Figure 4-1 6 

• In the Parametric tab>Manage panel, you can click di (Delete Constraints) and then select 
the object from which you want to delete all of the constraints. 
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Constra int Settings 

Cl ick � in  t h e  Parametric tab>Geometr ic pane l  t o  open t h e  Constra int Setti ngs  d i a log box i n  
the Geometric tab, as  shown i n  F igure 4- 1 7 . I t  conta ins  three tabs:  Geometric, Dimensional, and 
AutoConstrain . The opt ions i n  these tabs enab le you to control how the constra i nts a re 
d isp layed and used i n  the d rawi ng .  

Q Constrain t  Settings 

l �.e.o�e�icj Dimensional AutoConstrain 

0 !nfer geometric constraints 

Constra i nt bar display settings 

Y 0 £erpendicular 

� G2] Horiiontal 

(} 0 Iangent 

y
.r 

G2] comnear 

CU G2] Symmetric 

,_ 0 Coinc ident 

/,/ [2j Paralle l  

[2j ','ertical 

"1:- [2j Smooth (G2) 

© [2] Conc§.ntric 

= E2] Egual 

al [2j fix 

O Qnly display constraint bars for ob1ects in the current p lane 

Constra int ,Qar transparency 

I 

;,electAII 

Clear All 

E2] Sh>J'.!Y constraint bars after applyi ng constraints to se lected objects 

0 Show £Onstra int bars when objects are selected 

OK Cancel !::!elp 

Figure 4-1 7 

X 

• The Geometric tab enab les you to control the constra i nts that d i sp lay i n  the constra i nt bar  
and the transparency of  the bar. 

• The Show constraint bars after applying constraints to selected objects contro ls  whether 
or  not constra int bars d isp lay when you have app l ied constra i nts to objects .  

• The Show constraint bars when objects are selected contro ls  whether o r  not the constra i nt 
bars d isp lay when objects a re selected . 

• The Infer geometric constraints opt ion uses ex ist ing constra i nts to determine whether 
add it iona l  constraints a re requ i red as more objects a re added to the d rawing .  The 
constra i nts a re then automat ica l ly  added as req u i red . Use Infer Constraints in the 
Custom ization l ist i n  the Status Bar  to togg le  the Infer geometric constraints opt ion on 
or  off. 

• The AutoConstrain tab sets the pr ior ity in wh ich constraints a re app l ied when Auto 
Constrain is used.  You can a lso control the To lerance. 
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4.3 Dimensional Constraints 
The dimensional constraints that are created to define a feature's shape are considered 
parameters. They drive the object's size, distance, and angle and can be changed at any time, 
causing the features to update automatically. 
In the example shown in Figure 4-18, the dimensional value that posit ions the cut feature has 
been changed. Therefore, the posit ion of the feature updates to reflect the design change. 
The AutoCAD software automatically assigns names (e.g. ,  d1 or d2) to dimensions. You can 
display the name, name and value, or value of the dimension, as required. 

CJ CJ 

,J 1='.:: 000J iil 
· "· >······ 

Figure 4-1 8 

How To: Assign D imensional Constraints 

1 .  Create the objects that you want to constrain and apply geometrical constrai nts to them. 
2. In the Parametric tab>Dimensional panel (shown in Figure 4-19), select the type of 

dimension that you want to place. 

� <, f&i � n Show11-lide 
l td! I 8 v 

/ ,;1_ � 1. Show All Linear Aligned "' 
r1 Hide All 

I '1 Dynamic Constraint Mode I 
t;\ Annotational Constraint Mode 

� Dimensional 

Figure 4-1 9 

3. Specify the points that you want to dimension and then pick the dimension line location. 
4. When the dimension highlights, type a number value, expression, or formula for the 

dimension. 
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Types of D imensional Constraints 
All available dimensional constraints are described as follows: 

Linear: Constra ins the hor izontal or vert ica l  d istance between two po ints .  The d i rect ion 
depends on the p lacement of poi nts and d imens ion l ine .  

Horizontal :  Constra ins the X d istance between two poi nts or  objects ( in  the L inear fly-out) . 

fil 
� 

,-,,; 
8--1. 

Vertical: Constra ins  the Y d istance between two poi nts or objects ( in  the L inear  fly-out) . 

Aligned: Constra ins  the d istance between two po ints on an object or on two d ifferent 
objects. 

Radius: Constra ins  the rad ius  of a circle or arc.  

Diameter: Constra ins the d iameter of a c i rcl e or a rc .  

Angular: Constra ins  the angle between two l i nes o r  polyl ine segments, or  between th ree 
poi nts (vertex, fi rst, and second  ang le constra i nt po ints) . 

Convert: Turns a l ready exist ing d imensions i nto d i mens iona l  constra i nts.  

• The dimensional constraints work in the same way as the standard dimension commands. 
• For some Dimensional Constraints, you can select entire objects. 

• Click � (Show/Hide Dynamic Constraints) to toggle the visibility of the selected 

dimensional constraints on and off. You can also click 191 (Show All Dynamic Constraints) 

or 191 (Hide All Dynamic Constraints) to toggle all of the constraints on or off. 
• Dimensional constraints are dynamic. They display at the same size when you zoom, but 

they do not plot. 
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• You can change dynamic  constrai nts to annotat ion constra i nts i n  the Propert ies pa lette, as 
shown in  F igu re 4-20.  Annotat ion constra i nts use the act ive annotat ion scale and 
d imens ion sty le .  

)( 

j ◄  Rota ted Dimension (D . . .  • 'i1" • -� � 
Q 

Vl w 

w a.. 
0 a: a.. 

Constraint ... 
Constraint Fom1 Dynamic 

Reference Dynamic 

Name An notational 

Expression 0.02655988395 . . .  
Va lue .0266 
Description 

Misc ◄ 

Text .... 
Text rotation 0 

Figure 4-20 

• By defau lt, the Name and Expression d isp lay for d imens iona l  ( i n  both the dynamic  and  
a nnotat ion) constra i nts .  Th is  can be changed to  Name or  Value i n  the Dimensional tab  of  

Constra int Sett i ngs  d ia log box, as  shown i n  F igure 4-21 . Open the  d ia log box by  c l i ck ing  � 
i n  the Parametric tab>D imens iona l  pane l .  

4- 1 4  

li1 Constra i nt Setti ngs 

Geometric Dimensional AutoConstrain 

Dimensional constraint format 

Dimension !}ame format : 

Name and Expression 
Name 
Value 
Name and Expression • 

V 

d 1 =d2+ d 3  

onstraints 

0 ;ihow hidden dynamic constraints for selected objects 

Figure 4-21 

X 

© 2023, ASCENT - Center for Technical Knowledge® 



Para metric Drawing 

How To: Convert Dimensions into Constraints 

1. Draw the dimension(s) using standard dimension commands. 

2. In the Parametric tab>Dimensional panel, click r::.-1 (Convert) . 
3. Select the dimension and press < Enter>. The dimension becomes a parameter 

(dimensional constraint), as shown in Figure 4-22. The parameter value can then be 
modified. 

d 2 = !: ,  DC, rX: ilil 

L'-------------+CJ � 

d 1= 2 . 0 0() 1J iii 

Figure 4-22 

� Hint: Best Practices for Dimensional Constraints 
When creating dimensions, use the following guidelines: 

• Consider the dimensions that are going to be displayed in drawings and note the 
resulting feature relationships. 

• Consider changes that might be made to the model in the future and how easily the 
dimensions facilitate those changes. 

Periodically modify dimensions to test what if scenarios. This is called flexing the model and 
helps eliminate future problems by verifying that the model behaves correctly. 
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Modifying D imensional Constraints 

To mod ify a d imens iona l  constrai nt, you can doub le-cl ick on the text and type the new 
information i n  the text f ie ld ,  as shown in  Figu re 4-23 .  

_J d i nl = 2  0000 - ,  

fx :  d f c 2 = d i iJ 1  • 1 .  5 al-· 

Figure 4-23 

d fi = 2 . 50 00 11i 

* 

• When d imens iona l  constra i nts reference one another, fx: i s  added to the beg i nn i ng  of the 
d imension to i nd icate that a reference a l ready ex ists. 

You can a lso modify the constra i nts i n  the Parameters Manager  pa lette, as  shown i n  

Fi gure 4-24. C l ick  fi,j (Parameters Manager) i n  the Parametric tab>Manage pane l .  

X 
j◄ )7 f, )( Search fo r parameter 0, 

(i Name Expression Value » ... 
G Dimensional Constraint Parameters 

ai ang 1 1 50 1 50 
jil d 1  1 1 ,0000 
ii d2 w 2 2 JOOC' 
' ;- d3 d2+ 1 + base l50LO 

,<� rad 1 0.5 SOOl' :::,; 
Vl G User Parameters 

base 1 . 5  1 .SOC.O w ..!. 

» 

ji,i 
All : 6 of  6 parameters displayed 

Figure 4-24 

• I n  the Parameters Ma nager, modify the Expression .  The Value updates automat ica l ly. 

• To remove a d i mens iona l  constra i nt, select it in the Parameters Manager a nd c l ick X or  
press <De lete>. 
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* • By default, all of the parameters in a drawing display. Click � (Filter) and select All Used in 
Expressions to only display the parameters used in expressions, as shown in Figure 4-25. 

Filters 
H j" AII 

f" X Search for parameter 0-.. 

« Name .. Expression Va lue 

er w v 
.,: 

.v;.· .. All Used in Expressions 
B Dirnens,ona: Con5tramt Parameter� 

2 

V, 
rY 

� D !nvert filter 
;,/; 

d2+ 1 +base 
G User Parc:Hn�tei s 

!.� base 1 . 5  

« < 

fa) 

All Used in Expressions: 3 of 6 parameters displayed 

Figure 4-25 

> 

• You can search for parameters by typing a value in the Search for parameter field in the 
Parameters Manager. 

Formulas in  Constraints 

Formulas can be added to dimensional constraints when they are inserted or in the Parameters 
Manager. 
• Formulas are user-defined mathematical relations that are used to capture and control 

design intent. 
• An equation is created by writing a relation using dimensions or parameters from the model. 

For example, equations can be used to keep a hole centered on a block, as shown with the 
dimensions for d3 and d4 in Figure 4-26. 

(" �---

f :c cfl = d  1 iii 

Figure 4-26 
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Creating User Parameters 
User parameters can be added to strengthen the formulas. For example, you might have a bolt 
size that impacts several other parameters in the drawing, as shown in Figure 4-27. By creating 
a user parameter, you can easily flex the object by changing the user variable and noting how 
the other objects react. Changing the user value modifies the object. 

'i? J�, X Search for parameter O� 

Filters « Name .-. Expression Value 

F:J .fi•1 All El Dimensional Constraint Parameter! 
' ."1J·,, All Used in Expressions 01_ ang 1 1 50 iso 

er UJ <.'.) <C z <C 
� 
Vl 
oc I.LJ >­w 

j D I nvert f i l ter 

fc,; 
All: 7 of 7 parameters disp layed 

A d l  1 .0J00 
1a1 d2 2 2 0000 

.;, d3 d2+ 1 +base 4.5000 
,";, rad l  0.5 .5000 

El User Parameters 

« < 

!.rt, base 1 . 5  1 .51)()(: 
!. userl 1 1 .0000 

Figure 4-27 

How To: Create a User Parameter 

> 

� 
1 .  In the Parameters Manager, click JI (Create User Parameter). A new parameter displays in 

the User Parameters area. 

Note: User parameter names cannot contain spaces, begin with a number, or be over 
256 characters. 

2. Type a name and an expression. 
3. Use the parameter in the expression of other parameters. 
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Work with Constraints 

Practice Objectives 
• Add geometric constraints to the drawing. 
• Add dimensional constraints to the drawing. 

Parametr ic Drawing 

i 30 minutes 

In this practice, you will add geometric constraints to a drawing using the Auto Constrain 
command. You will then add dimensional constraints to drive an existing model's shape and 
size, as shown in Figure 4-28 . 

0 -� I l)U [; O u 

\-(y·_.

.

./ ·,. 
·· ~ -J n g l cc, I 50 u 

Figure 4-28 

Task 1 :  Add automatic geometric constraints. 

1 .  In the AutoCAD software, open Entry-Clamp-M.dwg from your practice files folder. 

2. In the Parametric tab>Geometric panel, click J:. (Auto Constrain) . 
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3. Select all of the objects in the drawing (use crossing or window selection) and press 
<Enter> .  Many constraints are applied, as shown in Figure 4-29. 
• If the constraints were not applied correctly, open the Constraint Settings dialog box and 

check the settings in the AutoConstrain tab. 

Figure 4-29 

4. Select one of the lines and move it by its grip. Note that the object is not constrained 
enough to keep it from distorting, as shown in Figure 4-30. Press <Esc> twice to exit the 
selection. 

Figure 4-30 

5. In the Geometric panel, click j_ (Coincident) . 
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6. Select the right end point of the bottom arc and then the left end point of the closest line, as 
shown in Figure 4-31. The arc and the line is joined. 

0 0 
1 Select second point or ml 

Figure 4-31 

Note: As you add the constraint, its symbol is displayed with the object it is applied to. 

7. Add a Tangent constraint to the arc and coincident line. In the Geometric panel, click 

0 (Tangent) and select the arc (created in the previous step) and its corresponding line 
(the line to which you joined it) . 

8. To make the same line parallel to the line above, click // (Parallel) and select the top line 
and the bottom line. 

9.  Click X (Perpendicular) to make the right line touching the two horizontal parallel lines 
perpendicular. Select the top horizontal line, and then the right line. The object should now 
be similar to the one shown in Figure 4-32. 

// 

J' 

Figure 4-32 
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1 0 . In the Geometric panel, click = (Equal) . Select the vertical line on the right and then the 
angled line on the bottom left, as shown in Figure 4-33. The two lines become equal in 
length . 

1 1 .  Modify one of the lines using grips. The vertical lines automatically adjusts to stay equal in 
length . 

0 

First Equal line 

// 

Figure 4-33 

1 2 . Similarly, make the two arcs = (Equal) . Select the bottom arc and then the top arc. 

1 3 . Use © (Concentric) to have the circle and top arc share the same center point by selecting 
the top arc and then the circle. The circle might move outside the lower arc. 
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1 4. Select the bottom left angled parallel line to display its grips. Pull the middle grip slightly 
down to resize the object so that the circle is inside the lines, as shown in Figure 4-34. 
Press < Esc>. 

= 

Figure 4-34 

1 5. In the Geometric panel, click 0 (Fix). Select the circle to make this a fixed point. 
1 6. Flex the object by moving one of the lines. Note that it is still not fully constrained and 

needs to be finished with dimensional constraints. Undo the flex action. 

[ ,, 1 7 . Click "-f (Hide All) to hide the geometric constraints. 

Task 2: Add d imensional constraints. 

1 .  In the Parametric tab>Dimensional panel, click � (Linear) . If  the Annotation Scale dialog 
box opens, click OK. 

2. Press < Enter> to change to the Object option. 
3. Select the vertical line on the right and then click to the right of it  to place the dimensional 

constraint value field. 
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4. Type 1 in the Dimensional constraint field and press < Enter>. The dimensional constraint is 
applied, as shown in Figure 4-35. 
• Both the vertical line on the right and the angled line on the bottom left automatically 

adjust their lengths because they are equal . 

d 1  = 1. 0000 at 

0 

Figure 4-35 

Note: I f  the dimensional constraint does not display in the format shown in Figure 4-35, 
set the Dimension name format to Name and Expression in the Constraint Settings dialog 
box (Dimensional tab). 

5. Use I a I (Linear) with the Object option to select the top horizontal line. Set the value of the 
dimension text to 1 .  

6. Use � (Aligned) with the Object option to select the top left angled line. Set the value of 
the dimension text to d2+1 , as shown in Figure 4-36. 
• If the name of the top horizontal line Dimensional constraint is something other than d2, 

type its current name in the formula expression of the Dimensional constraint value field 
for the angled line in the top left. 
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I 

fx : d.3= d 2 + 1 ti 
I 

I 
I 

� d2=1  QQOO iii� 

I . "' 1  
--------------, ---,-

0 

Figure 4-36 

7. Double-click on the l inear dimensional constraint d2. 

Para metric Drawing 

8. Type 2 in the linear Dimensional constraint field to change its value and press <Enter> .  Both 
the d2 l ine and the d3 al igned lines update. 

9. In the Dimensional panel ,  cl ick � (Radius) and set the bottom arc to the dimension text 
value of 0.5. 

1 0 . In the Dimensional panel ,  click B) (Angular) . Select the horizontal line at the bottom right 
and then the angular line at the bottom (left of arc), as shown in Figure 4-37. Set the 
dimension text value to 120 . 

i i 

0 
--------,--� 

rad1  .5000 ii 

J / 
c n g 1  1 20 &  

Figure 4-37 
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Task 3: Modify values in the Parameters Manager. 

1 .  In the Parametric tab>Manage panel, click flc! (Parameters Manager), if it is not already 
open. 

2. In the Parameters Manager, under the Expression column for ang 1 ,  change the value to 100 
and press <Enter>. The model updates accordingly. Change the same parameter to 150 (as 
shown in Figure 4-38) and press <Enter> to update the model. 

3. At the top of the Parameters Manager, click .f (Create User Parameter) to create a new 
user parameter. 

4. Change the name of the new user parameter to base and change its Expression to 1.5, as 
shown in Figure 4-38. 

5. In the Parameters Manager, change the Expression for d3 to d2+1 +base, as shown in 
Figure 4-38, and press <Enter>. Note how the model updates. 

,? f .. X Search for parameter 0, 

» Name .... Expression Value 
El Dimensional Constraint Parameters 

UJ 

w 

f,,J 

» 

ul. ang1 
� d 1 

r-1 d2 

�-� d3 
;'; rad 1 

1 50 
1 
2 
d2+ 1 +base 
0.5 

El User Parameters 

:. base 1 .5 

All :  6 of 6 parameters d i sp layed 

1 50 
1 .0000 
2.,)000 
,,.5000 
:;ooo 

1 .SOCO 

Figure 4-38 

6.  Flex the model several times using different values in the Parameters Manager. 
7. Hide the Parameters Manager. 

Task 4: Modify constra int settings. 

1 .  In the Geometric panel, click ['<'} (Show All) to display the geometric constraints. 

2. In the Geometric panel, click � to open the Constraint Settings dialog box. 
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3. Ensure that you are in the Geometric tab. In the Constraint bar display settings area, clear 
the Tangent option, as shown in Figure 4-39. 

Constra int Settings 

Geometric D imens iona l  AutoConstra in 

D )nfer geometric constra ints 

Constra int ba r  display settings 

'( [2] E'.erpendicu lar  [2] Parajlel 

� [2] Horiiontal II [2] \,[ertica l  

O iangent 0 Smooth (G2) 

V 
, 

[2] Col l inear [2] Conc.!,ntric / 

[2] Symmetric [2] Egua l  

[2] Coinc ident trJ [2] Eix 

D Qnly display constra int ba rs for objects in the current p lane 

Figure 4-39 

12.elect AII 

C lear 811 

X 

4. Select the Dimensional tab and change the Dimension name format to Value, as shown in 
Figure 4-40. 

5. Click OK. 

• _ Constra int Settings 

Geometric D imens iona l  AutoConstra in 

D imensional  constraint format 
Dimension name fo rmat 

��_a_lu_e ________ �: v 

[2] Show lock icon for a nnotationa l  constra ints 

[2] Show hidden dynamic constraints fo r se lected objects 

Figure 4-40 
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6. The dimensional constraints now only display the value and the tangent constraint glyphs 
are no longer displayed, as shown in Figure 4-41. 

0 1 . 0000 i 

// .c>ooo a / 

----- i so u  
/,/ 

Figure 4-41 

7. Save the drawing. 

End of practice 
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Chapter Review Questions 

1 .  Which Geometric constraint forces two linear objects to take on the angle of the first 
object? 
a. Symmetrical 
b. Parallel 
c. Vertical 
d. Perpendicular 

Answer: b 

2. Which of the following can be displayed for Dimensional constraints? 
a. Symmetrical 
b. Tangent 
c. Name and Value 
d. Equal 

Answer: c 

3. You can convert existing dimensions into Dimensional Constraints. 
a. True 
b. False 

Answer: a 

4. How can you add Formulas in Dimensional Constraints? 
a. You cannot add Formulas in Dimensional Constraints. 
b. When the Dimensional Constraints are inserted. 
c. Use the Tool Palettes. 
d. Use the Layer Properties Manager. 

Answer: b 

5. The Auto Constrain command is best used with the __ object type. 
a. Ellipse 
b. Circle 
c. Rectangle 
d. Arc 

Answer: c 

© 2023, ASCENT - Center for Technical Knowledge® 4-29 



AutoCAD 2024: Beyond the Basics - Instructor Guide 

6. If  you create user parameters, how do they affect the constrained object? 
a. They delete all of the formulas. 
b. They control Geometric constraints. 
c. Changing the user value modifies the object. 
d. They remove Dimensional constraints. 

Answer: c 
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Command Summary - Command Location 

Constraint Management 

cR Delete Constraints • Ribbon: Parametric tab>Manage pane l  

Parameters Manager • Ribbon: Parametric tab>Manage pane l  

Dimensional Constraints 

� 
Aligned • Ribbon: Parametric tab>D imens iona l  pane l  

ei) Angle • Ribbon: Parametric tab>D imens iona l  pane l  

� 
Convert • Ribbon: Parametric tab>D imens iona l  pane l  

,�-...., E!i":Y 
Diameter • Ribbon: Parametric tab>D imens iona l  pane l  

� 
Hide All Dynamic • Ribbon: Parametric tab>D imens iona l  pane l  
Constraints 

� 
Horizontal • Ribbon: Parametric tab>D imens iona l  pane l  

� 
Linear • Ribbon: Parametric tab>D imens iona l  pane l  

(� 
Radius Ribbon: Parametric tab>D imens iona l  panel 

� 
Show All Dynamic Ribbon: Parametric tab>D imens iona l  pane l  
Constraints 

r-J1 Show/Hide Dynamic Ribbon: Parametric tab>D imens iona l  pane l  
Constraints 

fil Vertical • Ribbon: Parametric tab>D imens iona l  pane l  

Geometric Constraints 

Auto-Constrain Ribbon: Parametric tab>Geometr ic panel 

Coincident Ribbon: Parametric tab>Geometr ic pane l  

Colinear • Ribbon: Parametric tab>Geometr ic panel 
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' Command Location 

© Concentric • Ribbon: Parametric tab>Geometr ic pane l  

Equal • Ribbon: Parametric tab>Geometr ic pane l  

6:J Fix • Ribbon: Parametric tab>Geometr ic pane l  

['�� Hide Al l  Geometric • Ribbon: Parametric tab>Geometr ic pane l  
Constraints 

= Horizontal Ribbon: Parametric tab>Geometr ic pane l  

// Parallel • Ribbon: Parametric tab>Geometr ic pane l  

"<·' Perpendicular • Ribbon: Parametric tab>Geometr ic pane l  

[·s!} Show All Geometric Ribbon: Parametric tab>Geometr ic pane l  
Constraints 

[ ,., Show/Hide Geometric • Ribbon: Parametric tab>Geometr ic pane l  '<d 
Constraints 

�Q 

l' 
Smooth • Ribbon: Parametric tab>Geometr ic pane l  

[ ! J  Symmetrical • Ribbon: Parametric tab>Geometr ic pane l  

& Tangent • Ribbon: Parametric tab>Geometr ic pane l  

� I Vertical • Ribbon: Parametric tab>Geometr ic pane l  
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Working with B locks 
In this chapter, you learn how to create local blocks, edit blocks, and remove unused elements 
by purging . You also learn how to add blocks to tool palettes and to modify tool properties in 
palettes. 

Learn ing Objectives I 1 hr 35min 

• Create different types of blocks that can be used in the same drawing or inserted into 
other drawings. 

• Modify block objects and customize block settings to remove elements from a drawing . 
• Create a palette and add blocks to it. 
• Modify the properties of a tool . 

© 2023, ASCENT - Center for Technical Knowledge® 5-1  



AutoCAD 2024: Beyond the Bas ics - I nstructor Gu ide 

5. 1 Creating B locks 
The objects that are reused frequently can be saved as a blocks. The blocks you need to use 
might already exist in your drawings, or you can buy block libraries for almost any type of 
drawing. You can also easily create your own blocks. A block can be locally defined in a drawing 
or saved as a drawing file for use in other drawings. 

Creating Local B locks 

The Create Block command converts a group of selected objects into a single named object or 
local block definition that only belongs to the current drawing. 

How To: Create a Block 

1 .  Draw the objects that you want to include in a block. "" 
2. In the Insert tab>Block Definition panel or Home tab>Block panel, click [(!) (Create Block). 
3. In the Block Definition dialog box (as shown in Figure 5-1 ), specify the Name, Base point, 

Objects, Behavior, Settings, and Description . 

Q Block D ef, rntwn 

Name: 

Base point 

D Specify On-screen 

•
r; 

Pick point 

X: 0 

Y: 0 

Z: 0 

Settings 
Block unit: 
Milhmeter,; 

Hyport/nk . . .  

D Open in block editor 

4. Click OK. 

5-2  

Objects 

D Specify On-screen 

!, Select ObJOCtS 

Q Retain 

@ Convert to block 

Q oelete 

No objeC1s selected 

Descripuon 

Figure 5-1 

c.o 

OK 

Bahavior 

D Annolative 

Match block onenlatraf'l 
To Layout 

0 Scale unifo,mly 

0 Allow exploding 

Cenoel Help 

x l  
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Block Settings 

When you create a b lock, you need to  specify various parameters in  the Block Definition dialog 
box, as shown in Figure 5-2. 

Block Definition 

Name: 
Part 

Base point 

Spoofy On· scrfion 

•� Pick point 

X:  144 .7209469102729 

Y: 348 .s.191!997362569 

Z: 0 

Sonings 
Block urnt: 
Mllhrneters 

Hyperllnk ... 

0 O1)6fl on block editor 

Objects 

� Select objects 

Q Retoin 

O conven ,o blocl< 

@ Delete 

1 object selected 

Description 
Mechan«::al Part 

Figure 5-2 

Base Point Area 

OK 

Behavior 

0 Annotalive 

D Match �ock orientation 
to layout 

Swlu umtormly 

(21 Allow e,ploding 

Cancel Help 

X 

The Base point is a critical setting, which controls the handle of the b lock when it is inserted. A 
good base point makes a b lock much easier to insert . In the example shown in Figure 5-3, the 
block  for a door has its base point at the hinge corner, where it attaches to the end of the wal l  
and the block for the manhole cover has its base point at the center of the cover. 

Base point Base point 

Figure 5-3 

In the Base point area, you can specify the base point by doing one of the fol lowing : 
• Select Specify On-screen to select the base point after you c lose the dialog box. 

• Click (Pick point) to select a point on the screen and then return to the dia log box. 
• Type an exact X,Y,Z coordinate. 
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Objects Area 
• Select Specify On-screen to select the objects after you close the dialog box. 

� • Click _..:}J (Select objects) to select objects on the screen and then return to the dialog box. 
• Define what you want to do with the objects after you select them. You can retain them, 

convert them to a block, or delete them. 

• Click l�I (Quick Select) to start the Quick Select command, which can be used to filter out 
objects in your selection as required. 

Behavior Area 
• Blocks can be annotative, which means they scale appropriately to the sheet of paper when 

they are plotted. This is used when you are creating annotation blocks, which often include 
text (such as a section callout bubble or room tags), as shown in Figure 5-4. Use 
Annotative to make the new block annotative. 

OF F IC E  
, A2·5 1 i 
I 

OFF ICE 
A2 D ·J 

Figure 5-4 

• Create annotative blocks at the correct size for plotting. The Annotation Scale factor of a 
viewport scales them when they are inserted through the viewport. 

• You can also use Scale uniformly to force the X- and Y-scaling of the block to be the same 
when the block is inserted into the drawing. 

• Use Allow exploding to explode the block into its components after it is inserted into the 
drawing. 
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Settings Area 
• Select a type of measurement in the Block unit drop-down list. This controls the scaling of 

the block when it is inserted into another drawing that uses a different type of unit. For 
example, if the unit in the block and the units in the drawing are different, the block is 
automatically scaled when it is inserted. 

• Click Hyperlink ... to add a link to another file or to a web address. 
• Select Open in block editor to add dynamic features to the block. 
• In the Description area, you can type a description of the block or any notes as required. 

Creating Drawing F i les from Objects {WBlock) 

Blocks created with the Create (Block) command are stored in the drawing file in which they 
were created and are only available through that drawing. If you want to select objects and save 
them as a separate drawing file that can be used globally in other drawings, use the Write Block 
(Wblock) command. 
• The Write Block command saves a copy of a block definition on your computer as a drawing 

file. Each use of Write Block creates a separate drawing file (.DWG). 
• As with any .DWG file, the drawing files created with the Write Block command can be 

inserted into other drawings. Drawings to be used as blocks are often stored in a block 
library, which is a shared network folder containing drawings that are available to everyone 
in an office. 

• You can use Write Block to break a large drawing into smaller components. 
• To insert a file made with Write Block into another drawing, in the Libraries tab of the Blocks 

Palette, use the navigation tool to the drawing that you want to insert. 
• Once you have inserted the file, it creates a local block definition in the drawing. The local 

block definition is not linked to the DWG file that was made with Write Block. 
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How To: Create a Wblock 

-� 
1 .  I n  the Insert tab>Block Definition panel, expand the Create Block flyout and click r f (Write 

Block). The Write Block dialog box opens, as shown in Figure 5-5. 

Q Write Block 

So<Jrce 
Q Blocl<; 
Q Entire drawing 
@ Objects 

Base point 

[S3 P1t:k poin1 

2(: l 70.5063732483582 

)'.; 331 .803048646314  

2:  0 

Destination 

file name and path : 

C:\Us0rs\rmuthoo1new block 

lnsen units: Millimeters 

Objects 

, r; �ecJ objects 

@ Batain 

0 Conver1 to block 
0 Delete from drawing 

I No objects sel<>eted 

OK Cancel 

Figure 5-5 

lielp 

X 

2. Select an option in the Source area: 
• Block: Select a block name from the drop-down list to create a Wblock from an existing 

block in the drawing. 
• Entire Drawing: Selects all of the objects in the drawing including any named objects 

(such as layers and dimension styles that are associated with the objects), and the 
current layer. Any unused named objects (such as empty layers) are not included. This is 
a quick way to clean up a file before it is stored. 

• Objects: Select the objects using the options in the Base point and Objects areas. 
3. In the Destination area, specify the destination filename and path. 
4. Also, specify the Insert units if they are to be different than the default units. 
5. Click OK. 
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5.2 Ed iting B locks 
You might have a library of standard details, but need to change one of them for your current 
project. You can change a local block definition in a drawing using the Block Editor, as shown in 
Figure 5-6. 

• · D L?J Q l?. 0 " -11 " 0. JL rmulhoo 

ci .� � :f L ·,/ @ i [,'. 
� y 4 --< ""  ll [<1 

Ed t Save Tes1 Auto 
Block Block Block Constrdin () w)_ (!] = [·<'J 

Sloci< Parameters: Aulhoring 
�: Mandger Palettes I 

� 
Point Move Attribute 

Defin1tlon 

0 n/Save • Geometnc Mana e Action Parameters • 

" 
)• 

(I 

� Point 

'v• Polar 

■ ■ T  XV 
• • -'-

.t:-. Rotation 

a Alignment 

., [!j Visib1l1ty 

., 
� Lookup 

-E:f}- S,uepo,nt 

11 
b1 

[ _Door 

§ H·•HU±3%tl,•mttii!itlttitfl@mtiffltttltft@ftt❖iGMli4¥ilUfl 
;;.1, Fl,l•Ano&:i:W+tiiY -li•i4shl·lli!tttilfli&tfi:MZ!3tibTJWWW 

--------- X ft EJ .. Typr a c nd 

0 X 

�.:::-:=• � 
Vis1b1hty Cto� 

B!odc£d1tot 

Close 

Model ISO AO ISO A 1 + ,o85 92S5, 108.m,. 0.0000 Moo,, m = = =  • E;) b_ 0 • --.. • �ID! • Wlil t:P • � ,:;i • � = 
Figure 5-6 

When you open the Block Editor, the Block Editor contextual tab opens containing the tools 
that are required to create complex dynamic blocks, including constraints and special 
parameters. You can use the tools on any of the other tabs as well to create or modify block 
objects. 

Changing the block definition modifies all of the instances of the block in the drawing. 

The fastest way to start the Block Editor is to double-click on the block that you want to edit. 
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How To: Edit a Block in the B lock Editor 

1 .  Double-click on the block that you want to edit. Alternatively, in the Insert tab>Block 
}. 

Definition panel, click 0b (Block Editor). 
2. In the Edit Block Definition dialog box (as shown in Figure 5-7), select the block that you 

want to edit and click OK. 

I) Edit Block Definition X 

Block to create or edrt 
l'•tM@a Preview 

<Current Drawing> " 
_Arch Tick 
A$C08041 1 B0 
ADSH2426 

� 

ARROW 
CNTRLINE 
D + DBLSINK 
DOOR 
l&liiWJ.14161 Description 
DOOR26 
DOOR3 
DOORSL 
ELLIPSE 
FOS 

OK Cancel !::!elp  

Figure 5-7 

3. The Block Editor contextual tab opens, the drawing window background changes to gray, 
the Block Authoring Palette displays, and many of the constraint tools display with the 
selected block. 

4. Modify the block. 

5. When you are finished, click '1./ (Close Block Editor). 
• The selected block displays in the Block Editor in its original position, even if you selected an 

instance that was rotated. 

Remaking B locks 
• To modify a single instance of a block (rather than the block definition), you can Explode the 

block into its original raw components, provided that the Allow Exploding option was 
toggled on when the block was created. This command also converts polylines into lines 
and arcs. 

• If the block objects were originally created on layer 0, they revert to this layer when the block 
is exploded. 
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• If you have exploded a block and modified its components, you can use the Create (Block) 
command to make the components into a block again. 

• If other instances of the block are in the drawing, select the insertion point that was used for 
the previous block. 

• If you use the same name as the original block when you redefine it, all of the instances of 
that block in the drawing update to match the new block definition. 
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Practice Sa 

Create and Edit Blocks 

Practice Objectives 
• Defi ne a b lock.  
• Create a new d rawi ng fi l e  from a loca l b lock. 
• C reate a new fi le  and then redefi ne  the block. 

:i 25 minutes 

I n  th is  p ractice, you w i l l  def ine a b lock for a couch, fi rst d rawing the objects and then us ing the 
Create Block command .  You wi l l  then use Write Block to create a n ew d rawing fi l e  f rom you r  
local b lock. You w i l l  a l so  use  Write Block to select part o f  a d rawing  and create a new fi l e, and  
then use Block Editor to redefine a b lock .  

Task 1 :  Create a local b lock. 

I n  th is task, you wi l l  defi ne a b lock for a couch, f i rst d rawing  the objects and  then using the 
Create Block command,  as shown i n  F igure 5-8 .  

,. 533 
7� 7l 

1 800 

Figure 5-8 

1 .  Open California House-AM.dwg from you r p ract ice fi les fo lder. 
2. Set the current layer to Furniture. (H i nt: You w i l l  d raw the block on th is  layer so that it 

reta ins the properties of the layer Furniture no matter what layer you i nsert it on . )  
3 .  Zoom in  on  any one of  the rooms and d raw a couch (without the d imens ions; they a re for 

reference on ly), as  shown in F igu re 5-8 .  Add 1 mm to the m idd le  seat to make it 534mm 
wide .  * 

4. In the Insert tab>Block Defi n it ion panel, c l ick C4:i (Create B lock) . In the Block Defi n it ion 
d i a log box, name the b lock Couch. 

+. 
5. In the Base point a rea, c l ick  lit (P ick poi nt) and select the m idpo i nt at the back of the 

couch as the base po int .  
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6. In the Objects area, click r;, ,  (Select objects), select the couch objects, and press < Enter>. 
Select the Delete option. 

7. Verify that the Block unit is set to Millimeters. 
8. Verify that Open in block editor is N OT selected. 
9. Click OK. The block is created and the couch is deleted from the active drawing. 
1 0 . Set the current layer to 0. 
1 1 .  Open the B locks Palette in the Recent or Current Drawing tab. Using the Repeat Placement 

option, insert a couch in several rooms (note that it is sti l l  the color of the layer Furniture). 
1 2. Save the drawing with a few couches inserted. 

Task 2: Create a drawing f i le from a block. 

_ e,  
1 .  In the Insert tab>Block Definition panel , expand the B lock flyout and click • -� (Write B lock). 
2. In the Write B lock dialog box, for the Source, select Block, expand the drop-down l ist of local 

blocks in the drawing, and select Couch. You do not need to select the Base point or Objects 
because you are using an existing block definition which has a l l  the options already set. 

3. In the Destination area, use . . .  to set the path to your practice folder and the filename to 
Couch, as shown in Figure 5-9. The Insert units should be set to Millimeters. Click OK to 
create the new drawing file. 

• Write BI ock 

Source 

@ fllock· 

0 Emre drawing 
Q Objects 

Base poir,t 

0 

r 0 

0 

Destinstaon 

Eilo name and path· 

Objects 

Re1.a1n 

Convert to blocj,(, 

Oelets from drawing 

ed 

C.\AutoCAD 2024 Fundamentals Pradiea F ,les\Couch.dwg 

Insert units. Mdhmeters 

OK Cancel 

Figure 5-9 
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4. Open the new drawing Couch.dwg from the practice files folder. 
5. Use the Zoom Extents command to display the couch. Save and close the drawing. 
6. Open Plan1 -AM.dwg from your practice files folder. 
7. In the Blocks Palette>Current Drawing tab, note the list of blocks displayed. The Couch 

block is not in the graphics list. Open the Libraries tab. Click ITTJ (navigation tool) near the 
top right corner of the palette to open the Select a folder or file for Block Library dialog box. 
Navigate to your practice files folder and select the Couch.dwg file. Click Open. Note that it 
is listed in the Libraries tab of the Blocks Palette, as shown in Figure 5-10. 

g, Filter _ _ 
-� 
� D Couch.dwg Cl _ ,  
c Path: Couch.dwg 

*Couch.dwg 

-� 
.'.I'. Options 

� ,R,  Insert ion Point 

D6] Scale ,... X: 1 

D G Rotation 0 

� � Auto-Placement 

� & Repeat Placement 

D 10il Explode 

Y: 1 

Angle 

Z: 1 

X 

V1 � u 

cy 
Figure 5-1 0 

8. Insert a couch into one of the rooms. Open the Current Drawing tab of the Blocks Palette 
and note that it is listed there, which indicates that it is now a local block in the drawing 
Plan1 -AM.dwg. 

9. Save and close Plan1-AM.dwg . 
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Task 3:  Create a new drawing from part of a drawing.  

In this task, you will toggle off most of  the layers in a drawing and use Write Block to copy the 
remaining objects to a new f ile, as shown in Figure 5-11. 

□ □ n □ □ □ 

Figure 5-1 1 

1 .  In the California House-AM.dwg, use the Zoom Extents command to display the entire 
plan. 
• If California House-AM.dwg is not already open, open it from your practice f i les folder. 

2. Freeze all of the layers except 0, Doors, Walls, and Windows (many layers are already 
frozen). 

3. Click : -�r (Write Block). In the Write Block dialog box, in the Source area, select Objects. 

4. In the Objects area, click [; � (Select objects) and select all of the visible objects. Right­
click or press <Enter> to return to the dialog box. 

5. Leave the Base point at 0,0,0. Set the path to your practice folder and name the f ile 
Floorplan-1 M.dwg. 

6. Click OK to close the dialog box. 
7. Close California House-AM.dwg. Do not save changes. 
8. Open Floorplan-1 M.dwg. Only the objects that you selected display along with the layers 0, 

Doors, Walls, and Windows (Layer Control). 
9. Close the drawing. Do not save changes. 
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Task 4: Edit a block. 

In this task, you will use the Block Editor to redefine a block with a new design, as shown in 
Figure 5-12. 

R200 �, 

R1 00 \_,_ ---- -- ---- -- -­?, ----�---- � ----

Figure 5-1 2 

\ i 

1 .  Open California House-AM.dwg and thaw the layer Furniture. Double-click on one of the 
Couch blocks. 

2. In the Edit Block Definition dialog box, Couch is highlighted with its preview displayed. Click 
OK to continue. 

3. The Block Editor opens with the block filling the drawing area. Also the background is 
changed to gray and the Block Authoring Palettes displays. Close or hide the Block 
Authoring Palettes. 

4. Fillet the back corners of the couch, as shown in Figure 5 -12. 

5. In  the Block Editor contextual tab, click '1./ (Close Block Editor) and click Save the changes 
to Couch. 

6. Note that all of the instances of the Couch block in this drawing are automatically updated 
to the new style. Insert another Couch and note that it has also changed. 

7. Save and close the drawing. 
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5.3 Removing Unused Elements 
A drawing might contain elements that were defined once but are no longer used. Common 
examples of this include: 
• Blocks that are defined but not inserted anywhere. 
• Layers that do not contain any objects. 
• Named components that are no longer used. 

These unused (or unreferenced) definitions use disk space and can significantly increase the 
size of your drawing. Use the Purge command to remove these items. 
The various Purge tools are available in the Manage tab> Cleanup panel, as shown in the 
Figure 5-13. 

� Purge 

Find 
l Overki l l  

Non- Purgeable Items G:J Audit 

Cleanup 

Figure 5-1 3 

1 Use (Overkill) to remove duplicate and overlapping geometric objects such as lines, arcs, 
and polylines. Examples of the changes made by the Overkill command include: 
• Deleting duplicate line or arc segments. 
• Deleting arcs that overlap portions of circles. 
• Combining partially overlapping lines drawn at the same angle. 
• Deleting zero-length and overlapping polylines. 

How To: Purge Al l Unreferenced Items 

1 .  In the Manage tab>Cleanup panel, click 1 (Purge) or in the Application Menu, select 
Drawing Utilities>Purge. The Purge dialog box opens.Click Purge All and click Close to end 
the command. 
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How To: Purge Specific Types of Items or Individual Items 

1 .  I n  the Manage tab>C leanup pane l ,  c l i ck  1 (Purge) or i n  the App l icat ion  Menu,  select 
D rawing Uti l it ies> Purge. 

2. In the Purge d ia log box, in the Named Items Not Used area, select the category of the item 
that you want to pu rge (such as Blocks, Layers, etc . ) .  You can a lso expand the l i st fo r any 
category and select i nd ivi dua l  items to purge, as shown i n  F igure 5-1 4 .  The Preview area 
d i sp lays the i mage of the i tem to be pu rged .  
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i --□ r.:(!) .. f+-1:.1111s�,1!1,m!ll,, .. ,'l!!,=l!lm 
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D � Dimension styles 
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LJ Q Multileader  Styl e s  
1-J, Plot styles 
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10 Shapes 
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D A,, Text styles 
(/Ji Visua l  styles 

i:.J. Preview 
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G2] l;;onfirm each item to be purged 
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Empty text ob1ects 

D Orphaned _ctata 

X 

P.urge Check'ild tter 5 Purge 811 j _ CIQse 1 !::!elp L.........::::: __ ····· -

Figure 5-1 4 

3 .  C l i ck  the check boxes of the i tems to be purged. C l ick Purge Checked Items. 
4. C l i ck  Close when you a re f in ished .  
• If the Confirm each item to be purged opt ion is se lected, you are prompted to verify each 

item before it i s  purged . 
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• To completely purge all of the unreferenced elements in the drawing, select the Purge 
nested items option. For example, this enables you to purge any unreferenced layers that 
are part of (or nested in) an unreferenced block definition. 

• The Purge Unnamed Objects area provides you with the options of purging Zero-length 
geometry and Empty text objects separately. 

• Selecting the Find Non-Purgeable Items tab in the dialog box displays a list of items that are 

in use and cannot be purged. ( I f  you are not in the Purge dialog box, you can use lo. (Find 
Non- Purgeable Items) in the Manage tab>Cleanup panel.) Select an item to display the 
information about why it cannot be purged. A detailed information such as the number of 
items on each layer and their effect on the size of the file is also provided, as shown in 
Figure 5-15. You can also click the Select Objects button to zoom in to the specific non­
purgeable object. 
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Practice Sb 

Purge 

Practice Objective 
• Remove unused block definitions and empty layers. 

i 5 minutes 

In this practice, you will remove unused block definitions and empty layers from a drawing 
using the Purge command. 
1 .  Open Purge-AM.dwg from your practice files folder. 
2. Open the Layer Control and review the list of layers. 

• There are 29 layers in the list. 
3. Expand the Insert Block gallery and note that several blocks are defined in this drawing, but 

are not used. 
4. In the Manage tab>Cleanup panel, click 11'1 (Purge), or in the Application Menu, expand 

Drawing Utilities and select Purge . 
5. In the Purge dialog box, expand the Blocks category to display the blocks that can be 

purged, as shown on the left in Figure 5- 1 6. 
6. Expand the Layers category to display the layers that can be purged. 
7. Click Purge All . In the Purge - Confirm Purge dialog box, select Purge all checked items. 
8. Most of the unused items are purged, but some still remain. These items were nested in 

blocks, as shown in the middle in Figure 5-1 6. 
9. Click Purge All again and select Purge all checked items. All of the unused items are 

purged, as shown on the right in Figure 5- 1 6. 
-·.:: ·

==-·mn 
----- -- - ---- -- ---
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1 0. Click Find Non-Purgeable Items and expand Blocks. Select _Arch Tick and note the 
information about why it cannot be purged. Also note the additional information such as 
the number of items and their effect on the size of the file, as shown in Figure 5-17. 
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1 1 .  Close the Purge dialog box. 
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Figure 5-1 7 
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1 2. Open the Layer Control. Only six layers are listed and the unreferenced layers have been 
removed. 

1 3 .  Expand the Insert Block gallery. The unused blocks have been removed. 
1 4. Save and close the drawing . 

End of practice 
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5.4 Adding Blocks to Tool Palettes 
Tool palettes are the easiest way of  inserting b locks into your drawing. You can create custom 
palettes in the Tool Palettes to organize your b locks into logical categories. 
Once the palette has been created, drag and drop blocks into it to create tools for those b locks. 
Then use the palette tools to insert the blocks into the drawings in which you want to use them, 
whether or not the block has been defined in the drawing . 

How To: Create a New Tool Palette 

1 .  Right-click in the Tool Palettes tit le bar or tab and select New Palette . 
2. In the Edit field, type a name for the palette (as shown in Figure 5-18) and press <Enter> .  

The new palette does not contain any tools. 

Figure 5-1 8 

a: r-.1 �-nir.ii:miiirJiii;aill � z 

n:i 
-5 

TI] 

• Although you can add tools to the defau lt palettes supplied with the AutoCAD software, 
creating custom palettes enab les you to better organize the tools as you want. 

• You can also right-click on the tab and select Delete Palette or Rename Palette to delete or 
rename existing palettes. 
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How To: Add Blocks to a Palette 

1 .  Select a block in the drawing area. 
2. Drag and drop it onto the palette, as shown in Figure 5-19.  

Work ing  w ith Blocks 

Note: The file containing the blocks must be saved before you can add a block to a palette. 

C: "' .c 

tub-whirlpool 

LAV 

PWCF 

V} 
UJ 
I­
f­
UJ 

<( '.:; �==========:::::: 
Vl 
u.J 
I-

Figure 5-1 9 

F)RIM ARY B ATH 

• Drag the block onto the palette by its edge, not by its blue grip. Dragging the grip moves the 
block in the drawing but does not enable you to drop it into the palette. 

• The tool uses the layer, color, and other properties of the object used to create it. Therefore, 
blocks that you insert with the tool are automatically placed on the same layer as the 
original block, no matter which layer is current. 

• You can rearrange the tools in the palette by dragging and dropping. 
• You can also delete individual tools from the Tool Palettes. Select the tools that you want to 

delete (use <Shift> or <Ctrl> to select multiple icons), right-click, and select Delete. 

• You must add blocks to the palette one at a time using this method. 
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Preparing B locks for a Tool Palette 
• The drawing from which you add the block to a palette becomes the source file for the block 

tool in the palette. If you move or delete this source drawing file, the palette tool no longer 
works. 

• Create and store your blocks in a library drawing, or several such drawings for different 
categories of blocks. For example, you can define your furniture blocks in a drawing called 
Furniture L ibrary and then add the blocks to a palette from that drawing. 

• Keep your block library drawings in a location from which they cannot be moved or deleted. 
Make it a network location if everyone needs to access these blocks. 

11 Hint: Creating a Tool Palette from the DesignCenter 
The DesignCenter offers a quick way of creating a tool palette using the entire set of blocks 
in a drawing. Right-click on the drawing name in the DesignCenter and select Create Tool 
Palette, as shown in Figure 5-20. A palette is created with the same name as the drawing, 
containing tool icons for all of the blocks defined in that drawing. 

5-22 

• DesignCenter 
.Analog Integrated Orcurts .dwg 
.AJ.JtoCAD Texlstyles and Unetypes .dwg 
Basic Electronics .dwg 

"· CMOS Integrated Circutts.dwg 

Hydraulic J Kitchens .di 
L..andscapi 

Explore 

Search . . .  

Add to Favorites 

Organize Favorites . . .  

Create Tool Palette 

Set as Home cy Block 
A""' '"' . .  " ',-,-...,....,,_ ________ _ 

Figure 5-20 
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5 .5  Modifying Tool Properties i n  Tool Palettes 
Each tool in a palette can be modified to insert the object using specific properties, such as 
layer, scale, or rotation. For example, you might need to place a block at two different angles. 
• You can create two tools in the palette for inserting the block, each preset to be inserted at 

the required angle. 
• Once a tool has been added to a palette, you can drag and drop it to different places in the 

palette or to other tabs as required. 

Modifying Tool  Properties 

To modify a tool's properties, right-click on a tool in the palette and select Properties ... The Tool 
Properties for a block tool are shown in Figure 5-21. Other types of tools (e.g., for hatching or 
commands) have different properties. 

• Too! Properties 

tmage: 

Insert 

Name; 
Hex Nut - Metnc 
Qescription; 
Hax nut supporting various standard metric sizes 

Name Hex Nut - Metric 

X 

Sowce file C:\Program File,\Autodesk\AutoCAD . . .  
Scale 1 
Auxil iary scale None 
Routir.in o 
Prompt for r No 

r �plode No 

General 
Co,or ■ Bylayer 
li.,yer  use nment 

OK 

Figure 5-21 
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Command Options 

Image 

Name 

Description 

I nsert Options 

Name 

Source file 

Scale 

Rotation 

Prompt for 
Rotation 

Explode 

The preview image that d isp lays for the too l .  

The name that  d isp lays with the  tool i n  Too l  Pa lettes .  By defau lt, th i s  is set to the 
name of the block. 

An opt iona l  descript ion for the tool , taken from the b lock descript ion. 

The name of the block i n  the source f i le .  

The d rawing fi le  used to create th is tool i n  the pa lette and where the b lock 
defin it ion is stored .  

I nsert ion sca le fo r the b lock. You can preset a va lue here .  Auxil iary scale enab les 
you to scale based on the cu rrent d imension sca le factor or p lot sca le  factor. 

Sets the rotat ion ang le for the block when i nserted . 

If set to Yes, you a re prompted for the rotat ion ang le  in the Command Li ne when 
you i nsert using the c l i ck and pick poi nt method. Th is has no effect when you 
insert using the d rag-and-drop method . 

If set to Yes, the b lock is inserted as its component p ieces, not as a s ing le  b lock 
object. 

Genera l  Options 

Layer 

Other Options 

Sets the l ayer on which the block is inserted .  

The other Genera l  opt ions (Color, Linetype, etc . )  a re norma l l y  set to Bylayer so 
that the i r  propert ies a re contro l led by the layer. 

• If the layer spec ified i n  the Too l  Propert ies does n ot ex ist i n  the cu rrent d rawing,  it i s  
automatica l ly created w h e n  you i nsert t h e  b lock .  

• If the specif ied l ayer is togg led off or frozen, the b lock i s  st i l l  p l aced on that l ayer. However, 
it does not d i sp lay unti l you togg le  on  or thaw the l ayer. 
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Redefin ing B locks in  Tool Palettes 

I f  the block definition in the source file changes, it does not automatical ly update in the palette. 
Open the Tool Properties dialog box and select the source fi le again. 
• You can update a block definition in the current drawing to match a block in the Tool 

Palettes by right-clicking and selecting Redefine, as shown in Figure 5-22. 

X 

j ◄  O· 
a Redefine 

a] PWC Block Editor 

� LAV 
Cut 

Copy : I  
Figure 5-22 

• If you open a block in the Tool Palettes in the Block Editor, any changes are saved to the 
block in the palette and automatical ly  update in the active drawing. 

• You can specify an image for a tool palette icon. Right-click on the tool and select Specify 
image ... , as shown in Figure 5-23. In the Select Image File dialog box, you can select the file 
you want to use. BMP, J PG, PNG, G I F,  and T IF  files are al l supported image types. 

X 1 1J j ◄  l ·O· ,,., 'l 

a Redefine 

a] PWCF Block Editor 

� LAV 
Cut 

Copy 
"' 

Delete 

Rename 

....J Update tool image 

Specify image . . .  

Properties . . .  
w 

Figure 5-23 
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Practice Sc 
Modify Tool Properties 

Practice Objectives 
• Create a custom tool pa lette and add b locks to the pa lette .  
• Copy and mod ify a b lock too l .  

i 1 0  minutes 

In th is  p ractice, you w i l l  c reate a custom tool pa lette with b locks and use the pa lette to i nsert 
the b locks. You wi l l  then add b locks to the custom tool  pa lette us ing  the d rag-and-drop method .  
You w i l l  a lso modify the propert ies of the b locks i n  the tool  pa lette .  

Task 1 :  Add b locks to a custom tool palette. 

In th is  task, you w i l l  c reate a custom tool pa lette w ith b locks and  use the pa lette to i nsert the 
b locks, as shown i n  F igu re 5-24 .  

I I I 
I 

X 

(±) Phi llios Flathead Sc. .. 

ll:D Hex Bolt 1 2mm -si .. . 

V) 13:D Sauare bolt 1 2mm . . .  

! I i 

. r® - - __ ,_,_, .. ··--··- -·· -© --·- -@ -

© Hex Bait 1 2mm -too 

� � Hex Nut 1 2mm -side 

I I I 
� -i- - --(±) - - -®- - +- --

V> © Hex Nut 1 2mm -too I 

8 t;; Souare nut 1 2mm ... 
-;£ 0 Souare nut 1 2mm . . .  

<©> Sauare bolt 1 2mm .. . >-
@] · ·© 

I @ . . . . . 

' I 
r:; I 

I I I I 
Figure 5-24 

1. Open Fasteners-M.dwg from your  p ractice fi les fo lder. The objects a re a l l  defined as b locks 
i n  th is  d raw ing .  

�-·•··; . . ; 
2. In the View tab>Palettes panel ,  c l i ck  ■ '!_ (Tool  Pa lettes) to open the Too l  Pa lettes if it i s  n ot 

a l ready open .  
3.  Right-c l ick i n  the pa lette t it le  bar  o r  the tab bar, and  se lect New Palette. I n  the New Palette 

edit f ie ld,  type Fasteners and press < Enter>.  A new b lank  pa lette with the name Fasteners i s  
created and  the Fasteners tab is  active. 
• You can also r ight-c l ick on the New Palette tab a nd c l ick  Rename Palette. 
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4. In the drawing window, select the round Phillips screw and drag and drop it onto the blank 
open palette (Fasteners tab). (Do not select the object by its grip. Select any other 
highlighted part instead.) An icon and description for the block is added automatically as 
shown in Figure 5-25. 

W Ph i l l i p s  Flathead -.; 
\9 Screw 12mm -to p  1l 

:.: 

Figure 5-25 

5. Repeat Step 4 to add the other bolt and nut blocks to the palette (9 blocks). You must add 
them one at a time. 

6. Close Fasteners-M.dwg . Do not save changes. 
7. Open Assembly-M.dwg from your practice files folder. 
8. Set OSNAP to Endpoint and Intersection. 
9. Drag and drop the block Phillips Flathead Screw 12mm -top to the intersections of the 

construction lines, as shown in Figure 5-24. 
1 0 . Drag and drop the Hex Bolt 12mm -top blocks into the drawing, as shown in Figure 5-24. 

Task 2: Modify the tool properties. 

In this task, you will copy a block tool in the new tool palette and modify the tool properties, as 
shown in Figure 5-26 . 

. ® Phi llios Flathead Sc ... i ,. I 

@J " " © © � Hex Bolt 1 2mm -si... I! 
g' I "' B::n Souare bolt 1 2mm .. .  I I § © Hex Bolt 1 2mm -too 
::. I I I 
� - -(B - _ 1  _ _  ®-Cl. 

� _J_ 
Hex Nut 1 2mm -side % I � z <( I � © Hex Nut 1 2mm -too t I 

� 8 Souare nut 12mm ... 8 I I 
© © @ Q. 0 Souarn nut 1 2mm .. .  i 8 <©> Souare bolt 1 2mm .. .  "' 

f:i 

Figure 5-26 

1 .  To make a copy of the Hex Nut 12mm -side tool, hold <Ctrl> and drag and drop the tool 
directly below the original one in the palette. The copy of the tool has the same name. 
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2. Right-click on the new tool icon and select Properties, as shown in Figure 5-27 . 

� 
V, ... 

� 
a. 

� 
---------··-·-··· ·-" 

...J 
Redeme 

<( 

V, ❖ Square nu Blodc Editor ... 
-top I 

Cut 

.J. © Hex Nut Copy a. top ...J 

Delete 0 
� Square b I-

-top RenM!e 

Update tool image 

Specify image . . .  

Propefijes . . .  

Figure 5-27 

3. In  the Tool Properties dialog box, change the Name to Hex Nut - Horizontal. (Do not change 
the name under the Insert properties. Doing so breaks the link to the block definition.)  

4. In  the Insert area, change the Rotation to 90 (note that at the time of release of this guide, 
the image in the Tool Palettes does not update to display horizontally; however, when you 
drag it into the drawing window, it comes in horizontally) . 
• To display the image horizontally, open it in the Block Editor, change it manually and 

re-save it. 
5. In  the General area, verify that the Layer is set to Object, so that the block is always inserted 

on this layer. Click OK. 
6. Insert the Hex Nut - Horizontal and the Hex Nut 12mm -side along the top and side 

respectively, as shown in Figure 5-26. 
7. Save and close the drawing. 

5-28 

End of practice 
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Chapter Review Questions 

1 .  When you define a block, you specify a base point. Which of the following is true about the 
base point? 
a .  It is the handle that you use when inserting the block. 
b. It  is always at 0,0 .  
c .  I t  is always at  the center of the block. 
d. It is the point used to select the block objects. 

Answer: a 

2. Which command creates a separate drawing file from selected objects, that can be used in 
other drawings? 
a .  Make Block 
b. Wblock 
c. Purge 
d .  Annotative Block 

Answer: b 

3.  I f  you change the definition of  a block, what happens to any instances of that block that 
were already inserted in the drawing? 
a .  They are automatically renamed. 
b. They are erased . 
c. They change to match the new definition. 
d .  Nothing. 

Answer: c 

4. After adding blocks from a drawing to a Tool Palette, it does not matter if you move or 
delete the source drawing file. 
a .  True 
b .  False 

Answer: b 
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5. Which of the following can you set in the Tool Properties for inserting a block? 
a. Offset 
b. Rotation 
c. Freeze 
d. Flip 

Answer: b 

6. If a layer that is specified in the Tool Properties of a block does not exist in the current 
drawing, what happens when you insert that block into that drawing? 
a. The block is inserted on layer 0. 
b. The block cannot be inserted into that drawing. 
c. You are prompted for a new name for the layer. 
d. The layer is automatically created in the drawing. 

Answer: d 
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Command Summary -
Q

5 

la.. 

LI 

ru 
c8 

Command 
Block Editor 

Location 
• Ribbon: Home tab>B lock Defi n it ion pane l  or 

Insert tab>B lock pane l  

• Command Prompt: bedit or BE 

Create Block • Ribbon: Home tab>B lock pane l  o r  Insert tab>B lock 
Defi n it ion pane l  

• Command Prompt: b lock or B 

Find Non-Purgeable Items • Ribbon: Manage tab>Cleanup  pane l  

Purge • Appl ication Menu: Drawing Ut i l i t ies>Purge 

Tool Palettes 

Write Block 

• Ribbon: Manage tab>C leanup pane l  

• Command Prompt: purge or PU 

• Ribbon: View tab>Pa lettes pane l  

• Command Prompt: too lpa lettes, too lpa lettesclose, or 
<Ctr l>+<3> 

• Ribbon: Insert tab>B lock Defi n i t ion pane l ,  Create B lock 
d rop-down l ist 

• Command Prompt: wblock 
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Projects: Creat ing and Organiz ing 
B locks 
This chapter contains practice projects that can be used to gain additional hands-on experience 
with the topics and com mands covered so far in this guide. These projects are intended to be 
self-guided and do not include step-by-step information. 

Learning Objectives 

• Mechanical: Create a control panel that contains objects and blocks. 

:i 45min 

• Architectural: Create a floor plan that contains office furniture using features such as 
blocks. 

• Civil: Create a utility layout that contains objects and blocks. 
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6. 1 Mechanical Project: Contro l  Panel  

:i 45 minutes 
In this project, you will draw objects to represent components in a control panel, make blocks of 
those objects, and insert the blocks to complete the drawing, as shown in Figure 6 -2. 
1 .  Open Panel-M.dwg from your practice files folder. 
2. Create the blocks shown in Figure 6-1. All objects should be drawn on layer 0. Do not 

create the text captions, dimensions, or center marks. 
• Tip: In the CON N ECT block, draw the hexagons using the Polygon command. Select the 

Circumscribed option with a radius of 2.2. 

/ "  01 5 00 
_,,-01 2 .00 
... . 01 0.00 

• - 0 1 .00 TYP .  

1 2 .50 
08.00 

0 0  0 0  
c--i �  

"-R3 .50 '--06.00 
04.00 

PUSH VIDEO AUDIO 

CONNECT DC 

Figure 6-1 

3. Insert the blocks on the layer Component as shown in Figure 6-2. 

6-2 

• Block objects created on layer O use the properties of the current layer. Block objects 
created on other layers use the properties of those layers, no matter which layer is 
current when the block is inserted. 
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Figure 6-2 

4. (Opt iona l )  Create a tool pa lette with the b locks from th is  project, so that you can use it  to 
insert them i nto the cu rrent d raw ing  or  other d rawings .  
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6.2 Architectura l  Project: Furn iture Layout 

i 45 minutes 
In this project, you will create blocks for office furniture and insert them into a floor plan, as 
shown in Figure 6-3.  

□□□□ 

0 1 1° 
□□□□ 

0 

Figure 6-3 

1 .  Open Office3-AM.dwg from your practice files folder. 

0 0 

□ 

2. Create the blocks shown in Figure 6-4. All of the objects should be drawn on the layer 
Furniture, except the door which should be drawn on layer Doors. Do not create the text 
captions and dimensions. 
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Figure 6-4 
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3 000 

CTABLE 
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DOOR WlDTH  SOrnrn 

3. Insert the blocks as shown in Figure 6-3.  (Tip: Use the Array and Mirror commands to help 
place some of the furniture). 

4. (Optional) Create a tool palette with the blocks from this project, so that you can use it to 
insert these blocks into the current drawing or other drawings. 
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6.3 C ivi l Project: Uti l ity Layout 

i 60 minutes 

In th is project, you will create blocks for a util ity layout and insert some of them into an existing 
plan, as shown in Figure 6-5.  

Figure 6-5 

1 .  Open Observatory Site-CM.dwg from your practice files folder. 
2. Pan to an empty part of the drawing and create the blocks shown in F igure 6-6.  All of the 

objects should be drawn on layer 0. Do not create the text captions and dimensions. 

w 

6-6 

s 
North Arrow 

R3.00 

30 

�l 

"'© ® ® 
t +

. ···· 9 .02 

O' 
E!ectric Storm Sanitary Power Pele 
\/ anho!e �.tanho!e M anhole · ·· R 3 . 00 

@ 0 � 0 -c5 
V'/ater Telephone Grate light Pc1e Fire Hydrant 
Manhole f,,1anho!e Man hole 

Deciduous Tree Coniferous Tree 

__L 
Figure 6-6 
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3. Insert the blocks in the drawing as shown in Figure 6 -5. Insert the blocks on the 
appropriate layers. 
• Not all the blocks have been used in the drawing. 

4. (Optional) Create a tool palette with the blocks from this project, so that you can use it to 
insert the blocks into the current drawing or other drawings. 
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Creating Templates 

In this chapter, you learn how to  create template drawings, control drawing units and limits, 
create new layers, set up standard layouts, and save template drawings. 

Learn ing Objectives i 1 hr 30min 

• Set standards for creating templates. 
• Set the type of drawing units and their precision used in a drawing. 
• Create new layers, customize their options, and organize them. 
• Create custom page setups and associate them to specific layout tabs. 
• Apply a new page setup or an imported page setup to a layout tab. 
• Set up layouts to be used in a template. 
• Save a drawing as a template file. 
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7 . 1  Why Use Templates? 

Creating templates is an important step in customizing the AutoCAD® software to your specific 
work and drawing projects. A template is a drawing that contains the settings that you want to 
include as the foundation for new drawings. When correctly defined, these settings also 
establish a set of standards for each project. 
Features that should be set in a template include the following (as shown in Figure 7-1 ) :  
• Units (coordinates) and limits 
• Layers 
• Annotation styles for Text, Dimensions, and Multileaders 
• Layouts with page setup, border, and title block 

Home lnSHt Annotate View Maf\i!ge OUtpYt Add ms Cc.llaborata Expreu loob feattnd Apps. Q • 

/ _'.) 0 (-· □ • + v i • ·- A 1--! t 1 • t:1 . • a • '"""··· • □-. � [5*J 

0 X 

lr D 
lJ!'lf Pl:;,.lyhflf (Stell' A1t .., W • i��t 01tl'��1o,i Laye, 1 � -, t HltxJ P�;ti..-i: Gwup� • • G · "' & (- - B 

l · l t<' � 0 £> <7 0' fj \  E'J . 
Utifait>i C!ipbo.ird V 

• • 
El • Q.\ bJ gg • � • 

§} Pt0pt,rtr_.., fl. � � � @:, 

Ot,JW ,. Modify ,,,. l.a}MS ,,,. = �.rt Cahfom1.t HouH•AM� )( + I\, A H:ac-ct ., 

[-l(Top]l]D Wire•,;i�] t---4 A Ai(hittY.tura Mt.� 

I :J -·····-!\ = Model 

✓- Layouts 

• X . 

I + 

i �=� -•-\ • Layera 

Annotation styles 

10-020. 10281. o MODEL ill : : ,  • f� b. .. G • , - �J[ti] • l�.ljJ FJI • �] '.::l • [!'; .K ). ,w • , .  •· • -

Figure 7-1 

• Several predefined templates are supplied with the AutoCAD software, some with title 
blocks and borders at standard sizes. You need to add layers, text styles, and dimension 
styles if you use these templates. 
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• Other settings that can be saved in a template are system variables (such as Global 
Linetype Scale), and the Snap and Grid drafting settings. The Object Snap, Polar Tracking, 
and Object Snap Tracking drafting settings are stored in the AutoCAD system files and 
cannot be saved in a template. 

Drawing Standards 

I n  addition to  templates, you should consider the other standards that you might need to  add. 
Creating standards for using with the software enables you to work efficiently and faster 
without having to search for them when required. 
Standards are important in the following key areas: 
• Naming Standards: Establish a consistent scheme for drawing filenames, folders, and 

servers. 
• Layer Standards: Your office or organization should have a standard layer scheme that 

everyone follows. 
• Your standard layer scheme should be included in your template drawings so that it is 

available in new drawings. You should rarely need to create a new layer. 
• A logical approach to layer names can simplify layer management. For example, if you 

name all of the layers related to plumbing with the prefix P-, they are grouped together in 
the Layer Control and are easy to manipulate as a group. 

• Block Standards: Establish a consistent naming scheme for blocks. Store drawings (that 
are to be inserted into other drawings) as blocks in a shared network folder that is 
accessible to everyone who needs them. Alternatively, place sets of related blocks into 
block library drawings to be accessed using the Tool Palettes or DesignCenter. 

• You can also include standard blocks in your template file. (Tool Palettes are not related to 
templates. When you create custom Tool Palettes, they are available for any drawing) . 

• Annotation Styles: Use text, dimensions, and multileader styles to ensure consistency and 
minimize the formatting required each time you add text, a table, or dimensions to the 
drawing. 
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i Hint: Default Template for QNEW 

In the Quick Access Toolbar, click □ (New) to launch the QNew command. QNew can be 
set to use a default template f i le, so that you are not prompted to select the template when 
creating a new drawing. You can specify the template along w ith its path in the Default 
Template File Name for QNEW option in the Files tab in the Options dialog box, as shown in 
Figure 7-2. 

Drawing Template Flle Location 

fii Sheet Set Template File Location 
i;;;,:i Default Template File Name for Q N EW  

L .  · c:::>  IC:\<user name>\acad .dwtl I 
Default Template for Sheet Creation and Page Setup Ovenides 

Figure 7-2 

• If a default for QNew is set to None and has not been specified, the command opens 
the Select template dialog box, similar to the regular New command. 

The QNew template also controls which template is used for the new drawing that 
automatically opens at startup. 
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7 .2 Control l ing Units Display 
The first setting you should establish in your template is the type of drawing units to be used. 
By setting the units in a template, you ensure that any new drawing based on that template 
automatically starts with the correct units. The Units command enables you to specify the type 
of drawing units used and the precision that the AutoCAD software displays for those units, as 
shown in Figure 7-3. 

Q Drawing Units 

Length 
Iyp e: 

.Erecision: 
0.0000 

I nsertion scale 

Angle 
Txpe:  
Decimal Degrees 

Precision: 
0 

O £1ockwise 

Units to scale inserted content 
Meters 

Sample Output 
1 . 5.2.0039.0 
3<45.0 

Lighting 
Units for spec ifying the intensity of l ighting: 
International  

OK Cancel Qirection . . .  

Figure 7-3 

How To: Set the Drawing Units 

1 .  Open the template drawing that you are creating. 
2. In the Application Menu, select Drawing Utilities>Units . 

X 

tjelp 

3.  In the Length area, select an option in the Type and Precision drop-down lists. 
4. In the Angle area, select an option in the Type and Precision drop-down lists and set the 

angle rotation to be Clockwise from O as required. 
5. In the Insertion scale area, select an option in the Units to scale inserted content drop-down 

list. 
6 .  In the Lighting area, select an option in the Units for specifying the intensity of lighting drop­

down list (this is only required if you are working in 3D). 
7.  Click OK. 

© 2023, ASCENT - Center for Technical Knowledge® 7- 5  



AutoCAD 2024: Beyond the Basics - Instructor Guide 

• The Length Type options include Architectural, Decimal, Engineering, Fractional, and 
Scientific. 

• The Angle Type options include Decimal Degrees, Deg/Min/Sec, Grads, Radians, and 
Surveyor's Units. By default, angles are measured in a counter-clockwise direction. If you 
need them to go in the other direction, select the Clockwise option. 

• Note the Sample Output area as you modify the settings, as shown in Figure 7-4. 

Sample O utp,;t 
1 1 /2",2",0" 
3"<45,0" 

Architectural 

Sample O utp1.it 
1 50,2. 00,0. 00 
3.00<45,0.00 

Decimal 

S ample Output 
1 . 50",2 00",0. 00" 
300"<45,0 00" 

Engineering 

Figure 7-4 

S ample Output 
1 1 /2,2,0 
3< 45,0 

Fractional 

S ample O utput 
1 . 50E +00,2 OOE +00,0 OOE +00 
3. OOE +00< 45,0. OOE +00 

Scientific 

• Decimal units can stand for many unit types: inches, feet, meters, millimeters, miles, etc. 
• The Insertion scale controls how blocks created in different units, are scaled when inserted 

into the drawing. For example, if the block units are inches and the drawing units are 
millimeters, the AutoCAD software scales the block based on the conversion factor for 
inches to millimeters (25.4). 

• For Architectural or Engineering units, the Insertion scale units should be set to millimeters 
or meters. 

• The Insertion scale should be set to the unit of measure that each unit is intended to 
represent (for example, Meters, Feet, US Survey Feet, Inches, etc.) regardless of how it is to 
display. If the inserted content is also set in this way, the scale conversion is going to be 
correct. 

• Changing the p'recision here only controls the degree of precision that displays and does not 
affect the size of objects that are drawn. The AutoCAD software still works with its full 
degree of accuracy, regardless of the precision setting. 

• Click Direction ... to open the Direction Control dialog box in which you can set the base 
angles for East, North, South, West, and Other. This is usually used in civil engineering 
drawings. 
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� Hint: Editing the Scale List 
The Scale List (used for the Viewport Scale, Annotation Scale, and Plot Scale), is stored in 
each drawing file and can vary from drawing to drawing. Therefore, if you want to use a 
standard scale list in each drawing, you should set it in the template drawing as you want it 
to be displayed. 
To edit the scale list, click Custom ... in the Annotation scale list (as shown in Figure 7-5), or 

click J • (Scale List) in the Annotate tab>Annotation Scaling panel to open the Edit Drawing 
Scales dialog box. 

4:l / 400% 

8:1 / 800% 

10:1 / 1000% 

100:1 / 10000% 

Custom ... 

Xref scales 

• ✓ Percentages 

)._ 1:1 / 100% � 0 

Figure 7-5 

You can Add, Edit, and Delete scales, as shown in Figure 7-6. You can also move them up 
and down in the list so that the most commonly used scales are at the beginning. Click 
Reset to return to the default scale list. 

Q Edit Drawing Scales 

Scale List 

1 :2 
1 : 4  
1 5  
1 :8  
1 1 0 
1 : 1 6  
120 
130 
140 
1 50 
1 : 1 00 
2:1 
4: 1 

1 paper un it = 1 d rawing unit 

OK Cancel 

Figure 7-6 
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Drawing Limits 

When you begin drawing, i t  helps to start with an area of an appropriate size displayed on the 
screen. For example, a site plan in Engineering units needs to have a larger area displayed than 
a small mechanical part in the same units. 
The limits of a drawing define the rectangular area (extents of the area) in which you are going 
to draw. You can set the limits by selecting a lower left and upper right corner. For example, you 
might set the upper right limits of a site plan to 300m, 150m while a mechanical part can be set 
to 300mm,180mm, as shown in Figure 7-7. 

Figure 7-7 

How To: Set the Drawing L imits 

1 .  Start the Limits command by typing limits in the Command Line. 

300mm, 1 80mm 

2. Type the coordinates for the lower left corner, which is normally set to 0,0 . 
3. Type the coordinates for the upper right corner. They should define an area slightly larger 

than the objects you are planning to draw. 
4. Use Zoom All to fit the drawing in the drawing area. 
5. Save the drawing. 
• Once you set the limits, use Zoom All . It zooms to fit the limits of the drawing in the drawing 

area (if there are objects outside the limits, it displays them as well) . 
• The limits can be changed at any time without harming your drawing. 
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7 .3 Creating New Layers 
A layering scheme is the most important organizing tool in any drawing . A standard layer 
scheme should be included in your template drawings. Use the Layer Properties Manager to 
create new layers and change the properties or status of existing layers, as shown in 
Figure 7-8. 

X 

i •  Current layer. Contour-Exist ing 

a Ev � ,  � � 0 g, � -· 
F i lters « S .. Name - 0. F . .  L . .  P lot 

es 
l.!) 

z 

� 

� 

El 

I <  

,t All u o 
: ..... E\7 All Us, , BLDG 

• B order 
_,., Bu i l d i ng  
.,. Centerl i ne  
../ C ontcur-E . . .  
, Contour-P . . .  
, Oefpoints 
, Dimensions 
, Ditch 

> I ,., Fire l ine 
,, F IRELINE D [nvert fi « < 

<? 
9 
� 
<;> 
9 
? 
<? 
? 
9 
9 
"i 

� Al l :  2.8 l ayers d i sp l ayed of 28 tota l  l ayers 

@ 
" ..l § 

-5 @ • @ 
0. ::f @I 
• .J @ 
• oj° @ 
0. 1t1° 

lli Ji @ 
• rj' @I 
D. itl' @I 
Cf .Ji' @ 

Coler  L inetype 
l!l white Continuous 
■ wh ite Continuous: 
■ b lue  Contin u ous 
■ wh ite Con inuous  
■ b lue CENTER 
0 9  DASHED 
■ wh ite Com:inuou� 
■ wh ite Continuous 
□ red Contin u ous 
0 62 DIVIDE 
D magenta FIRE_L INE 
D maqenta FIRE_LIME 

Figure 7-8 

Layer Properties Manager 

SeMch fo r layer 

c □ (I, 
L ineweight Transparency N. Description " 

-- Default 0 r' 
-- Defau l t  0 :['' 

-- Defau l t  0 :ri' 
-- Default 0 :[", 

-- Defau l t  0 :(', 

-- Defau l t  0 :'r"' 

-- Default 0 :c, 

-- Defau l t  0 :r, 
-- Default 0 :r"' 

-- Default 0 :r: 
-- Defau l t  0 :r, 
-- Default 0 :["' .. 

> 

The Layer Properties Manager is a palette and can stay open while you are working in the 
drawing. It can also be docked and hidden to create space in the drawing area. When layers are 
modified in the Layer Properties Manager, the changes are automatically applied to the drawing 
and listed in the Layer Control list in the Home tab>Layers panel. 
• When you create layers, you set their color, linetype, lineweight, and plot or no-plot status, 

and the plot style (if applicable). 
• Layers defined in a template establish a consistent layer standard for all drawings based on 

that template. 

• The icon in the Status column indicates whether the layer contains objects (L7), does not 

contain objects ( ,:::::7°), or is the current layer C�)-
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How To: Create a New Layer 

?" 
1 .  In the Home tab>Layers panel or in the View tab>Palettes panel, click =§ (Layer 

Properties). 
a 

2. Click ::7-. (New Layer). A new layer is added to the list with the default name Layer1. 
L7, • To create several new layers quickly, click =' . (New Layer) once and then type the layer 

names separated by a com ma. 
3. Type a name for the new layer. 

• Layer names can have up to 255 characters and can include letters, numbers, spaces, 
and most other special characters (the following symbols are not permitted: < > / \ ? * I , 
= ' . ) .  

4.  To set the Color, select the color swatch for that layer, select a color in  the Select Colar 
dialog box (as shown in Figure 7-9), and click OK. 
• The Select Colar dialog box has three tabs: Index Colar, True Colar, and Colar Books. The 

Index Colar list (256 colors) is adequate for most needs. 

Qolor: 
I-red- -

OK 

Byl.ayer ByBloc� 

Cancel tielp 

Figure 7-9 

5. To set the Linetype, select the linetype name for that layer, select a different linetype in the 
Select Linetype dialog box (as shown in Figure 7-10), and click OK. 
• Linetypes are set by default to display in a Paper Space viewport according to the current 

viewport scale. 

7-1 0 

Q Select Linetype 

Loaded l inetypes 
Linetype 

CENTER 

X 

Appearance Description 

ontinuous ----- Solid l ine 
DASHED 
HIDDEN 
PHANTOM2 

- - - - Dashed _ _ _ _ _ _ _ _ _ _  _ 

- - - - - - ·  Phantom (.Sx) _ _ _ _ _ _ _ _ _  _ 

Figure 7-1 0 
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6. To set the Lineweight, select the lineweight setting for that layer, select a width in the 
Lineweight dialog box (as shown in Figure 7 - 1 1 ), and click OK. 

• Uneweight 

Lineweights: 

----- Default 

----- 0.00 mm 
1----- 0.05 mm 

,----- 0.09 mm 

Figure 7-1 1 

? X 

7. To make the layer non-plotting, click � (Plot) or � (No Plot), as shown in Figure 7- 1 2. No 
Plot layers are useful for construction lines, notes, viewports, and other information that is 
required for drawing construction, but not for the plotted output. 

8. If you want to freeze a layer by default in a new viewport, click :r' (New VP Freeze), as 
shown in Figure 7- 1 2 . For example, you might want to create a layer that is only displayed 
in one viewport. 

P l ot New VP Freeze 

@ :r,, 
@ t, 
� :�, 

Figure 7-1 2 

9. To add a description, click in the Description column and type the description. 
• The changes are automatically applied to the drawing. 

• If a layer is selected in the Layer Properties Manager when you click F9• (New Layer), the 
new layer copies the properties of the selected layer. 

Sorting Layers by Properties 
• You can sort layers in the list according to their properties by selecting any of the column 

headings at the top of the list. For example, selecting the Name column sorts the list 
alphabetically by name, and selecting the Freeze column separates the frozen from the 
thawed layers. Clicking on a heading again reverses the sort order. 
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• You can rearrange the display order of columns in the Layer Properties Manager by dragging 
the column header to a new location, as shown in Figure 7-13. The new location is saved by 
the AutoCAD software. 

0. Freeze l
�

lor Lock L i netype L i ne, 
. ·•· ■ e rf Continuous  

·♦ ■ wh ite n Contin uous  • ■ bl u e  a CENTER 

Figure 7-1 3 

• You can res ize the width of the columns in the Layer Propert ies Manager by dragging the 
border between the column headings. You can also right-cl ick on a column header and 
select Maximize column to maximize one column, or select Maximize all columns to resize 
all of the columns to the width of their  largest cell. 

• You can remove any columns that you do not want displayed. Right-cl ick on any column 
header and select a column name to clear the checkmark and remove it from the display. 
Name is grayed out and cannot be removed, as shown in F igure 7 -14. 

0. Free, ' • v' Status  , Name 

v' On  

v' Freeze 

v' Col or 

v' Lock ' * v Linetype 

v L ineweight 

v' Transpa rency .., v P l o,t 

P l ot Style  

v New VP Freeze 

Figure 7-1 4  

• Additional column names display if you are in a layout. 
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Lineweights 
Lineweight refers to how heavy or wide the lines are in an object, as shown in Figure 7-15. 
Heavier lineweights are used to emphasize parts of the drawing. This becomes important when 
the drawing is plotted. 

Figure 7-1 5 
• == .,.. (Show/H ide L ineweight) i n  the Status  Bar  contro ls  the  v i s i b i l ity of l i neweights on  the 

screen. 
• Depending on the resolution of your monitor, you might not be able to distinguish between 

similar lineweights in your drawing. When you print the drawing, the lineweights are easier to 
differentiate. 

• Plotted lineweight in the AutoCAD software is often controlled by color. 

Linetypes 
Linetype refers to whether the objects are drawn with dashed, dotted, continuous, or other line 
styles, as shown in Figure 7-16. Usually, specific types of lines are used for specific types of 
objects. For example, hidden lines are usually dashed, while most objects are drawn with 
continuous linetypes. 

Figure 7-1 6 

How To: Load a Linetype 

The AutoCAD software comes with a wide selection of standard linetypes. If the required style 
does not display in the Select Linetype dialog box, you can load other linetypes into the drawing. 
1 .  In the Layer Properties Manager, select the linetype name for the layer that you want to 

modify. The Select Linetype dialog box opens. 
2. Click Load . . . .  
3. In the Load or Reload Linetypes dialog box, select the Linetype(s) that you want to use. To 

select more than one, hold <Shift> or <Ctrl> while selecting. 
4. Click OK. The linetypes are now available for use. 
• The standard linetype definitions are stored in the file Acad.lin . 
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i Hint: Linetype Scale 
The Linetype Scale controls the length of segments and gaps for all of the linetypes in the 
drawing. A larger value for the linetype scale places longer segments and gaps. Depending 
on the size of your drawing, you might need to adjust the linetype scale so that linetypes 
display and plot at an appropriate size. 

• By default, the linetype scale is set to display in Paper Space viewports so the 
linetypes are scaled correctly for each viewport. 

• You can type ltscale in the Command Line to launch the command. 

Other Layer Options 

The left panel in the Layer Properties Manager displays the layer filter tree. Layer filters are an 
advanced layer management tool that are used to control the layer list and to group layers. 
• One layer filter, All Used Layers, is predefined. Selecting this filter only lists layers that 

contain objects. To return to the full list, select All in the Layer Filter tree. 
• If you do not use layer filters, you can hide that portion of the Layer Properties Manager by 

clicking « (Collapses Layer filter tree), as shown in Figure 7-17 .  

• •  Cu rrent layer. Contou r-Existi n g  

� Ev u l � � ?� � g  
Fi lters <h 5 •• Name ... 0 .  Freeze C< 

El �  Al l 
L .u;,  Al l U Co l l a pses Layer filter tree. 

, en ,er me  

Figure 7-1 7 

How To: Delete a Layer 

1 .  Select a layer name in the list. 

g, 
2. Click -x (Delete Layer) . The layer is removed. 

■ 
■ 
■ 

• You cannot delete layers that contain objects or certain special layers, such as layer 0 .  
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How To: Rename a Layer 

1 .  In the list, click once on the layer name to select it and then click it again. An edit box 
displays around the highlighted name (you can also right-click on a Layer name and select 
Rename Layer). 

2. Type a new name. 
• You cannot rename layer O and should not rename the default layer defpoints. 

How To: Merge Layers 

You can select multiple layers in the Layer Properties Manager and merge their objects into one 
layer. All of the objects on the selected layers are moved to the merged layer and the selected 
layers are removed from the drawing. 
1 .  In Layer Properties Manager, use <Shift> or <Ctrl> to select one or more layers to merge. 
2. Right-click and select Merge selected layer(s) to .... 
3. In the Merge to Layer dialog box, select the layer to which you want to merge the other 

layers. 
4. Click OK. 
5. In the warning box, click Yes. 
6. The AutoCAD Text window opens displaying the progress of the merge procedure. The 

selected layers are merged to the target layer. The selected layers are then deleted. 
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7.4 Adding Standard Layouts to Templates 
You can simplify your day-to-day work by creating layouts in your template files that match the 
printers and paper sizes that you normally use, as shown in Figure 7-18 .  These layouts are then 
ready to use in new drawings based on the templates. 
• To create a new layout tab from an existing layout, right-click on the one that you want to 

use and select Move or Copy. In the Move or Copy dialog box, select Create a copy and 
select a layout before which the copy is going to be placed. Double-click on the new copied 
layout tab and enter a new name for the layout. 

ISO A2 

It 1:1 0 l\ J i 
f :  

----··--·---� �===--=-·=·--=-"""·-;;;!t,..;;c.d;,_,tf._$ {-1 W v iype jJ CC•»�and 
Model ISO .AO ISO A 1 ISO A2 ISO A3  ISO M-Portrait + 

Figure 7-1 8 

Working in  the Page Setup Manager 

When you set u p  template files for your office, you need to be able t o  specify the layouts that 
use your office printers and title blocks. To do so, create page setups in the Page Setup 
Manager (as shown in Figure 7-19) ,  and then associate standard page setups with the layout 
tabs. 
• In the Page Setup Manager, you can assign an existing page setup to the current layout tab, 

create new page setups, modify existing page setups, and import page setups from 
another file. 
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I) Page Setup Manager .... i:..,- Current layout: ISO Al 

Page setups 

Current page set:up: <None> 

.. lSO AO" 

• 1s0 A2· 
*ISOA3* 
.. ISO A•H>ortrait" 

Selected page setup details 

Device name: 

Plotter: 

P1ot size: 

Where: 

Descrll](loo: 

DWffi ePlolpc3 

DWffi el'lot 

84 1.00 x 594.00 mm (Landscape) 

File 

0 Display when creating a new layout 

Figure 7-1 9 

How To: Create a Page Setup 

X 

Modify ... 

Import ... 

Oose llelp 

1 .  In the Output tab>Plot panel, click ra (Page Setup Manager). Alternatively, in the 
Application Menu, select Print>Page Setup. 

2. In the Page Setup Manager dialog box, click New. 

3. In the New Page Setup dialog box, shown in Figure 7 -20, type a name for the setup. Select 
an existing setup in the Start with area if the new setup is similar to an existing one. 

• New Page Setup 

N.ew page set\Jp name: 

a:11 

Start with: 

<None> 
< Default output devia!> 
•rso AO• 
"ISO At•  
*ISO A2• 
*ISO J\3• 

Figure 7-20 
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4. Click OK. 
5. In the Page Setup dialog box (shown in Figure 7-21 ), select the printer or plotter that you 

want to use. This determines the paper sizes from which you can select. 

Page Setup - ISO AO X 

Page setup 

Name : Setup l 

Printer /plotter 

Name: [i - - -
. . .. 

-- - -

,� DWF6 ePlot.pc3 

Plotter: DWF6 ePlot - DWF ePlot - by Autodesk 

Where : File 

Description : 

Paper sile 

�expand AO (I!_'.! 1. 00 x 1 189.00 MM) 

Plot area 

�hat to plot: 

!Layout � 

Plot offset (origin set to printable area) 
�: I 0 .00 I mm kenter the plot 

Y.: I 0 .00 I mm 

Preview . . .  �--

-1 8 41 MM � 

Plot scale 

F[t to paper 

�cale: it:!-- -· - 3  
CJ

;m - --
-

C] uoit 

0 Scale [ineweights 

OK 

Figure 7-21 

Plot style table (pen assig_nments) 

� -- -
□ bi splay plot styles: 

Shaded viewport options 

Sh:.iije plot. As displayed 

Quality [ Normal � 

r,PJ 100 

Plot options 

0 Plot object lineweights 

0 Plot transparency 

0 Plot with plot styl�s 

0 Plot paperspace last 

0 Hide paperspace obiects 

Drawing orientation 

O Portr�t 

@ LaQdscape 

0 Plot upside_:down 

tJ.elp 

6. Specify the Paper size, Plot area, Plot offset, Plot scale, Plot style table, Shaded viewport 
options, Plot options, and Drawing orientation . 

7. Click Preview ... to display a preview of how the setup is going to print on the sheet. 
8. Right-click in the preview and select Exit. 
9. When the page setup is finished, click OK to return to the Page Setup Manager. The new 

page setup can now be applied to a layout. 
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Page Setup Options 

Printer/plotter 

Paper size 

Plot area 

Plot offset 

Enab les you to select from the l i st of ava i l ab le  pr int ing devices. Check with you r  
CAD manager i f  t h e  pri nter/p lotter you want t o  u s e  is not in  t h e  l i st .  The AutoCAD 
software inc ludes several predefi ned p lotter configu rations, such as DWF6 e-plot. 

Print..r,Plol:ler -----
�• : j!i' Dl'/F6 ePlot.pc.3 

Plotter: DWF6 ePlot - DWF ePlot - by Autodesk 

Where: File 

De:saipoon : 

Pr_operties 

Enab les you to set the s ize of the layout. The ava i l ab le  s izes depend on the 
selected plotter. 

Paper !il�e 

ISO expa-id A0 (841 . 00 x 1 189 , 00 MM) 

Sets the pr intable area.  Norma l ly, you use the Layout option to p lot the ent ire 
layout to the extents of the pr intable a rea .  You can a l so pr int the Extents of the 
d rawing, the D isp lay i n  the d rawing  a rea, a Window that you select, or a View that 
has been defi ned in  the drawing .  

Plot area 
'.llhat ID plot: 

I Layout 

Controls where the drawing sta rts to p lot on the paper .  Depend ing  on your p lotter, 
you m ight need to set th is  so that the d rawi ng fits correctly on the paper .  The 
Center the plot opt ion is not ava i l ab le  when the Plot area is set to Layout. 

P lot offset (origil set to print.able area) 
�; I 0 . 00 I mm �enter the plot 

:r_:  I 0 . 00 I mm 
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Plot scale 

Plot style table 

Shaded 
viewport 
options 

Plot options 

Sets the sca le when you a re pr int ing from a l ayout. The defau lt scale i s  1 : 1 . 
However, you can set a d i fferent sca le  if you a re creat i ng  a check p lot on a sma l ler 
p iece of paper .  

Plot scale 

F It to p,,J)Er 

LC_J rm, V -= 

[c=) ucit 

D Scale [neweights 

IMPORTANT: The Plot scale for a layout is a lmost a lways 1 : 1  because the layout i s  
created at  the actua l  s ize requ i red to f i t  on  the p iece of paper .  The sca l i ng  of the  
mode l  is  done us ing the Viewport Scale .  

Coord i nates the layer co lor  to pen weight, or sets up  other spec ia l  effects for 
p lotted output .  Consu lt your CAD manager about wh ich one you shou ld use .  

Plot style table (pen assignments) 

l,_aca_d.ctb ___ __,"I� 
D Display plot styles 

For 3D mode ls, th is enab les you to set v iewports to be h i dden or rendered and  to 
control the image qua l ity. 

Shaded viewport options 

A� displayed 

Quality Normal 

PT 100 

v] 

Enab les you to p lot us ing l i neweights or p lot styles  and to specify how to t reat 
Paper Space objects. 

-- --- ----

7-20 

Plot options 

E2J Plot object lineweigh1s 

D P lot transparency 

E2J P lot with plot sty!� 

[;21 Plot paperspace last 

D Hide paperspace objects 
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Drawing 
orientation 

Sets the paper o rientation to Portrait (the short edge of the paper is at the top of 
the page) or  Landscape (the long edge of the paper is  at the top of the page) .  

Layout Size: Printable Area 

Drawing orientaOon 
Q Portr!!it 

@ Lao.dsc:ape 

0 Plot upside:down 

The AutoCAD software displays the printable area of the layout as a dashed boundary, as 
shown in Figure 7-22. Because printers or plotters cannot print to the edges of the sheet, the 
printable area is smaller than the actual paper size. The size of the margins varies from one 
printer model to another, and even from one sheet size to another. Ensure that the objects you 
place on the layout fit in the printable area. 

Printable Area Boundary 

�: 
I 
I 
I 
I 
I 
I 
I 
I L _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _  J 

Figure 7-22 

How To: Apply a Page Setup to a Layout 

1 .  Right-click on the layout that you want to set and select Page Setup Manager .... 
2. In the Page Setup Manager, select a page setup with the required plotter and paper size. 
3. Click Set Current to apply it to the layout. 
4. Click Close to close the Page Setup Manager. 
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How To: Import a Page Setup from Another Fi le 

1 .  Open the Page Setup Manager. 
2. Click Import .... 
3. In the Select Page Setup From File dialog box, select the file that contains the page setup 

you want to use and click Open. 
4. In the Import Page Setups dialog box, select the setup that you want to import, as shown in 

Figure 7-23. 

Note: If names are not displayed in the list, the drawing might have layouts but they have 
not been saved as page setups. 

I) Import Page Setups 

Source drawing: C:\AutoCAD 2023 Fundame ... \Factory Site.dwg 

!'.age setups 

Location 

ISO AO Layout 
lSO Al Layout 

Figure 7-23 

X 

5. Click OK to complete the process. The imported page setup can now be used in your 
current drawing. 

Sett ing Up Layouts to Use in  a Template 

To prepare layouts to be used in a template, specify generic names for the layout tabs, add title 
blocks, and set up at least one viewport on each Layout. 
• Rename new layouts using a generic name. For example, it might be one that reflects the 

printer and paper size, such as Printer-ANSI C. When it is used in a project, you can change 
the label to match the sheet number and/or sheet name. 

• Your company title block should be designed to fit on the paper size specified in the page 
setup. 

• Verify that the viewport is on the layer Viewport. 
• Repeat the steps for each plotter and paper size required. 
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7 .5  Saving Templates 
All of the established settings can be saved in a template file. By saving the settings in a 
template, you automatically make them available in every new drawing based on that template. 

How To: Create a Template 

1 .  Start a new drawing or open an existing drawing. 
2. Establish all of the drawing settings as required (e.g., units or layers). 
3. In the Application Menu, select Save As>Drawing Template to save the drawing as a 

template. 

Note: If you use the standard Save As command, the di a log box defaults to the AutoCAD 
201 8  Drawing (*.dwg) file type. You should change the file type to AutoCAD Drawing 
Template (*.dwt). 

4. The Save Drawing As dialog box opens in the AutoCAD Template folder with AutoCAD 
Drawing Template (*.dwt) selected in the Files of type field. 

5. Navigate to the required folder, give the file a name, and click Save. 
6. In the Template Options dialog box, in the Description area, type a brief description of the 

template, as shown in Figure 7-24. 

• Template Options: 

Oe&erlptJof'i 
Metric (Mi l l1rneIers) drawi11

_� Iemplale for use 
with Architocturnl prnjocts� 

Measurement 
Metrlo 

New Laye, Notification 

@ Siilve iilll liilyan; a& unraoonci!ad 

0 Save all layers as Ioconcil11d 

Figure 7-24 

7. Select the system of measurement (Metric) . 

X 

OK 

Cancel 

Help 

V 

Note: For more information on reconciled layers, see Reconcile New Layers in the 
AutoCAD Help system. 
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8. Select whether to save all of the layers as unreconciled or reconciled. 
9. Click OK. 
• Templates have the file extension . DWT to distinguish them from normal . DWG files. 
• Templates should be saved in a separate folder to which everyone has access. 
• You can modify an existing template as you would a normal drawing. To open a template, 

start the Open command and select Drawing Template (*.dwt) in the expanded Files of type 
drop-down list, as shown in Figure 7-25.  

7-24 

Fi les of type : D rawing [" dwg] 
____ _, D rawing [". dwg] 

S tandards [" dws] 
DXF f". dxfl 
I • I 

V 

Figure 7-25 
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Practice 7a 

Save a Template 

Practice Objectives 
• Set the units and limits in a drawing. 
• Create a set of layers in a drawing. 
• Create a page setup and apply it to a layout tab. 
• Add a title block to a layout tab. 
• Save the drawing as a template. 

Creating Templates 

:i'. 30 minutes 

In this practice, you will create a drawing that you will turn into a template. You will set the units 
and test them by measuring distances using grips and use the Layer Properties Manager to 
create and modify new layers. You will also create a Page Setup and apply it to a standard 
layout, and then save the drawing as a template. 

Task 1 :  Control and test the units display. 

In this task, you will create a drawing that you will turn into a template. You will set the units and 
test them by measuring distances using grips, as shown in Figure 7-26. 

Figure 7-26 

1 .  Start the QNEW command and select acad.dwt from the default AutoCAD Template folder 
to open a new drawing. Save the new drawing as AEC-Facilities.dwg in your practice files 
folder. Toggle off Drawing Grid in the Status Bar. 

2. In the Application Menu, select Drawing Utilities>Units . In the Drawing Units dialog box, in 
the Length area, set the Type to Decimal and the Precision to 0.00. 

3. Set the Insertion scale to Millimeters. Click OK. 
4. Draw a 100.25mm radius circle (type 100.25 for the radius). 
5. Use Zoom Extents to display the circle. 
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6. Select the circle and hover the cursor over one of the outer grips. The radius should be 
listed as 100.25. 

7. Start the Units command again to open the Drawing Units dialog box. Change the Length 
Type to Scientific and the Length Precision to 0.00E+01. Click OK. 

8. Select the circle again and hover the cursor on one of the grips. The radius is reported as 
1.00E+02. 

9.  Start the Units command to open the Drawing Units dialog box. Change the Type to 
Decimal and Length Precision to 0.0. 

10. Select the circle and hover the cursor over one of the outer grips. The radius is reported as 
100.3 . 

11. Start the Units command to open the Drawing Units dialog box. Set the Length Type to 
Decimal with a Precision of 0 .  

1 2. In the Command Line/Dynamic Input, type limits . Set the lower left corner to 0,0 and the 
upper right corner to 30400,22800. 

13. Use Zoom All to fit the drawing on the screen. Note that the circle displays very small 
(almost invisible) in the drawing window. 

14. Use Zoom Extents to display and fill the drawing window with the circle. 
15. (Optional) Set the Scale List to only display Metric scales. 
16. Save the drawing. 

Task 2: Create new layers. 

In this task, you will use the Layer Properties Manager to create new layers and change their 
properties, as shown in Figure 7 -27. 

;, Current layer. 0 Search fer layer Q. 

i:e E'.v EJ l f� 9 ?- � 1?l. 
,....,, □ i) ..... 

F i lters « S .. Name • 0. Fre . . .  Lo . . .  Co lar  L inetype L ineweight Tra .. . P . . .  New VP Free2e 

"' < z < 

G � AII  >l' O  

i . . E'.i7 Al l  Us, .,,, Border 
, Cabl ing 
,,, Demol it ion 
.,- Dimensions 
-" Doors 
,., Electrica l  

? llJ 
9 'ii "1 

9 "J 
8 ,a " 

9 "1 
'? e 

■ white Continuous -- Default 0 @ t., 
■ b lue Continuous -- Defau l t  0 @ :C"-
D cyan Continuous -- Defau lt  0 §I :r., 

D red DASHED -- Default 0 §I :C": 
Q red Conti nuous -- Default 0 @ :r., 
□ yel low Continuous -- Default 0 @ :["'" 

D g reen Continuous -- Default 0 @ :r., 

Figure 7-27 

1 .  Open the Layer Properties Manager and note that layer O is the only layer present. 
a, 2. In the Layer Properties Manager, use 2' (New Layer), create the layers specified in the 

following table, as shown for few layers in Figure 7-28 . 
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X 
- ◄  

Current l ayer: 0 

� ev E:J I � 0?'- � g _., 
F i l  ers « S . .  Name  � 0 .  F r e  . . .  Lo  . . .  Co lor  L inetype L ineweight 

B· l$ Al l v O  � :f ■ wh ite Conti nuous  -- De au l t  

L ·Ev Al l Us, ,,,, Border 4? • ::f ■ b lue Con· inuous  -- De au l t  
,,,, Cabl ing <l> •· .s D cyan Continuous  -- De'au l t  
,,,, Demol it ion •• red DASHED -- Defau l t  

et: ,,,, Dimensions  Q "l' [] red Conti nuous -- Default 
o mJ  El red Continuous -- Defau lt  

Figure 7-28 

Note: The DASHED linetype is not listed in the Select Linetype dia log box. To load it, select 
Load . . .  and then DASHED in the list. 

Layer Name Color Linetype Other 

Border b lue  Cont inuous 

Cab l i ng  cyan Cont inuous 

Demol i t ion red DASHED 

D imens ions red Cont inuous 

Doors ye l low Cont inuous 

E lectr ica l  g reen Cont inuous 

Equ ipment green Cont i nuous 

Furn iture green Conti nuous 

HVAC b lue  Cont inuous 

Notes cyan Cont inuous 

P lumb ing magenta Cont inuous 

Tit les b lue Cont inuous 

Viewports gray (8) Cont inuous No p lot 

Wa l l s  white Cont inuous 

Windows ye l low Cont inuous 

• If  you have a white background then the white color will display as black in the Select 
Color dialog box. 

• You are using a color-to-lineweight scheme, in which red is the lightest color and white 
the heaviest. Gray is used to indicate a no plot layer. 
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• Close the Layer Properties Manager and verify that all of the layers display in the 
Layer Control. 

• The layers are automatically added to the Layer Control. 

Task 3: Create a page setup. 

In this task, you will create a page setup and apply it  to a standard layout for the template file, 
as shown in Figure 7-29. 

g Page: Setup r,,'1anager 

:- current •--ut· ow'7' ... , ... .  ISO M 

CUrrent page setup; DWF M 

QVIIF M 

Selected page setup clelals 

De,nc;e name: OWF6 ePtot.pc:3 

PlottEf: OWF6 eAot 

Plot size: 297.00 x 210.00 mm (lan<l=pe) 

Where: Ale 

Otscrlpdon: 

0 Display when creating a new layout 

Figure 7-29 

New .. . 

Modify .. . 

Import. .. 

tlelp 

X 

• Ccrttu for Technlc-fll Kt 

1 .  Switch to Layout1. In the Status Bar, right-click on the selected layout tab and select Page 
Setup Manager .... 

2. In the Page Setup Manager, click New, enter the name as follows (DWF A4) and click OK. I n  
the Page Setup dialog box set the remaining information from the table below and click OK. 

Name: DWF A4 

Printer/plotter: DWF6 ePlot . pc3 

Paper size: I SO expand A4 (297. 00 x 2 1 0 .00 MM)  

Drawing orientation: Landscape 

3.  In the Page Setup Manager, verify that DWF A4 is selected and click Set Current to apply 
the setup to Layout 1 .  Close the Page Setup Manager. 

4. Rename Layout1 tab as ISO A4. 
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Task 4: Add a title b lock and border. 

1. Make the layer Border current. 
2 .  In the Insert tab>B lock Panel , expand the Insert Blocks gallery and use Recent Blocks to 

open the B locks Palette. Switch to the Libraries tab, use the [D (navigation tool) to get the 
Tblk-A4-M.dwg from the practice folder. I nsert the drawing using 0,0,0 for the insertion 
point. Close the Blocks Palette. 

3. Select the viewport and change it to the layer Viewports. 

4. Using grips, resize the viewport as required to fit title block inside the border. 
5. In the Status Bar, set the Viewport Scale to 1:100. 
6. Save the drawing. 

Task 5: Save a template. 

In this task, you wil l save a drawing file as a template, as shown in Figure 7-30 . 

' Template Options 

DescrlptJOn 
5'1mple tern plate for facdit1es drawing� 

Measurement 

Mettle 

New Laye< Noti fication 

@ save all layers a� unreoonciled 

0 Save all layers as ceoonciled 

1. Switch to the Model layout. 

Figure 7-30 

X 

OK 

Cancel 

Help 

2. Erase everything in the drawing, zoom all, and set the current layer to Wal ls. 
3. In the Application Menu, select Save As>Drawing Template. In  the Save Drawing As dialog 

box, note that the Files of type is set to AutoCAD Drawing Template (*.dwt) . Navigate to 
your practice files folder. For the name, verify that AEC-Facilities.dwt is already displayed. 
Click Save to continue. 

4. In the Template Options dialog box, enter the description Sample template for facilities 
drawings and set the Measurement to Metric. Click OK to finish. 
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5. Close the template file. 
6. Start a new drawing based on AEC-Facilities.dwt, which you saved in the practice files 

folder. 
7. Verify that the settings you built into the template (units, layers, and layouts) are working in 

the new drawing. 
8. Close the file without saving changes. 

End of practice 
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Chapter Review Questions 

1 .  Which objects should be set in the template file? 
a. Layers 
b. Polygons 
c. Constraints 
d. Polylines 

Answer: a 

2. Which of the following is controlled by the Drawing Limits? 
a. The drawing precision. 
b. The extents of the area where you intend to draw. 
c. The scale of the drawing. 
d. The maximum number of objects added in the drawing. 

Answer: b 

3.  Changing the Units Precision in a drawing changes the size of objects that you have drawn. 
a. True 
b. False 

Answer: b 

4. When creating a template file, you want to add custom layouts. Which of the following 
commands enables you to define the printer, paper size, and plot scale for a layout? 
a. Page Setup 
b. Plotter Setup 
c. Layout Setup 

Answer: a 

5. Which command enables you to create a template file? 
a. Template 
b. New 
c. Save As 
d. Open 

Answer: c 
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Command Summary -

� 

/\ 
,!'.[jg) 

am 

C'1o. 

7-32 

Command Location 
Layer Properties Manager • Ribbon: Home tab>Layers pane l  or  View tab>Pa lettes 

Limits 

New 

Page Setup Manager 

Save As 

Scale List 

Units 

Zoom All 

panel 
• Command Prompt: l ayer or  LA 

• Command Prompt: l i m its 

• Quick Access Toolbar 

• Command Prompt: qnew 

• Ribbon: Output tab>Plot pane l  
• Appl ication Menu: Pr int>Page Setup 
• Shortcut Menu: (right-click on  Model tab or Layout tab) 

Page Setup M anager 
• Command Prompt: pagesetup 

• Appl ication Menu: Save As 
• Command Prompt: saveas 

• Ribbon: Annotate tab>Annotat ion Sca l i ng  pa nel  
• Command Prompt: sca le l i stedit 

• Appl ication Menu: Drawing Uti l it ies>Un its 
• Command Prompt: un its or  UN 

• Ribbon: View tab>Navigate 2D pane l  
• Navigation Bar :  Zoom Al l  
• Command Prompt: zoom+a or  ZA 
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Working with Layouts 
In this chapter, you learn how to work with named views, create multiple viewports, create 
additional viewports, add layer overrides in viewports, and modify annotative scales. 

Learn ing Objectives :i 1 hr 35min 

• Create viewport configurations and named views of specific areas in a drawing. 
• Modify a viewport by removing portions so that it displays more clearly in the layout. 
• Override layer properties in a viewport. 
• Control the display of objects in viewports. 
• Modify annotative object scales. 
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8. 1 Creating and Using Named Views 
Named views are a reas of a d rawing that are stored u nder spec if ic names and can be accessed 
as req u i red .  I n  a la rge or  complex d rawing,  named v iews provi de a faster method of d i sp lay 
contro l than the Zoom command .  
• You can create named views by either us ing  the New View com mand or the View Manager. 

These can be accessed i n  the View ta b>Named Views pane l ,  as shown i n  F igure 8 - 1 . 

ucs 
Icon 

�1ew Navigation 
Cube Bar 

�-�-�---11 
Viewport Tools ,., 

la., New View 

� View Manager 

Named Views 

Figure 8-1 

Viewpor1 
Configurati 

• Once the named v iews have been created, you can access them i n  the Unsaved View l i st, as 
shown i n  F igure 8-2.  

Ii; Unsaved View 

User-created � II Class Rooms 
named views � IIEievators and Stairs 

------... IIToilets 

, [!!)Top 

dt1Bottom 

�Left 

Figure 8-2 

How To: Create a Named View Using the View Manager 

1 .  I n  the View tab>Na med Views panel ,  c l i ck � (View Manager) t o  open the View Manager 
d ia log box, and then c l i ck  New. 

2. In the New View / Shot Propert ies d ia log box, type a name in the View name: f ie ld ,  as shown 
i n  F igure 8-3 .  

3. The View type shou ld be set to Stil l ,  as th is  opt ion is typ ica l  for 2D views. The other View 
type opt ions relate to 3D  featu res. 
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Working with Layouts 

Q New View / Shot Properties; 

View name: 

View cat�ory: 

View type: 

Boundary 

e 

@ Current display 

0 L)efine window 

Gallery! 

< None.> 

StiD 

lf16'1 Properties Shot Properties 

Settings 

0 Save !,ay,,r snapshot with view 

!.!CS; 

� Wood 

Live i;ection; 

<None> 

Current 

ll;!ckground 

Default 

D Save run properties wrth view 
Current override: Nooe 

OK 

Figure 8-3 

X 

Cancel Help 

4. In the Boundary area, select the Current display option to save the current screen view, or 

select the Define window option to define a different view by clicking 
window). 

(Define view 

5. In the Settings area, select whether to save the layer snapshot with the view. 
6. Click OK to create the view. 
• The view can be defined to store the current layer settings (On/Off, Freeze/Thaw, etc.), so 

that these layers are automatically displayed when the view is restored. 
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Additional View Manager Options 
I n  the View Manager dialog box, there are additional options available for you to  control and 
modify named views. 
• After a view has been defined, you can modify its boundaries by selecting it in the Views 

area, under the Model Views node and clicking Edit Boundaries, as shown in Figure 8 -4 .  
The current view area is then highlighted. Select two points on screen to define a new area 
and press < Enter> .  

• Views that store layer settings are marked Yes in the Layer snapshot under General 
properties. You can select a view in the Views area and click Update Layers (as shown in 
Figure 8-4) to save the current layer settings with the view. 

8-4 

• View Manager 

Current View: Current 
Yiews 

. G� Current 
$ � Mode! Views 

. If:':: Full 
i ... . . � Part 

f�(r. Layout Views ;:-1 1 
l'b t.il

0 
Preset Views 

General 

Name 

Category 

ucs 

Part 

<None > 
World 

Layer snapshot Yes 

Annotation s . . .  t 1 
Visua l  Stvle 2D Wireframe 

Figure 8-4 

X 

Set .(;urrent 

New . . .  

r­L :�it ]1oundaries . . .  

Qelete 
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8.2 Advanced Viewport Options 
To be more efficient in the creation of layouts, you can use previously created named views of 
your model as the basis for Viewports in a layout. You can also modify the shape of existing 
viewports, as shown in Figure 8 -5.  

Figure 8-5 

Creating Viewports from Named Views 

Once a named view has been created, you can insert it as a viewport in a layout. You can create 
viewports from named views using the Layout tab>Layout Viewports panel. (For the Layout tab 
to display in the ribbon, you must be in one of the layouts. )  

Q ,  • The '-+ ,□, ( Insert View) drop-down menu displays all of the named views that you have 
created in a gallery. Once you insert a view, use the various grip options to size, move and 
scale the view and the layout viewport . 

• The Viewports dialog box enables you to select named views to create single or multiple 
named view viewports at the same time. 

How To: Create Viewports Using the Viewports Dia log Box 

1 .  Verify that you are in an active layout. 
2. Set the layer to which you want to add the viewports to be current. 

3. In the Layout tab>Layout Viewports panel, click � (arrow) . 
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4. In the Viewports dialog box, select the New Viewports tab. 
5. In the Standard viewports area, select the standard viewport configuration that you want to 

use. If required, set the Viewport Spacing. 
6. In the Preview area, select one of the Views as shown in Figure 8 -6 .  The Preview View is 

highlighted and, by default, the current view is displayed in all of the viewports. 

IQ viewports 

New Viewports Named Viewports 

Current name: Three :  Above 

Standard yiewports: 

'Active Model Configuration• 
Single 
Two Vertical 
Two: Horizontal 
Three: Right 
Three: Left 
11 N;◄fflffl 
Three: Below 
Three: Vertical 
Three: Horizontal 
Four: Equal 

Viewport Sp.!,cing· 

10 00  

.S.etup: 

2D 

Preview 

View: 'Current* 
Visual  style: 2D Wireframe 

View: 'Current* View: 'Current• 
Visual  style: 2D Wireframe Visual style: 2D Wireframe 

l:;_hange view to 

•current"" 

Figure 8-6 

OK 

Visua l  S!"yle·  

v 2D Wireframe 

Cancel 

X 

7. In the Change view to drop-down list, select a named view (if any have been saved), as 
shown in Figure 8-7, to display in that Viewport location. 

8-6 

Change view to: 

·current· 
·current· 
Entry 
Kitchen 
Famil  Room • • 

Visua l  Style: 

2D Wireframe 

Cancel J:lelp 

Figure 8-7 
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8. The view name displays in the Preview area, as shown in Figure 8-8.  

Preview 

View : Kitchen 
Visual sr,1e :  2D V>lireframe 

View : Family Room View: Entry 
Visual st,1e 2D Wireframe \'isual st,1e 2D V'i'treframe 

Oiange view to: Visual Sl)le: 

l�Kil_ch_en _____ .,�I I 20 Wireframe 

Figure 8-8 

9. The Visual Style can be preselected if you are working in 3D. 
1 0 . Click OK to continue. 

vj  

Working with Layouts 

1 1 .  I f  you are working in a layout, you are prompted to select two corners or to use fit to place 
all of the viewports on the sheet. 

• By default, 2D puts the current view in all of the viewports. 3D  puts standard 3D views (Top, 
Front, and SE Isometric) in the new viewports. 

• The Named Viewports tab enables you to restore the saved configurations of Model Space 
viewports. However, the configuration of viewports in a layout cannot be saved. 

• The Viewports dialog box works in both Model Space (for tiled viewports) and Paper Space 
or Layout mode (for floating viewports) . 
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� Hint: Model Space Viewports 
Model Space can also be divided into viewports, but only for viewing. For example, if you 
have a very complex drawing you might need to display multiple close-up views at the same 
time as shown in Figure 8 -9. The viewport that is currently active is highlighted with a blue 
border. You can drag the edges of the viewports to resize them. 

Figure 8-9 

I n  Model Space, you can use Named in the View tab>Model Viewports panel to create a new 

□ viewport configuration. However, it is easier to expand L= c1 (Viewport Configuration) in the 
View tab>Model Viewports panel and select the required arrangement, as shown in 
Figure 8 -10. 

8-8 

D rm 

.,:-tsl Named 
l-= c!.l r

b!j

j7 

Viewport " " Join 
Configuration � :C); Restore 

!□ Single I -
m l-= cJ 

E I I 

Two : Vertical 

Two :  Horizontal 

Figure 8-1 0 
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Cl ipping Viewports 

You can remove any port ions of a viewport that are not required, or make its shape fit better in 
the available layout space. Th is is most effective if you have already created the v iewport with 
the correct scale and view of the drawing. 

How To: Cl ip a Viewport 

1 .  In the Layout tab>Layout Viewports panel, click :-i=( (Cl ip) .  
2. Select the viewport that you want to cli p. 
3.  Select a cli pp ing object (wh ich has already been created) or press < Enter> to draw a 

polygonal object, as shown in Figure 8-11 . 

FO "''T:: n'.  .... ..., � .. � 
cO.Hl ' ... Ii 

'Jot- T\t 

i 

Figure 8-1 1 

OF:DROO \l z\ 
=--��� 
.. .-.. tAIP' , . ,...  

BEDROOM 3 

• Use the Delete option to remove the cl ipp ing boundary and restore the original viewport. 
• If the cli pp ing boundary extends outside the current viewport boundary, the viewport is 

extended in that direction. 
• You can recli p  a viewport without needing to delete the old cli p boundary first. 
• You can also change the shape of a polygonal v iewport (without clipp ing) by using gri ps to 

stretch the vertices to new locations. 
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8.3 Layer Overrides in Viewports 
When you are working in viewports, you might want to modify the layers that display in the 
various viewports, as shown in Figure 8-12. You can modify layers per viewport and change 
their color, linetype, lineweight, and plot style using the Layer Properties Manager. To create the 
viewport specific changes, you need to be working in a layout tab. 

CJ □ □  
CJ O D  

Figure 8-1 2 

Overrid ing Layer Properties in  Viewports 

You can use the Layer Properties Manager to change layer properties (such as color, linetype, 
and lineweight) in a single viewport without the change being made in other viewports. The 
changes only affect the current viewport and not the model or other viewports, as shown in 
Figure 8-13. 

Figure 8-1 3 
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• Viewport specific settings inc lude New VP Freeze, VP Freeze, VP Color, VP Linetype, VP 
Lineweight, VP Transparency, and VP Plot Style. As the name specifies, the VP Freeze can 
be used to freeze/thaw a layer in only one viewport. Similarly, VP Color enables you to 
change tfie color of a layer in a single (current) viewport. The New VP Freeze tool can be 
used to freeze/thaw a layer in any subsequent viewport that you might create and does not 
affect the current viewport. 

• To create these changes, you must be in a layout tab and working through a viewport. 

How To: Modify Layer Properties in a Viewport 

1 .  In a layout tab, double-click in a viewport to enter Model Space. 
2. Open Layer Properties Manager and modify the viewport properties as required. Their icon 

changes to �g;.. and the changes are high lighted as they are modified, making it easy to see 

the changes (the � (Toggle Override High light) should be toggled on), as shown in 
Figure 8 -14. 
• You might need to extend the Layer Properties Manager to display a l l  the columns. 

ff ? g 
-x £ 

5 .. Name 0.  F . .  V . . L . . .  
1 Grid 9 :r .. 
.,,, Grid Te.�t :[' .. 1 

P . . .  Co l e r  VP Co lor 

@ D 132 0 1 3 2  

@ ■ wh . . .  ■ whi e 

L i netype 

Conli n u  . . .  
Conti n u  . . .  

C �.d) 
VP L inetype ... Lineweight VP L i neweigh l  

� 
Conti nuous  - Defa . . . - Defau l t  Togg l ,  
Con i nuous - Defa . . .  - Defau l t  

:,i H andrai l  :['
"' i @ 0 40 ■ blue Conti n u  . . .  Continuous  - Defa . . . - Defau l t  0 

.,,, H atch i ng � :['
"' -f @ O red D red Conti n u  . . .  Conti nuous - Dela . . .  - Default 0 

.,,, M isc "' :['
"' .i @ O gr . . . D g reen Con i n u  . . .  Conti nuous  - Defa . . .  - Defau lt  0 

.,,, N otes 9 . :C'' j § □ 1 3 2  □ ! 3 2  Conti nu  . . .  Continuous - Defa . . .  - Defau lt  0 
�,;t. Pa •j ions � O ma . . . D m agen . . . Contin u . . .  Continuous - De a . . .  - 0.1 3 mm 0 
.,, P lumbi ng  :r., j § O gr . . .  D g reen Conti n u  . . .  Continuous - Defa . . .  - Defau lt 
:,i Stai r  t� a' @ ■ b lue  D g reen Conti n u  . . .  Continuous - Defa . . .  - Defau l t  
.,, Structural t, a' § D ma . . .  D m agen . . .  Conti n u  . . .  Continuous - Defa. . .  - Defau l t  

Figure 8-1 4 

3. These changes are immediately and automatical ly reflected in the viewport. 

0 
0 
0 

• The layers also high light in the Layer Control in the Layers panel as shown in Figure 8-15. 

:t', ■ Walls 

1 1 :r;; � - 0 

� �- t"'� r:fr ■ Border 

' Ji h -f ■ Defpoints 

-:_ · �- ;r; -f D Dimensions 

] 11 J' llJ D_o_or __ 

} l n .g □ Doors 

Figure 8-1 5 
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• The Viewport Overrides layer filter is automatically created when you use viewport 
overrides. Selecting Viewport Overrides displays only those layers that contain viewport 
overrides, as shown in Figure 8-16. 

Current layer. Wal ls 

41 EJ I � 
F i l ters 

B � Al l  

« S . .  Name 
:rt, HVAC 

, E\i All U sed Layers :,.;. H:ancirail 

L .. :1 Viewport Overrides �g;. Partitions 
�et, Sta ir 

Search for l ayer 0-.. 

0. F . . V .. L. . .  P ... Colar VP Colar Linetype VP L inotype • Li neweight VP L inewei 
� e J""' a' I§ □ 72 □ 72 Continu  ... CENTER - Defa ... - Defa• 
• ••· :c-' a @ 0 40 ■ blue Cont, n u . . .  Continuous  - Dela . . .  - Defa, 
1? • :c-' a � D ma . . .  D magen . . . Continu . . .  Con inuous - De!a . . .  - 0.13 

:r' Q @ ■ blue D green Conti nu . . .  Continuous - Dela . . .  - Defa, 

Figure 8-1 6 

Freezing Layers i n  Viewports 

The VP Freeze tool is also available in the Layer Control for easily freezing a layer in a viewport. 

In the Layer Control, use J1 (Freeze or Thaw in current viewport) to freeze/thaw a layer in only 
one viewport. 

Note: If you freeze a layer or toggle it off using the standard tools, it becomes hidden in all 
of the viewports. 

How To: Freeze a Layer in a Viewport 

1 .  Make the viewport active in which you want to freeze the layer. 
rr �  rr,1 

2. In the Layer Control, click t½•· (Freeze or thaw in current viewport) so that it displays H�, for 
the required layer. 

3. Repeat for any other layers that you want to freeze in the current viewport. l f  you use this 
tool when you are in a layout but not in a viewport, it freezes a layer in the layout without 
affecting other layouts. It does not affect the layer display in any viewports when used 
this way. 
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Practice Sa 

Viewports and Named Views 

Practice Objectives i 25 minutes 

• Create and  use named views. 
• Mod ify an exist ing v iewport and remove a viewport c l i p .  
• Apply viewport overr ides. 

I n  th is  pract ice, you wi l l  c reate and use named views using the Viewport Manager  and the 
Viewports command .  You wi l l  set up mu l t ip le  viewports based on  named views. You w i l l  
remove a viewport c l i p  us ing the Clip command .  You w i l l  a lso freeze layers i n  i nd iv idua l  
viewports and apply l ayer overr ides to the co lor  sett ings for  layers i n  a v iewport .  

Task 1 :  Create and use named views. 

I n  this task, you w i l l  create and restore views i n  a drawing .  
1 .  Open Office-M.dwg from your pract ice f i les fo lder. 
2. Zoom i n  on  the sta i rway i n  the upper r ight corner, as shown i n  F igure 8-1 7 .  

STAI R 
:fi\ ) -- - -) I 

1 1 1 1 1 1 1 1im=L 
' ... � ..... ,. _ ........... -............ J 

lJTIJ1•-i< :JJlI . 

Figure 8-1 7 

3. I n  the View tab>Na med Views panel, c l ick � (View Manager) . The View Manager d ia log 
box opens. 

4. Cl ick New ... to open the N ew View / Shot Properties d ia log box. 
5. In the View name field, type Stairs and select the Save layer snapshot with view opt ion 

(View Properties tab i n  the deta i l s  sect ion,  wh ich m ight need to be expanded), if requ i red .  
6 .  Accept the other defau lt sett ings and  c l ick OK.  C l i ck OK to c lose the View Manager 

d ia log box.  
7. Zoom extents to d isp lay the ent i re d rawing ,  and togg le  off the layer HVAC. 
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t "' 
8. In the View tab>Named Views panel ,  c l ick � °' (New View) . 
9. In the New View / Shot Properties d ia log box, type Elevators for the view name.  
1 0. Verify that the Save layer snapshot with view opt ion is se lected.  

1 1 .  I n  the Boundary area, c l ick i-'\l (Defi ne view wi ndow) . The d rawi ng  a rea d isp lays .  
1 2. Use Zoom and Pan to d isp lay the two elevators i n  your  d rawi ng w indow. Select two corner 

poi nts of a w indow to define  the view, as s hown i n  F igure 8 - 1 8, and  press < Enter> to retu rn 
to the d i a log box.  

E l.CV. 
! {+2-1 

Figure 8-1 8 

1 3. Cl ick  OK to close the View Manager d ia log box. 
14. In the View tab>Na med Views panel ,  use the View l i st (where it d isp lays Unsaved View) to 

select the v iew Stairs, as shown in F igure 8- 1 9 .  The d rawing  zooms in to the stai rs a rea .  
Zoom out and  note that the HVAC l ayer is  togg led on (green HVAC components d isp lay) . 

Amotate Parametric View Manage output 

f ffll st:alrs 

■Elevators 

� 
Viewport ■stairs l:s,,,_ ______ _,! 

1 

Configuration 
[H,)Top 

d I Mo e \  Af1 R.-.t+,..,.m 

Figure 8-1 9 

1 5 .  I n  the View l ist, select the v iew Elevators. You are zoomed i n  to the e levators a rea .  Zoom 
out and  note that the layer HVAC i s  togg led off. 
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Task 2: Create mult iple viewports from named views. 

In this task, you will create multiple viewports based on named views using the Viewports 
dialog box, as shown in Figure 8-20. 

L--=:I'f----_-_-_-_-_-_..,,,._""'_"'=_1=1,_,,.,,_ ... _-_""_""i-�--_--'----i· · / •• 

Figure 8-20 

1 .  Switch to the A-401 Detail Plans layout and set the current layer to Viewports. 

2. In the Layout tab>Layout Viewports panel, click � (arrow) . In the Viewports dialog box, 
verify that you are in the New Viewports tab . In the Standard viewports area, select Three: 
Left, and set the Viewport Spacing to 10 (distances in this drawing are in millimeters) .  
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3. In the Preview area, click in the top right viewport. In the Change view to drop-down list, 
select Stairs. Click in the bottom right viewport and change the view to Elevators, as shown 
in Figure 8-21. Click OK to close the Viewports dialog box. 

Standard yiewports: 

"Active Model Configuration" 
S ing le 
Two:  Vertical 
Two: Horizontal 
Three: Right 
Three: Left 
Three: Above 
Three: Below 
Three: Vertica l  
T hree: Horizontal 
Four: Equal 

Viewport Sp£c ing 

11000 

�etup: 

20 

Preview 

View: Sta i rs 
�isual style: 2D Wireframe 

View: 'Current• 
�isual style: 2D Wireframe 

,C.hange view to: 

v] Elevators 
�current� 
Stairs 

Figure 8-21 

i"" UI\ 

View: Elevators 
2D Wireframe 

Visua l  Style: 

v 2D Wireframe 

Cance l  t!elp 

4. Select two corners to place the three viewports in the layout, as shown in Figure 8-20. 
5. Activate the top right viewport, and pan to display the stairs. In the Status Bar, change the 

scale to 1 :20 and lock the viewport. 
6. Activate the viewport on the left and pan inside it to display the restrooms located near the 

center left of the drawing. Change the scale to 1 :30 and lock the viewport. Use viewport 
grips to make the viewport narrower to only display the restrooms, as shown in 
Figure 8-20. 

7 .  Use viewport grips to make the other 2 viewports wider, i f  required. Using viewport grips, 
move the three viewports as required to center them better in the layout, as shown in 
Figure 8-20. 

Task 3: C l ip a viewport. 

In this task, you will clip an existing viewport using the Polygonal option. 
1. Copy the existing layout by right-clicking on the tab and selecting Move or Copy. In the 

dialog box, select A-401 Detail Plans and select the checkbox for Create a copy. Click OK. 
The copy of the layout is placed before A-401 Detail Plans. Rename the new layout as 
A-201 1 st Floor Plan. 

2. If required, switch to the A-201 1st Floor Plan layout. Delete the two viewports (Stairs and 
Elevators) on the right side. 
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3. Use viewport grips to resize the narrow remaining viewport so that it fills most of the sheet. 
Unlock the viewport and set the scale at 1 :50. Pan to center the floor plan in the viewport. 

4. In the Layout tab>Layout Viewports panel, click :P: (Clip). 
5. Select the viewport, press <Enter> to select the Polygonal option. Starting from the lower 

left corner of the viewport, select points to define a clipping boundary that cuts out the 
bottom right portion of the view, similar to what is shown in Figure 8-22. Select the Close 
option to complete the polygon. Note that the right corner of the viewport is removed. 

6. Double-click outside the irregular viewport. In Paper Space, in the cleared area that was 
created by clipping the original rectangular viewport (i.e. ,  the bottom-right corner area), 
draw a circle with a radius of 150. 

t .. t 7. In the Layout tab>Layout Viewports panel, expand � � (Viewports flyout) and click 

[@:] (Viewports, Object) and select the circle. Double-click inside the circular viewport and 
set its viewport scale to 1 :30. Pan to display any one room of the plan, similar to what is 
shown in Figure 8-22. 

• I ' 

• "" "" �r 1,.-_ _' _�+;_r --=-+--•,I 
,.. 1_ .. · ··· ; ·I"' 

Figure 8-22 
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Task 4: Remove viewport c l ip and apply viewport overrides. 

In this task, you will remove a viewport clip, freeze layers in individual viewports, and apply layer 
overrides to the color settings for layers in a viewport, as shown in Figure 8 -23 . 

□ 
□ 

l-----+---ill--------iEH+-----HH---icI· 

Figure 8-23 

1 .  Copy the A-201 1 st Floor Plan layout and rename it as H-201 1 st HVAC Floor Plan. 
2. Switch to the H-201 1 st HVAC Floor Plan layout, if required. 
3. Delete the circular viewport. 
4. Select the large irregular viewport. In the Selection box, select Polyline. In the Layout 

tab>Layout Viewports panel, click :P: (Clip) . 
5. At the Select clipping object prompt, press <Down Arrow> and select the Delete option (as 

shown in Figure 8-24) to remove the clipping boundary. Note that it becomes a rectangular 
area again. 

Select c l ipping object or IIl 

Figure 8-24 
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6. Double-click inside the rectangular viewport. Open the Layer Properties Manager and for 
t:f layer HVAC, toggle the " * (VP Freeze) option, as shown in Figure 8-25. Note that the 

HVAC components do not display in this viewport only. 
7. Change the VP Co/or for the layer Stair to Green (as shown in Figure 8-25) and note that 

the stairs become green in this viewport only. Note that the regular layer color is still blue. 

s. Name .. o F .. VP Freeze 
• Grid :r: 
• Grid Text :r: 
• Grid l ine 'I,' , . .  
• Handra i l  r· 
"' Hatching :r· 
• HVAC 0 
• Misc r· 

Notes r. 
Partition ·�· .. .  

• Parti tions :r: 
• Plumb i ng :r-: 
:g;. Stair :c,: 
• S ructural t: 
I Te�l :(": 

l. P .. Color 
@ ■ m 
@ ■ wh . . . 

il @ ■ 1 32 
a © □ <10 

€ HI red 
� 72 
@ gr . .  , 

d @ ■ 1 32 
Ii @ □ gr. . .  

� ma ... 
@ n gr . . .  
@ ■ blue 

a © ma ... 
D @ ■ 1 50 

VP Color 
■ 1 32 
■1 white 
■ 1 32 
□ .so 
■ red 

72 
D green 
■ 1 32 
O green 

magenta 
■ 1 so 

Figure 8-25 

Linetype VP Linet.. Uneweight 
Co ntinu . . . Continu . . .  - Defa . .  
C o ntinu Continu - Defa . . .  
CE T ER  CENTE R - Defa , . .  
C o ntinu . . .  Con ·nu . . .  - Defa . . .  
C o ntmu . . .  Conbnu . . .  - Defa . . .  
C o ntinu .. . Contmu . . .  - Defa . . . 
C ontinu Continu - Defa . . .  
C o ntinu . . .  Continu . . .  - Defa . . . 
C o ntmu . . .  Conbnu . . .  - Defa . . .  
C o ntmu ... Contmu . . .  - Dela . . .  
C o ntinu . . . Continu . .. - Defa . . .  
C ontinu . .  Continu .. . - Dela . . .  
C o ntinu . .  C o n  n u  . . .  - Defa . . .  
C o ntmu . . .  Contmu . . .  - Defa . . . 

8. Switch to the A-201 1st Floor Plan layout. It should display differently from the H-201 1st 
HVAC Floor Plan layout. The objects on the HVAC layer should be visible and the stairs 
should be blue. 

9 .  Save and close the drawing. 

End of practice 
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8.4 Annotative Scale Features 
The Annotation Scale is  connected to the Viewport Scale. Therefore, annotative objects, such 
as dimensions and text, display in viewports that have the same scale. You can add Annotation 
Scales to objects, enabling them to display in viewports of different scales. This ensures that all 
of the relevant information always displays at the correct scale and in the required viewports. 
For example, for the drawing shown in Figure 8 -26, you might want the room names to display 
in each view, and to display different dimensions for each view. 

Scale 1 · fj0 

TRAS 

Scale 1 · 1 00 S cale • 1 .50 

Figure 8-26 

• When you change a Viewport Scale, the annotation objects displayed in the viewport change 
as well . The display of objects depends on what the annotation visibility is set to and 
whether or not the scale is automatically added to the object. 

8-20 

Annotation Visib i l ity (Show annotation objects - At current scale): When togg led Off, o n ly 
a nnotative objects with the current sca le  d isp lay.  It is recommended that you use th is  
opt ion  most of the t ime.  It is  what  is  p lotted. 

Annotation Visibi l ity (Show annotation objects - Always): When togg led On, annotative 
objects for al l of the scales d isp lay.  Use when you need to add or  remove an annotative 
object to the cu rrent sca le .  

Add scales to annotative objects when the annotation scale changes: When toggled Off, 
annotat ion scales a re not automatica l ly added to objects in the viewport. 

Add scales to annotative objects when the annotation scale changes: When On, annotation  
objects i n  the d rawing update to  match the  n ew an notation  sca le .  
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• When you add a scale to an object, a scale representation is created. When you select an 
annotative object that has more than one scale, all of its scale representations display, as 
shown in Figure 8-27. There is no limit to the number of scales that can be added to an 
object, but too many scales can be confusing when you try to grip edit the object. 

R2J)()Ci BORE 
1 HOL� THRU 
R2.000 8�E 

1 HOLE. THRU 

Figure 8-27 

R2.U:HJ BCVE 
1 HOtF.:. THRH 

• If you modify the information contained in the annotation, it updates in all of the scale 
representations. 

• You can grip edit each scale representation separately in its associated viewport so that it 
fits the location. 

Modifying Annotative Object Scales 

When you add annotative objects to a viewport, they automatically use the scale of the 
viewport. If you need to change the scale or move annotative objects out of a viewport, you can 
modify the scales associated with the objects or with the viewport. 
• These tools are available in the Annotate tab>Annotation Scaling panel, or when you right­

click on an annotative object, as shown in Figure 8-28. 

Jt ). .. , Scale List 

Add 
Jim Add/Delete Scaies 

Current Scale • )r:, Sync Scale Positions 

Annotation Scaling 

!3aepeat Add/l)elete Scales . , ,  
Recent Input 

/;., Ed[t. . .  
Add Current Scale Annotative ObJect Srale

� 
► 

. .  �1 Add/Delete Scales . .  , Clipboard 

Isolate Synchronize Multiple-scale Positions 

Figure 8-28 
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• To display an annotative object in several viewports that use different scales, right-click on 

an annotative object, select Add/Delete Scales or click ,,iim (Add/delete Scale), and then 
select an annotative object. This opens the Annotation Object Scale dialog box (shown in 
Figure 8-29), where you can click Add to set the other annotative scales that are used in 
each viewport. 

Q Annotation Object Scale X 

Object Sca le List 

1 :2 
�dd . . .  

Qelete 

1 paper un it = 1 drawin� un it 

@ !Jst a l l  scales for selected objects 

0 List scales £Ommen to a l l  selected objects only 

OK -1 I Cancel l f - !:!elp - ] 

Figure 8-29 

• You can change the locations of individual scale representations, but you might need to 

have them all return to one position. In the Annotation Scaling panel, click )t;i (Sync Scale 
Positions) to move all of the related representations to the same location as the selected 
item. 

• If you do not want an annotative object to display in the current viewport, but do want it to be 

visible in a viewport at a different scale, click J:. (Delete) to delete the current scale. 

8-22 © 2023, ASCENT - Center for Technical Knowledge® 



Work ing with Layouts 

Practice Sb 

Annotative Scale Features 

Practice Objectives l 1 s  minutes 

• Create annotative styles and annotative hatching. 
• Control the visibility of annotation objects. 

In this practice, you will specify annotative styles for text, dimensions, and multi leaders. You 
will create annotative hatching using the Hatch command. You will then create viewports at 
different scales and add annotative objects to them, as shown in Figure 8-30 . 

. LJ 

,E 
; STAIRS 

-", . . . . . . . . . . . . . . . . ..... . . .. ... .. .. :: .. .. : . .  ·" . .. . . . . . ... : . . .. . 

Figure 8-30 

Task 1 :  Define annotative text and dimensions. 

1 .  Open Service-AM.dwg from your practice files folder. 
2. In the Annotate tab, set the Dimension style to Architectural-MM (an annotative style), as 

shown in Figure 8-31. 
3. Set the Text style to Hand (an annotative style), as shown in Figure 8-31. 
4. Set the Multileader style to Annotative, as shown in Figure 8-31. 

Pari1111!1ric View Manage �!put Addft Colaborab! Elqnss Tools Foaflnd Apps 8 • 

Text • 

y H. A Archtcctural-MM 
1 , · , I 

� Dmension � ■use Current 

H · r.l !ii · 
Omensions • 

Figure 8-31 
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5. Switch to the /SO A 1 layout tab, wh ich contains four v iewports. 
6. Select each viewport in Paper Space by clicking on the viewport border. Confirm the 

Annotation Scales: 
• Service :  1 :50 
• Vestibule : 1 :30 
• Bathroom: 1 : 1 6 
• Stairs : 1 :20 

7. Click l:rl (Lock/Unlock Viewport) to lock the Viewport Scales for each viewport. 
8. Set the layer Dimensions to be current. Double-click inside the v iewport that displays the 

Service area and add the d imensions and text shown in Figure 8-32. They only display in 
the current viewport. 

S E RVI CE 

Figure 8-32 

Task 2: Define the annotative hatching. 

1 .  Continuing in the Serv ice viewport, set the layer Hatching to be current. 
2. Start the Hatch command. 
3. In the Hatch Creation contextual tab>Options panel, click A (Annotative) . 
4. Set the Hatch Pattern to ANSI 31 and the Hatch Pattern Scale to 1. Add hatch ing to the three 

counter areas inside the Service area viewport. 
5. Close the Hatch Creation. In the Vestibule viewport, note that the portion of the counter 

area in the upper-right corner does not display any hatch.  The hatch ing displays in the 
current viewport only. 
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Task 3: Add annotative scales. 

1 .  Select the hatch object that you just created. 
2. Right-click on the selected hatching and select Annotative Object Scale>Add/Delete 

Scales. The Annotation Object Scale dialog box opens. Only the current Annotation Scale 
displays. 

3. Click Add ... to add the other scales. The Add Scales to Object dialog box opens. 
4. Select the scales 1 :30 and 1 :20 . Doing so will enable the annotative hatch object to display 

in the Vestibule viewport and the Stairs viewport. 
5. Click OK. The scales display in the Annotation Object Scale dialog box. 
6. Click OK. Note that the annotation objects (hatches) now display in the Vestibule and Stairs 

viewports. 

Task 4: Change the annotation object display. 

1. Switch to the Model tab and note how the annotative objects (text, dimensions, hatch) 
display. 

2. Click Ji.. (Show annotation objects - At current scale) to toggle it off. Note that the 
annotative objects no longer display. 

3.  Save and close the drawing. 

End of practice 

© 2023, ASCENT - Center for Technical Knowledge® 8-25 



AutoCAD 2024: Beyond the Bas ics - I nstructor Gu ide 

Chapter Review Questions 

1 .  What is the purpose of the View Manager? 
a. To create layouts using different areas of a drawing. 
b. To create a new block using selected objects. 
c. To create a new drawing file using selected objects. 
d. To store areas of a drawing under specified names. 

Answer: d 

2. It is possible to create a single or multiple named view viewports at the same time. 
a. True 
b. False 

Answer: a 

3.  What does the :.i::t: (Clip) command do? 
a. Fillets the corners of an existing viewport to make it circular. 
b. Removes the portions of a viewport that are not required. 
c. Joins multiple viewports to create a single one. 
d. Breaks a viewport to create multiple viewports. 

Answer: b 

4. How can you change the color of a layer in a single (current) viewport? 
a. In the Layer Properties Manager, change the VP Co/or property. 
b. In the Layer Properties Manager, change the New VP Freeze property. 
c. In the viewport, switch to Model Space and change the col or of the layer. 
d. Create a new layer and move the objects to the new layer. 

Answer: a 

5. If you want to display an annotative object in several viewports that use different scales, 
what should you do? 
a. Create separate layers for each viewport and put the objects on each layer. 
b. Create annotative styles (dimension, text, etc.) for each viewport. 
c. Use Add/Delete Scales to add the scales for each viewport. 
d. Lock each viewport. 

Answer: c 
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Command Summary 

1111111 

Jt. 

□ l= !.I 

Command 
Add/Delete Scales 

Add Annotation Scales 
Automatical ly 

Annotation Visibi l ity 

Cl ip 

Named (Paper Space) 

Named (Model Space) 

New View 

Sync Sele Positions 

View Manager 

Viewport Configuration 
Control 

Working with Layouts 

Location 
• Ribbon: Annotation tab>Annotat ion Sca l i ng  pane l  
• R ight-c l ick menu 

• Status Bar  

• Status Bar  

• Ribbon: Layout tab>Layout Viewports panel  
• Command Prompt: vpcl ip  

• Ribbon: Layout tab>Layout Viewports pane l  
• Command Prompt: viewports or vports 

• Ribbon: View tab>Model Viewports panel  
• Command Prompt: viewports or vports 

• Ribbon: View tab>Named Views panel  

• Ribbon: Annotation tab>Annotat ion Sca l i ng  pane l  
• R ight-c l ick menu 

• Ribbon: View tab>Named Views panel  
• Command Prompt: view or  V 

• Ribbon: View tab>Model  Viewports panel  
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Annotation Styles 
I n  this chapter, you learn how to  create annotation styles, including text styles, dimension 
styles, and multi leader styles. 

Learning Objectives 
• Create and modify text, dimension, and multileader styles. 
• Create sub-styles of existing dimension styles. 
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9 . 1 Creat ing Text Styles 
When you add text t o  your drawing, i t  uses the properties (e.g. ,  height, font, etc.) of the current 
text style, as shown in Figure 9-1.  Text styles should be created in the template file so that 
everyone on the same project uses the same styles. You can create a new style by assigning 
the height, width, and slant to a text font, or to a typeface design. 

Home Insert Annotate Parametric View Manage 

A A� J.. Hand � H 
Multi l ine . , lg I AaBb 1 23 I I  Ao 8b 1 2� FaB61 2� 

Text � 
J.. Annotative Dimens ion J.. Hand 

5tart I AaBb123 I I AaBb1 23 I �a B b 1 21 
-l[f op] [2D Wiref 

Logo Standard J.. Title 

Manage Text Styles . . .  

Figure 9-1 

• There are two default styles: Standard and Annotative. You can create other styles as 
required. 

• A variety of font files are available for creating different styles of text. There are two 
different types of fonts: Truetype fonts (used by most Microsoft Windows software) and 
AutoCAD® shape fonts. You can use the fonts that the AutoCAD software installs or the 
other Truetype fonts that were installed with Windows. 

How To: Create a Text Style 

1 .  In the Annotate tab> Text panel> Text Style list, select Manage Text Styles .... 

• You can also open the dialog box by clicking � (Panel Arrow) in the Annotate tab> Text 
panel. 

2. In the Text Style dialog box (shown in Figure 9-2), click New .... The new style takes on the 
attributes of the current text style. 
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Current text style: Hand 
.S.tyles: 

A Annotative 
Dimension 

A ISO Proportional 
Standard 

A Tille 

All styles 

Font 
Eont Name: 

11' CityBlueprint 

\.!se 819 Font 

Size 
E2] Annotaqve 

O Match text orientation 
to layout 

Effects 

D Ups id!! down 

O Bac�wards 

Y:emcal 

Figure 9-2 

Font Style: 

Regula r  

Paper  Text Heigh! 
0 

�idth factoc 

Qblique Angle: 

.C.lose 

3 .  In the New Text Style dialog box, type a new name and click OK. 

Annotation Styles 

Set.C.urrent 

Q.elete 

l:jelp 

4. Expand the Font Name drop-down list, select a font (a preview of the font displays in the 
Preview area) . For some fonts, you can also specify a Font Style (such as bold or italic) . 

5. Select the Annotative option if you want the text style to scale per viewport. You can also 
set a default height for the style, but this is typically left at O so that you can use one style 
for different sizes of text. 

6. In the Effects area, set up the required properties. 
7. Click Apply to continue working in the dialog box or Close to close the dialog box. The style 

that was created is now the current style. 
• You can change the current style in the Text Style Control in the Home tab>expanded 

Annotation panel, the Annotate tab> Text panel, or the Text Editor contextual tab>Style panel 
when you have started the Multiline Text command. 

• You can change the style of existing text by selecting the text object and then selecting a 
style in the Home tab>Annotation panel or Annotate tab> Text panel. 

• If you modify an annotative style, you need to use annoupdate to update any existing 
objects to match the revised annotative style. 
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Style Effects 

The style effects make a text style different from a standard font. You can define several text 
styles that use the same font but differ in width, oblique angle, etc. 

Width 
Factor 

Oblique 
Angle 

Defi nes the character width relative to the he ight .  A width factor of 1 is  the defau lt. 
Numbers greater than one increase the width and  numbers less than one decrease the 
width . Typ ica l  width factors are i n  the range of 0 .8 to 1 . 5 .  
Enab les  you to s lant the letter ing .  Posit ive va lues inc l i ne the top of the text to the r ight 
and negative va lues s lant it to the left. Typica l  ob l i qu ing ang les range from + 1 0  to -1 0. 
Angles of +30 and -30 a re commonly used to labe l  isometr ic d rawings. 

• Text is normally placed horizontally in a drawing. Vertical, upside-down, or backward text 
orientation can also be defined when creating text styles. 

Notes on Text Styles 
• The Preview displays an image of how your text style is going to be displayed when used 

in the drawing. All of the effects of a text style are previewed except the height. 
• To rename a text style, double-click on the style name. In the Edit box, type the new name. 
• To delete a text style, highlight it in the list and click Delete. It is only deleted if it is not 

in use. 
• Some True Type fonts can be filled or outlined. To have them filled in your drawing, you need 

to set the textfill system variable to ON (textfill = 1 ). 
• Match Properties (in the Home tab>Properties panel) enables you to copy the style from one 

text object to another in your drawing. It is also available in the Text Editor contextual tab. 
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Practice 9a 

Create and Use Text Styles 

Practice Objective 
• Create several new text styles. 

Annotat ion Styles 

i 1 0  minutes 

In this practice, you will define several new text styles using the Text Style command, as shown 
in Figure 9-3. The color of the text in Figure 9-3 has been changed to black for printing clarity. 

The Standard Sty le 
Title Text Style 

Figure 9-3 

·~ianc.,- I .:0·t·:er itic1 

t m ens ions Style 

1 .  Open AEC-Facilities1-AM.dwg from your practice files folder. It is a blank file. 
2. Make the layer Notes active. In the Annotate tab> Text panel, note that the active text style is 

Standard. 
3. Switch to one of the layouts. Start the Multiline Text command. Note that the preview text 

(abc) is not currently visible with the cursor. Zoom in until it displays. Place the text The 
Standard Style anywhere in the drawing. 

4. In the Annotate tab> Text panel, in the Text Style list, select Manage Text Styles, or click 

� (Panel Arrow) in the Annotate tab> Text panel to open the Text Style dialog box. Modify 
the Standard Style by changing the Font Name to romans.shx. Click Apply and Close. Note 
how the text you just entered has updated. 

5. Open the Text Style dialog box again and click New. 
6. Create a new style named Title2. Set the Font Name to Arial, the Font Style to Bold, and the 

Width Factor to 2. Click Apply to save the changes. 
7. Create another new text style named Hand2. For the Font Name, select CityBlueprint. Set 

the Width Factor to 2. Click Apply to save the changes. 
8. Create another new text style named Dimensions. For the Font Name, select romans.shx. 

Set the Width Factor to 1. Click Apply to save the changes and click Close. 
9. Make each style current and then add text to the drawing using a text string to test the 

styles. 
1 0 .  Set the current style to Hand. Erase all of the text and save the drawing. 

End of practice 
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9 .2 Creating D imension Styles 
The dimension style controls all aspects of how your dimensions display (type and size of 
arrows, type of units displayed, text specifications, text placement, etc.). You might need to 
have several styles in a drawing to display different information, as shown in Figure 9-4. For 
example, in mechanical drawings you might have one style with decimal units that displays two 
decimal places of precision, another that displays three decimal places, and a third that 
displays both English and Metric units at the same time. 

1 
235 

1 

I : I 
I .  235 [9.25'1 . I  

Figure 9-4 

• You can set the current dimension style in the Dimension Style Control in the Home tab> 
Annotation panel or Annotate tab>Dimensions panel. 

• There are two default styles: Standard and Annotative. You can create other styles as 
required. 

How To: Create a D imension Style 

1 .  In the Annotate tab>Dimensions panel>Dimension Style list, select Manage Dimension 
Styles .... 
• You can also open the dialog box by clicking � (Panel Arrow) in the Annotate tab> 

Dimensions panel. 
2. Click New ... in the Dimension Style Manager, as shown in Figure 9 -5. 
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Annotation Styles 

Q Dim ension Style Manager 

Current dimension style : Nchitectural-MM 
Styles: Preview of: hchitectural -MM 

A hlnotative 
A tm@@UMl®l4i 
' · · · · · A Linear 

A 1S02 
1s0,2s 
Standard 

List : 

AJI styles 

• • Don I list st;1es 1n Xrefs 

Description 
Nchitectural-MM 

Figure 9-5 

Oose Help 

X 

3. The Create New Dimension Style dialog box opens, as shown in Figure 9-6. In the Start 
With drop-down list, select a style to use as a template. In the New Style Name field, type a 
new style name and then select the Annotative option as required. Click Continue. 

Create Nevv Dimension Styi'e 

New Style Name: 
M3™ 

$tart With : 
ISO 

[21 AnnotaUve 

Use for. 

All dimeC1si.ons 

Figure 9-6 

4. Modify the tabs as required and click OK. 

X 

Cancel 

l:!elJ> 

5. I f  you want to make the new style current, double-click on its name in the Styles area or 
select it and click Set Current. 

6. Click Close. 
• All of the distances and sizes specified for the dimension style should be at their final 

plotted distance or size. 
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Modifying D imension Styles 

I n  the D imension Style  Manager, c l ick  Modify to open the Mod i fy D imens ion Style d ia log  box.  

Dimension Style Lines Tab 

The Lines tab contro ls  the appearance of the d imens ion l i n es and extens ion l i nes, as shown i n  
F igure 9 - 7 .  

Modify Dimension Styl'e: Architectural-MM 

Line$ Symbol� and Airows Text Fil Pnmary Ur,its Altema1e Un1ta Tolerances 

Dimehsion linoo 

Coloc 

Linotyp@: 

Linowoight 

• By��ock __ 

--- ByBlock 

--- ByBlock 

Saselfn,:, spacing: 

Suppress: O D,m line 1 

Extension lines 
Color: ■ ByBlock 

liMtype ext tine 1 :  --- ByBlock 

Unetypo ext tine 2: --- ByBlock 

lineweigh!: --- ByBlock 

0 

10 

Supprer;s: O Ext lfno 2 

60° 

R1 3 -/ 

Extend beyond dfm tines: 

0flset frorn origin: 

D Fixed l<>noth extension lines 

[_ OK l CBncel 

Figure 9-7 

X 

5 

2 

Help 

• Co/or and Lineweight are set to ByBlock by defau lt .  Th is  i s  essentia l ly the same as Bylayer. 
The d imens ion e lements use the co lor  and l i netype of the cu rrent layer. 

• Extend beyond ticks on ly  app l ies if t icks are used rather than a rrowheads.  
• Baseline spacing is used for basel i ne  d imens ions that a re app l ied  with the Baseline or Quick 

Dimension commands .  
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• Offset from origin controls the size of the gap between the object and the start of the 
extension line. 

• Fixed length extension lines controls how far the line reaches from the dimension line 
toward the dimensioned object. 

Dimension Style Symbols and Arrows Tab 
The Symbols and Arrows tab controls the size and style of the arrowheads on the dimension 
lines and leaders, and other symbols, such as Center marks (for circles and arcs) or the Arc 
length symbol, as shown in Figure 9-8. 

Modify Dimension Style: Architectural-MM 

Lones Symbols and Arrows Text Fit Primary Unlts AJtemate Uruts Tolerances 

Arrowheads 

First: 
• Closed filled 

Second: 
• Closed filled 

Loader: 
► Closed filled 

Arrow size: 
3 

Center ma!ks 
Q None 

@ Mark 
O un., 

Dimension Break 

3.5 

2 

R13 
l 

Arc !ongth symbol 

, 
/ 

50• 

I 
@ Et<,OO<J,r,g d1men$1on te�I 

0 Above dimension text 

Q None 

Radim; i<lll dimoosioo 

Jog angle: 

Unoar jog dimension 
Jog height factor: 

1 .5  

[_ OK J 
Figure 9-8 

45 

Caocel 

• The Leader can have a different arrow style from the dimension lines. 

X 

l:laip 

• Center marks are used with Radius and Diameter dimensions and the Center Mark 
command. 
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Dimension Style Text Tab 
The Text tab controls the p lacement and appearance of the dimension text, as shown in 
Figure 9 -9 .  

Modify Dimension Styl'e: Architectural-MM 

Lines Symbol& and Arrows Taxi ___ _flt 

Text appearance 

Text sty:le: 

Tex\ Qolor; 

Fill coJor: 

Fraciion height scale; 

Standard 

■• B�Block 

Q None 

D 0raw frame arouml le<t 

Text placement 

Centared 

Hofi�onlal: Centered 

View Qirocrion: u,ft-lo-Right 

Qfts,;t from dim line: ;:: 

Primary Units Alternate Umls Tolerances 

T exl ahgnmen! 

0 Alignoo wi1h dimension li:ne 

0 ISO 31andar<l 

[ OK l Cancel 

Figure 9-9 

X 

f:lalp 

• You can specify a text style in the Text style drop-down list. If you have not defined one, you 

can click O (Browse) to open the Text Style dia log box to create a new style. The text 
height should be set to the required plotted height. 

• Do not set a height in text styles to be used for dimensioning. Use the dimension style to 
control the height. 

If you want the text to plot at a heavier weight than the rest of the dimensions (a standard 
drafting technique), set the text color to be a color that plots to a medium weight and leave 
the rest of the dimension elements with the Text co/or set to ByBlock. You can set the layer 
Dimensions to be a lightweight color. 

• The Fill color can be set to Background or another color so that the text masks any objects 
behind it. 
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In the Text placement area, you can set the text placement to Vertical and Horizontal 
dimensions. 

Offset from dim line controls the size of the gap between the text and dimension lines. This 
applies when the text is centered on the line and above the line. 

View Direction displays the dimension text Left-to-Right or Right-to-Left. 

Dimension Style Fit Tab 
The Fit tab controls the positions of arrows, text, leader lines, and the dimension line, as shown 
in Figure 9-10 . It also controls the scale for dimension features. 

Modify Drmension Style: Architectura. 1 -MM 

Lines Symbole and Arrows Text Fit Prirn<>ry Units AHemate Units Tolerances 

Elt opbons 

If there isn't onough room to placo both tax.I and 
arrows Inside s.xt-E:1nsion lines, the 'first th1ng to 
move outside 1he extension lines is: 

@ Eithe, text or arrows (best fit) 

0 Arrows 

Q Tex\ 

0 Both toxt and arrnws 

0 Always koop te•t be1ween ext r,nes 

0 Suppress arrows if lhey don't flt IM;de 
ext-en.s�on lines 

Toxt placement 

When text is not in lhe defouit pos,tion , p!ace It:. 

@ .B;,si,l-0 tho dimension lino 
0 Over dimension ltne, with leader 
0 Over dim,msion Imo, wilhout leader 

0 
N 

f---/ 

··· ". . + 

Scale for dimension fei!wres 

0 Annotative 

Fino iunir,g 

0 eJac,, text manually 

0 Qraw dim /Ifie between ext 1ines 

[ OK ] Cancel 

Figure 9-1 0 

X 

Help 

When you set the Scale for dimension features to Annotative, the other options are grayed 
out The dimensions are scaled according to the scale of the viewport th rough which they 
are inserted. 

If you are not using Annotative dimensions, you can use Scale dimensions to layout to 
display the objects in all viewports. You can also select Use overall scale of to dimension 
directly on the model when you are plotting from Model Space. 
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Dimension Style Primary Units Tab 

The Primary Units tab controls the format of the primary units in the dimension text, as shown in 
Figure 9-11. This is independent of the type of units that are used in the drawing. 

• l\fodify Dimension Style: Architectural-MM 

Lines Symbol& and Alrow,; Text Fil Pnmary Unils Alternate Umt• Tolerances 

Linear dimensiO!'lfi 

Erecision 

Fraction format: 

Decimal sepamtor: 

Suffix: 

Seal� factor: 

Oec,mal 

0 

J lcr 1.outa.l 

, .,- , ., _  ~ ·  vv--- , ,  

'.' ( Period) 

0 

R13 j,I 

D Apply to layout dimensions only Angular dimensions 

Zeto aupp,ession 

O t.eoo,ng 
Sub-units factor: 
1 00 

0 Irail1ng 
Precislon: 

Zaro suppression 

O leadmg 
0 Trailmg 

OK ] 
Figure 9-1 1 

Oocimal Degrees 

0 

Cancel 

X 

f:lalp 

• You can set the required type of units for dimensioning, the number of decimal places, and 
other information to define the appearance of the text. 

• A default Prefix and Suffix can be added in front or after all of the dimension values (for 
example, a suffix of mm for millimeters) . 

• The Scale factor multiplies the actual dimension value. For example, if the actual distance is 
5 and the scale factor is 2, the value that displays in the dimension text is 10 . If objects are 
drawn at full size, the scale should normally be set to 1. 

• The Sub-units factor eliminates the leading zeros in dimension values by specifying that any 
measurement less than one primary unit be dimensioned in a smaller unit of measure. The 
Sub-unit suffix automatically appends a different dimension suffix to such dimensions. 
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Dimension Style Alternate Units Tab 
The Alternate Units tab is very similar to the Primary Units tab. 
• Multiplier for aft units is the conversion factor between the units in which your drawing was 

created and the units you want to use for alternative dimensions. For example, if the Primary 
Units are millimeters and the Alternate Units are decimal inches, Multiplier for aft units 
should be 25.4 (1 inch = 25.4mm). 

Dimension Style Tolerances Tab 
The Tolerances tab is usually used in mechanical design to indicate the degree of precision 
required in manufacturing. 
• Method determines how the tolerance is calculated and displayed. The options are None, 

Symmetrical (equal bilateral), Deviation (unequal bilateral), Limits, and Basic (places a box 
around the dimension and is used with Geometric Dimensioning & Tolerancing) . 

Creating D imension Sub-Styles 

You might need to use a slightly different style for a specific type of dimension. For example, 
you might want linear dimensions to use tick marks instead of arrows and to always be forced 
above the dimension line. You can create a style that uses arrows, and then create a sub-style 
that is only used for linear dimensions, as shown in Figure 9-12. When using that style, all of 
the dimensions that you place have arrows, except for the linear dimensions. 

IQ Dimensi on Sty le  Manager 

Current dimension style :  A,chnectural-MM 
�tyles: Preview of : A,chnedural-MM:  Unear 

A J!.nnotative 
A /lrchnedural-MM 
' · · · · A lllll 

A 1S02 
1 S0-25 
Standard 

X 

New . . .  

.;;: eride 

!;;_ompare . . .  ., 

!Jst: 

AJI styles ---::1 --- � 
' Qon \ list sl',les in Xrefs 

Description 
A,chnectural-M M + Text inside align = Off. 
Text outside align = Off, Text pos vert = 1 ,  
Arrow = Arch Tick 

Figure 9-1 2 

Oose Jielp 
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How To: Set Up a D imension Sub-Style 

1. Open the Dimension Style Manager. 
2. Click New .... 
3. In the Create New Dimension Style dialog box, in the Start With drop-down list, select the 

style to use as a template. 
4. In the Use for drop-down list, select a dimension type for the sub-style (linear, angular, etc.) 

that you are creating, as shown in Figure 9-13. 

Q Create New Dimension Style X 

New Style Name: 

J Copy of Annotative I I Continue I 
jitartWith: [ __ Cancel ] 
1Annotative V -- --- --� 

G2J 8nnotative �1p =:J 

.Use for: 

All dimensions V 

All dimensions 
-. 

ylE Angular d imensions W' 
Radius d imensions 
Diameter dimensions t Close ] Ordinate dimensions - Leaders and To lerances -

Figure 9-1 3 

5. Click Continue. 
6. In the New Dimension Style dialog box, define the sub-style as required with settings for 

lines, arrows, text, fit, etc. 
7. When all of the settings have been adjusted, click OK. The new sub-style is listed in the 

Dimension Style Manager under the main style. 

� Hint: Modifying a Single Dimension 
Select a dimension and use the Properties palette to modify the style of a single dimension 
without changing the style definition. In the Properties palette, all of the dimension style 
settings are listed. Each setting can be changed for the selected dimension. 
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Practice 9b 

Create Dimension Styles (Architectural) 

Practice Objectives I 1 0  minutes 

• Change the dimension style of various dimensions. 
• Create a new dimension style and a related sub-style. 

In this practice, you will test exist ing dimension styles and change them as required. You will 
also create a new dimension style with a related sub-style, as shown in Figure 9-14. 

R3000.0000 

+ 
RJOOO 

90' 

l 1 5200 l 1 
Figure 9-1 4 

Task 1 :  Test the existing d imension styles. 

1 .  Open AEC-Facilities2-AM.dwg from your pract ice files folder. I t  is a blank drawing. 
2. Change the current layer to Walls and draw a 15200 x 7500 rectangle with a 3000 radius 

circle at its center. 
3. Switch to the ISO A3 layout. 
4. Double-click in the viewport to activate it. Pan in the viewport to display the rectangle and 

the circle. Set the Viewport Scale to 1:100. Lock it. 
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5. Set the current layer to Dimensions. Using the Standard dimension style, add a linear 
dimension for the top length (horizontal) line and a radial dimension for the circle. The 
dimension text and arrows are not displayed because this dimension style is not 
annotative. 
• Use grips to move the dimensions to the required location. 

6. Using the Properties palette for each of the dimensions, change the Dim style to 
Annotative. The dimension information is now available, but it is not designed to work with 
architectural dimensions. 

Task 2: Create a new dimension style. 

1 .  In the Annotate tab>Dimensions panel, expand the Dimension Styles list and select Manage 

Dimension Styles, or click ·::ti1 (Panel Arrow) to open the Dimension Style Manager. Click 
New . . .. 

2. In the Create New Dimension Style dialog box, set the New Style Name to Decimal. In the 
Start With drop-down list, select the Standard style to use as a template. Select Annotative 
and click Continue. 

3. In the New Dimension Style dialog box, set the following options and click OK: 

Symbols & Arrows tab 

Text tab 

Fit tab 

Primary Units tab  

Arrowheads area Fi rst, Second,  and  Leader: Right angle 

Text appearance area Text sty le :  Dimensions 

Scale for dimension features area Annotative 

Linear dimensions area Un it format: Decimal; Precis ion :  0 

4. Select Decimal and click Set Current in the Dimension Style Manager. Click Close. 
5. Using the new style, add linear dimensions for the left and bottom edges of the rectangle. 

Add radial dimensions to the circle and angular dimensions to the left corner of the 
rectangle. Note the differences from the dimensions in the previous style. 

Task 3: Create a d imension sub-style. 

1 .  In the Dimension Styles list, select Manage Dimension Styles . . . .  
2. In Dimension Style Manager, select the new Decimal style and click New . . .. 
3. Delete Copy of Decimal and leave the New Style Name blank. 
4. In the Use for drop-down list, select Linear dimensions and click Continue. 
5. Modify the options as follows: 

Symbols & Arrows tab 

Text tab 

Text tab 

9- 1 6 

Arrowheads area 

Text alignment a rea 

Text placement a rea 

F i rst and Second :  Architectural tick 

Al igned with d imens ion l i ne 

Vert ica l :  Above 
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6. Click OK and Close to exit the Dimension Style Manager. Note that the linear dimensions 
update to display the new format, as shown previously in Figure 9 - 1 4. 

7. Erase all of the dimensions. 
8 .  Double-click outside the viewport to return to Paper Space. 
9. Save the drawing. 

End of practice 
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Practice 9c 

Dimension Styles (Mechanical) 

Practice Objective 
• C reate d imens ion sty les and  apply them to d imens ions .  

i 1 5  minutes 

I n  th is  p ractice, you w i l l  c reate two d imens ion sty les and then apply d i mens ions with those 
styles, as shown in F igure 9 - 1 5 and  F igure 9 - 1 6 .  
1 .  Open Dim-M.dwg from you r  p ract ice fi l es fo lder. 
2. Create the two d imens ion styles (Tolerance a nd Metric_lmperial) based on  the sett ings 

l i sted i n  the tab les .  Start With the Standard sty le, make each sty le Annotative, and use the 
defau lt  sett ings for  options that a re not specif ied . 

Tolerance Metric_lmperial 
Lines tab 

Basel i ne  spac ing 1 0  1 3  

Symbols and Arrows tab 

Arrowheads R ight ang le  C losed fi l l ed  

Center marks Mark L ine 

Text tab 

Text sty le Standard Standard 

Text co lor ByB lock Magenta 

Text he ight 5 5 

Vert ica l  P lacement Centered Above 

Horizontal P l acement Centered Centered 

Text a l i gnment Horizontal A l igned with d i mens ion l i ne  

Primary Un its tab 

Un it format Dec ima l  Dec ima l  

Precis ion 0 .00 0 
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Alternate Units tab 

Alternate u n its 

Tolerances tab 

Method 

Upper va lue 

Lower value 

Sca l i ng  for height 

Tolerance 

None 

L imits 

0 . 5  

0 .8  

Annotat ion Styles 

Metric_lmperial 

Arch itectura l ,  p recis ion 0'-0" 

Mu l t ip l ie r  25.4 

None 

3. For Metr ic_lmperial, create the Angular dimensions and Diameter dimensions sub-sty les. 

• To create a sub-sty le, in the Dimension Style Manager, select Metric_lmperial and c l ick 
New. In the Use for drop-down l ist, select Angular dimensions, and then set the options 
below. Repeat th is for Diameter dimensions. 

Text tab 

Vert ica l  text p lacement 

Text a l i gnment 

Angular dimensions 

Centered 

Horizontal 
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Centered 

Horizontal 
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4. Use the new d imens ion sty les to d imens ion the objects shown i n  F igure 9 - 1 5 and 
F igure 9 - 1 6 .  
• Set the l ayer Dimensions to be current. 
• A layout is prepared fo r each sty le .  The sca le of the v iewport i n  the ISO A2 TOL l ayout i s  

1 : 1  a n d  t h e  sca le o f  t h e  v iew port i n  t h e  ISO A 1 MET-IMP l ayout i s  2 : 1 . Lock the v iewports 
so that you do n ot change the sca le by m istake. 

Tolerance 

9-20 

89.40 
88 . 1 0  

.30 
50 .00 

1 36" 
1 34" 

54.38 
53.08 

I 51 .30 51 .30 76. 70 ' .. 
50.00 --+-- 50.00 --+--- 75.40 ...... . . . . ..... ... . . ... .. . . . .. . ; 

Figure 9-1 5 

5 1 .30 
50.00 
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Metric_lmperia l  

102 j21 5'-1')  -----

"' "' 

s1 r 1 0r..,;·1 

, . _  ,N,-.•ON,-.N�C• J\ 

Figure 9-1 6 

End of practice 
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9 .3 Creating Mu lti leader Styles 
Multi leaders are used to  point to  objects in  your drawing with text or  symbols. Use the 
Multi leader Style Manager to create styles that control the display options for different 
multileaders. The styles can be annotative or a specified scale, and have different arrowheads, 
text styles, colors, linetypes, etc., as shown in Figure 9-17. You can create styles for specific 
uses and then use the Multileader Style Manager to update them as required. This ensures 
accuracy throughout the drawing and makes it easy to modify multileaders. 

�------ POV,' E R  CO R D  

Figure 9-1 7 

How To: Create a Mu lt i leader Style 

1 .  In the Annotate tab>Leaders panel>Leader Style list, select Manage Multileader Styles .... 
The Multileader Style Manager opens, as shown in Figure 9-18 . 
• You can also open the dialog box by clicking � (Panel Arrow) in the Annotate tab> 

Leaders panel. 

9-22 

Q Multi!eader Style Manager 
Current mlJlieader style: Standard 

;ityles: 
�P,,,_vie_w_<i_: S_tand_a_rd ___ _ 

A. A.nnoiative 

!Jst: 
All Styles 

Dose 

Figure 9-1 8 

X 

Set Cy,rent  

!few .. . 
Modify . . .  
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2. Click New .... 
3. In the Create New Multi leader Style dialog box, type a New style name, expand the Start with 

drop-down list and select a style, and select or clear the Annotative option, as shown in 
Figure 9-19. 

• Create New Mu ltileader Style 

New style name:  

li4JM•li#Jfflffltffi;j 
Qtart with: 
Standard 

0 8nnotative 

Figure 9-1 9 

CQntinue 

Cance l  

l:!elp 

4. Click Continue . The Modify Multileader Style dialog box opens. 

X 

5. In the Leader Format tab, specify the leader's Type (Straight, Spline, or None), its formatting, 
the style and size of the Arrowhead, and the distance for the Leader break, as shown in 
Figure 9-20. 

Q Modify Mutti leader Style: Copy of Standard 

Leader Format Leader Structure Content 

General 

,Color 

1.inetype: 

Lineweight 

Arrowhead 

Leader break 

.S.reak s ize 

�traight 

ii syBlock 

--- ByBlock 

--- ByBlock 

• Closed fil led 

Figure 9-20 
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6. In  the Leader Structure tab, specify how you want the leader to work, as shown in 
Figure 9 -21. For example, the default leader style has the Maximum leader points set to 2 
and Landing Settings toggled on. Select Annotative if you are using the annotative scaling 
tools. 
• If you are creating a spline leader style, you might need to clear the Constraints and 

Landing Settings options. 

Q Modify Multi leader Style: Copy of Standard 

Leader Format Leade r Structure Content 

Constraints 

G2] Maximum leader points 

0 Eirst segmen! angle 

D .Second segment angle 

Landing settings 

(21 ,8utomatica lly include landing 

Ga Set !anding _Qistance 

Sca le 

E2Je;·nn·�1a·f;�-� 

Spgcify scaie ] (Kl(!{i • 

Figure 9-21 

X 

7. In the Content tab, you can specify whether you want the multi leader content to be Mtext, 
Block, or None. Once you set the Multileader type, the rest of the options vary according to 
the selection. The Mtext option is shown in Figure 9-22. 
• When you have selected text, you can set the attachment to be Horizontal or Vertical. 
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Q Modify Multi leader Style: Copy of Standard 

Leader Fomiat Leader Structure [ Content : 

Multileader type: 

Text oplions 

Qefaulttext 

Text _:,tyle :  

Text 2.ng le: 

Text £olor: 

I ext height 

D Always left justify 

Leader connection 

@ HQrizonta! attachment 

0 ',/ertica l  attachment 

Lgft attachment 

Bight attachment 

Landing gap: 

0 E�end  leader to text 

Mtext 

Defa lJ!t Text 

Standard 

Keep horizontal 

iil syBlock 

l�•1_soo ______ p • 
D Erame text 

Middle of top l ine 

Middle of top line 

1 � o_9oo ______ ., 

Figure 9-22 

Annotat ion Styles 

X 

OK Cancel !:ielp 

8. When you use the Block Multileader type, you can se lect from a var iety of preset b locks with 
attr i butes o r  use you r  own b locks, as shown i n  F igure 9-23 .  

Q Modify Multi leader Style: Copy o f  Standard 

Leader Format Leader Structure Content 

Mu!ti leader type: Block 

Block options 

.Source block: 18 Detail Callout 

cl•NtffiMII 8ttachment 

�olor: 

Sca!e: 

□ Slot 
() circle 
=! Box 
() Hexagon 
6. Triangle 

User Block. 

Specifies the block used for multtleader content 

I/ 
Figure 9-23 

X 

9. When you are sat isfied with the sty le, c l ick OK. In the M u lt i leader Sty le Manager, sel ect the 
new sty le and cl ick Set Current. 

1 0. Cl ick  Close. 
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• If you need to make a change to a style, open the Multi leader Style Manager, select the style 
that you want to change, and click Modify. 

• If you need to delete a style, open the Multileader Style Manager, select a style, and click 
Delete. 

• You can also create style overrides for the Leader, Content, and Workflow by selecting 
Options in the Multileader command. 
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Practice 9d 

Create Mult i leader Styles 

Practice Objective i 1 0  minutes 

• Create a multi leader style. 

In this practice, you will create a multi leader style using a spline and a block, as shown in 
Figure 9-24. 

Figure 9-24 

1 .  Open AEC-Facilities3-AM.dwg from your practice files folder. 
2. Set the layer to Dimensions. 
3.  In the Annotate tab>Leaders panel, click � . 
4. In the Multi leader Style Manager, click New .... 
5. In the Create New Multi leader Style dialog box, name the new multileader Keynote. Start 

with the Standard style and make it Annotative. Click Continue. 
6. In  the Leader Format tab, in the General area, set the Type to Spline. In  the Arrowhead area, 

set the Symbol to Right angle and Size to 1 0 . 
7. In the Leader Structure tab, clear Maximum leader points (this enables you to make as 

many points on the spline as required) . 
8. In the Content tab, change the Multileader type to Block. I n  the Block options area, set the 

Source block to Circle and set the Scale to 2. Click OK. 
9. In  the Multileader Style Manager, select Keynote and click Set Current. Click Close. 
1 0. Select the /SO A 1 layout tab. 
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11. Start the Multileader command to test the new multi leader style by clicking several points 
to create a zig zag leader. Press <Enter> to stop selecting points along the spline. 

12. In the Edit Attributes dialog box, enter a tag number (01,02,03, etc.) for the keynote. 
Click OK. 

13. Erase the leaders, switch to Model Space, and save the drawing. 

End of practice 
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Chapter Review Questions 

1 .  If you change the font of a text style, what happens to existing text that uses that text style? 
a. The text is moved to a new layer. 
b. The text remains the same. 
c. The text is deleted. 
d. The text updates with the new font. 

Answer: d 

2. What are dimension sub-styles used for? 
a. To override the dimension style settings for a particular type of dimension, such as angle 

or radius. 
b. To automatically dimension specific objects, such as rectangles and circles. 
c. To link dimensions to specific layers. 
d. To copy dimension styles between drawings. 

Answer: a 

3. You have a dimension style that uses decimal units and you want to change it to use 
fractional units. What do you do? 
a. Modify the Alternate Units in the dimension style. 
b. Modify the Primary Units in the dimension style. 
c. Edit the text of the dimension and change the value. 
d. Edit the Fit settings in the dimension style. 

Answer: b 

4. What multi leader type in the multileader style would prompt users for input, such as sheet 
number or callout? (Select all that apply.) 
a. Block 
b. Mtext 
c. None 
d. Circle 

Answer: a, b 

5. You cannot use custom blocks with Multi leader. 
a. True 
b. False 

Answer: b 
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6. When creating a Text Style, Dimension Style, or Multi leader Style, you want the size of the 
text and other objects to scale automatically according to the scale of the viewport in which 
they are used. In the related Style Manager, which of the following options would you set? 
a. Text Size 
b. Alternate Units 
c. Scale Text 
d. Annotative 

Answer: d 
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Command Summary - Command 

Dimension Style 

Multi leader Style 

Text Style 

Annotation Styles 

Location 

• Ribbon: Home tab>expanded Annotat ion  panel or the 
Panel  Arrow i n  the Annotate tab>D imens ions pane l  

• Command Prompt: d imstyl e  

• Ribbon: Home tab>expanded Annotat ion panel or  t h e  
Panel  Arrow i n  the Annotate tab>Leaders pane l  

• Command Prompt: mleaderstyle 

• Ribbon: Home tab>expanded Annotat ion panel or 
Annotate tab> Text pane l> Text Sty les l i st>Manage Text 
Styles or the Panel  Arrow in the Annotate tab> Text 
panel  

• Command Prompt: sty le or  ST 
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Projects: Drawing Setup and Uti l ities 
This chapter contains practice projects that can be used to gain additional hands-on experience 
with the topics and commands covered so far in this guide. These projects are intended to be 
self-guided and do not include step-by-step information. 

Learn ing Objectives i 30min 

• Mechanical: Create a template that contains features such as layers, limits, text, and 
multileader styles to use for electronic schematics or part designs. 

• Civil: Create a template that contains features such as layers, limits, text, and multileader 
styles to use for mapping. 
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1 0 . 1  Interiors Project 

I 30 minutes 
In this project, you will create a new template drawing for use with Interior Design projects. You 
will establish units, limits, layers, a text style, and a multileader style, as shown in Figure 10-1. 

11 Multi leader Style Manager 

Current mu ltileader  style: Keynote s  
lityles: Preview of. Keynotes 
A Annotative .,,.,. 

Standard 

List 
1All Styles 

------------
X 

LSet Cyrrent l 
[ �ew . . .  ] 
L Modify .. . l ---

Qe,ete 

C lose !::!elp - 1  
Figure 1 0-1  

1. Start a new drawing based on AEC-Millimeters.dwt, which is located in your practice files 
folder. 

2. Verify that the units are Decimal. Set the Limits to 22800, 13700. 
3. Add the following new layers: Existing, New, and Demo. 
4. Add a text style named Room Names. 
5 .  Create a new multi leader style named Keynotes using the Circle block and any type of 

leader, as shown in Figure 10-1. 
6. Save the drawing as a template named AEC-lnteriors.dwt. Ensure you save it as a DWT file 

and add a description as required. 
7. Start a new drawing using your template and test some of the settings. 
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1 0 .2 Mechanical/Schematic Project 

i 30 minutes 

In this project, you will create a new template drawing for use with electronic schematic 
diagrams. You will establish units, limits, layers, a text style, and a multi leader style, as shown in 
Figure 10-2. 

• Drawing Units 

Length 
Iype: 
Dec imal 

.e_rec is ion :  

V 

Angle 
Type: 
Decimal Degrees 

Prec is ion: 

�:0_000 _________ .==-�' V 0 

O �lockwise 

Figure 1 0-2 

X 

1 .  Start a new drawing based on Mech-Millimeters.dwt, which is located in your practice files 
folder. 

2. Verify that the units are Decimal and set the Precision to 3 decimal places, as shown in 
Figure 10-2. Set the Limits to 900,600. 

3. Toggle on Snap and Grid and set them to 3. 
4.  Add the following new layers: Resistor, Transistor, and Capacitor. 
5. Add a text style named Wiring. 

6. Create a new multileader style named Keynotes using the Circle block and any type of 
leader. 

7. Save the drawing as a template named Elec-Metric.dwt. Save it as a DWT file and add a 
description as required. 

8. Start a new drawing using your template to test some of the settings. 
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1 0 .3 Civi l/Map Project 

i 30 minutes 

In this project, you will create a new template drawing for use with mapping. You will establish 
units, limits, layers, a text style, and a multi leader style, as shown in Figure 10-3. 

Current text style: P.,,notative 

Styles: 

A P.,,notative 
A Hand 

Font 
Font Name: Font Style: 

X 

!set Current J 
A ISO Proportional 
A LOGO 

I� CityBl�nt "J �ula;:- - V I r- -New . . . l 
A Roman 

Standard 

All styles 

AaB61 25 

Style Name : I Road Names 

0 Upside down 

D Backwards 

Vertical 

Figure 1 0-3 

X Delete 

"ght 
OK 

Width Factor: 

Oblique llllgle: 

1 .  Start a new drawing based on Civil-Meters.dwt, which is located in your practice files 
folder. 

2. Change the Units to Decimal, with the Precision set to 0. Set the Limits to 3000,2100. 
3. Add the following new layers: City Line, County Line, and District Line. 
4. Add a text style named Road Names, as shown in Figure 10-3. 
5. Create a new multileader style named Keynotes using the Circle block and any type of 

leader. 
6. Save the drawing as a template named Civil-Mapping.dwt. Ensure you save it as a DWT file 

and add a description as required. 
7. Start a new drawing using your template to test some of the settings you have established. 
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1 0 .4 Mechanica l  Project: D imension Styles 

:i 40 minutes 

In th is project, you will create dimension styles and dimension the part, as shown in 
Figure 10-4. 

06 . 350 , TYP .  
2 PLACES 

R 1 2 .700 

I 25 .400 

0 1 9 .050 

Figure 1 0-4 

I 
J 

1 .  Open Dimplate-M.dwg from your practice files folder. 

I 
I 

04 .763, TYP . 
5 PLACES 

\ 
\ 

70° 

\ 

2. Create two dimension styles: Normal and Tolerance. Use Annotative style as the base for 
your new dimension styles. 

• The Normal style should have sub-styles for angular and radial dimensions. 
(Hint :  The Fit option in the angular dimensions needs to be adjusted to move the text 
outside the lines first, and set the Text Placement option to Over dimension l ine, without 
leader. The Fit option in the radial dimensions needs to be set to Draw dim l ine between ext 
lines for Fine Tuning.) 
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• The Tolerance style, for the toleranced dimensions, uses a deviation style tolerance. Ensure 
the following values are set: 
• Precision : 0 .000 
• Upper value: 0.762 
• Lower value : 0.254 
• Scaling for tolerance text height: 0.75 (75% of the other dimension text) 

3. Make the layer Dimensions current and dimension the part as shown in Figure 10-4. You 
will need to draw the arc that displays the placement of the five small holes, and the lines 
from the center of those holes to the large hole. 
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Externa l  References 
I n  this chapter, you learn how t o  attach drawing, image, DWF, DGN,  and PDF reference files and 
to open reference files from within a host drawing. You also learn how to detach, unload, and 
reload reference files, clip reference files, work with drawing reference specific information, edit 
drawing reference files In- Place, and bind external references. 

Learn ing Objectives i 1 hr 20min 

• Attach image files along with DWF, DG N,  and PDF underlays to a drawing. 
• Customize the attachment of external references. 
• Open, modify, detach, and unload referenced files. 
• Toggle layers and snap to objects on and off in a DWF underlay. 
• Clip the referenced file to control the part that is visible. 
• Set a drawing reference file to be an attachment or an overlay. 
• Copy data of a referenced drawing into the host drawing and then detach it. 
• Bind blocks, layers, dimensions styles, etc., from a reference drawing into a host drawing. 
• Control how much of a drawing reference file is loaded into the host file. 
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1 1 . 1 Attaching External References 
When you insert one drawing into another as a block, the graphics are merged and no link 
remains between the two files. External References enable you to combine files and retain the 
link, as shown in Figure 11-1. This serves two main purposes: it controls the file size because 
objects in the referenced drawing do not become part of the host drawing, and objects modified 
in the reference file are automatically updated in the host drawing because the files are linked. 

I X  i 
I �◄ 

1 � ! 

I I 

0 

§Ii ... c ... �� ... G) 

File Ref-erence:s 

Reference Name .... Status 

l!lj Factory Site' Opened /iJ ASCENT logo Loaded 
:� Factory Electric.-M Loaded 
�; Factory Floorplan-M 'aJ Loaded 
@� Fa ctory land1;cape-M Leaded 
'9 Factory Site-M - Mo  . . .  Loaded 
I < 

Pr,eview 

" "
rt
. 

'\<' 
!!ml ,,, 

u.iii1iWiii.ill 

Size " , 

B1 .8 K I 11 
I! 

66.2 K · !l 
I I 62.3 K 

145 KE i 
1 29 KE I 
14.9 K " 

> I 

Figure 1 1 -1 

• Reference files enable members of a design team to share common source files and still 
have the most current information. 

• External reference files can be managed through the External References palette. 
• When you open a drawing that contains an external reference file that cannot be found, a 

References - Not Found Files warning box opens, as shown in Figure 11-2. Here you can 
directly open the External References palette, which enables you to check for the missing 
file and resolve the issue, or ignore the unresolved reference file. 

1 1 -2 © 2023, ASCENT - Center for Technical Knowledge® 

( 

( 

( 

( 

( 
( 



References - Not Found Files 

One or  more referenced fi les could not be located or read .  
What do you want to do? 

Number of reference fi les that are Not  Found: 1 

I ➔ Open the External  References pa lette 

➔ Ignore unreso lved reference fil es 

D Always ignore unresolved references 

Figure 1 1 -2 

Externa I References 

X 

�' ! • When you open the External References palette, unresolved files display the ...,. warning 
symbol file icon, and the ! ,  warning symbol displays beside the file with Not Found in the 
Status column. 

Several file formats can be used as external references: 

AutoCAD® 

drawing fi les 

Raster image fi les 

DWF underlays 

DGN underlays 

PDF Underlays 

Also known as Xrefs, they are connect ions to other drawings that you can edit 
in-p lace or externa l ly, whi le reta i n ing the l i n k. You can turn l ayers o n  and off in 
the host d rawing .  

Var ious types of g raph ic  f i les, such as G I F, J PG, and PNG .  They can be  
render ings or scanned i mages that can be used  as a reference as you trace over 
exist ing d rawings .  

Non-ed itab le  f i les that inc lude vector i n formation that can be d isp layed i n  the 
DWF vi ewer and i ncorporated as an  underlay i n  any draw ing  fi le .  

F i les that come from the MicroStat ion p latform. You can a lso i mport and export 
to DGN f i les .  

Attach PDF fi les as underlays one page at a t ime. 
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External References Palette 

You can use the External References palette (shown in Figure 11-3) to attach, unload, reload, 
and detach reference files. You can open a reference file in an appropriate software to make 
modifications to the original file and can also change the location in which the original file is 
saved if it is moved. 
• You can open the External References palette by clicking 0 in the Insert tab>Reference 

panel or by typing Xref in the Command Line. 
• You can also open the External References palette by clicking O in the View tab>Palettes 

panel. 
• If you have a reference file in the drawing, you can right-click on it and select External 

References to open the palette. 
• When you have external references in a drawing, b (Manage Xrefs) displays near the right 

end of the Status Bar. Click it to open the External References palette. b (Manage Xrefs) 
does not display in the Status Bar until. the drawing contains at least one Xref. 

• The External References palette is similar to other palettes and can be either floating, 
docked, or hidden. 
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File References 

Reference Name "" Status 
� Factory Site* 
� Factory Floorplan-M 
•� Factory Landscape-M 
1� Factory Site -M - Model 

< 

Details 

Opened 
Loaded 
Loaded 
Loaded 

Reference N .. .  Factory Floorplan-M 
Status 
S ize 

Loade(: 
1 09 ,s 
Attach 
2 1 1  '202:: IO SC �5  A '.1 

Size 
58.7 KB 
109 KB 
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14.9 KB 

> 

Type 
Date 
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Figure 1 1 -3 
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The External References palette is divided into two panes. 

Top Pane 
In the top pane, a list of file references displays, as shown in Figure 11-4. 
• By selecting the appropriate column heading, you can sort the files in the list according to 

name, status, size, date, and saved path. 

List View
� 

� �:. • C • �ci • G) 

Tree V/ew

� 

File References ::: 'i!. File References ::: t§ 
Reference Name ... Status .... 

""II Fa ctor; Site Opened 
�.lj Factory Floorplan-M Loaded 
�,:. Fa ctory Landscape-M Loaded 
'&;J Fa ctory Site-M - Mo . . .  Load ed 

Size 

TT.8 KB 
1 09 KB 
1 1 1  KB 
1 4.9 KB 

Type 

Current 
Attach 
Attach 
DWF 

�-l;I Factory Site 
!--· .@:I Factory Floorplan-M 
L .. �:. Factory Landscape-M 
1. jtg Factory Site-M - Model 

Figure 1 1 -4 

• § §;  (List View) displays all of the attached external references and detailed information 
including : size, date, and saved path. 

• t: (Tree View) switches to an hierarchical view that displays nested reference files (i.e., 
drawings that are attached to referenced drawings). Double-click on a reference filename in 
Tree View to display or hide the nested reference files below it. 

Bottom Pane 
In the bottom pane, a list of details about a selected file or a preview of the file displays, as 
shown in Figure 11- 5. 

Details
� 

Preview 

Details - liJ Preview 

Reference . .. Factory Floorpl an-M ,., 
Status LcadHI 

�J-0 I� C:-J;•_ ;::Jj 

Size 1 .; ?  i 8 

Type Attach J I [ . · [t  I '  
Date ; 3. n �  l 1 ": :: Pt,1 .., 

Figure 1 1 -5 

• S (Details) displays information about a selected file and enables you to modify the name 
of the reference. If the file is a drawing file, it enables you to modify the type of attachment. 

• � (Preview) displays a small image of the selected file. 
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How To: Attach a Reference Fi le 

1. In the View tab>Palettes panel, 0 click (External References Palette) . 
• You can also open the External References palette by clicking the Reference panel arrow 

in the Insert tab of the ribbon. 
0• 2. In the External References palette, click on the arrow with .,. ...,. (Attach DWG) to open the 

file list, as shown in Figure 11-6, and select a file format to attach. 

� ,.._ I M\ V=Jrv ... l'.ci ... 0 
Attach DWG . . .  

Atta ch Image . . .  

Attach DWF . .  . 

Attach  DGN . .  . 

Atta ch PDF . .  . 

Attach Po int Clo u d  . . .  

Attach Coord inat ion Model . . .  

Figure 1 1 -6 

3. In the Select Reference File dialog box, select the file that you want to attach and click 
Open. 

4. In the Attach External Reference dialog box, set the options as required, as shown in 
Figure 11-7. 
• The options and title of the dialog box (External Reference, Image, or Attach DWF 

Underlay) vary depending on the type of file selected. Several options are used in every 
situation. 
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Re'erence 

Name:  Factory F loorplan-M 

Preview 

��t 
Reference Type 

@ Attachment Q overlay 

-

L
D�

ate using Geog raph ic Data 

Show Deta i l� ] 
-- -----

5. C l i ck OK. 

Browse . . .  

Sca le  

0 Specify On-screen 

X 1�
1 .00 ___ 

� 

y 1._,_.00 ____ __, 

z-. �1 1 oo 
___ � 

0 Uniform Sca le  

Insertion point 

G2] Specify On-screen 

O.OG 

Z O DO 

Figure 1 1 -7 

X 

Path type 

Re lative path 

Rotation 

0 Spec ify On-screen 

Angle :  
IL_o ____ __, 

Block Un it 

Unit !Meters 

Factor: ! '-
1----

� 

Cance l  '-- Help J 

6. If you used the Specify On-screen opt ion fo r Insertion Point, Scale, and Rotation in the 
d ia log box, then specify them i n  the d rawing w indow. 

• You can use the Reference too ls i n  the Insert tab>Reference pane l  to attach o r  modify 
var ious types of externa l ly referenced f i l es, as shown i n  Fi gure 1 1 -8 .  

o �:?} @_,-:i_ � Underlay Layers 

Q Hide frames • 
Attach Clip Adjust 

J� Snap to Underlays ON • 

�} Edit Reference 

50 

Reference 

Figure 1 1 -8 
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Genera l  Attachment Options 

Name 

Path type 

Insertion Point, Scale, 
and Rotation Angle 

Select a name from the l i st o r  c l ick Browse . . .  and select a d ifferent f i le to 
attach .  

Contro ls how the AutoCAD software searches for the reference fi le to load 
it .  By defau lt, the Path type i s  set to Relative Path . It sta rts from the fo lder  of 
the host d rawing .  Full path uses the ent i re path .  With No path, the AutoCAD 
software searches i n  the cu rrent fo lder  of the host d rawi ng,  and i n  the 
project paths, su pport paths, and Start-in fo lder. The defau lt Relative path 
type can be changed us ing the REFPATHTYPE system variab le .  

These opt ions a re s im i l a r  to the select ions for  b lock i nsert ions .  The va lues 
can be entered i n  the Attach Externa l  Reference d ia log box or i n  the 
Command L ine .  

Shortcut Menu Options 
In the External References palette, right-click on an Xref file to  open a shortcut menu that 
contains various options for the attached Xref file. 
• When a drawing has an external reference that has been moved and cannot be found, the 

shortcut menu offers you options to find the file, as shown in Figure 11-9. The Select New 
Path option enables you to fix the missing path by selecting the file from the new location. 
Once the reference file's new location has been selected, the software prompts you to use 
the new path for the other missing references or leave the rest of the paths as is. The Find 
and Replace option opens the Find and Replace dialog box, which enables you to find the 
current path and replace all of its instances with the new path, all at once. 

1 1 -8 

! .... � Factory F loorp l an -M 
! - - �  Facto') • 
! . � Facto') Open 

Attach . . .  

Com pare 

Un load 

Reload  

Preview Detach 

B ind . . .  

Xref Type 

F ind and  Replace . .  

Figure 1 1 -9 

© 2023, ASCENT - Center for Technical Knowledge® 



Externa l  References 

• The shortcut menu also provides you with the option of changing the path type by selecting 
Change Path Type. If the path type option of the selected reference file is grayed out and 
cannot be selected, it indicates that it is the current path type. Figure 11-10 shows an 
example of the referenced file using the Relative Path type, which is grayed out to indicate 
that the path type is currently used. 

: .. ... [l.;j Fa ctory Floorp l an -M 
\ .... . [l.;j Fa cto� • 
L� Fa cto�  Open 

Attach . . .  

Compare 

Un load 

Rel o ad  

Preview Detach 

B i nd . . .  

Xref Type 

Change Path Type 
� 

Select New P ath . . . 

F ind and Rep lace .. . 

Figure 1 1 -1 0  

Xref Specific Attachment Options 

Make  Abso lute 
t··.'l a k e  P �htive 
Remove Path 

Reference Type Two types of references are ava i l ab le  when one AutoCAD drawing is i nserted 
i nto another: Attachment and Overlay. 

Block Unit The I nsert ion Sca le  un its of the reference f i le  and host d rawings (expand 

Appl icat ion Menu, expand D rawing Ut i l i t ies, c l ick l1E (Un its)) control the 
automatic sca le factor that d isp lays i n  the Block Units area. 

Image Specific Attachment Options 

You can attach an image as many times as required in the same drawing file. I f  a raster image 
by that name already exists in the drawing (even if the extension type is different) a Substitute 
Image Name dialog box opens in which you can type a new name. This name displays in the 
External References palette. 
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DWF Specific Attachment Options 

Select one or more sheets If you are us ing a mu lt i-sheet DWF f i le  you can select any of the sheets 
to i nsert i nto the host d rawing .  

• If you set the scale factor to Specify on Screen then, at the Specify Scale Factor or [Unit]: 
prompt, you have the option to select the units of the existing drawing and have the 
software automatically scale the DWF file to those units. For example, if you are working in a 
drawing whose insertion scale units are set to Meters and the DWF file is in Architectural 
units, it automatically scales the DWF file by 0.0254. The default insertion scale unit is set to 
the current drawing units. 

• You can insert multiple copies of a DWF file using the same sheet or different sheets in a 
multiple sheet file. 

DGN Specific Attachment Options 
MicroStation DGN file units are set up in Master units and Sub units . When you insert a DGN as 
an underlay, you need to specify the units that you want to convert. For example, if you attach a 
mechanical drawing that is created with Master units of millimeters and Sub units of 
thousandths of millimeters, you would convert the Master units . However, if you are working 
with a file that has Master units of feet and Sub units of inches and you want to insert it into an 
AutoCAD Architectural unit file (which uses inches as its default units), you would convert the 
Sub units. 

PDF Specific Attachment Options 

Select one or more pages I f  you a re us ing a mu lt i -sheet PDF fi le, you can select any sheet(s) to 
insert into the host d rawing .  

• All the supported objects in the PDF file are converted into 2D geometry, raster images, and 
True Type text. 

• Once you have attached the PDF file as an overlay, you can modify how the PDF objects are 
...... 

converted using Im (Import as Objects). In the External References palette, select the 
attached PDF file. It opens the PDF Underlay contextual tab. In the PDF Import panel, click 
...... Im ( Import as Objects) and then click Settings in the Command Line. The PDF Import 
Settings dialog box opens and you can set the import options for the PDF file, as shown in 
Figure 11-11. 
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' PDF  Import Settings 

PDF data to import 

� '!ector geometry 

� Solid fi l l s  

� IrueType text 

D Raster i!!lages 

Import options 

D Import as block 

Layers 

@ jJ_se P DF layers 

0 Crea e Qbject layers 

0 i::_urrent l ayer 

� !oin l ine and arc segments 

0 Convert sol id fi l ls lo hatches 

� Apply l ineyteight p roperties 

D I n fer linetypes from col l i near dashes 

Figure 1 1 -1 1  

X 

OK 

Cancel 

Ogtions ... 

Help 

• I n  the PDF data to import area, se lect the types of data to import, as fo l lows: 

• Vector geometry: Lines that touch become connected po ly l ines .  
• Solid Fills: Jo ins 2D so l ids  with co incident edges to create hatch objects . 
• TrueType text: Converts True Type fonts to text objects.  If the PDF fi l e  conta ins  SHX 

fonts, these a re converted to  separate geometr ic rep resentat ions, wh ich can be 
converted to mu lt i l ine text objects us ing the Recognize SHX Text tool i n  the Insert 
tab> lmport pane l  (PDFSHXTEXT command) .  

• Raster images: Extracts images to PNG f i les, which are  then attached to the d rawi ng as 
reference f i les .  

• I n  the Layers area, set wh ich l ayers the attached objects a re added to . 

• I n  the Import options area, set opt ions that are used as geometry is imported: 

• Import as block: Creates a s ing le  b lock rather than separate l i nes .  
• Join line and arc segments: Creates po ly l i nes from connected obj ects .  
• Convert solid fills to hatches: Jo ins  2D so l ids w i th  co inc ident edges to create hatch 

objects. 
• Apply lineweight properties: Assigns a l i neweight to the imported geometry accord i ng  

to i t s  th ickness i n  the PDF. 
• Infer linetypes from collinear dashes: Creates a s ing le  po ly l i ne  from co l l i near  dash  and 

dot segments .  
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1 1 .2 Modifying External References 
When you have attached external references to your drawing, you can modify the way they 
function in the drawing. 
• You can Open, Unload, Reload, and Detach individual references, as shown in Figure 11-12. 

, ,  ll1i T C T �tci T G) 

File Reference� 

Reference Name .... 

�=. Factory Site 

Status 

Opened 
@.lj Factory Fk-·- 1-- " 
llJi Factory L W' Open 

·ia Factory S Attach . . .  

< 

Compare 

Un load  

Reload 

Detach  

B i nd  . . . 

Xref Type 

Figure 1 1 -1 2  

1 ... ..  .,.1 ..,.-,1 

Size 

77.8 KB 
1 r.n  VO 

• All of the reference file formats can be clipped to display part of the reference. You can 
make changes to a selected reference in the Properties palette. 

• You can use standard AutoCAD® commands, such as Move, Rotate, and Scale on 
references. Raster images can also be used to trim or extend to another object. 

Open ing Reference F i les 

You can modify a reference file in the software in which it was created and then reload it into 
the drawing. You can open a reference file from within the host drawing. Select the file in the 
External References palette, right-click, and select Open. 
• A drawing reference file opens the drawing in the AutoCAD software. 
• Image files open the image in the software with which the file format is associated. 
• Autodesk® Viewer (https: //viewer.autodesk.com/) is a free on line file viewer that enables 

you to view DWF files. 
• DWF files also open in the Autodesk® Design Review software, if it is installed. DGN files 

cannot be opened with the AutoCAD software. 
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• You can also open drawing reference files by picking the reference in the drawing window, 
right-clicking and selecting Open Xref, as shown in Figure 11-13. 

Repeat XATTACH 

Recent I nput 

\!::'- Edit Xref I n -p l ace  

Open Xref 
� 

Cl ip  Xref 

Externa l  Reference,; . . .  

Figure 1 1 -1 3  

Detaching and Unloading Reference Fi les 

There are two ways of removing a reference file from your drawing : Unload and Detach (as 
shown in Figure 11-14). 

Detaching Fi les 

File References 

Reference Name  .... Status Size Typ e 

�-llli Factory Site• 
@� Factory Fl oorpl an -M 
�.lj Factory Lands 
'lei Factory Site-f\ 

Opened 51 . 1  KB Current 
Loaded 109 KB Attach 

Open 

Attach . . .  

Compare 

Un load 

Reload 

Detach 

Bind . . .  

ach 
F 

Figure 1 1 -1 4  

Use Detach to permanently remove a reference file from your drawing . 
• It severs the link between the current drawing and the external reference drawing . 
• To get the reference back after detaching it, you need to re-attach it . 
• If you have attached multiple copies of a DWF file, Detach removes all of them. 
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Unloading and Reloading Fi les 
Use Unload to temporarily remove a reference file. 
• When you unload a reference file, the AutoCAD software hides the reference geometry. 

However, it keeps the file in the External References palette list and remembers its insertion 
point, scale, and other attachment information. 

• Unloading references that are not currently required causes a drawing to open and 
perform faster. 

• To display an unloaded reference again, it must be reloaded using the Reload option. 
• You can use the Open option in the shortcut menu to quickly open the unloaded 

reference file. 
• Reloading loads the most recently saved version of the reference. 
• All of the references reload automatically when you open the host drawing . 
• Renaming the unloaded reference file in the External Reference palette does not 

automatically reload the renamed file. You have to explicitly reload it, as it remains unloaded 
until then. 

• Refresh synchronizes information stored in memory when used with the Autodesk® Vault 
software. 

• Reload All References (shown in Figure 11-15) updates all of the references in a drawing 
so that you are using the most up-to-date versions that have been saved. 

Comparing Xrefs 

File R 
Refresh 

Rel oad All Referen ces �·� Fa, ----------..J 
L. � Factory Floorp l a n -M 

Figure 1 1 -1 5  

Once you have made changes to an Xref, you can now compare the original and the modified 
Xref. By comparing the two Xrefs, you can now identify the modifications that were made to the 
drawing file that is attached as an external reference in the current drawing . The differences in 
the changed Xref are highlighted by a revision cloud. The comparison can be started by 
selecting Compare in right-click menu as shown in Figure 11-16 . 
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File References 

Reference Name • Status Size 
�·� Factory Site� 
fQ ASCENT logo 
�,:1i Factory F loorp l an  " 
�� Factory Landscap 
� Factor/ Site-M - � 

< 

Opened 68.2 KB 
Loaded 66.2 KB 

Open 
Attach . . . 
Compare 
Un load 

Figure 1 1 -1 6  

Type  
Current 
G I F  

,....____._ I _ _ ___ _ _ 
�ent Changes 

Selected F i le . . .  

• When a drawing which is referenced in a drawing is changed, a alert balloon is displayed in 
the Status Bar, as shown in Figure 11-17. Select the link in the balloon to reload the 
reference and also to compare the changes. This message also displays when someone 
else changes a reference while you have the host file open. 

0 An xref was modified [El 
Reload Factory Floorpla n -M  - by nnuthoo 
P' Compare the ch anges 

.ft + � D •.-1 :1 ..,. y ,, � t,.O •� '-A 

Figure 1 1 -1 7  

121 = 

• When you start the Xref Compare command, the drawing opens in a Compare window 
which is indicated by drawing being enclosed in a blue border and the Xref Compare toolbar 
displayed along the top of the drawing window, as shown in Figure 11-18. The changes are 
highlighted in a revision cloud as shown in Figure 11-18 . 

� Xref Compare • <? -=;> X 

L 

X 
;c --� .,. C ... ... G) 
(l 

File References 
Reference Name 

� Factory Si te• 
tl'.""1 ASCENT logo 
�- Factory Floorp lan-M 
Q:t. Factory La ridscape-M 
lj.3 Factory Site ·M - Model 

Figure 1 1 -1 8  

© 2023, ASCENT Center for Technical Knowledge® 

... Status 
Opened 
Loaded 

�, In  Compare 
Loaded 
Loaded 

1 1 - 1 5  



AutoCAD 2024: Beyond the Bas ics - I nstructor Gu ide 

• You can expand the Compare toolbar to toggle the various display options, change the color 
and shape of the revision clouds, and zoom to the previous and next comparison in the 
drawing, as shown in Figure 11-19. Use X to end the comparison. 

Difference 

(ti:-�f Compace • <? ◊ </' 

. .c:, 

! ■ Not in Current Xref 

■ On ly in Cu rrent Xrcf 

■ No D1ffercnc6 

� Not Compared 

Draw Order 

Revision Clouds 

� Cloud Display 

Re:chngu l a ,  

Siz1 

Filters 

•!El Hatch 

Figure 1 1 -1 9  

Cl ipping Reference Fi les 

When you attach an external reference to your drawing, the entire reference file displays. 
However, you might not want the entire file to display, even in Model Space. You can control 
which part of the referenced file is visible by clipping it, as shown in Figure 11-20 . 

Figure 1 1 -20 
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How To: C l ip a Reference Fi le 

1 .  In the drawing, select the reference that you want to clip, right-click and select the 
appropriate Clip command for the type of reference selected. (Drawings: Clip Xref; Images: 
lmage>Clip; DWF files: DWF Clip; DGN files: DGN Clip.) 

2. Enter a Clipping option. Press < Enter> to accept the default New boundary option. 
3. Select the Rectangular or Polygonal boundary option and draw a boundary. 

• If you have selected a drawing file, you have the additional option of selecting an existing 
polyline as the boundary. 

4. Specify the points or existing polyline. The reference is clipped so the reference information 
outside the boundary is invisible. 

• You can only clip one image ( . DWF or . DG N  file) at a time, but you can clip multiple 
drawing files. 

• Drawing reference files have an additional clip option: Invert Clip. I nstead of masking 
everything outside the boundary it covers everything within the boundary. This can be very 
useful if you are working on a renovation project in which you are moving interior walls but 
not changing other parts of the building. 

Other Cl ip Options 

On/Off 

Clipdepth 

Delete 

Generate 
Polyl ine 

Turns the cl ip boundary on or off without removing it from the reference. If the 
boundary is  off the entire reference d i splays. 

Contro ls  the front and back c l ipp ing p lanes i n  the Z-d i rect ion of the cl ip .  Drawing 
reference f i les on ly .  

Removes the c l ipp ing  bou ndary f rom the reference f i les .  You cannot use the Erase 
command to remove the c l i pp ing boundary. 

Creates a polyl i ne at the l ocation of an  ex ist ing cl ip bou ndary .  This is  a separate 
ent ity from the boundary. Drawi ng reference f i les on ly .  

• If you run the command on a file that already has a boundary, the AutoCAD software 
prompts you to delete the current boundary first. 

• To modify the clip boundary, start the associated Clip command. You can toggle the Clip 
Boundary on or off or delete it . 
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Cl ip Frames 

The l i nes around c l i pped references a re ca l led Clip Frames. They can be toggled on  o r  off for a l l  
o f  the references i n  a d rawing us i ng  system variab les that a re re l ated to each reference type: 
xclipframe for d rawi ng references, imageframe, dwfframe, pdfframe, and dgnframe, as shown 
in  F igure 1 1 -21 . 

Frame ON Frame OFF 

Figure 1 1 -21 

• Frame Boundaries have three opt ions .  When set to 0, the boundary i s  i nv is ib le .  When set 
to 1 ,  the boundary is  v is ib le .  When set to 2, the boundary is v is ib le  but does not p lot. 

• When the bou ndary i s  v is i b le, you can select the externa l  reference by select ing  the 
boundary o r  any v is ib le  part of the reference fi l e .  

Modifying References 

When you select the border of a reference f i le, a contextua l  tab d i sp l ays accord i ng  to the type of 
reference fi le  that was se l ected.  
• A D WF underlay contextua l  tab has panels for Adjust, C l i pp i ng,  Opt ions, and DWF Layers, 

as shown i n  F ig u re 1 1 - 22.  PDF and DGN u nderlays a re the same.  You can a lso r ight-c l ick  
on the DWF object i n  the d rawing window and select many of the opt ions from the 
shortcut menu .  
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Boundary Clipping Underlay Snap References 

Adjust dipping Options 

Figure 1 1 -22 

Externa l  References 

Edit 
Layers 

DWF Layers 

Modification options for drawing reference files include editing the reference, clipping, and 
access to the External References palette, as shown in Figure 11-23. 

Home Insert Amotate Parame:trk External Reference 

Edit Reference In.Place Open Reference Create Clipping Remove 
Boundary Clipping 

Edit Clipping 

Figure 1 1 -23 

Image panels include Adjust and Clipping, and an additional Transparency option, as shown 
in Figure 11-24. 

}ade 

] 
] 0 

Create Clipping Remove 
I 

Sho 11i1 Background External 
Boundary Clipping I Image Transparency References 

I I 
�---A�dJ�·us_t ___ l Clipp;ig I Options 

Figure 1 1 -24 

Underlays and image references can only be selected when the frame surrounding them is 
on. You can change the state of the frames in the Insert tab>Reference panel, as shown in 
Figure 11-25. 

b -� �-:i. Underlay Layers 

[7 "Frames vary• Attach Clip Adjust >--------< .,,___� 

[ 1 Hide frames 
Re • 

� Display and plot frames 

� Display but don't plot frames 

Figure 1 1 -25 
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Reference F i le Properties 

DWF, DGN, and Image references have several properties that can be modified, including how 
and what they display in the drawing. 
These options can be modified in the Properties palette. 

Miscel laneous Options 
In the Misc area in  the Properties palette, you can toggle off DWF or DGN underlays or  Images 
without unloading the files. Set Show image to No, as shown in Figure 11-26. 

I Misc - I 
Name  ASCENT logo  
Saved Path C : \AutoCAD 2. 
Show image Yes 
Show cl i pped  Yes 
Background Ira n spar . . .  N o  

Figure 1 1 -26 

• The Show clipped option changes the status of displaying whether the object is clipped or 
not clipped. This is different than displaying the clipping frame. 

• Images have the additional Background Transparency option. This permits the background 
of the image to become transparent, so that it matches the general background. However, 
not all of the file formats enable transparency. You can also access this option in the ribbon 
and in the shortcut menu under Image. 

Adjusting Underlays and Images 
DWF and DGN underlays and image reference properties can be adjusted. 
• With a reference file selected, in the Properties palette, in the Underlay Adjust or Image 

Adjust areas, you can specify the amount of Contrast and Fade, as shown in Figure 11-27. 
DWF and DGN files can be set to Monochrome and Image files have an additional 
Brightness adjustment. 

I Underlay Adjust 
Contrast 
Fade 

75 
2.5 

M o nochro m e  No  
Adjust co l o rs f o r b a c . .  Yes 

Figure 1 1 -27 

- ) 

• DWF underlays have an option to adjust the colors for the background. 

• Click �-;i. (Adjust) in the Insert tab>Reference panel to adjust the Fade, Contrast, or 
Monochrome settings for underlay and image files. 

1 1 -20 © 2023, ASCENT - Center for Technical Knowledge® 



External  References 

• Image references can also be adjusted in the Image contextual tab as shown in 
Figure 11-28 . A preview of the changes displays in the drawing window as the 
modifications are made. The contextual tab is opened by selecting the underlay or image. 

Brigi•tne s 50 
� � ½ � 0 

Contrast 50 
Create C l ipp ing Remove Show Backg round Externa l  

Fade 0 Boundary C l ipp ing � Transparency References 

Adjust C l ipp ing Options 

Start Bighouse1 -A* X Floor P lan-A' + 

S C E N T 
C F '-i TT !t H)k T f C: H ."\J ICJ\ l  K N (.1\'d . E C>l_if 

D i v i s i o n  o f  R A N D  W o r l d w i d e  

Figure 1 1 -28 

• The quality of an image can be set to High or Draft by typing imagequality at the 
Command Line. 

� Hint: Creating an Image File 
In the AutoCAD software, there are several ways of creating a raster file, which can then be 
used as an image: 

• You can copy the contents of the current viewport using saveimg at the Command 
Line. The image can be saved in the . B MP, . PCX, .TGA, .T I F, . JPEG, or . PN G  file formats. 

• You can render the display to a file (usually done with 3D objects) . Rendering can 
create several different raster formats. 
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DWF Specific Adjustments 

DWF reference files have two additional options because they are created from drawing files: 
toggling layers on and off and snapping to objects in the DWF underlay. 
• Layer visibility can be controlled in DWF underlays (as shown in Figure 11-29), if the DWF 

file was created with the layers toggled on. When you have selected a DWF underlay, in the 
D WF underlay contextual tab, select Edit Layers. In the Underlay Layers dialog box, select 
the layers you want to toggle on or off and click OK. 

• Underlay layers 

Select im underlay to view its !eyers. 

Reference Name: Factory S ite-M - Model 

Search for layer 

On Name 

Q FUTURE ROAD 
Q PARKING LOT LINES 
Q Text 
Q trees 

Figure 1 1 -29 

X 

• To adjust another reference file's layers, select it in the Reference Name drop-down list. 
• If a reference file does not contain layers, this is indicated in the Underlay Layers dialog box. 

By default, layers are not saved in the DWF6ePlot.pc3 file supplied with the software. 
• You can snap to objects in a DWF underlay. If you do not want object snaps to work with 

DWF files, select the DWF underlay, right-click and clear DWF Object Snap, as shown in 
Figure 11-30. You can also clear Enable Snap in the DWF underlay contextual tab. This 
impacts all of the DWF underlays in a drawing. 

1 1 - 22 

d] DWF Clip ... 
( owr - g DWF Lay_ers . . .  
!� DWF Object Snap 

:□ External References ... 

Cl ipbo;ird 

Figure 1 1 -30 
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1 1 .3 Xref Specific I nformation 
The reference file tools works slightly differently with drawing references (also known as 
Xrefs) . Because drawing reference files contain the same components as the host files, you 
can manipulate them using methods that cannot be applied to raster images, .DWF, and .DGN 
files. You can set drawing reference files to be attachments or overlays and can modify Xref 
layer states in the host drawing without impacting the original file. You can also import (bind) 
layers and block components of the drawing reference file into your drawing. 

Attachments vs. Overlays 

You can specify whether a drawing reference file should be an attachment or an overlay when it 
is originally referenced. Attachments and overlays work in the same way in the host file. You 
only notice the difference if you reference that host file in another file, as shown in 
Figure 11-31. 

Attachment 

Overlay 

Dr<Jwing A 

Attach ment  

1---

-

I Overlay 

I Overlay 

Figure 1 1 -31 

Drawing B 

,A,ttachment 
of Drawing A 

Attach rnent in 
Drawing A 

When a f i le is referenced as an attachment, it d isp lays with the host fi l e  if the host 
f i le itself is then referenced i n  another drawing .  Us ing attachments enables a f i le 
to travel a long the path with i ts host .  A typ ica l  use for th is  opt ion wou l d  be i f  there 
were a part referenced i ns ide a subassemb ly, which i s  then referenced into a 
l a rger assembly. 
When a fi le is  referenced as an overlay, it does not d i splay i n  the host fi le i f  the 
host f i le itself is  referenced i n  another d rawi ng .  Using overl ays helps to avo id  
problems of  c i rcu la r  references. (C i rcu la r  references occur when a f i le  references 
itself, usua l ly i nd i rectly. For examp le, d rawing A references d rawing B, which 
references d rawing C, which references d rawing A. )  
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• To change a drawing reference file from an attachment to an overlay, select the reference in 
the External References palette and modify it in the Details pane, as shown in Figure 11-32. 

Details Is L:.I -
Reference . . .  Factory Landscape-M A -
Status Loaded = 
Size 121 KB 
Type Attach vj 
Date ... .  

Overlav l-

Figure 1 1 -32 

• You can also right-click on a filename(s) in the External References palette, expand Xref 
Type, and select Overlay. 

Xref Layers 

When you attach or overlay a drawing reference file, it brings the drawing objects and its named 
objects, such as layers and blocks, into the host drawing. 
• In the Layer Properties Manager, you can quickly display all of the layers in a specific 

drawing reference file by selecting the Xref filter, as shown in Figure 11-33. The Xref filter is 
automatically created when you attach a drawing reference file. 

• A special prefix is added to any named objects from the referenced drawing when the 
names display in the host drawing, as shown in Figure 11-33. It consists of the name of the 
referenced drawing and a vertical bar (" I") . For example, a layer named 1 F in a reference file 
named Factory Floorplan-M would display as Factory Floorplan-Ml 1  F .  

1 1 -24 

Cu rrent l ayer: 0 
Ev E:J I � 
F i lters « 5 .. Name 

B·· § Al l  LT �a .  r, E ectr c - , I  3 
..._ I 

i - - - - -� Al l n on -Xref Layen I Fac:cr; E lectnc-M IC . . .  1 
i·· -� Al l  Used Layers. ., Face,:, :: eclrc - \1 . . • f 
L ... ;:f Un reco n ci l ed New I Face�, : ee l  c -'.1 . . .  

----.,►...- cl:J-.. � Xref ,., Fac:c r1 :,ect c - ',1. . .  f 

j .. ... Q Fa ctory Electric ,., Faccr1 E ect c - ',I : .. . • 
L. ... � Fa ctory lighti n ,., Fac:cr:, : ee l  c -\1 c . . .  • 

# Factcr1 : ect ( - '.1 = 

Figure 1 1 -33 
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• In order to clearly distinguish which layers come from referenced drawings and which layer 
reside in the active drawing, Xref layers are shown in gray text in the Layer Properties 
Manager and the Layer Control drop-down list, as shown in Figure 11-34. Additionally, you 
can change the visibility of Xref layers in the layer panel drop-down. 

0 • D Contour - Existing ,.. 

�� 
rJ 

"' j D Contour - Existing 
Layer , �-•---------------

Properties } -•· e' ■ Contour - Proposed 

-/ - , i cl' ■ Defpoints 

: � □ ::c,ocs / 

e: EJ' ■ Facrory Floor plan-M l lF 

�- cl' ■ Facrory Floorplan -M l 1FIN 

--.:- di' ■ Factory Floorplan -M :2F 

• -�- cJ ■ Factory Floorplan -M :2FIN 

Figure 1 1 -34 

• You can change the Xref layers state or properties (Freeze/Thaw, Colar, etc.) in the current 
drawing. However, you cannot make an Xref layer current in the host drawing. 

• The layer on which the drawing reference file is inserted controls the visibility of the drawing 
reference file. The drawing reference file is hidden when that layer is frozen. To specify a 
default layer on which you want the reference files inserted, use the XREFLAYER system 
variable. 

• Renaming or deleting an Xref layer in the Xref drawing, automatically renames and deletes 
the layer when the Xref is reloaded in the host drawing. 

• If you change the properties of an Xref layer, the change does not affect the referenced 
drawing. However, the change is retained in the host drawing by default. The default is 
controlled by the VISTRETAIN system variable. You can also control it in the Layer Settings 
dialog box, in the Xref Layer Settings area, by using the Retain overrides to Xref layers 
properties option. 
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In the Layer Settings dialog box, you can specify the various Xref layer properties that you 
want to reload, as shown in Figure 11-35. These Xref layer properties are stored in the 
VISRETAINMODE system variable. 

Xref layer Settings 

'• @ .8,etain  overrides to xref layer properties 

G2] 2S_,ef layer properties to reload (except overrides) 

O Qn10tt [2] Qolor 

0 Freere{Thaw 0 lin§_type 

[;2j !cock/Unlock 0 line:!'_10ight 

D ]:lot/No Plot 0 !ransparency 

0 Newl,/P Freeze PI,, ?!tie 

0 Qescri ption 

Q Don't ret�in overrides to xref layer properties 

!� D ! reet xref object properties as By Layer 

Figure 1 1 -35 

• In the Layer Properties Manager, a �- icon is displayed beside Xref layers that contain 
overrides. Hovering the cursor over this icon displays a tooltip that lists the override 
information, as shown in Figure 11-36. In the top right corner of the Layer Properties 
Manager, the 27- icon (shown in Figure 11-36) can be used to toggle the shading 
background of the layers with overrides. 

E?r EJ I =i 

Layer Settings dialog box 

Shad/ag baokg-d oofo� 

"-' ;;;;,  (I, 
F i lters « S .. Name � 0. Fre. . .  Lo . . .  

El . § Al l  " Fac:cr1 : en < 1 3, 

L .. Bj; Al l  non-Xref L ayers !£> Fae cry El ectric -M IC.. . 

' .... Bj; Al l  Used L ayers " Fa,·cr· = ec: c · '  1 

: .... . v Unreconc i led New I Farler ' ec•  ,: · '  L . . 

r¼J--- �• Xref � Facer: : cc - c v '.1 , . , .  

'. .. b Factory E l ectric 'i;l- Factory Electric· MIE . . .  

-� Factory Li ghtin " =a, ·er " �c.· C ·  • F . . 
' � Xref Overri d es t::::;; �'::�::�I:: : ·  

d' 
r.f 
Ii 

II If 
a' 
af 
rf 
rf 

Layer: Factory E l ectric •M I FRAME 050 

�I < ________ �> I ., X
r
�:0

Li
�;ty::c�

v

:
rri de: Div'.d

e 

Figure 1 1 -36 

Colar Lin etype L ineweight . ,..  
■ b lue Conti nuous  -- Defau l  
■ white Conti nuous  -- 0.35 mm 
■ blu e Contin u ous  -- 0.25 mm 

red Contin uous -- Defau lt  
□ yel low Conti nuous -- Defau lt 
D magenta Conti nuous  -- De au l t  
■ wh ite Conti n u ous  -- De au lt 
0 magenta Divide -- Defau lt 
■ blu e Conti n u ous  -- Defau lt 

red H idden -- Defau l  
Cl red Continuous -- De au l t  

O vel l ow Continuous -- Defau l t  
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• In the Layer Properties Manager, an Xref Overrides filter is automatically created when 
some Xref layers have overrides applied to them. 
• Clicking Xref Overrides displays only the list of Xref layers with overrides. 
• To reset any or all of the layer properties to their original state, right-click on Xref 

Overrides and select Reset Xref Layer Properties to access the options, as shown in 
Figure 11-37. 

½? □ I � 
F i l ters « S . .  Name A 0 .  

El-· g, A l l  � - Factory Electric-M[B. . .  9 

< 

;·· · ·El\? Al l  non-Xref Layer, �- Factory El ectric-M IC. . . (/1 

j . . El\? Al l  Used Layers �- Factory ::fectric- :Al  .. , 

! . .. .} Unrecon c i l ed Ne:W � Factory Electric-Ml . . , 9 
� -� Xref �- Fae ory Efectric-MI . . , I? 
! \.- - -� Factory El ectric �- Factor/ Elec ·c-MIE . . . � 

i L � Factor; L i g htin �- Fae ory Electric-Mlf .. , � 

I •••• �- Xref Ove Vi si b·:hty 

Lock 

Viewpo rt 

0 invert fil er I so late Group 

Al l Propert ies 

On 

F reeze 

Lock 

P lot 

Co la r  

L inetype 

L ineweight 

Transparency 

P lot Styl e 

New VP Freeze 

Xref Overrides: 21 l a  
Reset Xref Layer Properties � > Description 

New Properties Fi lter. . .  L 
Figure 1 1 -37 

• You can control the display of layers for objects in an Xref drawing that were not set to 
"ByLayer" for the layer property updates in the original Xref. The XREFOVERRIDE variable 
enables you to force objects to be set to ByLayer in the host file. 
• Setting the XREFOVERRIDE to 1 enables the original file to set the properties and 

enables Xref objects to be forced to use ByLayer in the host file. 
• Setting the XREFOVERRIDE to O enables the drawing in which it is referenced to control 

the properties and only enables Xref objects that are already set to ByLayer to be 
changed in the host file. 

• This can also be controlled in the Layer Settings dialog box>Xref Layer Settings area, 
using the Treat Xref object properties as Bylayer option. 
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Binding Drawing Reference F i les 

The Bind option in a drawing reference file copies all of the referenced drawing's data into the 
current drawing and then detaches the reference. The referenced drawing becomes an inserted 
block. 

How To: Bind a Drawing Reference Fi le 

1. Open the External References palette. 
2. Right-click on the drawing reference file that you want to bind in the list and select Bind. 
3. In the Bind Type area, select Bind or Insert (as shown in Figure 11-38) and click OK. 

' Bind Xrefs,/OGN underlays 

B ind Type 

@ Bind 

Q insert 

Figure 1 1 -38 

X 

OK 

Cancel  

When a drawing reference file is bound, it brings all of its layers, blocks, and other named 
objects into the host drawing. The Bind Type controls how these named objects are named in 
the host drawing. 
• When you use the Bind Type Bind, the object names are prefixed with the name of the 

reference file (filename$0$1ayername). For example, if the layer Ref:Floor (from the drawing 
Ref.dwg) was bound to the current drawing, its name would become Ref$0$Floor. This can 
result in long names, but keeps the layers that were originally in the drawing reference file 
separate from the layers that were originally in the host file. 

• When a drawing reference file is bound as an Insert, the block and layer names are added to 
the current file without change. For example, the Xref layer Ref:Floor would become Floor. I f  
the current file contains a block or layer with the same name, the drawing reference file 
object is updated to match the definition already in the current drawing. 

• Binding a drawing reference file as an Insert is equivalent to detaching the reference file and 
inserting it as a block. 
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Binding Drawing Reference F i le Components 

Instead of binding the entire drawing reference fi le, you can bind one or more blocks, layers, 
l inetypes, text styles, and dimension styles. B inding any of these named objects adds their 
definit ion to the host drawing so that you can use them in the drawing. 
• The Xbind command, accessed in the Command Line, enables you to bind specific named 

objects from a drawing reference file (such as layers or blocks). 
• Xbind opens the Xbind dialog box (shown in Figure 11-39), in which you can select the 

drawing reference file from which to bind, the type of object (layer, block, etc.), and the 
specific named object to bind. Click the + sign to display the listings under each category. 
Select the object and click Add to add it for binding. 

' Xbind 

Xrefs 

• � Factory F loo rp lan-M 

[B · · Ci, Block 

[fJ • � D imstyle 

B fJ Layer 
; 

�' Factory F loorp lan-MIFRP 

" 

: · -l!i Factory F loorplan-MIFRP 

n_ Factorv Floorplan-MIViev v 
< > 

X 

Definitions to B i nd  

8dd -> Factory Floorplan-M IFRAME 070 

<- Bemove 

OK Cancel 

Figure 1 1 -39 

• When named objects are bound with Xbind, the 'T' in the name is replaced with "$0$". For 
example, the block Office3:Lamp becomes Office3$0$Lamp. There is no option, such as 
Insert, to add the name without a change. However, you can rename the resulting objects 
using Rename. 

• You can use the Design Center to copy these components into your current drawing without 
us ing the long names. 
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Demand Loading 

Demand Loading controls how much of a drawing reference file is loaded. With Demand 
Loading enabled, only the visible parts of the drawing reference file (that are not clipped or on 
layers that are off or frozen) are loaded. Since it does not have to load the entire drawing 
reference file, the AutoCAD software responds more quickly. 
• Demand Loading can be set in the Options dialog box, in the Open and Save tab, by selecting 

the Demand load Xrefs options, as shown in Figure 11-40. 

External References O(refs) 
Demand load �s : 

Enabled wtth copy 

Figure 1 1 -40 

V 

• When Demand Loading is enabled, others cannot edit the file that is being referenced. To 
enable others to use the file that is being referenced and take advantage of the improved 
performance, set Demand Loading to Enabled with copy . A copy of the file is used in place of 
the drawing reference file, so that others can use the file. 
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Practice 1 1  a 

Attach External References 

Practice Objectives 

• Attach and modify external references and overlay drawing references. 
• Adjust the layers in a referenced file. 
• Bind a reference to a file. 

Externa l  References 

i 35 minutes 

In this practice, you will attach and modify external references using the External References 
palette. You will also attach and overlay drawing references and note how they function in 
another file. You will then adjust layers in a referenced file and bind a reference to a file, as 
shown in Figure 11-41. 

,, �-- T C y l:'ci T G) 

File References 

Reference Name .... Status Size " 

Il!ii F a ctory Site' Opened 81 .8 K 
� ASCENT l ogo  Loaded 66.2 K 
�ljj Factory E l ectri c -M Loa ded 62.3 K 
�� Factory F loorp l an -M Qi Loa d ed 1 45 KE 
�� Factory Landscape-M Loaded 1 29 KE 
'i@ Factory Site-M - Mo. . .  Loaded 14,9 K " 
< > 

Preview 

1inrniiiillililliifi
1 

Figure 1 1 -41 
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Task 1 :  Attach external references. 

In this task, you will explore the features of the External References palette. You will attach a 
Reference File DWG, Raster Image, and DWF Underlay. 
1 .  Start a new drawing based on Civil-Meters.dwt, which is located in your practice files folder 

and save the drawing as Factory Site.dwg. 

2. In the View tab>Palettes panel, click O (External References Palette) to open the External 
References palette. 

3. Near the top of the External References palette, click on the arrow with � ,.. (Attach 
DWG) and select Attach DWF. ... 

4. In the Select Reference File dialog box, open Factory Site-M.dwf from your practice files 
folder. 

5. In the Attach DWF Underlay dialog box, for Insertion point, clear Specify on-screen and verify 
X,Y,Z values are set as 0,0,0. Select Specify on-screen for the Scale, if required. Note that 
the Path type is set to Relative path. Click OK to continue. 

6. At the Specify scale factor prompt, right-click and select Unit. Verify that Meter is selected 
and press <Enter> to accept the default selection. 

7. Press <Enter> to finish placing the DWF underlay. DWF underlay is placed in the drawing 
window and the DWF file displays as Loaded in the External References palette. 

8. Using the above steps, and using Attach DWG, attach Factory Floorplan-M.dwg from your 
practice files folder at 0,0,0 Insertion point with the default scale and rotation (Specify On­
screen cleared for all three). Verify that the Reference Type is set to Attachment. 

• Note that the (Manage Xrefs) tool now displays in the Status Bar, which can be used 
to open the External References palette at a later time. 

9. Zoom Extents to display Factory Site-M.dwf and Factory Floorplan-M.dwg. 
1 0. Similarly, attach Factory Landscape-M.dwg from your practice files folder at any location 

(Insertion point: Specify On-screen) towards left side of the drawing (you will move it later). 
1 1 .  In the External References palette, Select Factory Landscape-M.dwg. In the Details section, 

click � (Preview) to display an image of the landscape reference file in the Palette. 
1 2. Switch to the ISO AO layout. Activate the viewport by double-clicking inside it and Zoom 

Extents. 
1 3 .  Activate the Paper Space (double-click outside the viewport). 
1 4. In the External References palette, using Attach Image, attach ASCENT logo.git from your 

practice files folder at a scale factor of 50. Place it near the left of the title block, as shown 
in Figure 11-42. (Select Specify on-screen for both Scale and Insertion point.) 
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JJ--.f OIMltfit-,- - till!i-!w..-t. �-. qf.p�, � i;l, Attiu, &i1li,I� 
0nlpl(l lrf �i!O Dl �Pf'VM!ll \rf - �  � (\fr,. 1<,at.i !) 

A S C E N T  

Figure 1 1 -42 

1 5 . Save the file. 

Task 2: Modify external references. 

In this task, you will move a reference file to a new location, clip a DWF file, open a reference file 
and make a change to that drawing, close and reload it, and detach and unload it. The 
completed drawing is shown in Figure 11-43. 

\I 
I 

Figure 1 1 -43 
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1 .  Switch to the Model tab. In the drawing window, select Factory Site-M.dwf (the outer 
rectangle). Right-click and verify that DWF Object Snap is enabled (blue frame), as shown in 
Figure 11-44. (You can also use Enable Snap, found in the D WF Underlay contextual tab.) 
Press <Esc> to exit the selection. 

fi} DWF Clip . . .  
t nwr  

IWF Layers ... 
WF Object Snap 

Extem al References ... 

Cl ipboard 

Figure 1 1 -44 

2. Move Factory Landscape-M.dwg (file with trees that was placed along the left side of the 
drawing) so that the existing road in the DWF file is at the end of the entrance to the parking 
lot, as shown in Figure 11-45. In the landscape drawing, use the bottom left endpoint of the 
vertical portion of the road as your base point and snap it to the right endpoint of the top 
horizontal line of the road in the site DWF, as shown in Figure 11-45. 

Figure 1 1 -45 

3. In the drawing window, select Factory Site-M.dwf (outer rectangle), right-click and select 
DWF Clip . . . .  Press <Enter> to accept the New boundary option and create a new rectangular 
boundary close to the landscape elements, building, and road, similar to the area shown 
previously in Figure 11-43. 

4. In the Insert tab>Reference panel, expand Frames vary flyout, and select Hide frames to 
hide the boundary frame. 
• You can also type dwfframe and set the system variable to 0. 
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5. Check the Layer Control, and note that the layers associated with Factory Floorplan-M.dwg 
and Factory Landscape-M.dwg are listed but they are grayed out. 

6. In the External References palette, right-click on Factory Floorplan-M.dwg and select 
Detach. The building is removed from the drawing window and the file is removed from the 
External References palette. 

7. Save the drawing. 
8. Attach Factory Floorplan-M.dwg from your practice files folder to your file at an Insertion 

point of 0,0,0 and a Rotation of 0. The building displays in the drawing window and the file is 
added to the External References palette back again. 

9. In the External References palette, unload Factory Floorplan-M.dwg (right-click and select 
Unload). Note that the building is removed from the drawing window but the file is still 
listed in the palette with a red arrow displayed along with it, as shown in Figure 11-46. 

X '  
; ,  �; .... C .... L13ci .... G) 

File Referenc,es 

Reference Name A Status 
1 !·=. Factory Site* 0pe:ned 

itJ ASCENT logo Loaded 
Gl;t Factory Floorplan-M .t Un l oaded 
�.Iii Factory Landscape-M Loaded 
g Factory Site- M - rvlo. . .  Loa ded 

Figure 1 1 -46 

1 0. Reload Factory Floorplan-M.dwg. (Right-click and select Reload.) 
1 1 .  In the External References palette, select Factory Floorplan-M.dwg. Right-click and select 

Open. The Factory Floorplan-M.dwg drawing opens in another window and its tab is added 
to the File Tabs bar. I t  also becomes the currently active drawing. 

1 2. Set the layer Equipment to be current and draw a circle with a radius of 2 near the 
approximate center of the floor plan. 

1 3. Save and close Factory Floorplan-M.dwg. 
1 4. Back in the Factory Site.dwg, note that the new circle is not displayed. 
1 5. In the External References palette, reload Factory Floorplan-M.dwg. Note that the new 

circle displays. 
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16. In the External References palette, right-click on Factory Floorplan-M.dwg and select 
Compare>Recent Changes. Note that the drawing is in the Compare mode, enclosed in a 
blue border and the Xref Compare toolbar displayed along the top of the drawing window, 
as shown in Figure 11-47. Also note that the circle that you added to Factory Floorplan­
M.dwg is surrounded by a yellow rectangular revision cloud, as shown in Figure 11-47. 
Additionally, note that in the External References palette, the Factory Floorplan-M.dwg 
displays as In Compare, as shown in Figure 11-47. 

0, Xref Compare • <i=' r::i> X 

[ 

X 

�• �� • C ... ;:-. ... G) 
0 

file lhiferenc:es 
Releren,e Name 

., 
•"I Factory Site• 
t;j ASCENT logo �= Factory Floorpl<1n-M 
�� Factory Landsca pe-M 
'3 Factory Site-M - Model 

Figure 1 1 -47 

17. Click X in the Compare tool bar to end the comparison. 
18. Save and close the drawing. 

• $!.)!US 
Opened 
Loaded 

�" In Compare 
Loaded 
Loaded 

Task 3: Attach and overlay drawing references in another f i le .  

In this task, you will attach and overlay drawing references and note how they function in 
another file. You will then adjust layers in a referenced file and finally bind a reference to a file. 
The completed drawing is shown in Figure 11-48. 

Figure 1 1 -48 
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1 .  Open Factory Floorplan-M.dwg from your practice files folder. 
2. Set layer O to be current and attach Factory Electric-M.dwg from your practice files folder 

to the current drawing at 0,0,0 as an attachment. Accept the defaults for the Scale, 
Rotation , and other options. Note that there might be some Unreconciled New Layers.Close 
the unreconciled bubble in the Status Bar. 

3. Attach Factory Lighting-M.dwg from your practice files folder to the current drawing at 
0,0,0. Accept the defaults for the other options. Close the unreconciled bubble in the Status 
Bar, if required. 

4. In the External References palette, right-click on Factory Lighting-M.dwg, expand Xref 
Type, and select Overlay. Close the palette . The overlay file remains visible in the drawing. 

5 .  Save and close the drawing. 
6. Open Factory Site.dwg if it is not already open . Note that the attached reference Factory 

Electric-M.dwg displays but the overlaid lighting reference is not displayed. 
7. Save and close the drawing. 

Task 4: Work with drawing reference fi le layers. 

1 .  Open Factory Floorplan-M.dwg from your practice files folder. Close the unreconciled 
bubble in the Status Bar, if required. 

2. Expand the Layer Control and note the layers that begin with Factory Electric-M and 
Factory Lighting-M are all gray. All of these layers belong to the drawing reference files. 

3. Open the Layer Properties Manager. 
4. In the left pane, note the Xref category in the list. I t  is an Xref filter group that gets added 

when an Xref is attached. 
5. Expand the Xref group and select Factory Electric-M. All of the layers in the Factory 

Electric-M drawing reference file display in the right pane. 
6. In the right pane, right-click and select Select All. 
7. Select one of the color blocks and change the co/or to light gray. The selected layers 

display in that color in the current drawing. 
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8. In the left hand pane, note that the Xref Overrides filter is added and that the listed layers 
have a blue background with their icons changed to � - Hover the cursor over the icon to 
display the Xref override details, as shown in Figure 11-49. 

Fi lters « s . .  N a me & 0. Fre . . .  L o  . . .  Co lor  Li n etype 

B @ Al l  �- Factory Electric-MIIL . •· r:£ 0 9  Contin u ou s  

·· ·C:ir All n on -Xref Layer� �- Factor/ El ectric-M l(, .. � --�•- r::f 0 9  Cont inuous 

\ ·C:ir A l l  Used Layers �- Factory Electric-Ml . .  , 9 cjl rS 0 9  Continuous  

!- · · · · � Unreconci led New �- Factor/ Electric-Ml . .  , 9 -�· rS 0 9  Conti n uou s 

�--- � Xref �
' Factor/ Electric-Ml . .  , 9 ·•cjl· rS 0 9  Conti n u ou s  

! l �  Factory Electri c ,::_ . • FactorJ Electric-Ml E . . .  � ·•i?· rf 0 9  Contin uous 

� Factory Lig htin 
1) rf 0 9  Conti n u ou s  

\ .  .. . . �. Xn,f Overri des 
1) CJ 0 9  Conti n u ou s  

r:f 0 9  Continuous  

Figure 1 1 -49 

9. Open Factory Electric-M.dwg from your practice files folder and verify that the layers retain 
their original colors. Close the file. 

10 .  In the Factory Floorplan-M.dwg, note that the layers from the Factory Electric-M 
referenced drawing are still gray. 

1 1 .  In the left pane, right-click on Xref Overrides category. Expand Reset Xref Layer Properties 
and select All Properties. Note that all of the layers retain their original color and that the 
Xref Overrides filter category is no longer displayed. 

Task 5: Bind drawing reference fi les. 

1 .  Continue working in Factory Floorplan-M.dwg. 
2. In the External References palette, right-click on Factory Lighting-M.dwg (which is an 

underlay file) and select Bind ... to bind it to the host file. I n  the dialog box, ensure that Bind 
is selected and click OK. 

3. In the External References palette, note that the Factory Lighting-M.dwg is no longer 
displayed. 

4. In the Layer Properties Manager, note that all of the Factory Lighting-M layers contain $0$ 
and are no longer gray, as shown in Figure 11-50. Note that all  of the Factory Electric- M 
layers are still displayed in light gray, indicating that they are Xref layers. 
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5 . .  Name ... 0. Fre. . .  Lo. . .  Co ler  
1 ;:acer- i: l ec··i c - '.1 11:::x ·  D cyan 
.1 �ace r; E le-cn1- -\  j . . i i:-, 1�crs 0- D 8 
1 ca� ·c • ·:, E l ec'1 c -\1 l \'1 a l l ,  
I ;:ac ·cr  � l ec :n�- ',1 1hir. (1 C  -
1 ;:ace r·, c 1ec: · • 1 c - '  ! I  ·· g 1 • 
, Factory L ig ht in g -M$0$Border a: 
, Fae or; Lighti ng -M$0$Dime. . .  o 
1 Factor; L ighti n g -M$0$Dcors • 
, Factor; ligh:ing -M$0$El ec :ri. . .  • 
,, Factor; Lighti ng-M '>0 $ F RAM. . .  , 
1 Fae ory L ighti ng -M$0$ FRAM . . .  

5. Undo the Bind process. 

Figure 1 1 -50 

·· ■ wh ite 
□ yel l ow 
■ wh ite 
■ bl u e  
D red 
□ yel l ow 
D cyan 
■ white 

cl' D magenta 

6. Bind the same file (Factory Lighting-M.dwg) again, but this time as an Insert (select Insert 
in the Bind Xrefs/DG N underlays dialog box). 

7. In the External References palette, note that the Factory Lighting-M.dwg is no longer 
displayed. 

8.  Look at the layers. They are now integrated into the main layer names. 
9. Save and close the drawing. 
1 0 . Open Factory Site.dwg. In the drawing window, note that the Factory Lighting-M.dwg 

objects are displayed but the file is not listed in the External Reference palette, as it is a part 
of the Factory Floorplan-M drawing file and not an overlay in the referenced file. 

1 1 .  Save and close the drawing. 

End of practice 
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Chapter Review Questions 

1 .  Which of the following describes how external references are different from blocks? An 
external reference . . .  
a .  Can contain one or many objects. 
b. Is a link to another file. 
c. Includes layers. 
d. Acts as one object in the drawing. 

Answer: b 

2. What is the default Path Type that is used when attaching an external reference file to the 
host drawing? 
a. Relative path 
b. Full path 
c. No path 

Answer: a 

3. What happens when you open a drawing containing a referenced file that cannot be located 
by the software? (Select all that apply.) 
a. The References - Not Found Files dialog box opens. 
b. A warning symbol displays next to the drawing file in the External References palette. 
c. It becomes a block. 
d. It is compressed to take up less memory. 

Answer: a, b 

4. Which of the following file formats cannot attach to an AutoCAD drawing as an external 
reference? 
a . .  DWF 
b . .  DOC 
c . .  DWG 
d . .  DGN 

Answer: b 
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5. Drawing A is attached as a drawing reference file to host drawing B and both are then 
closed. Drawing A is then modified. Drawing B is opened and displays an image of 
drawing A. What happens to the image of drawing A when drawing B is opened? 
a. It displays a warning message. 
b. It does not change. 
c. It updates to display the changes. 
d. It displays as a blank image. 

Answer: c 

6. When describing Xref layers, which of the fol lowing statements are wrong? 
a. You can change the Xref layers state or properties (Freeze/Thaw, Color, etc.) in the 

current drawing. 
b. You can make an Xref layer current in the host drawing. 
c. You can specify a default layer for inserting the reference file on. 
d. Renaming or deleting an Xref layer in the Xref drawing automatical l y  updates the layer 

when reloaded in the host drawing. 

Answer: b 

7. Which command or option enables you to bind one or more blocks, layers, linetypes, text 
styles, or dimension styles? 
a. Reload 
b. Demand Load 
c. Bind 
d. Xbind 

Answer: d 
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Command Summary - Command 

Adjust 

Attach Xref 

Cl ip Xref 

0 External References 

1 1 -42 

Location 

• Ribbon: Insert tab>Reference pane l  
• Command Prompt: adjust 

• Ribbon: Insert tab>Reference pane l  
• Command Prompt: attach 

• Ribbon: Insert tab>Reference panel  
• Command Prompt: c l ip  

• Ribbon: View tab>Pa lettes pane l  o r  Insert tab> 
Reference panel a rrow 

• Command Prompt: externa l references 
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Projects: Drawing 

This chapter contains practice projects that can be used to gain additional hands-on experience 
with the topics and commands covered so far in this learning guide. These projects are 
intended to be self-guided and do not include step-by-step information. 

Learning Objectives 

• Create title blocks that contain borders using rectangles and lines. 

= 
� 1 hr 

• Mechanical: Create a drill press base using features such as fillet, offset, trim, hatching, 
and viewports. 

• Architecture: Create a room layout using features such as hatching, viewports, text, and 
dimensions. 

• P&ID: Create a piping schematic using features such as viewports and commands such 
as move, rotate, and sketch. 

• Civil: Create a warehouse site using features such as viewports, text, hatching, and 
dimensions. 
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1 2 . 1  ISO A 1 Tit le Block 

}t 1 s  minutes 
In this project, you will create a title block. You will add a border using rectangles and lines, and 
add a logo and permanent text in the title block. This title block (shown in Figure 12-1) works 
with the DWF6 ePlot plotter with an ISO expand Al paper size when inserted at 0,0. 

T'l!lt> 

�er islr;M'; !tt 

µ"" 

I'S'�� l!IUlfl ft 

My Company ..... " 

Figure 1 2- 1  

1 .  Start a new drawing based on Mech-Millimeters.dwt, which is located in your practice files 
folder and save it as Titleblock_lSO_A 1.dwg. 

2. Set the current layer to Border. 
3. Draw a 829 x 572 rectangle. Zoom out to display the entire drawing. 
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Projects : Drawing 

4. Draw the lines for the title block, as shown in Figure 12-2. Place it in the lower right corner 
of the border. 

Title 

My Company 

300 

Date 

Project Number 

Sheet of 

Figure 1 2-2 

1 50 

lD 
N 

lD 
N 

lD 
N 

lD 
N 

lD 
N 

5. Change the current layer to Text. Draw circles, lines, and rectangles to create a logo in the 
largest box of the title block. 

6. Move, rotate, and/or scale the logo so that it fits inside the box, but with enough room to 
add text later. 

7. Add the text shown in Figure 12-2. All of the small text is 6 units and uses the Standard 
text style. The text style for the logo is Title and you can use any height that fits in the 
space. 

8. Save the drawing. 
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1 2 .2  Mechanical  Project: Dri l l  Press Base 

l 45 minutes 

In this project, you will create a mechanical drawing of a drill press base and prepare it for 
plotting. You will draw the top view, insert a pre-drawn side view, and lay the drawing out for 
plotting, as shown in Figure 12-3. 

❖ 

�- � .�-- -� -----� 

$ 

Top Vlew 
S..k: U  

Section View 

Figure 1 2-3 

Task 1 :  Draw the base. 

1 .  Start a new drawing based on Mech-Millimeters.dwt, which is located in your practice files 
folder, and save it as Drill Press Base.dwg. 
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2. Draw the objects shown in Figure 12-4 on the layer Object. Use Offset to help locate the 
lines correctly. Use Fillet or Trim to clean up any extra overlapping lines. 

------ 1 80 ----
1----------� 290 

� - 25 
---------------1---,' ·-��. · • 

$ I-------+--+ 
--------'----'-----------'�_J 

Figure 1 2"".4 

3. Add the opening shown in Figure 12-5. 

1 1 2 .S TYP . · ..., •• •  - • 

I 
2s 

,- 1 00 - 0i 

.,.- R25 X 4 

' 
lf) i 
<:r :  

....___ __________ _L___!'-

Figure 1 2-5 

4. Save the drawing. 
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Task 2: Create a block. 

1 .  Draw one lug in empty space to the side of the part, as shown in Figure 12-6. 

0 1 0 � 

R1 3 ···_,,✓ 

Figure 1 2-6 

2. Make a block called Lug from the circle, arc, and lines. Select the center of the circle as the 
base point, as shown in Figure 12-7. 

240 

Figure 1 2-7 

3. Insert the four lugs, as shown in Figure 12-7. When you rotate, you can obtain the angles 
using grips and by snapping to the centerlines used to place the block. 

4. Trim the lines that cross over the lugs. 
5. Insert Section-M.dwg from your practice files folder. Position it above or below the top 

view of the base. Do not be concerned with its exact position. You can arrange the layout 
later in Paper Space. 

6. Save the drawing. 
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Task 3: Set up the drawing for p lotting in  a layout. 

1 .  In Drill Press Base.dwg, create a new layout and rename it Sheet 1 .  Apply a Page Setup to 
the layout using the plot device DWF6 ePlot and the paper size ISO expand A 1 (841.00 x 
594.00 MM) . 

2. Set the current layer to Border and insert the file Tblk_A 1-M.dwg (located in your practice 
files folder) at 0,0. 

3. Erase the existing viewport in the layout. 
4. Set the current layer to Viewports. 
5. Create three new viewports, as shown in Figure 12-8 .  Scale the Top View and Section View 

to 1 : 1 . Scale the Lug Detail to 2 : 1 . 

, - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - 7 

$ 

$ 

... .... . .. . ... ... --······· -- . . . . . . 

L _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 

Figure 1 2-8 

6. I f  the viewport is not big enough, you can return to Paper Space and stretch the viewport 
using grips. 

7 .  Make the Section viewport active. 
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8. Set the current layer to Hatching and hatch the areas of the section view with the ANSl31 
pattern, as shown in Figure 12-9. 

Figure 1 2-9 

9. Save the drawing. 

Task 4: Add text to the l ayout. 

1. Set the current layer to Text and toggle off the layer Viewports. Add labels to each view 
using the Hand text style with a height of 6. Change the title part of the label to the Arial font 
and the size to 13, as shown in Figure 12-10. 

$ 

. . . . . . ... . . . .. ....... .... .. ..... 

$ .L.,,yg Detai l  
:!l,,--.M,$ ; :/, !  

To_1:1 Vi evv 
...,,,._,, hi 

Section Vlaw 
� , !,! 

Figure 1 2-1 0 
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2. Using multi line text with the Hand text style, add the text shown in Figure 12-11 to your 
drawing. The text height is 6. Change the text Notes: to the Arial font and make it 13 units 
tall. 

NoL-e> : 

Figure 1 2-1 1 

3. Position the text from Figure 12-11 so that it is below the Lug Detail view, as shown in 
Figure 12-12. 

$ 

-·· - -··-···- • -·-·-- - .�--- ... ---

,$-

Section Vl'!tW 
,;.,.._d,11; hl  

Figure 1 2-1 2 

Lug p,et�U 
".,W; ;�i! 

Notes: 
! .  M flb.W< !lllri � 0.!7:'JK 
:.:. ;.,:,.�,tll: �,i 5l.o4, 
�- �i, .. _.,J wl¾i f'1lll r,,..,.. �H6;. 

4. Fill out the title block with the Standard text style and a height of 6. 
5. Save and close the drawing. 
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1 2.3  Arch itectura l  Project: Office Tower 

i 45  minutes 
In this project, you will create an architectural drawing of one floor in an office tower. You will 
draw the floor plan for the building core, mark the areas for various tenants, and lay the drawing 
out for plotting, as shown in Figure 12-13. 

•,;( 
oo oo ' °"Y �--

> ou [JJ 
oo oo 
() �,, 0 

0 

Figure 1 2-1 3 

Task 1 :  Draw the interior and exterior wal ls and elevators. 

1 .  Start a new drawing based on AEC-Millimeters.dwt, which is located in your practice files 
folder and save it as Tower.dwg. 

2. Draw a rectangular building outline of 45720 x 38100, starting with the absolute coordinate 
3000,3000 in the lower left corner, as shown in Figure 12-14. 

3. Fillet the upper left corner with a radius of 15200, as shown in Figure 12-14. 
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4. Chamfer the lower right corner with distances of 12000, as shown in Figure 12-14. 
5. Use Offset to create the walls. The exterior walls are 300 thick, as shown in Figure 12-14. 

Figure 1 2-1 4 

6. Draw the interior walls, as shown in Figure 12-15. Start at the absolute coordinate point of 
15540,19350 at the intersection of the 1370 and 7000 lines. The interior walls are 150 
thick. 

6400 1 0640 

1
---
: -TO 

1 800 1 800 

3700 2740 "" 
0 
0 

. . -

L I I IL 
3700 I. 

1 0830 4840 l 
Figure 1 2-1 5 
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7. Use Trim, Extend, and Fillet (with a radius of 0) as required to clean up the intersections of 
the walls at the core of the building, as shown in Figure 12-16. 

8. Draw a 1670 x 2400 elevator in the bottom left elevator shaft space (the 1800 wide space). 
There should be 75 units of clearance between the elevator and the walls (you might want 
to create an Elevator layer). 

9. Use Mirror to create the other three elevators. They are centered in the middle of the 3700 
wide space, as shown in Figure 12-16. 

Figure 1 2-1 6 

1 0. Save the drawing. 

Task 2 :  Create doors and insert the bathroom block. 

1 .  Cut the door openings, as shown in Figure 12-17. The elevator openings are 1800. All of 
the other doors are 900 units wide and either centered on the wall or offset 150 units from 
the closest wall. 
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Figure 1 2-1 7 

2. Set the current l ayer to Doors. D raw the doors shown i n  Figu re 1 2- 1 8 and create b locks .  
The door pane ls  are 50 units th ick. Do not inc lude the d imens ions i n  the b locks. 

Door 

Figure 1 2-1 8 
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3. Insert the door blocks, as shown in Figure 12-19. Insert Restrooms-AM.dwg into the 
restroom areas as well. 

oo 
.>' C)□ 

0 
c:t 

4. Save the drawing. 

0 
0 

Figure 1 2-1 9 

Task 3 :  Set up the drawing for plotting i n  a layout. 

1. Switch to the ISO A 1 layout. 
2. Set the current layer to Viewports and create three viewports, as shown in Figure 12-20. 

� 

1 2- 1 4  

Figure 1 2-20 
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3. In one viewport, display the entire drawing scaled at 1 :200. 

Projects : Drawing 

4. In another viewport, display only the layout of the bathrooms scaled at 1 :20. Freeze the 
layer Hatching in this viewport only. 

5. In the third viewport, display the core of the building scaled at 1 :50 . Freeze the layers 
Hatching and Restroom. You might have to change the sizes of the viewports to fit all of 
the information once you have applied the scale. You can do this in Paper Space with grips. 

Task 4: Create a tenant layout. 

1 .  Set the current layer to Hatching.  
2. In the overall viewport, divide the building into several areas, with lines radiating from the 

core, as shown in Figure 12-21. These are subdivisions for various tenants. 

Figure 1 2-21 

3. Set the current layer to Text . Add text in each space with the tenant's name. 
4. Set the current layer to Hatching again. Hatch each tenant's space with a different hatch 

pattern. Use annotative scales for the hatches. 
5. Save the drawing. 
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Task 5: Add text and d imensions to the layout. 

1 .  In Paper Space, set the current layer to Text and freeze the layer Viewports. Use the Title 
text style and add a title for each view, as shown in Figure 12-22. The text size should be 
6 for the title and 3 for the scale. 

TENANT'S LAYO UT 
SCALE: 1 :200 

2. Set the current layer to Dimensions. 

Figure 1 2-22 

3. Dimension the core, as shown in Figure 12-23. Use the annotative Architectural-MM 
dimension style supplied with the template. 
• To check the dimensions, refer to Figure 12-15. 

I '] 

,r · f----1-'==========i 

4. Save and close the drawing. 

Figure 1 2-23 
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1 2.4 P&ID  Project: Oi l  Lubrication System 

i 45 minutes 

In this project, you will create a schematic piping diagram for the oil lubrication system shown 
in Figure 12-24. 
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Figure 1 2-24 
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Task 1 :  Draw the schematic layout. 

1. Start a new drawing based on Mech-Millimeters.dwt, which is located in your practice files 
folder, and save it as Lubesys.dwg. 

2. Create the blocks shown in Figure 12-25. Study the diagram shown in Figure 12-24 to 
determine an appropriate size and insertion point for each block. 

Note: The grid is meant for approximation purposes so that  you know the approximate 
size of  the blocks. You are not required to draw the blocks with exact dimensions. 

Figure 1 2-25 
• For the mesh in the Strainer, use the ANSl37 hatch pattern with the Scale set to 1.0 . For 

the arrow in the Check Valve, use a polyline with the Width option. 
3. Insert the blocks and draw the other elements to create the diagram. 

Tips: 

• Exact dimensions are not important because this is a schematic drawing. It might help to 
start by drawing and positioning some of the large parts (tanks and sumps) and then filling 
in the connecting pieces. 

• Use Move, Rotate, and Stretch as required to arrange the parts correctly. Remember to use 
Snap or Object Snaps to connect the parts at precise points. Use Copy to save time and 
effort. 

• The text should be 3 units high. 
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Task 2: Set up the drawing for plott ing. 
------------------------

1. Switch to the ISO A3 layout. 
2. Make the viewport active. Set the scale to 1 :1 and adjust the view in the viewport by 

panning until the diagram fits the viewport. 
3. Switch back to Paper Space and freeze the layer Viewports to hide the viewport border. 
4. In Paper Space, add a Legend on the right side of the sheet, and include the symbols used 

in the diagram and their descriptions, as shown in Figure 12-26. 

5. Save and close the drawing. 

Figure 1 2-26 
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1 2 . 5  Civi l Project: Warehouse Site 

i 45 minutes 
In this project, you will create a drawing of a warehouse site. You will draw the property line, and 
locate the building, parking, driveway, and existing wetlands area. You will then layout the 
drawing for plotting . Finally, you will dimension, hatch, and add text, as shown in Figure 12-27. 
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Figure 1 2-27 

Task 1 :  Draw the property l ine, bui ld ing location, and pavement. 

1 .  Start a new drawing based on Civil-Meters.dwt, which is located in your practice files 
folder, and save it as Warehouse.dwg. 

2. Draw the property line, building location, existing pavement, and new pavement, as shown 
in Figure 12-28. 
• Note: Draw the right-hand slanting portion of the property line by joining the endpoints of 

upper and lower horizontal portions of the property lines. 
• Use approximate dimensions, if required, to complete the drawing . 
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Projects : Drawing 

r 

3. Add a wetlands area and hatch it with the Swamp hatch pattern. You need to use a hatch 
scale of 0.5. 

4. Add the parking area and concrete valley swale to the driveway, as shown in Figure 12-29. 
Hatch the areas shown in Figure 12-29 on the layer Pavement Hatching, using the AR­
Cone pattern, with a scale of 0.03. 
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Figure 1 2-29 
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5. Add the loading dock pad and dumpster pad, as shown in Figure 12-30. Hatch these areas 
using the AR-Cone pattern and a scale of 0.03 . 

!------------�� . 
•• • 

" 

1 5  

Figure 1 2-30 

Task 2: Lay out the drawing for plott ing. 

1 .  Switch to the ISOA 1 layout . 

0) 

.... . . . .. .... . .. . ,, 
J 4 I 

2. Set the current layer to Viewports and create four viewports, as shown in Figure 12-31. 
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Figure 1 2-31 
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3. Switch to Model Space so that you can adjust the view in each viewport. For the larger view, 
set the scale to 2 : 1 . For the smaller views, set the scale to 8 : 1  and display the parking area 
in one, the loading dock in the second, and the dumpster pad in the third. You might need to 
change the sizes of the viewports to fit all of the information once you have scaled them. 
You can do this in Paper Space using grips. 

4. In the Linetype Manager dialog box, in the Details area, set the Global scale factor to 20 and 
verify that the Use Paper Space units for scaling option is selected. This displays the 
linetypes correctly in Paper Space. 

5. Freeze the layer Pavement Hatching in the site plan view only. 

Task 3 :  Add d imensions and text. 

Note: Refer to Figure 1 2-28 for a clearer view of the placement of the dimensions. 

1 .  Set the current layer to Dimensions and add the required dimensions to each viewport, as 
shown in Figu re 12-32. Use the annotative Civil dimension style. Use text to input the 
property line dimension information, as shown previously in Figu re 12-28. 

Figure 1 2-32 
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2. I n  the Text l ayer, add t it les to labe l  each view and the other text as requ i red .  The text height 
for t it les is 0.25 with the Hand text sty le .  A l l  of the other text (refer to F igu re 1 2-28) i s  0.18 
with the Standard text style .  The t it les of the viewports a re as fo l lows: 
• Viewport 1: Site P lan, Sca le :  2 : 1  
• Viewport 2: Parki ng P lan ,  Sca le :  8 : 1  
• Viewport 3 :  Load ing Dock  Pla n, Scale :  8 : 1  
• Viewport 4: Dumpster Pad P lan, Scale :  8 : 1  

3. Freeze the l ayer Viewports. 
4. Save and c lose the d rawi ng .  
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Optional Topics 

In this appendix, you learn how to use the calculator to perform standard calculations. You learn 
to navigate the drawing using some additional zoom commands. You learn to use some 
additional text and dimensioning tools. You also learn to create boundaries and lengthen 
objects. 

Learning Objectives 
• Perform calculations and send the output to the Command Line. 
• Create and modify single line text . 
• Change the size of multi line text objects and change the justification point (alignment) of 

selected text objects. 
• Make temporary changes to a dimension style and compare various dimension styles. 
• Set and compare dimension styles in a part or assembly. 
• Create a closed, complex polyline from existing objects. 
• Create a single object that contains an outline and holes. 
• Combine regions by adding, subtracting, or intersecting them. 
• Change the length of an object or the included angle of an arc. 
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A. 1 Using QuickCalc 

QuickCalc is a calculator that is included with the AutoCAD® software (as shown in Figure A-1) 
and can be used for standard calculations. I t  sends the output to the Command Line. 
The Quickcalc is similar to other palettes in that it can be left floating, docked, or hidden while 
you are working in other commands. 

' U ' 

5 
0 

0 

Basic Calculator Mode 

Number Pad 

Scientific 

Units Conversion 

Variables 

Figure A-1 

• To paste a value from the QuickCalc Input box to the Command Line, click � (Paste value 
to command line) located in the toolbar near the top of the palette . 

A-2 © 2023, ASCENT - Center for Technical Knowledge® 

( 

( 

( 

( 

( 
( 
( 



Opt iona l  Topics 

• In the Units Conversion area, you can obtain equivalent values for different units of 
measurement as shown in Figure A-2. Unit conversions are available for length, area, 
volume, and angular values as shown on the right in Figure A-2. Based on the unit type 
selected, you can select a list of units to convert from and a list of units to convert to. 

Units Conversion Units C onversion .... 
Un its ty p e  Len gth U n its type Length 
Convert from M eters Conv ert ·rom Length 
C o n Y ert to M eters Ccn'1ert to Area 
Va l ue  to convert 0 Va l u e  to convert Vol u me 
Converted ·, a l u e  Converted va lue  Angu l ar 

Figure A-2 

How To: Convert Units of Measurement with QuickCalc 

1 .  In the View tab>Palettes panel or the Home tab>Utilities panel, click l=1 (Quick Calculator). 
2. In the Units Conversion area, expand the Units type drop-down list and select a unit 

category. 
3. Expand the Convert from drop-down list and select the type of unit from which you want to 

convert. 
4. Expand the Convert to drop-down list and select the type of unit to which you want to 

convert. 
5. I n  the Value to convert field, enter the value you want to convert. Press < Enter>. 
6. The converted value displays in the Converted value field. 
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A.2 Add itional Zoom Commands 
While these Zoom command options are not used frequently, you can access them in the 
Navigation Bar, as shown in Figure A-3. 

Dynamic 

Scale 

► a ◄  Center 
"Q. 

� 
Object 

❖ Q. 
I n  

Q. 
Out 

A-4 

@ 

Yq, 

✓ Zoom Extents 

Zoom Window 

Zoom Previous 

Zoom Realtime 

Zoom All 

Zoom Dynamic 

Zoom Scale 

Zoom Center 

Zoom Object 

Zoom In 

Zoom Out 

Figure A-3 

Enab les you to defi ne an area to d isp lay us ing  an overa l l  v iew of the 
d raw ing .  The screen zooms o ut to d isp lay the fu l l  d rawing, and a view box 
opens to represents the view port. C l ick to res ize the view box. Move the box 
to the locat ion that you want to d isp lay and p ress < Enter> to zoom to that 
a rea .  

Changes the sca le (magnif ication) of the d isp lay .  The scale can be entered 
as a funct ion of the l im its of the drawing and press < Enter>. You can a l so 
enter the sca le as a function of the s ize of the active d isp lay where you type 
the sca le  fo l lowed by X, and press <Enter>. 

Enab les you to p ick a po int to be the new center of the d isp lay and to 
change the scale .  

Zooms to f it  the object(s) that you sel ect on  the screen .  

Makes the drawing twice as l a rge as the cu rrent d isp lay (ha lf  of  the a rea 
d isp lays), whi le keeping the same center. 

Makes the drawing ha lf  as  l a rge  as the current d isp lay (twice as much area 
d isp lays), wh i le  keep ing the same center. 
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A.3 Add it ional Text Tools 
Several text tools add to the versatility of the AutoCAD software. You can create single line text 
where multi line text is not required. There are also special tools for scaling and justifying text. 

Creating Single Line Text 

Single-line text adds each line of text as a separate object, as shown in Figure A-4. This type of 
text is quick and easy to use. However, multi line text offers more options in formatting and is 
better for paragraph editing. 

F l O O r p l a n .....,.M,....,,ulti,,,.-_line--i 1� Fiarf texl: 
---------- Text ? i.6] 0 . 2  

l : ?0 A 
Text � 

Multiline Text 
Drawing l� 

• 1A Single Line ;J e] 

Figure A-4 

How To: Create Single Line Text 

1 .  In the Home tab>Annotation panel or the Annotate tab> Text panel, click A (Single Line) . 
2. Select a start point. 
3. Specify the paper height or press <Enter> to accept the default height. 
4. Specify the rotation angle or press <Enter> to accept the default angle. 
5. Start typing. 
6. When you press <Enter> at the end of the line, you are prompted for another line. 
7. Press <Enter> at an empty line to finish the command. 
• While still in the command, you can select another point to place another line of text. It is a 

separate text object in the drawing. 
• To make single-line text annotative, set an annotative text style to be current before creating 

the text, or change the existing text in the Properties palette. 
• The Single Line Text command enables multiple lines of text to be entered in one sequence. 

However, each line is a separate text object. 
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Editing S ing le Line Text 

Doub le-c l i ck  on any l i ne  of text to edit it. It h i gh l i ghts on the screen and you can make changes 
as shown in  F igure A- 5. The Text Editor contextua l  tab and the ru ler  d o  n ot d i sp lay with a s i ng le  
l i ne text. 

This is a l i ne  of s in g le-l i ne  text. 

is 1s a secon separa e me 

Figure A-5 

• You can change the sty le, he ight, j ust if icat ion ,  and  a few other text p roperties i n  the 
Properties pa lette . 

Justify Text 

.[ID (Justify Text) in the Annotate tab> Text pane l ,  changes the just if icat ion po int (a l i gnment) of 
selected text objects without chang ing  the locat ion  of the text, as shown in F igure A-6 .  If you 
use other  methods to change the justif icat ion ,  such as Edit Text or  the Propert ies pa lette, the 
text sh i fts genera l ly .  

New Col l e g e  Art B u i l d i n g  
P roject  No ;  0 1 25 
5 1 3  Ma in  Street 
A lexa n d ri o ,  V i rg i n ia 

Left Justified 

New Co l lege Art Bu i l d i n g  
Project N o :  0 1 2 5  
5 1  3 lv\o i  n Street  

A lexand r ia ,  Vi rg i n ia 
Center Justified 

Figure A-6 

The options  that can be used with the Justify Text com mand are as fol l ows. 

Left 

Align 

Fit 

Center 

Middle 

Right 

Al igns text to be left-justif ied aga inst an  end po int on  the left s ide  of the text stri ng .  

A l igns text between any two selected points and determ ines the text he ight 
automat ica l ly  (sim i l a r  to Fit) . 

Pl aces text between any two selected poi nts at a user-specified heig ht .  

P laces text i n  the d rawing,  centered above the selected po int .  

Pl aces text i n  the d rawing, centered at the top of the selected po int .  M idd le  text is  
conven ient for mark ing ca l l outs and  tags .  

Al igns  text to be r ight-just i fi ed aga i nst an end po int on the r ight s ide of the text 
string .  

• Other  a l ignments a re fo r top, m idd le, bottom, left, center, or r ight (TL for Top Left, TC for Top 
Center, etc . ) .  
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• Once a justification has been set, it remains the default each time Single Line Text is used 
and until it is modified. 

• You can also use � (Text Align) in the Annotate tab> Text panel to align Single Line text. The 
command also works with multi line text. First select the text objects that you want to align 
and then select the text to which you want them to be aligned. 

Scale Text 

With the regular Scale command, scaling several text objects at once changes the location of 

the text. P'til (Scale Text) in the Annotate tab>expanded Text panel, changes the size of multiple 
text objects without changing their location as shown in Figure A- 7. 

FCV 156 1  FCV 1 5 6 1  
6. Hll S G.�lE VALVE 6 . 1 0 1 S GATE VALVE 

6.1 JG'.S GLOC<E V.•LVE 6 . 1 30S G LO B E  VALVE 

1 50# M . I .  TEE 

Before Scaling After Scaling 

Figure A-7 

• You can scale the text around existing base points or specify a different justification base 
point for scaling (Top Left, Middle Center, etc . ) .  

• The scaling can be specified as a text height, as a scale factor, or to match another text 
object. 

Model Space Text and Paper Space Text 

It is recommended that you use Annotation Scaling for most of the text in your drawings. 
However, text can be placed in either Model Space or Paper Space. In Paper Space, as with an 
annotative text style, you make the text the required printed height. For example, 3mm text is 
exactly that height when you print the layout. 
For text placed in Model Space without annotation scaling, some calculation is involved for the 
height, because this text is scaled along with the model when it is printed. For example, room 
labels in a floor plan would normally be placed directly on the model. If you want the labels to be 
3mm on the paper, and you are printing at a scale of 1:100, the labels need to be 300mm high in 
Model Space. The table displays some of the common values. 

Scale 

1 : 1 00 

Paper Text Size 

2mm 

3mm 

6mm 
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Scale 

1 : 50 

1 :25 

Paper Text Size 

2mm 

3mm 

6mm 

2mm 

3mm 

6mm 

Model Text Size 

1 1 5m m  

1 50mm 

300mm 

57mm 

75mm 

1 50mm 

Convert Text to Mtext 

In the Express Tools tab> Text panel, use the Convert to Mtext tool (shown in Figure A-8) to 
combine multiple individual text objects to create one multi-line text object. 

arametric View Manage Express Tools Oi 

� B e � 
Arc 

Aligned 

A_ 
1 1111 1  

Modify 
Text 

E1A Convert to Mtext 
._ _____ _,, ('.,: MOVE 

1-,,3 Auto Number 

Endose in Object 

Text ...-

Figure A-8 

Bs Stret 

• When you start this command, you can select the individual single line text objects and then 
press <Enter> .  In the Command Line, it displays the number of Text line objects that were 
converted to a single multiline object, as shown in Figure A-9 . 

A-8 

3 Text objects removed ,  1 MText object added , 

.�=-' � Type o command 

Figure A-9 
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• Before selecting the individual text lines, you can select the Settings option (<Down Arrow>) 
which opens the Text to MText Settings dialog box, as shown in Figure A-10. You can use 
the default Sort top-down setting, which sorts the collinear multiple text lines as they are on 
the same line with a space between them. 

Text to MText Settings 

G2) r;ombine i nto e. s ingle mtext objed 

Text order ing 

@ Sort Jop-down 

Q �eled o rder  of text 

G2] '!!'.1Lord-wre.p text 

force un iform l i ne spaci ng  

Figure A-1 0 

X 

OK 

Cancel 

Help 

• If you clear the Combine into a single mtext object option, the selected multiple single line 
text objects are converted to individual multi-line text objects, without combining them into 
one object. 

• The Force uniform line spacing option keeps the existing line spacing between the 
individual text lines. 
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A.4 Add itional D imension ing Tools 
When you work in Dimension Style Manager, advanced tools can be used to override and 
display the differences between dimension styles as shown in Figure A-11. 

Cl Dimension Sty le Manager 

Current dimension style :  Architectural-M M 
Styles : Preview of : !vchitectural-MM 

X 

A .Annotative 
" G!lffi!tillili 

M 
-� Curre� 

'-·· · A Unear 
A. 1502 

150-25 
Standard 1�. N ,--~ > 

( + ',) 6Q" \ 
•. \. ,J '-\ ---- I \ 
� \ 

R 1 3 __;  

Ust: Description 

I All styles v ! 
Architectural -M M 

· ,  Don\ list styles in Xrefs 

Figure A-1 1 

Dimension Style Manager 

Adding Style Overrides 

Close 

[ �w: 

Modify . . .  

Override . . .  I 
Compare . . .  J 

Help ] 

With the Override option, you can make temporary changes to a style and add several 
dimensions with those changes. For example, you might need to add a few dimensions with a 
different precision or tolerance value from others in the drawing. 

How To: Apply a Style Override 

1. In the Dimension Style Manager, make the style you want to override current. 
2. Click Override . . . .  

3 .  In the Override Current Style dialog box, make the required override changes to the style. 
Click OK. 
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4. Overrides display in the styles list below the style. The Description area displays the 
overrides that you have applied. 

5. Click Close. In the drawing, add the required dimensions with the overrides. 

Note: To stop using the overrides, set the original style ( or any other style) to be current. 
The override changes are discarded. 

Comparing Dimension Styles 

In the Dimension Style Manager, click Compare ... to open a table listing the differences 
between two styles, as shown in Figure A-12. You can pick any two styles or sub-styles that 
have been defined in the current drawing in the Compare and With lists. The AutoCAD software 
lists all of the dimension variables that differ and the settings of the variable in each style. 

Ill Compare Dimension Styles X 

�ompare: Civi l  

�ith: Annotative V 

Auto CAD found 1 9  differences :  

Description Variab le Civi l Annotative 
Alt p recis ion D IMALTD 2 3 
Alt sca le factor D IMALTF 25.400{) 0.0394 
Alt lei precision D IMALTTD 2 3 
Angle format DIMAUNIT 4 0 
Arrow DIMBLK Arch T ick  ClosedFi l led 
Arrow s ize DIMASZ 0 . 1 250 2.5000 
Center mark s ize D IMCEN 0.0900 2.5000 
n P. r. i m r=i l  �P-nr1r;::itn r n1Mf1SFP V 

Close Help 

Figure A-1 2 
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I nspection D imensions 

The Inspect (dimension) command creates special types of dimensions for quality control in 
mechanical drafting and manufacturing. They are used in Inspection Drawings to indicate 
dimensions that must be checked for the part or assembly, as shown in Figure A-13. They are 
useful for companies who out-source parts and must ensure that specific dimensions are met 
so that the parts fit into an assembly correctly. 

r:: ----�B j R OOt)J j mJ;: :o------
,..._.,_ .. --------- 7,1) .. j(l'J-----------

,...... ____ 4 .i)O(tJ -----.-; 

Figure A-1 3  

• You can add Inspection dimensions to any dimension object. Inspection dimensions consist 
of text and a frame and contain three information fields: 

• Inspection Label: Located on the left side and used to identify the dimension. 
• Dimension Value: Located in the middle and containing the original dimension text, 

tolerances, and prefix and suffix text. 
• Inspection Rate: Located on the right side, indicates inspection frequency, and is shown as 

a percentage. 
• Remove Inspection: Removes an inspection dimension from the selected dimension. 
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How To: Add an Inspection D imension 

1 .  In the Annotate tab>Dimensions panel, click t:;71 ( Inspect) . The Inspection Dimension dialog 
box opens as shown in Figure A-14. 

Ill I nspection Dimens ion 

m �elect dimensions 

Shape 

@ B,_ound ( x .xx 1 1 00%) 

O �ngular  <x xx l1 00%) 

O !:!one X .XX 1 00% 

R!;.move Inspection 

Label/Inspection rate 

O �abel 

G2J tnspection rate 

1 100% 

Figure A-1 4  

X 

2. Click (Select dimensions) and select the dimensions to be used as inspection 
dimensions. 

3. Press < Enter> to return to the dialog box. 
4. Set the Shape to Round, Angular, or  None. 
5. Select Label and type an identifier for the inspection dimension. 
6. Type a percentage for the Inspection rate option or accept the default of 100%. 
7. Click OK to close the Inspection Dimension dialog box and add the inspection dimensions. 
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A.5 Creating Boundaries and Regions 

Creating Boundaries 

Sometimes you need to create a complex polyline from several existing objects using the 
Boundary command, as shown in Figure A-15. 

Figure A-1 5 

• The Boundary command can also create regions. 

How To: Create Boundaries 

1 .  In the Home tab>Draw panel, in the Hatch flyout, click O (Boundary). 
2.  In  the Boundary Creation dialog box, select the required options. 

3.  Click � (Pick Points) or  click OK. 
4.  Select a point inside a closed area, as shown in Figure A-16. You can select points in 

multiple closed areas. 
• The AutoCAD software creates a closed polyline or region that is defined by the edges of 

the first objects it detects. 

5. Press < Enter> to create the boundary. 

A-1 4 

Figure A-1 6 
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Boundary Options 
When you create boundaries, you can specify what is i nc luded i n  the bou ndary a rea with the 
opt ions shown i n  F igure A- 1 7 . You can e i ther  create a polyl ine object o r  a reg ion  of the 
bou ndary area. 
• The new polyl i ne  is p l aced d i rect ly on top of the exist ing bou ndary l i nes .  It i s  recommended 

that you create the boundary on a separate layer from the other objects. 

Island detection 

Object type 

Boundary set 

• Boundary Creation 

�?J j f:ick Po ints 

[;2] Is land _getection  

Boundary retention  

Reta in  boundarie;;_ 

Qbject type: Polyl ine 
Re ion 

Boundary set . .  
--- --, 

Current viewp ort v i � New 

OK Cance l_ J 

Figure A-1 7  

X 

Help 

Select this opt ion if you want the Boundary command to f ind any i nteri or 
objects (islands) and create poly l ines a round them, in add it ion to f ind ing  
the  exter ior boundary. 

You can create a polyl i ne  or  a reg ion .  I f  a boundary set inc l udes e l l ipses, 
e l l i pt ica l  a rcs, or  spl i nes, the Boundary command automat ica l ly creates a 
reg ion .  

The defau l t  opt ion, Current viewport, calcu lates the boundary based on a l l  
of the objects that are v is ib le i n  the cu rrent v iewport. 
To select the objects that should be considered when ca lcu lat ing the 

boundary, c l ick I [::� I (New - Select new boundary set) . This enab les you to 
exc lude objects from the bou ndary ca lcu lat ion and it can make the 
boundary ca lcu lat ion faster i n  a complex d rawing .  
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Working with Regions 

A polyline is a continuous object. It can be closed, but cannot contain holes . Regions are used 
to create single objects that contain an outline and holes, as shown in Figure A-18 .  

Figure A-1 8 

• A region is a 2D solid object or infinitely thin surface. The edges cannot be separated from 
the shape. Therefore, if you move an edge, the entire surface moves. Typical uses for 
regions include a plate with holes or a wall with windows. 

• You can create objects with holes that are part of the object. 
• Regions can be used in many cases to quickly create complex geometry using the Union, 

Subtract, and Intersect commands. 
• The area of a region, even one with holes, can easily be found using the Area command with 

the Object option. 

How To: Create a Region 

1 .  Draw the closed shape for the region using lines, polylines, etc. The lines must connect 
precisely end point to end point. 

2. In the Home tab>expanded Draw panel, click @:i (Region) . 
3 .  Select the objects. You can select several closed shapes and convert them all into regions 

at the same time. In the Command Line, the AutoCAD software reports the number of 
regions it has created. 
• Regions can be created out of existing closed shapes made of lines, arcs, polylines, 

circles, etc. 
• If the closed shape consists of separate segments, the segments must connect end 

point to end point to make a region. 
4. The original objects are consumed when you use them to create a region. 
• You can Explode a region to convert it into lines, arcs, splines, or circles, depending on the 

shapes involved. 
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Combin ing Regions 

Regions are useful construction tools because of the ways in which they can be combined. For 
example, you can create a hole or cutout in a region by subtracting one region from another. 
You can also add regions and find the intersection of regions as shown in Figure A-19. The 
addition (union), subtraction, and intersection actions are cal l ed Boolean Operations . 

• u,;oo 

•1 S,btroel 

Overlapping � �. . 
Regions 

� 
Intersect 

Figure A-1 9 

• You can union, subtract, or intersect two or more regions at a time. 
• The regions on which the Boolean Operations are performed do not need to intersect. 

However, the intersection of two objects that do not overlap erases the regions. 
• Regions are considered solid objects and the tools for editing them are located in the Home 

tab>Solid Editing panel (as shown in Figure A-20) when the 3D Modeling workspace is 
active. 

Note: You are required to be in the 30 Modeling workspace for the 30 ribbon to display. 

� C£D Extract Edges ? 

� � U ➔ Extrude Faces • 

@ (; OI Separate • 

Solid Editing 

Figure A-20 

• You can type the name of the command if you do not want to switch workspaces. 
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Union 

(Union) combines two or more regions into a single region as shown in Figure A-21. 

Figure A-21 

Subtract 

� (Subtract) removes the area of one region from another where they overlap as shown in 
Figure A-22. You can also use Subtract to create regions containing holes. By subtracting the 
holes, you can also find out the area of the closed shape. 

Figure A-22 

• Select the region (s) to subtract from first. Then select the regions that you want to subtract. 

I ntersect 

�J ( Intersect) finds the common area of two or more regions as shown in Figure A-23. Only 
the area that is shared by the selected regions remains in the new region. 

0 0 
Figure A-23 
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A.6 Modifying Length 
You can use the Lengthen command to change the length of an object or the included angle of 
an arc as shown in Figure A-24. However, you cannot change the length of a closed object. 

Shorter 

How To: Lengthen an Object 

Original 

Figure A-24 

1 .  In the Home tab>expanded Modify panel, click 

Longer 

(Lengthen). 
2. Select the object. Its current length displays in the Command Line. 
3 .  Select an option to modify the object's length: 

• Delta: Specify the increments by which the object's length is to be modified. To extend 
the object, enter a positive value. To shorten it, enter a negative value. The length is 
always measured from the closest end point to the selection point. Use the same 
method to change the angle of an arc. 

• Percent: Modify the object by a percentage of its length. 
• Total: Modify the object's length by a specific amount from a fixed end point. Specify the 

total required angle to modify the included angle of an arc. 
• Dynamic: Toggle on Dynamic Dragging mode. Pick an object's end point and drag it to 

the required length. The other end point does not change. 
4. Hover over the object to preview the changes depending on the selected option and the 

specified values. Select the object to change it. 
5. Press <Enter> to end the command. 
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Chapter Review Questions 

1. You can use the QuickCalc command to obtain equivalent values for different units of 
measurement. 
a. True 
b. False 

Answer: a 

2. The Dynamic Zoom command: 
a. Makes the drawing twice as large as the current display. 
b. Makes the drawing half as large as the current display. 
c. Enables you to define an area to display using an overal l  view of the drawing. 
d. Zooms to fit the object(s) that you select on the screen. 

Answer: c 

3 .  Which one of the fol lowing is  true of  single-line text? 
a. You can only type in one line at a time and then have to start the command again. 
b. There are no options for al ignments of single-line text. 
c. You can type in multiple lines, but each line is separate from the last. 
d. You can format the text using the Text Editor contextual tab. 

Answer: c 

4. In which of the fol lowing industries are Inspection Dimensions most useful? 
a. Architectural building inspection 
b. Electrical control inspection 
c. Plumbing flow control 
d. Manufacturing qual ity control 

Answer: d 

5. When you want to inquire about the area of a closed shape that contains holes, you can 
create a region and use which of the fol lowing Boolean commands? 
a. Union 
b. Remove 
c. Intersect 
d. Subtract 

Answer: d 
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6. What does the Delta option of the Lengthen command do? 
a. Modifies the object's length by specified increments. 
b. Modifies the object by a percentage of its length. 
c. Modifies the object's length by a specific amount from a fixed end point. 
d. Modifies the object's length by dragging its end point to the required length. 

Answer: a 
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Command Summary -
t1 

00 

@i 

[h 

A-22 

Command 

Boundary 

Inspect 

I ntersect 

Justify Text 

Lengthen 

QuickCalc 

Region 

Scale Text 

Single Line Text 

Subtract 

Union 

Zoom Center 

Zoom Dynamic 

Zoom In 

Zoom Object 

Zoom Out 

Zoom Scale 

Location 

• Ribbon: Home tab>Draw pane l  

• Ribbon: Annotate tab>D imens ion pane l  

• Ribbon: Home tab>So l i d  Ed it ing pane l  (in the 30 
Modeling workspace) 

• Ribbon: Annotate tab> Text pane l  

• Ribbon: Home tab>expanded Mod ify pane l  

• Ribbon: View tab>Pa lettes pane l  

• Ribbon: Home tab>expanded Draw pane l  

• Ribbon: Annotate tab>expanded Text pane l  

• Ribbon: Home tab>Annotat ion pane l  or  Annotate tab> 
Text pane l  

• Ribbon: Home tab>So l i d  Ed it ing pane l  (in the 30 
Modeling workspace) 

• Ribbon: Home tab>So l i d  Ed it ing pane l  (in the 30 
Modeling workspace) 

• Navigation Bar 

• Ribbon: Home tab>Ut i l i t ies pane l  

• Navigation Bar 

• Ribbon: Home tab>Ut i l i t ies pane l  

• Navigation Bar 

• Ribbon: Home tab>Ut i l i t ies pane l  

• Navigation Bar 

• Ribbon: Home tab>Uti l it ies pane l  

• Navigation Bar 

• Ribbon: Home tab>Uti l it ies pane l  

• Navigation Bar 

• Ribbon: Home tab>Ut i l it ies pane l  
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Ski l ls Assessment 

To test your knowledge on the course material, answer the questions that follow. Select the 
best answer for each question. 

1 .  What does the Closeall command do? 
a. Closes all of the open drawings including the Start tab. 
b. Closes all of the open drawings except the Start tab. 
c. Closes all of the open drawings including the currently active drawing and the Start tab. 
d. Closes all of the open drawings except the currently active drawing and the Start tab. 

Answer: b 

2. When defining a block, you specify a base point. Which of the following is true of the base 
point? 
a. It should always be at the center of the block. 
b. It should always be at the bottom of the block. 
c. It should always be an end point. 
d. It is the handle by which the block is held when being inserted. 

Answer: d 

3. What technique could you use to draw a circle with its center point 3 units over and 8 units 
up from the center of an existing circle? 
a. Temporary Tracking Point 
b. Measure 
c. Locate Point 
d. Array 

Answer: a 
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4. Settings you can build into a template file include: 
a. Layers 
b. Units 
c. Text and Dimension Styles 
d. A l l  of the above 

Answer: d 

5. How can you add blocks to a Tools palette? 
a. Use Insert Block. 
b. Use Make Block. 
c. Use Wblock. 
d. Drag and drop blocks from drawing window onto the palette. 

Answer: d 

6. Which key enables you to make multiple grips hot? 
a. <Shift> 
b. <Alt> 
c. <Esc> 
d. <Ctr l> 

Answer: a 

7. Which phrase describes relative coordinates? 
a. They are relative to the current screen display. 
b. They are relative to the object snap. 
c. They are measured from the last point picked. 
d. They are measured from the origin (0,0). 

Answer: c 

8. What layer properties can you override in viewports? 
a. Color 
b. Freeze 
c. Linetype 
d. Al l of the above 

Answer: d 
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9.  Which of the following statements is true? 

Ski l l s  Assessment 

a. If you change the properties of an Xref layer, the change affects the referenced drawing. 
b. If you rename an Xref layer in the Xref drawing, the layer is automatically renamed when 

the Xref is reloadetl in the host drawing. 
c. Any Xref layer can be made current in the host drawing. 
d. It is impossible to distinguish which layers come from referenced drawings, and which 

layers reside in the active drawing. 

Answer: b 

1 0 . Which command converts a local block or selected objects into a separate drawing file? 
a. Explode 
b. Wblock 
c. Group 
d. Purge 

Answer: b 
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I n d e x 

# 
2024 Enhancement 

A 

Cut with Base Point 1 -35 
Files tab menu 1 -29 
Floating windows 1 -30 

Absolute Cartesian Coordinates 2-2 
Add Selected 1 - 1 9  
Annotation Styles 7-3, 9-1  
Annotative Scale 

Add Scales 8-20 
Annotation Visibility 8-20 
Modify 8-21 

Application Menu 
Select Drawings 1 -33 

Auto Constrain 4-3 
Autodesk Viewer 1 1 - 1 2  

B 
Block Standards 7-3 
Blocks 

Add from Tool Palettes 5-20 
Annotative 5-4 
Base Point 5-3 
Blocks Palette 5-1 1 
Create Block 5-2 
Editing 5-7 
Exploding 5-8 
Tool Palettes 5-21 
Wblock 5-5 

Blocks Palette 5-1 1 
Boolean Operations A- 1 7  
Boundary A- 1 4  

C 
Calculator A-2 
Cartesian Coordinates 

Absolute 2-2 
Relative 2-2 

Clipboard 
Copy 1 -35 
Cut 1 -35 
Paste 1 -35 

Command Aliases 1 - 1 4  
Comparing Xrefs 1 1 - 1 4  
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Constraints 4-2 
Auto Constrain 4-3 
Dimensional (See Dimensional Constraints) 
Geometric (See Geometric Constraints) 

Construction Line 2- 1 4  
Convert Text to Mtext A-8 
Coordinate Entry 2-2 
Copy 

Clipboard 1 -35 
Objects to New Layer 1 -54 

Cut to Clipboard 1 -35 

D 
Dimension 

Inspection A- 1 2  
Style Override A-1 0 

Dimension Style 
Alternate Units Tab 9 - 1 3  
Annotative 9-6 
Compare Styles A-1 1 
Create 9-6 
Modify 9-8 
Standard 9-6 
Sub-Styles 9-1 3 
Tolerances Tab 9- 1 3  

Dimensional Constraints 4- 1 2  
Convert Dimensions 4-1 5 
Formulas 4-1 7 
Modify 4- 1 6  
Types 4-1 3 
User Parameters 4-1 8 

Drawing 
Limits 7-8 
Standards 7-3 
Units 7-5 

Dynamic Input 2-2, 2-4 
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E 
End Object Iso lat ion 1 -21 
External References 1 1 -2 

Attach 1 1 -6 
Attachment 1 1 -23 
B ind ing 1 1 -28 
Cl ip  Frames 1 1 -1 8  
Cl ipp ing  1 1 - 1 6  
Compar ing Xrefs 1 1 - 1 4  
Demand Load ing 1 1 -30 
Detach 1 1 - 1 3  
DWF 1 1 -22 
Find and Replace 1 1 -8 
Images 1 1 -20 
Layer Overrides 1 1 -26 
Modify i ng  References 1 1 - 1 8  
Not Found F i les 1 1 -2 
Open 1 1 - 1 2  
Overlays 1 1 -23 
Palette 1 1 -4 
Path Type 1 1 -8 
Propert ies 1 1 -20 
Reload 1 1 - 1 4  
Reload ing  F i les 1 1 - 1 4  
Reset Xref Layer Propert ies 1 1 -27 
Select New Path 1 1 -8 
Underlays 1 1 -20 
Un load 1 1 - 1 3  
VISRETA INMODE 1 1 -26 
Xbind 1 1 -29 
Xref Layer Sett i ngs 1 1 -25 
Xref Layers 1 1 -24 
Xref Overrides 1 1 -27 
XREFLAYER 1 1 -25 

External References Compare 1 1 -1 4  

F 
Fi le Tabs 1 -28 
floati ng 1 -30 
Funct ion Keys 1 - 1 6  

G 
Geometric Constra int 

Auto Constra in  4-3 
Col inear 4-7 
Concentr ic 4-7 
Constrai nt Bars 4-9 
Deleti ng  4-1 0 
Equa l  4-7 
F ix 4-9 
Horizonta l 4-4 
Modify ing 4-1 0 
Para I le i  4-5 
Perpend icu lar  4-5 
Sett ings 4-1 1 

l ndex-2 

Symmetri ca l 4-8 
Tangent 4-5 
Vert ica l 4-4 

G rips 1 -42 

H 

Chang ing the Base Point 1 -42 
Copying With 1 -43 
Reference Option 1 -44 
Setti ngs  1 -47 
Stretch Mu lt ip le 1 -45 

Hide Objects 1 -21  

I nsert View 8-5 
I so late Objects 1 -2 1  

J 
Justify Text A-6 

K 
Keyboard 1 - 1 3  

L 

Command Al iases 1 - 1 4  
Shortcut Keys 1 - 1 6  

Layer 7-9 
Addit iona l  Layer Tools 1 -5 1  
Change  to  Current Layer 1 -54, 1 -60 
Copy Objects to New Layer 1 -54 
Fi l teri ng Layers 1 -58 
Layer Delete 1 -56 
Layer Isolate 1 -53 
Layer Merge 1 -55 
Layer Overrides i n  Viewports 8-1  0 
Layer Prev ious 1 -54 
Layer States 1 -51  
Layer Un iso late 1 -54 
Layer Wa lk 1 -57 
L inetypes 7- 1 3  
L ineweight 7- 1 3  
Load Linetypes 7-1 3 
Mod ify 1 -55 

Layer Propert ies Manager 7-9 
Layer Standards 7-3 
Layer States 1 -51  
Layouts 

Pr intab le Area 7-21 
Lengthen A- 1 9  
L im its 7-8 

© 2023, ASCENT - Center for Technical Knowledge® 



M 
Match P ropert ies 1 -36 

Transparency 1 -24 
Mu lt i leader Style 9-22 

Create 9-22 
Modify 9-22 
Mu lt i  leader type 9-24 

Mult ip le Drawings 1 -28 
Match Propert ies 1 -36 

Mult ip le  Points 2-1 8 

N 
Named View 8-2 
Naming Standards 7-3 
New View 8-2, 8-1 4 
Node Object Snap 2-1 8  

0 
Object Select ion Cyc l i ng 1 -20 
Object Snap 2-8 
Object Snap Tracking  2-8 
Object V is ib i l ity 1 -2 1  

p 
Page Setup 7- 1 7  
Page Setup Manager 7-1 7 
Palettes 

Docking 1 -4 
H id i ng  1 -4 

Panel 
Expand 1 -5 

Paste from C l i pboard 1 -35  
Point 2- 1 8  

Div ide 2-20 
Measure 2-20 
Mu lt ip le 2-1 9 
Reference 2-1 8 
Sty le 2-1 9  

Polar Coordinates 
Relative 2-4 

Purge 5-1 5, 5- 1 6  

Q 

Empty Text Objects 5-1 7 
F ind Non-Purgeab le Items 5-1 7 
Preview 5-1 6  
Zero-length geometry 5-1 7 

QNew 7-4 
Defau lt Template 7-4 

QuickCalc A-2 
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R 
Ray 2-1 5 
Recogn ize SHX Text 1 1 - 1 1 
Reference Points 2- 1 8  
Reg ions A-1 6 

Comb in i ng  A-1 7  
I ntersect A-1 8  
Subtract A-1 8  
Un ion A- 1 8  

Relative Cartes ian Coord inates 2-2 
Relative Polar Coord i nates 2-4 
Ribbon 

s 

Disp lay 1 -6 
Docking 1 -8 
Expand Panel 1 -5 
Extra Tools in Panel 1 -5 

Select S im i l a r  1 - 1 9  
Shortcut Keys 1 - 1 6  
S ing le  L ine Text A-5 
Standards 

Block 7-3 
Drawing 7-3 
Layer 7-3 
Naming 7-3 

Switch ing Windows 1 -28 

T 
Templates 7-2 

Drawing Standards 7-3 
Mod ify Ex ist ing 7-24 
Saving 7-23 
Standard Layouts 7-1 6 

Temporary Tracking Po int 2-8 
Text 

Convert to Mtext A-8 
Justify Text A-6 
Model Space A-7 
Paper Space A-7 
S ing le  L ine A-5 
Style 

Annotative 9-2 
Create 9-2 
Standard 9-2 
Style Effects 9-4 

Tool Pa lettes 
Add Blocks 5-21 
Creat ing 5-20 
Modify 5-23 
New 5-20 
Redefi ne B locks 5-25 
Tool Properties 5-23 

Tracking 2-8 
Transparency 1 -23 

I ndex 
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u 
Un its 7-5 
User Coord inate System 2-6 

V 
View 8-2 

Create Named View 8-2 
Viewports 

w 

Cl ip  Viewport 8-9 
I nsert View 8-5 
Layer Overr ides 8- 1 0  
Modify Layer Propert ies 8-1 1 
Named Views 8-5 
New 8-5 
Overr ide Layer Properties 8-1 0 

Wblock 5-6 
Workspace 1 -2 

X 

Custom 1 -2 
Sett ings 1 -3 

Xbind 1 1 -29 
Xl ine 2- 1 4  
Xref (See External References) 

z 
Zoom 

Center A-4 
Dynamic  A-4 
In A-4 
Object A-4 
Out A-4 
Scale A-4 
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